source: projects/specs/trunk/n/nghttp2/nghttp2-vl.spec @ 12387

Revision 12387, 9.3 KB checked in by tomop, 4 years ago (diff)

updated 10 packages

Field3D-1.7.3-1

OpenImageIO-2.1.10.1-1

ekiga-4.0.1-11

galera-26.4.3-2

gnucash-3.10-1

libboost-1.72.0-1

nghttp2-1.40.0-2

opal-3.10.11-1

ptlib-2.10.11-1

source-highlight-3.1.8-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%bcond_with test
4%bcond_without app
5
6%define _unpackaged_files_terminate_build 1
7
8Summary: Experimental HTTP/2 client, server and proxy
9Summary(ja): HTTP/2クライアント・サーバ・プロキシの実験的実装
10Name: nghttp2
11Version: 1.40.0
12Release: 2%{?_dist_release}
13Group: Applications/Internet
14Vendor: Project Vine
15Distribution: Vine Linux
16
17License: MIT
18URL: https://nghttp2.org/
19Source0: https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/nghttp2-%{version}.tar.xz
20
21%if %{with test}
22BuildRequires: CUnit-devel
23%endif
24BuildRequires: jemalloc-devel
25BuildRequires: libboost-devel
26BuildRequires: libboost-thread
27BuildRequires: libev-devel
28BuildRequires: openssl-devel
29BuildRequires: zlib-devel
30
31%if %{with app}
32Requires: libnghttp2 = %{version}-%{release}
33BuildRequires: c-ares-devel
34BuildRequires: jansson-devel
35BuildRequires: libxml2-devel
36%endif
37
38%description
39This package contains the HTTP/2 client, server and proxy programs.
40
41%description -l ja
42This package contains the HTTP/2 client, server and proxy programs.
43 このパッケージにはHTTP/2クライアント・サーバ。プロキシのプログラム
44が含まれています。
45
46
47%package -n libnghttp2
48Summary: A library implementing the HTTP/2 protocol
49Summary(ja): HTTP/2ライブラリ
50Group: Development/Libraries
51
52%description -n libnghttp2
53libnghttp2 is a library implementing the Hypertext Transfer Protocol
54version 2 (HTTP/2) protocol in C.
55
56%description -l ja -n libnghttp2
57 libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
58実装したライブラリです。
59
60
61%package -n libnghttp2-devel
62Summary: Files needed for building applications with libnghttp2
63Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
64Group: Development/Libraries
65Requires: libnghttp2%{?_isa} = %{version}-%{release}
66Requires: pkgconfig
67
68%description -n libnghttp2-devel
69The libnghttp2-devel package includes libraries and header files needed
70for building applications with libnghttp2.
71
72%description -l ja -n libnghttp2-devel
73 libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
74をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
75す。
76
77
78%package -n compat32-libnghttp2
79Summary: A library implementing the HTTP/2 protocol
80Summary(ja): HTTP/2ライブラリ
81Group: Development/Libraries
82
83%description -n compat32-libnghttp2
84libnghttp2 is a library implementing the Hypertext Transfer Protocol
85version 2 (HTTP/2) protocol in C.
86
87%description -l ja -n compat32-libnghttp2
88 libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
89実装したライブラリです。
90
91
92%package -n compat32-libnghttp2-devel
93Summary: Files needed for building applications with libnghttp2
94Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
95Group: Development/Libraries
96Requires: compat32-libnghttp2%{?_isa} = %{version}-%{release}
97Requires: pkgconfig
98
99%description -n compat32-libnghttp2-devel
100The libnghttp2-devel package includes libraries and header files needed
101for building applications with libnghttp2.
102
103%description -l ja -n compat32-libnghttp2-devel
104 libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
105をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
106す。
107
108
109%prep
110%setup -q
111
112
113%build
114CFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS"    \
115CXXFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS"  \
116%configure                                  \
117%if %{with app}
118    --enable-app                            \
119%endif
120        --enable-asio-lib                       \
121    --with-pic                              \
122    --with-boost                            \
123    --with-boost-asio                       \
124    --with-boost-system                     \
125    --with-boost-thread                     \
126    --disable-python-bindings               \
127    --disable-static                        \
128    --without-libxml2                       \
129    --without-spdylay
130
131# avoid using rpath
132sed -i libtool                              \
133    -e 's/^runpath_var=.*/runpath_var=/'    \
134    -e 's/^hardcode_libdir_flag_spec=".*"$/hardcode_libdir_flag_spec=""/'
135
136make %{?_smp_mflags} V=1
137
138
139%install
140%make_install
141
142# not needed on Fedora/RHEL
143rm -f %{buildroot}%{_libdir}/libnghttp2*.la
144
145# will be installed via %%doc
146rm -f "%{buildroot}%{_datadir}/doc/nghttp2/README.rst"
147
148%if ! %{with app}
149rm -f %{buildroot}%{_mandir}/man1/*
150%endif
151
152
153%post -n libnghttp2
154/sbin/ldconfig
155
156%postun -n libnghttp2
157/sbin/ldconfig
158
159%post -n compat32-libnghttp2
160/sbin/ldconfig
161
162%postun -n compat32-libnghttp2
163/sbin/ldconfig
164
165
166%check
167%if %{with test}
168# test the just built library instead of the system one, without using rpath
169export "LD_LIBRARY_PATH=%{buildroot}%{_libdir}:$LD_LIBRARY_PATH"
170make %{?_smp_mflags} check
171%endif
172
173%if %{with app}
174%files
175%{_bindir}/h2load
176%{_bindir}/nghttp
177%{_bindir}/nghttpd
178%{_bindir}/nghttpx
179%{_bindir}/deflatehd
180%{_bindir}/inflatehd
181%{_datadir}/nghttp2
182%{_mandir}/man1/h2load.1*
183%{_mandir}/man1/nghttp.1*
184%{_mandir}/man1/nghttpd.1*
185%{_mandir}/man1/nghttpx.1*
186%endif
187
188%files -n libnghttp2
189%{_libdir}/libnghttp2*.so.*
190%{_datadir}/%{name}/fetch-ocsp-response
191%{!?_licensedir:%global license %%doc}
192%license COPYING
193
194%files -n libnghttp2-devel
195%{_includedir}/nghttp2
196%{_libdir}/pkgconfig/libnghttp2*.pc
197%{_libdir}/libnghttp2*.so
198%doc README.rst
199
200%if %{build_compat32}
201%files -n compat32-libnghttp2
202%{_libdir}/libnghttp2*.so.*
203%{!?_licensedir:%global license %%doc}
204%license COPYING
205
206%files -n compat32-libnghttp2-devel
207%{_includedir}/nghttp2
208%{_libdir}/pkgconfig/libnghttp2*.pc
209%{_libdir}/libnghttp2*.so
210%doc README.rst
211%endif
212
213%changelog
214* Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.40.0-2
215- rebuilt with boost-1.72.0.
216
217* Sun Feb 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.40.0-1
218- new upstream release.
219
220* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.39.2-1
221- new upstream release.
222
223* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.34.0-1
224- new upstream release.
225
226* Fri Mar 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.31.0-1
227- new upstream release.
228
229* Sun Jan 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.0-2
230- rebuilt with libboost-1.66.0.
231
232* Sun Dec 24 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.0-1
233- new upstream release.
234- enabled to build apps as default.
235
236* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.22.0-1
237- new upstream release.
238
239* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.20.0-1
240- new upstream release.
241- disabled to build apps as default.
242
243* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.17.0-1
244- new upstream release.
245
246* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-2
247- added compat32-* packages.
248
249* Thu Jul  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
250- new upstream release.
251
252* Tue Jun  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.1-2
253- initial build for Vne Linux.
254
255* Sun May 29 2016 Kamil Dudka <kdudka@redhat.com> 1.11.1-1
256- update to the latest upstream release
257
258* Thu May 26 2016 Kamil Dudka <kdudka@redhat.com> 1.11.0-1
259- update to the latest upstream release
260
261* Mon Apr 25 2016 Kamil Dudka <kdudka@redhat.com> 1.10.0-1
262- update to the latest upstream release
263
264* Sun Apr 03 2016 Kamil Dudka <kdudka@redhat.com> 1.9.2-1
265- update to the latest upstream release
266
267* Tue Mar 29 2016 Kamil Dudka <kdudka@redhat.com> 1.9.1-1
268- update to the latest upstream release
269
270* Thu Feb 25 2016 Kamil Dudka <kdudka@redhat.com> 1.8.0-1
271- update to the latest upstream release
272
273* Thu Feb 11 2016 Kamil Dudka <kdudka@redhat.com> 1.7.1-1
274- update to the latest upstream release (fixes CVE-2016-1544)
275
276* Fri Feb 05 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-3
277- make the package compile with gcc-6
278
279* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-2
280- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
281
282* Mon Jan 25 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-1
283- update to the latest upstream release
284
285* Fri Dec 25 2015 Kamil Dudka <kdudka@redhat.com> 1.6.0-1
286- update to the latest upstream release (fixes CVE-2015-8659)
287
288* Thu Nov 26 2015 Kamil Dudka <kdudka@redhat.com> 1.5.0-1
289- update to the latest upstream release
290
291* Mon Oct 26 2015 Kamil Dudka <kdudka@redhat.com> 1.4.0-1
292- update to the latest upstream release
293
294* Thu Sep 24 2015 Kamil Dudka <kdudka@redhat.com> 1.3.4-1
295- update to the latest upstream release
296
297* Wed Sep 23 2015 Kamil Dudka <kdudka@redhat.com> 1.3.3-1
298- update to the latest upstream release
299
300* Wed Sep 16 2015 Kamil Dudka <kdudka@redhat.com> 1.3.2-1
301- update to the latest upstream release
302
303* Mon Sep 14 2015 Kamil Dudka <kdudka@redhat.com> 1.3.1-1
304- update to the latest upstream release
305
306* Mon Aug 31 2015 Kamil Dudka <kdudka@redhat.com> 1.3.0-1
307- update to the latest upstream release
308
309* Mon Aug 17 2015 Kamil Dudka <kdudka@redhat.com> 1.2.1-1
310- update to the latest upstream release
311
312* Sun Aug 09 2015 Kamil Dudka <kdudka@redhat.com> 1.2.0-1
313- update to the latest upstream release
314
315* Wed Jul 15 2015 Kamil Dudka <kdudka@redhat.com> 1.1.1-1
316- update to the latest upstream release
317
318* Tue Jun 30 2015 Kamil Dudka <kdudka@redhat.com> 1.0.5-1
319- packaged for Fedora (#1237247)
Note: See TracBrowser for help on using the repository browser.