source: projects/specs/trunk/n/nghttp2/nghttp2-vl.spec @ 11610

Revision 11610, 8.9 KB checked in by tomop, 6 years ago (diff)

nghttp2-1.31.0-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%bcond_with test
4%bcond_without app
5
6%define _unpackaged_files_terminate_build 1
7
8Summary: Experimental HTTP/2 client, server and proxy
9Summary(ja): HTTP/2クライアント・サーバ・プロキシの実験的実装
10Name: nghttp2
11Version: 1.31.0
12Release: 1%{?_dist_release}
13License: MIT
14Group: Applications/Internet
15URL: https://nghttp2.org/
16
17Vendor: Project Vine
18Distribution: Vine Linux
19Packager: tomop
20
21Source0: https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/nghttp2-%{version}.tar.xz
22
23%if %{with test}
24BuildRequires: CUnit-devel
25%endif
26BuildRequires: jemalloc-devel
27BuildRequires: libboost-devel
28BuildRequires: libboost-thread
29BuildRequires: libev-devel
30BuildRequires: openssl-devel
31BuildRequires: zlib-devel
32
33%if %{with app}
34Requires: libnghttp2 = %{version}-%{release}
35BuildRequires: c-ares-devel
36BuildRequires: jansson-devel
37BuildRequires: libxml2-devel
38%endif
39
40%description
41This package contains the HTTP/2 client, server and proxy programs.
42
43%description -l ja
44This package contains the HTTP/2 client, server and proxy programs.
45 このパッケージにはHTTP/2クライアント・サーバ。プロキシのプログラム
46が含まれています。
47
48
49%package -n libnghttp2
50Summary: A library implementing the HTTP/2 protocol
51Summary(ja): HTTP/2ライブラリ
52Group: Development/Libraries
53
54%description -n libnghttp2
55libnghttp2 is a library implementing the Hypertext Transfer Protocol
56version 2 (HTTP/2) protocol in C.
57
58%description -l ja -n libnghttp2
59 libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
60実装したライブラリです。
61
62
63%package -n libnghttp2-devel
64Summary: Files needed for building applications with libnghttp2
65Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
66Group: Development/Libraries
67Requires: libnghttp2%{?_isa} = %{version}-%{release}
68Requires: pkgconfig
69
70%description -n libnghttp2-devel
71The libnghttp2-devel package includes libraries and header files needed
72for building applications with libnghttp2.
73
74%description -l ja -n libnghttp2-devel
75 libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
76をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
77す。
78
79
80%package -n compat32-libnghttp2
81Summary: A library implementing the HTTP/2 protocol
82Summary(ja): HTTP/2ライブラリ
83Group: Development/Libraries
84
85%description -n compat32-libnghttp2
86libnghttp2 is a library implementing the Hypertext Transfer Protocol
87version 2 (HTTP/2) protocol in C.
88
89%description -l ja -n compat32-libnghttp2
90 libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
91実装したライブラリです。
92
93
94%package -n compat32-libnghttp2-devel
95Summary: Files needed for building applications with libnghttp2
96Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
97Group: Development/Libraries
98Requires: compat32-libnghttp2%{?_isa} = %{version}-%{release}
99Requires: pkgconfig
100
101%description -n compat32-libnghttp2-devel
102The libnghttp2-devel package includes libraries and header files needed
103for building applications with libnghttp2.
104
105%description -l ja -n compat32-libnghttp2-devel
106 libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
107をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
108す。
109
110
111%prep
112%setup -q
113
114
115%build
116LIBEV_CFLAGS=`pkg-config --cflags libev`
117CFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS"    \
118CXXFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS"  \
119%configure                                  \
120%if %{with app}
121    --enable-app                            \
122%endif
123        --enable-asio-lib                       \
124    --with-pic                              \
125    --with-boost                            \
126    --with-boost-asio                       \
127    --with-boost-system                     \
128    --with-boost-thread                     \
129    --disable-python-bindings               \
130    --disable-static                        \
131    --without-libxml2                       \
132    --without-spdylay
133
134# avoid using rpath
135sed -i libtool                              \
136    -e 's/^runpath_var=.*/runpath_var=/'    \
137    -e 's/^hardcode_libdir_flag_spec=".*"$/hardcode_libdir_flag_spec=""/'
138
139make %{?_smp_mflags} V=1
140
141
142%install
143%make_install
144
145# not needed on Fedora/RHEL
146rm -f %{buildroot}%{_libdir}/libnghttp2*.la
147
148# will be installed via %%doc
149rm -f "%{buildroot}%{_datadir}/doc/nghttp2/README.rst"
150
151%if ! %{with app}
152rm -f %{buildroot}%{_mandir}/man1/*
153%endif
154
155
156%post -n libnghttp2
157/sbin/ldconfig
158
159%postun -n libnghttp2
160/sbin/ldconfig
161
162%post -n compat32-libnghttp2
163/sbin/ldconfig
164
165%postun -n compat32-libnghttp2
166/sbin/ldconfig
167
168
169%check
170%if %{with test}
171# test the just built library instead of the system one, without using rpath
172export "LD_LIBRARY_PATH=%{buildroot}%{_libdir}:$LD_LIBRARY_PATH"
173make %{?_smp_mflags} check
174%endif
175
176%if %{with app}
177%files
178%{_bindir}/h2load
179%{_bindir}/nghttp
180%{_bindir}/nghttpd
181%{_bindir}/nghttpx
182%{_bindir}/deflatehd
183%{_bindir}/inflatehd
184%{_datadir}/nghttp2
185%{_mandir}/man1/h2load.1*
186%{_mandir}/man1/nghttp.1*
187%{_mandir}/man1/nghttpd.1*
188%{_mandir}/man1/nghttpx.1*
189%endif
190
191%files -n libnghttp2
192%{_libdir}/libnghttp2*.so.*
193%{_datadir}/%{name}/fetch-ocsp-response
194%{!?_licensedir:%global license %%doc}
195%license COPYING
196
197%files -n libnghttp2-devel
198%{_includedir}/nghttp2
199%{_libdir}/pkgconfig/libnghttp2*.pc
200%{_libdir}/libnghttp2*.so
201%doc README.rst
202
203%if %{build_compat32}
204%files -n compat32-libnghttp2
205%{_libdir}/libnghttp2*.so.*
206%{!?_licensedir:%global license %%doc}
207%license COPYING
208
209%files -n compat32-libnghttp2-devel
210%{_includedir}/nghttp2
211%{_libdir}/pkgconfig/libnghttp2*.pc
212%{_libdir}/libnghttp2*.so
213%doc README.rst
214%endif
215
216%changelog
217* Fri Mar 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.31.0-1
218- new upstream release.
219
220* Sun Jan 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.0-2
221- rebuilt with libboost-1.66.0.
222
223* Sun Dec 24 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.0-1
224- new upstream release.
225- enabled to build apps as default.
226
227* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.22.0-1
228- new upstream release.
229
230* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.20.0-1
231- new upstream release.
232- disabled to build apps as default.
233
234* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.17.0-1
235- new upstream release.
236
237* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-2
238- added compat32-* packages.
239
240* Thu Jul  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
241- new upstream release.
242
243* Tue Jun  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.1-2
244- initial build for Vne Linux.
245
246* Sun May 29 2016 Kamil Dudka <kdudka@redhat.com> 1.11.1-1
247- update to the latest upstream release
248
249* Thu May 26 2016 Kamil Dudka <kdudka@redhat.com> 1.11.0-1
250- update to the latest upstream release
251
252* Mon Apr 25 2016 Kamil Dudka <kdudka@redhat.com> 1.10.0-1
253- update to the latest upstream release
254
255* Sun Apr 03 2016 Kamil Dudka <kdudka@redhat.com> 1.9.2-1
256- update to the latest upstream release
257
258* Tue Mar 29 2016 Kamil Dudka <kdudka@redhat.com> 1.9.1-1
259- update to the latest upstream release
260
261* Thu Feb 25 2016 Kamil Dudka <kdudka@redhat.com> 1.8.0-1
262- update to the latest upstream release
263
264* Thu Feb 11 2016 Kamil Dudka <kdudka@redhat.com> 1.7.1-1
265- update to the latest upstream release (fixes CVE-2016-1544)
266
267* Fri Feb 05 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-3
268- make the package compile with gcc-6
269
270* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-2
271- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
272
273* Mon Jan 25 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-1
274- update to the latest upstream release
275
276* Fri Dec 25 2015 Kamil Dudka <kdudka@redhat.com> 1.6.0-1
277- update to the latest upstream release (fixes CVE-2015-8659)
278
279* Thu Nov 26 2015 Kamil Dudka <kdudka@redhat.com> 1.5.0-1
280- update to the latest upstream release
281
282* Mon Oct 26 2015 Kamil Dudka <kdudka@redhat.com> 1.4.0-1
283- update to the latest upstream release
284
285* Thu Sep 24 2015 Kamil Dudka <kdudka@redhat.com> 1.3.4-1
286- update to the latest upstream release
287
288* Wed Sep 23 2015 Kamil Dudka <kdudka@redhat.com> 1.3.3-1
289- update to the latest upstream release
290
291* Wed Sep 16 2015 Kamil Dudka <kdudka@redhat.com> 1.3.2-1
292- update to the latest upstream release
293
294* Mon Sep 14 2015 Kamil Dudka <kdudka@redhat.com> 1.3.1-1
295- update to the latest upstream release
296
297* Mon Aug 31 2015 Kamil Dudka <kdudka@redhat.com> 1.3.0-1
298- update to the latest upstream release
299
300* Mon Aug 17 2015 Kamil Dudka <kdudka@redhat.com> 1.2.1-1
301- update to the latest upstream release
302
303* Sun Aug 09 2015 Kamil Dudka <kdudka@redhat.com> 1.2.0-1
304- update to the latest upstream release
305
306* Wed Jul 15 2015 Kamil Dudka <kdudka@redhat.com> 1.1.1-1
307- update to the latest upstream release
308
309* Tue Jun 30 2015 Kamil Dudka <kdudka@redhat.com> 1.0.5-1
310- packaged for Fedora (#1237247)
Note: See TracBrowser for help on using the repository browser.