source: projects/specs/trunk/n/nghttp2/nghttp2-vl.spec @ 10358

Revision 10358, 6.1 KB checked in by tomop, 8 years ago (diff)

nghttp2-1.11.1-2

Line 
1%bcond_with test
2
3Summary: Experimental HTTP/2 client, server and proxy
4Summary(ja): HTTP/2クライアント・サーバ・プロキシの実験的実装
5Name: nghttp2
6Version: 1.11.1
7Release: 2%{?_dist_release}
8License: MIT
9Group: Applications/Internet
10URL: https://nghttp2.org/
11Source0: https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/nghttp2-%{version}.tar.xz
12
13%if %{with test}
14BuildRequires: CUnit-devel
15%endif
16BuildRequires: jemalloc-devel
17BuildRequires: libboost-devel
18BuildRequires: libboost-thread
19BuildRequires: libev-devel
20BuildRequires: openssl-devel
21BuildRequires: zlib-devel
22
23Requires: libnghttp2 = %{version}-%{release}
24
25%description
26This package contains the HTTP/2 client, server and proxy programs.
27
28%description -l ja
29This package contains the HTTP/2 client, server and proxy programs.
30 このパッケージにはHTTP/2クライアント・サーバ。プロキシのプログラム
31が含まれています。
32
33
34%package -n libnghttp2
35Summary: A library implementing the HTTP/2 protocol
36Summary(ja): HTTP/2ライブラリ
37Group: Development/Libraries
38
39%description -n libnghttp2
40libnghttp2 is a library implementing the Hypertext Transfer Protocol
41version 2 (HTTP/2) protocol in C.
42
43%description -l ja -n libnghttp2
44 libnghttp2はHypertext Transfer Protocol version 2 (HTTP/2)をC言語で
45実装したライブラリです。
46
47
48%package -n libnghttp2-devel
49Summary: Files needed for building applications with libnghttp2
50Summary(ja): libnghttp2を利用するアプリケーションをビルドするために必要なファイル
51Group: Development/Libraries
52Requires: libnghttp2%{?_isa} = %{version}-%{release}
53Requires: pkgconfig
54
55%description -n libnghttp2-devel
56The libnghttp2-devel package includes libraries and header files needed
57for building applications with libnghttp2.
58
59%description -l ja -n libnghttp2-devel
60 libnghttp2-develパッケージにはlibnghttp2を利用するアプリケーション
61をビルドするために必要となるライブラリ・ヘッダファイルが含まれていま
62す。
63
64
65%prep
66%setup -q
67
68
69%build
70LIBEV_CFLAGS=`pkg-config --cflags libev`
71CFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS"    \
72CXXFLAGS="%{optflags} -fPIC $LIBEV_CFLAGS"  \
73%configure                                  \
74    --enable-app                            \
75    --enable-asio-lib                       \
76    --with-pic                              \
77    --with-boost                            \
78    --with-boost-asio                       \
79    --with-boost-system                     \
80    --with-boost-thread                     \
81    --disable-python-bindings               \
82    --disable-static                        \
83    --without-libxml2                       \
84    --without-spdylay
85
86# avoid using rpath
87sed -i libtool                              \
88    -e 's/^runpath_var=.*/runpath_var=/'    \
89    -e 's/^hardcode_libdir_flag_spec=".*"$/hardcode_libdir_flag_spec=""/'
90
91make %{?_smp_mflags} V=1
92
93
94%install
95%make_install
96
97# not needed on Fedora/RHEL
98rm -f $RPM_BUILD_ROOT%{_libdir}/libnghttp2*.la
99
100# will be installed via %%doc
101rm -f "$RPM_BUILD_ROOT%{_datadir}/doc/nghttp2/README.rst"
102
103%post -n libnghttp2 -p /sbin/ldconfig
104
105%postun -n libnghttp2 -p /sbin/ldconfig
106
107
108%check
109%if %{with test}
110# test the just built library instead of the system one, without using rpath
111export "LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir}:$LD_LIBRARY_PATH"
112make %{?_smp_mflags} check
113%endif
114
115%files
116%{_bindir}/h2load
117%{_bindir}/nghttp
118%{_bindir}/nghttpd
119%{_bindir}/nghttpx
120%{_datadir}/nghttp2
121%{_mandir}/man1/h2load.1*
122%{_mandir}/man1/nghttp.1*
123%{_mandir}/man1/nghttpd.1*
124%{_mandir}/man1/nghttpx.1*
125
126%files -n libnghttp2
127%{_libdir}/libnghttp2*.so.*
128%{!?_licensedir:%global license %%doc}
129%license COPYING
130
131%files -n libnghttp2-devel
132%{_includedir}/nghttp2
133%{_libdir}/pkgconfig/libnghttp2*.pc
134%{_libdir}/libnghttp2*.so
135%doc README.rst
136
137
138%changelog
139* Tue Jun  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.1-2
140- initial build for Vne Linux.
141
142* Sun May 29 2016 Kamil Dudka <kdudka@redhat.com> 1.11.1-1
143- update to the latest upstream release
144
145* Thu May 26 2016 Kamil Dudka <kdudka@redhat.com> 1.11.0-1
146- update to the latest upstream release
147
148* Mon Apr 25 2016 Kamil Dudka <kdudka@redhat.com> 1.10.0-1
149- update to the latest upstream release
150
151* Sun Apr 03 2016 Kamil Dudka <kdudka@redhat.com> 1.9.2-1
152- update to the latest upstream release
153
154* Tue Mar 29 2016 Kamil Dudka <kdudka@redhat.com> 1.9.1-1
155- update to the latest upstream release
156
157* Thu Feb 25 2016 Kamil Dudka <kdudka@redhat.com> 1.8.0-1
158- update to the latest upstream release
159
160* Thu Feb 11 2016 Kamil Dudka <kdudka@redhat.com> 1.7.1-1
161- update to the latest upstream release (fixes CVE-2016-1544)
162
163* Fri Feb 05 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-3
164- make the package compile with gcc-6
165
166* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-2
167- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
168
169* Mon Jan 25 2016 Kamil Dudka <kdudka@redhat.com> 1.7.0-1
170- update to the latest upstream release
171
172* Fri Dec 25 2015 Kamil Dudka <kdudka@redhat.com> 1.6.0-1
173- update to the latest upstream release (fixes CVE-2015-8659)
174
175* Thu Nov 26 2015 Kamil Dudka <kdudka@redhat.com> 1.5.0-1
176- update to the latest upstream release
177
178* Mon Oct 26 2015 Kamil Dudka <kdudka@redhat.com> 1.4.0-1
179- update to the latest upstream release
180
181* Thu Sep 24 2015 Kamil Dudka <kdudka@redhat.com> 1.3.4-1
182- update to the latest upstream release
183
184* Wed Sep 23 2015 Kamil Dudka <kdudka@redhat.com> 1.3.3-1
185- update to the latest upstream release
186
187* Wed Sep 16 2015 Kamil Dudka <kdudka@redhat.com> 1.3.2-1
188- update to the latest upstream release
189
190* Mon Sep 14 2015 Kamil Dudka <kdudka@redhat.com> 1.3.1-1
191- update to the latest upstream release
192
193* Mon Aug 31 2015 Kamil Dudka <kdudka@redhat.com> 1.3.0-1
194- update to the latest upstream release
195
196* Mon Aug 17 2015 Kamil Dudka <kdudka@redhat.com> 1.2.1-1
197- update to the latest upstream release
198
199* Sun Aug 09 2015 Kamil Dudka <kdudka@redhat.com> 1.2.0-1
200- update to the latest upstream release
201
202* Wed Jul 15 2015 Kamil Dudka <kdudka@redhat.com> 1.1.1-1
203- update to the latest upstream release
204
205* Tue Jun 30 2015 Kamil Dudka <kdudka@redhat.com> 1.0.5-1
206- packaged for Fedora (#1237247)
Note: See TracBrowser for help on using the repository browser.