source: projects/specs/trunk/n/newt/newt-vl.spec @ 5701

Revision 5701, 10.6 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Summary: A development library for text mode user interfaces.
5Summary(ja): テキストモードインターフェースのための開発ライブラリ
6Name: newt
7Version: 0.52.14
8Release: 1%{?_dist_release}
9License: LGPL
10Group: System Environment/Libraries
11URL: https://fedorahosted.org/newt/
12
13Source: https://fedorahosted.org/releases/n/e/newt/newt-%{version}.tar.gz
14# patches from mdv
15Patch1: newt-0.51.4-fix-wstrlen-for-non-utf8-strings.patch
16# patches from ubuntu
17Patch10: 400_python_memory_allocation.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: python-devel, popt-devel, slang-devel
21Provides: snack = %{version}-%{release}
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke
26
27
28%description
29Newt is a programming library for color text mode, widget based user
30interfaces.  Newt can be used to add stacked windows, entry widgets,
31checkboxes, radio buttons, labels, plain text fields, scrollbars,
32etc., to text mode user interfaces.  This package also contains the
33shared library needed by programs built with newt, as well as a
34/usr/bin/dialog replacement called whiptail.  Newt is based on the
35slang library.
36
37
38%package devel
39Summary: Newt windowing toolkit development files.
40Summary(ja): Newt ウィンドウツールキット開発ファイル集
41Requires: slang-devel %{name} = %{version}
42Group: Development/Libraries
43
44
45%description devel
46The newt-devel package contains the header files and libraries
47necessary for developing applications which use newt.  Newt is a
48development library for text mode user interfaces.  Newt is based on
49the slang library.
50
51Install newt-devel if you want to develop applications which will use
52newt.
53
54
55## to build compat32 for x86_64 architecture support
56%package -n compat32-%{name}
57Summary: A development library for text mode user interfaces.
58Group: System Environment/Libraries
59%description -n compat32-%{name}
60Newt is a programming library for color text mode, widget based user
61interfaces.  Newt can be used to add stacked windows, entry widgets,
62checkboxes, radio buttons, labels, plain text fields, scrollbars,
63etc., to text mode user interfaces.  This package also contains the
64shared library needed by programs built with newt, as well as a
65/usr/bin/dialog replacement called whiptail.  Newt is based on the
66slang library.
67
68%package -n compat32-%{name}-devel
69Summary: Newt windowing toolkit development files.
70Group: Development/Libraries
71Requires: compat32-%{name} = %{version}
72%description -n compat32-%{name}-devel
73The newt-devel package contains the header files and libraries
74necessary for developing applications which use newt.  Newt is a
75development library for text mode user interfaces.  Newt is based on
76the slang library.
77
78Install newt-devel if you want to develop applications which will use
79newt.
80
81
82%prep
83%setup -q -n %{name}-%{version}
84%patch1 -p1 -b .fix-wstrlen-for-non-utf8-strings
85%patch10 -p1 -b .python_memory_allocation
86
87%build
88%if %{build_compat32}
89export CC='gcc -m32'
90%configure --without-tcl
91make CC='gcc -m32'
92#make CC='gcc -m32' shared
93%else
94%configure --without-tcl
95make
96make shared
97%endif
98chmod 0644 peanuts.py popcorn.py
99
100%install
101rm -rf $RPM_BUILD_ROOT
102make instroot=$RPM_BUILD_ROOT install
103
104%find_lang %{name}
105
106%post -p /sbin/ldconfig
107
108%postun -p /sbin/ldconfig
109
110%if %{build_compat32}
111%post -n compat32-%{name} -p /sbin/ldconfig
112%postun -n compat32-%{name} -p /sbin/ldconfig
113%endif
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%files -f %{name}.lang
119%defattr (-,root,root)
120%doc CHANGES COPYING
121%{_libdir}/libnewt.so.*
122%{_bindir}/whiptail
123%{python_sitearch}/*.py*
124%{python_sitearch}/*.so
125%{_mandir}/man1/whiptail.1*
126
127%files devel
128%defattr (-,root,root)
129%doc tutorial.sgml peanuts.py popcorn.py
130%{_includedir}/newt.h
131%{_libdir}/libnewt.a
132%{_libdir}/libnewt.so
133%{_libdir}/pkgconfig/libnewt.pc
134
135%if %{build_compat32}
136%files -n compat32-%{name}
137%defattr (-,root,root)
138%{_libdir}/libnewt.so.*
139
140%files -n compat32-%{name}-devel
141%defattr (-,root,root)
142%{_libdir}/libnewt.a
143%{_libdir}/libnewt.so
144%endif
145
146
147%changelog
148* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.52.14-1
149- new upstram release
150
151* Thu Oct 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.13-1
152- new upstram release
153
154* Sat Jun 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.12-2
155- add patch2,3 from mdv
156- add patch10 from ubuntu
157
158* Tue May 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.12-1
159- update to 0.52.12
160- add patch0: don't hang in form when stdin disappears
161- remove patch100, fixed in upstream
162
163* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.52.10-7
164- rebuilt with recent environment.
165
166* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-6
167- rebuilt with gcc-4.4.3-3 on ppc
168
169* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-5
170- rebuilt with rpm-4.8.0-3 (on ppc)
171
172* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.52.10-4
173- rebuilt with python-2.6.4
174
175* Thu Oct  8 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-3
176- fix build_compat32 if-endif
177
178* Sat Sep 26 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-2
179- add patch100 for fix CVE-2009-2905 (textbox BoF) from fc10
180
181* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.10-1
182- new upstream release
183- use %%python_sitearch macro
184- remove --with-gpm-support
185- drop obsolete patches
186
187* Sun Aug 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.35-0vl6
188- rebuild to fix dependency problem on x86_64 architecture
189
190* Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl5
191- added BuildRequires: slang-devel
192- added newt-0.50.35-Makefile.in.patch
193- updated newt-0.50.35-make.patch
194- changed /usr/lib to %%{_libdir}
195- added compat32-* packages for x86_64 architecture support
196
197* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl4
198- rebuild with python-2.4.1-0vl1
199
200* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl3
201- rebuild with python-2.3.3-0vl1
202
203* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl2.1
204- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
205
206* Wed Jan 29 2003 Tomoya TAKA <taka@vinelinux.org> 0.50.35-0vl2
207- build against python-2.2
208- drop Patch20
209
210* Thu Oct 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.35-0vl1
211- updated to new upstream release 0.50.35
212- updated Patch11 and added Patch20
213  (Patch20 is for python 1.5: REMOVE IT WHEN WE DECIDED TO GO WITH PYTHON2)
214
215* Sat Mar 09 2002 Tomoya TAKA <taka@vinelinux.org> 0.50.33-0vl1
216- update to new upstream release
217
218* Mon Jul  2 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
219- 0.50.22-0vl1
220- updated to 0.50.22
221- use Release No for Vine Linux
222- use better macros
223- bytecompile the snack python module
224
225* Wed Sep 29 1999 Norihito Ohmori <ohmori@flatout.rog>
226- fix spec file
227
228* Sun Sep 11 1999 Norihito Ohmori <ohmori@flatout.org>
229- added Japanese support patch
230
231* Wed Sep 01 1999 Erik Troan <ewt@redhat.com>
232- added suspend/resume to snack
233
234* Tue Aug 31 1999 Matt Wilson <msw@redhat.com>
235- enable gpm support
236
237* Fri Aug 27 1999 Matt Wilson <msw@redhat.com>
238- added hotkey assignment for gridforms, changed listbox.setcurrent to
239  take the item key
240
241* Wed Aug 25 1999 Matt Wilson <msw@redhat.com>
242- fixed snack callback function refcounts, as well as optional data args
243- fixed suspend callback ref counts
244
245* Mon Aug 23 1999 Matt Wilson <msw@redhat.com>
246- added buttons argument to entrywindow
247
248* Thu Aug 12 1999 Bill Nottingham <notting@redhat.com>
249- multi-state checkboxtrees. Woohoo.
250
251* Mon Aug  9 1999 Matt Wilson <msw@redhat.com>
252- added snack wrappings for checkbox flag setting
253
254* Thu Aug  5 1999 Matt Wilson <msw@redhat.com>
255- added snack bindings for setting current listbox selection
256- added argument to set default selection in snack ListboxChoiceWindow
257
258* Mon Aug  2 1999 Matt Wilson <msw@redhat.com>
259- added checkboxtree
260- improved snack binding
261
262* Fri Apr  9 1999 Matt Wilson <msw@redhat.com>
263- fixed a glibc related bug in reflow that was truncating all text to 1000
264chars
265
266* Fri Apr 09 1999 Matt Wilson <msw@redhat.com>
267- fixed bug that made newt apps crash when you hit <insert> followed by lots
268of keys
269
270* Mon Mar 15 1999 Matt Wilson <msw@redhat.com>
271- fix from Jakub Jelinek for listbox keypresses
272
273* Fri Feb 27 1999 Matt Wilson <msw@redhat.com>
274- fixed support for navigating listboxes with alphabetical keypresses
275
276* Thu Feb 25 1999 Matt Wilson <msw@redhat.com>
277- updated descriptions
278- added support for navigating listboxes with alphabetical keypresses
279
280* Mon Feb  8 1999 Matt Wilson <msw@redhat.com>
281- made grid wrapped windows at least the size of their title bars
282
283* Fri Feb  5 1999 Matt Wilson <msw@redhat.com>
284- Function to set checkbox flags.  This will go away later when I have
285  a generic flag setting function and signals to comps to go insensitive.
286
287* Tue Jan 19 1999 Matt Wilson <msw@redhat.com>
288- Stopped using libgpm, internalized all gpm calls.  Still need some cleanups.
289
290* Thu Jan  7 1999 Matt Wilson <msw@redhat.com>
291- Added GPM mouse support
292- Moved to autoconf to allow compiling without GPM support
293- Changed revision to 0.40
294
295* Wed Oct 21 1998 Bill Nottingham <notting@redhat.com>
296- built against slang-1.2.2
297
298* Wed Aug 19 1998 Bill Nottingham <notting@redhat.com>
299- bugfixes for text reflow
300- added docs
301
302* Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
303- devel package moved to Development/Libraries
304
305* Thu Apr 30 1998 Erik Troan <ewt@redhat.com>
306- removed whiptcl.so -- it should be in a separate package
307
308* Mon Feb 16 1998 Erik Troan <ewt@redhat.com>
309- added newtWinMenu()
310- many bug fixes in grid code
311
312* Wed Jan 21 1998 Erik Troan <ewt@redhat.com>
313- removed newtWinTernary()
314- made newtWinChoice() return codes consistent with newtWinTernary()
315
316* Fri Jan 16 1998 Erik Troan <ewt@redhat.com>
317- added changes from Bruce Perens
318    - small cleanups
319    - lets whiptail automatically resize windows
320- the order of placing a grid and adding components to a form no longer
321  matters
322- added newtGridAddComponentsToForm()
323
324* Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
325- added newtWinTernary()
326
327* Tue Oct 07 1997 Erik Troan <ewt@redhat.com>
328- made Make/spec files use a buildroot
329- added grid support (for newt 0.11 actually)
330
331* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
332- Added patched from Clarence Smith for setting the size of a listbox
333- Version 0.9
334
335* Tue May 28 1997 Elliot Lee <sopwith@redhat.com> 0.8-2
336- Touchups on Makefile
337- Cleaned up NEWT_FLAGS_*
338
339* Tue Mar 18 1997 Erik Troan <ewt@redhat.com>
340- Cleaned up listbox
341- Added whiptail
342- Added newtButtonCompact button type and associated colors
343- Added newtTextboxGetNumLines() and newtTextboxSetHeight()
344
345* Tue Feb 25 1997 Erik Troan <ewt@redhat.com>
346- Added changes from sopwith for C++ cleanliness and some listbox fixes.
347
Note: See TracBrowser for help on using the repository browser.