source: projects/specs/trunk/n/newt/newt-vl.spec @ 5283

Revision 5283, 10.6 KB checked in by daisuke, 12 years ago (diff)

new upstream

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Summary: A development library for text mode user interfaces.
5Summary(ja): テキストモードインターフェースのための開発ライブラリ
6Name: newt
7Version: 0.52.13
8Release: 1%{?_dist_release}
9License: LGPL
10Group: System Environment/Libraries
11URL: https://fedorahosted.org/newt/
12
13Source: https://fedorahosted.org/releases/n/e/newt/newt-%{version}.tar.gz
14# patches from mdv
15Patch1: newt-0.51.4-fix-wstrlen-for-non-utf8-strings.patch
16# patches from ubuntu
17Patch10: 400_python_memory_allocation.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: python-devel, popt-devel, slang-devel
21Provides: snack = %{version}-%{release}
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke
26
27
28%description
29Newt is a programming library for color text mode, widget based user
30interfaces.  Newt can be used to add stacked windows, entry widgets,
31checkboxes, radio buttons, labels, plain text fields, scrollbars,
32etc., to text mode user interfaces.  This package also contains the
33shared library needed by programs built with newt, as well as a
34/usr/bin/dialog replacement called whiptail.  Newt is based on the
35slang library.
36
37
38%package devel
39Summary: Newt windowing toolkit development files.
40Summary(ja): Newt ウィンドウツールキット開発ファイル集
41Requires: slang-devel %{name} = %{version}
42Group: Development/Libraries
43
44
45%description devel
46The newt-devel package contains the header files and libraries
47necessary for developing applications which use newt.  Newt is a
48development library for text mode user interfaces.  Newt is based on
49the slang library.
50
51Install newt-devel if you want to develop applications which will use
52newt.
53
54
55## to build compat32 for x86_64 architecture support
56%package -n compat32-%{name}
57Summary: A development library for text mode user interfaces.
58Group: System Environment/Libraries
59%description -n compat32-%{name}
60Newt is a programming library for color text mode, widget based user
61interfaces.  Newt can be used to add stacked windows, entry widgets,
62checkboxes, radio buttons, labels, plain text fields, scrollbars,
63etc., to text mode user interfaces.  This package also contains the
64shared library needed by programs built with newt, as well as a
65/usr/bin/dialog replacement called whiptail.  Newt is based on the
66slang library.
67
68%package -n compat32-%{name}-devel
69Summary: Newt windowing toolkit development files.
70Group: Development/Libraries
71Requires: compat32-%{name} = %{version}
72%description -n compat32-%{name}-devel
73The newt-devel package contains the header files and libraries
74necessary for developing applications which use newt.  Newt is a
75development library for text mode user interfaces.  Newt is based on
76the slang library.
77
78Install newt-devel if you want to develop applications which will use
79newt.
80
81
82%prep
83%setup -q -n %{name}-%{version}
84%patch1 -p1 -b .fix-wstrlen-for-non-utf8-strings
85%patch10 -p1 -b .python_memory_allocation
86
87%build
88%if %{build_compat32}
89export CC='gcc -m32'
90%configure --without-tcl
91make CC='gcc -m32'
92#make CC='gcc -m32' shared
93%else
94%configure --without-tcl
95make
96make shared
97%endif
98chmod 0644 peanuts.py popcorn.py
99
100%install
101rm -rf $RPM_BUILD_ROOT
102make instroot=$RPM_BUILD_ROOT install
103
104%find_lang %{name}
105
106%post -p /sbin/ldconfig
107
108%postun -p /sbin/ldconfig
109
110%if %{build_compat32}
111%post -n compat32-%{name} -p /sbin/ldconfig
112%postun -n compat32-%{name} -p /sbin/ldconfig
113%endif
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%files -f %{name}.lang
119%defattr (-,root,root)
120%doc CHANGES COPYING
121%{_libdir}/libnewt.so.*
122%{_bindir}/whiptail
123%{python_sitearch}/*.py*
124%{python_sitearch}/*.so
125%{_mandir}/man1/whiptail.1*
126
127%files devel
128%defattr (-,root,root)
129%doc tutorial.sgml peanuts.py popcorn.py
130%{_includedir}/newt.h
131%{_libdir}/libnewt.a
132%{_libdir}/libnewt.so
133%{_libdir}/pkgconfig/libnewt.pc
134
135%if %{build_compat32}
136%files -n compat32-%{name}
137%defattr (-,root,root)
138%{_libdir}/libnewt.so.*
139%{python_sitearch}/*.py*
140%{python_sitearch}/*.so
141
142%files -n compat32-%{name}-devel
143%defattr (-,root,root)
144%{_libdir}/libnewt.a
145%{_libdir}/libnewt.so
146%endif
147
148
149%changelog
150* Thu Oct 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.13-1
151- new upstram release
152
153* Sat Jun 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.12-2
154- add patch2,3 from mdv
155- add patch10 from ubuntu
156
157* Tue May 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.12-1
158- update to 0.52.12
159- add patch0: don't hang in form when stdin disappears
160- remove patch100, fixed in upstream
161
162* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.52.10-7
163- rebuilt with recent environment.
164
165* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-6
166- rebuilt with gcc-4.4.3-3 on ppc
167
168* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-5
169- rebuilt with rpm-4.8.0-3 (on ppc)
170
171* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.52.10-4
172- rebuilt with python-2.6.4
173
174* Thu Oct  8 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-3
175- fix build_compat32 if-endif
176
177* Sat Sep 26 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-2
178- add patch100 for fix CVE-2009-2905 (textbox BoF) from fc10
179
180* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.10-1
181- new upstream release
182- use %%python_sitearch macro
183- remove --with-gpm-support
184- drop obsolete patches
185
186* Sun Aug 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.35-0vl6
187- rebuild to fix dependency problem on x86_64 architecture
188
189* Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl5
190- added BuildRequires: slang-devel
191- added newt-0.50.35-Makefile.in.patch
192- updated newt-0.50.35-make.patch
193- changed /usr/lib to %%{_libdir}
194- added compat32-* packages for x86_64 architecture support
195
196* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl4
197- rebuild with python-2.4.1-0vl1
198
199* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl3
200- rebuild with python-2.3.3-0vl1
201
202* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl2.1
203- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
204
205* Wed Jan 29 2003 Tomoya TAKA <taka@vinelinux.org> 0.50.35-0vl2
206- build against python-2.2
207- drop Patch20
208
209* Thu Oct 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.35-0vl1
210- updated to new upstream release 0.50.35
211- updated Patch11 and added Patch20
212  (Patch20 is for python 1.5: REMOVE IT WHEN WE DECIDED TO GO WITH PYTHON2)
213
214* Sat Mar 09 2002 Tomoya TAKA <taka@vinelinux.org> 0.50.33-0vl1
215- update to new upstream release
216
217* Mon Jul  2 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
218- 0.50.22-0vl1
219- updated to 0.50.22
220- use Release No for Vine Linux
221- use better macros
222- bytecompile the snack python module
223
224* Wed Sep 29 1999 Norihito Ohmori <ohmori@flatout.rog>
225- fix spec file
226
227* Sun Sep 11 1999 Norihito Ohmori <ohmori@flatout.org>
228- added Japanese support patch
229
230* Wed Sep 01 1999 Erik Troan <ewt@redhat.com>
231- added suspend/resume to snack
232
233* Tue Aug 31 1999 Matt Wilson <msw@redhat.com>
234- enable gpm support
235
236* Fri Aug 27 1999 Matt Wilson <msw@redhat.com>
237- added hotkey assignment for gridforms, changed listbox.setcurrent to
238  take the item key
239
240* Wed Aug 25 1999 Matt Wilson <msw@redhat.com>
241- fixed snack callback function refcounts, as well as optional data args
242- fixed suspend callback ref counts
243
244* Mon Aug 23 1999 Matt Wilson <msw@redhat.com>
245- added buttons argument to entrywindow
246
247* Thu Aug 12 1999 Bill Nottingham <notting@redhat.com>
248- multi-state checkboxtrees. Woohoo.
249
250* Mon Aug  9 1999 Matt Wilson <msw@redhat.com>
251- added snack wrappings for checkbox flag setting
252
253* Thu Aug  5 1999 Matt Wilson <msw@redhat.com>
254- added snack bindings for setting current listbox selection
255- added argument to set default selection in snack ListboxChoiceWindow
256
257* Mon Aug  2 1999 Matt Wilson <msw@redhat.com>
258- added checkboxtree
259- improved snack binding
260
261* Fri Apr  9 1999 Matt Wilson <msw@redhat.com>
262- fixed a glibc related bug in reflow that was truncating all text to 1000
263chars
264
265* Fri Apr 09 1999 Matt Wilson <msw@redhat.com>
266- fixed bug that made newt apps crash when you hit <insert> followed by lots
267of keys
268
269* Mon Mar 15 1999 Matt Wilson <msw@redhat.com>
270- fix from Jakub Jelinek for listbox keypresses
271
272* Fri Feb 27 1999 Matt Wilson <msw@redhat.com>
273- fixed support for navigating listboxes with alphabetical keypresses
274
275* Thu Feb 25 1999 Matt Wilson <msw@redhat.com>
276- updated descriptions
277- added support for navigating listboxes with alphabetical keypresses
278
279* Mon Feb  8 1999 Matt Wilson <msw@redhat.com>
280- made grid wrapped windows at least the size of their title bars
281
282* Fri Feb  5 1999 Matt Wilson <msw@redhat.com>
283- Function to set checkbox flags.  This will go away later when I have
284  a generic flag setting function and signals to comps to go insensitive.
285
286* Tue Jan 19 1999 Matt Wilson <msw@redhat.com>
287- Stopped using libgpm, internalized all gpm calls.  Still need some cleanups.
288
289* Thu Jan  7 1999 Matt Wilson <msw@redhat.com>
290- Added GPM mouse support
291- Moved to autoconf to allow compiling without GPM support
292- Changed revision to 0.40
293
294* Wed Oct 21 1998 Bill Nottingham <notting@redhat.com>
295- built against slang-1.2.2
296
297* Wed Aug 19 1998 Bill Nottingham <notting@redhat.com>
298- bugfixes for text reflow
299- added docs
300
301* Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
302- devel package moved to Development/Libraries
303
304* Thu Apr 30 1998 Erik Troan <ewt@redhat.com>
305- removed whiptcl.so -- it should be in a separate package
306
307* Mon Feb 16 1998 Erik Troan <ewt@redhat.com>
308- added newtWinMenu()
309- many bug fixes in grid code
310
311* Wed Jan 21 1998 Erik Troan <ewt@redhat.com>
312- removed newtWinTernary()
313- made newtWinChoice() return codes consistent with newtWinTernary()
314
315* Fri Jan 16 1998 Erik Troan <ewt@redhat.com>
316- added changes from Bruce Perens
317    - small cleanups
318    - lets whiptail automatically resize windows
319- the order of placing a grid and adding components to a form no longer
320  matters
321- added newtGridAddComponentsToForm()
322
323* Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
324- added newtWinTernary()
325
326* Tue Oct 07 1997 Erik Troan <ewt@redhat.com>
327- made Make/spec files use a buildroot
328- added grid support (for newt 0.11 actually)
329
330* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
331- Added patched from Clarence Smith for setting the size of a listbox
332- Version 0.9
333
334* Tue May 28 1997 Elliot Lee <sopwith@redhat.com> 0.8-2
335- Touchups on Makefile
336- Cleaned up NEWT_FLAGS_*
337
338* Tue Mar 18 1997 Erik Troan <ewt@redhat.com>
339- Cleaned up listbox
340- Added whiptail
341- Added newtButtonCompact button type and associated colors
342- Added newtTextboxGetNumLines() and newtTextboxSetHeight()
343
344* Tue Feb 25 1997 Erik Troan <ewt@redhat.com>
345- Added changes from sopwith for C++ cleanliness and some listbox fixes.
346
Note: See TracBrowser for help on using the repository browser.