source: projects/specs/trunk/n/newt/newt-vl.spec @ 3536

Revision 3536, 10.1 KB checked in by tomop, 13 years ago (diff)

newt-0.52.10-7

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Summary: A development library for text mode user interfaces.
5Summary(ja): テキストモードインターフェースのための開発ライブラリ
6Name: newt
7Version: 0.52.10
8Release: 7%{?_dist_release}
9License: LGPL
10Group: System Environment/Libraries
11URL: https://fedorahosted.org/newt/
12
13Source: https://fedorahosted.org/releases/n/e/newt/newt-%{version}.tar.gz
14# Security fix
15Patch100: newt-0.52.10-reflowbuffer.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
21BuildRequires: python-devel, popt-devel, slang-devel
22Provides: snack = %{version}-%{release}
23
24
25%description
26Newt is a programming library for color text mode, widget based user
27interfaces.  Newt can be used to add stacked windows, entry widgets,
28checkboxes, radio buttons, labels, plain text fields, scrollbars,
29etc., to text mode user interfaces.  This package also contains the
30shared library needed by programs built with newt, as well as a
31/usr/bin/dialog replacement called whiptail.  Newt is based on the
32slang library.
33
34
35%package devel
36Summary: Newt windowing toolkit development files.
37Summary(ja): Newt ウィンドウツールキット開発ファイル集
38Requires: slang-devel %{name} = %{version}
39Group: Development/Libraries
40
41
42%description devel
43The newt-devel package contains the header files and libraries
44necessary for developing applications which use newt.  Newt is a
45development library for text mode user interfaces.  Newt is based on
46the slang library.
47
48Install newt-devel if you want to develop applications which will use
49newt.
50
51
52## to build compat32 for x86_64 architecture support
53%package -n compat32-%{name}
54Summary: A development library for text mode user interfaces.
55Group: System Environment/Libraries
56%description -n compat32-%{name}
57Newt is a programming library for color text mode, widget based user
58interfaces.  Newt can be used to add stacked windows, entry widgets,
59checkboxes, radio buttons, labels, plain text fields, scrollbars,
60etc., to text mode user interfaces.  This package also contains the
61shared library needed by programs built with newt, as well as a
62/usr/bin/dialog replacement called whiptail.  Newt is based on the
63slang library.
64
65%package -n compat32-%{name}-devel
66Summary: Newt windowing toolkit development files.
67Group: Development/Libraries
68Requires: compat32-%{name} = %{version}
69%description -n compat32-%{name}-devel
70The newt-devel package contains the header files and libraries
71necessary for developing applications which use newt.  Newt is a
72development library for text mode user interfaces.  Newt is based on
73the slang library.
74
75Install newt-devel if you want to develop applications which will use
76newt.
77
78
79%prep
80%setup -q -n %{name}-%{version}
81
82%patch100 -p1 -b .CVE-2009-2905
83
84%build
85%if %{build_compat32}
86export CC='gcc -m32'
87%configure --without-tcl
88make CC='gcc -m32'
89#make CC='gcc -m32' shared
90%else
91%configure --without-tcl
92make
93make shared
94%endif
95chmod 0644 peanuts.py popcorn.py
96
97%install
98rm -rf $RPM_BUILD_ROOT
99make instroot=$RPM_BUILD_ROOT install
100
101%find_lang %{name}
102
103%post -p /sbin/ldconfig
104
105%postun -p /sbin/ldconfig
106
107%if %{build_compat32}
108%post -n compat32-%{name} -p /sbin/ldconfig
109%postun -n compat32-%{name} -p /sbin/ldconfig
110%endif
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%files -f %{name}.lang
116%defattr (-,root,root)
117%doc CHANGES COPYING
118%{_libdir}/libnewt.so.*
119%{_bindir}/whiptail
120%{python_sitearch}/*.py*
121%{python_sitearch}/*.so
122%{_mandir}/man1/whiptail.1*
123
124%files devel
125%defattr (-,root,root)
126%doc tutorial.sgml peanuts.py popcorn.py
127%{_includedir}/newt.h
128%{_libdir}/libnewt.a
129%{_libdir}/libnewt.so
130
131%if %{build_compat32}
132%files -n compat32-%{name}
133%defattr (-,root,root)
134%{_libdir}/libnewt.so.*
135%{python_sitearch}/*.py*
136%{python_sitearch}/*.so
137
138%files -n compat32-%{name}-devel
139%defattr (-,root,root)
140%{_libdir}/libnewt.a
141%{_libdir}/libnewt.so
142%endif
143
144
145%changelog
146* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.52.10-7
147- rebuilt with recent environment.
148
149* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-6
150- rebuilt with gcc-4.4.3-3 on ppc
151
152* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-5
153- rebuilt with rpm-4.8.0-3 (on ppc)
154
155* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.52.10-4
156- rebuilt with python-2.6.4
157
158* Thu Oct  8 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-3
159- fix build_compat32 if-endif
160
161* Sat Sep 26 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-2
162- add patch100 for fix CVE-2009-2905 (textbox BoF) from fc10
163
164* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.10-1
165- new upstream release
166- use %%python_sitearch macro
167- remove --with-gpm-support
168- drop obsolete patches
169
170* Sun Aug 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.35-0vl6
171- rebuild to fix dependency problem on x86_64 architecture
172
173* Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl5
174- added BuildRequires: slang-devel
175- added newt-0.50.35-Makefile.in.patch
176- updated newt-0.50.35-make.patch
177- changed /usr/lib to %%{_libdir}
178- added compat32-* packages for x86_64 architecture support
179
180* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl4
181- rebuild with python-2.4.1-0vl1
182
183* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl3
184- rebuild with python-2.3.3-0vl1
185
186* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl2.1
187- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
188
189* Wed Jan 29 2003 Tomoya TAKA <taka@vinelinux.org> 0.50.35-0vl2
190- build against python-2.2
191- drop Patch20
192
193* Thu Oct 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.35-0vl1
194- updated to new upstream release 0.50.35
195- updated Patch11 and added Patch20
196  (Patch20 is for python 1.5: REMOVE IT WHEN WE DECIDED TO GO WITH PYTHON2)
197
198* Sat Mar 09 2002 Tomoya TAKA <taka@vinelinux.org> 0.50.33-0vl1
199- update to new upstream release
200
201* Mon Jul  2 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
202- 0.50.22-0vl1
203- updated to 0.50.22
204- use Release No for Vine Linux
205- use better macros
206- bytecompile the snack python module
207
208* Wed Sep 29 1999 Norihito Ohmori <ohmori@flatout.rog>
209- fix spec file
210
211* Sun Sep 11 1999 Norihito Ohmori <ohmori@flatout.org>
212- added Japanese support patch
213
214* Wed Sep 01 1999 Erik Troan <ewt@redhat.com>
215- added suspend/resume to snack
216
217* Tue Aug 31 1999 Matt Wilson <msw@redhat.com>
218- enable gpm support
219
220* Fri Aug 27 1999 Matt Wilson <msw@redhat.com>
221- added hotkey assignment for gridforms, changed listbox.setcurrent to
222  take the item key
223
224* Wed Aug 25 1999 Matt Wilson <msw@redhat.com>
225- fixed snack callback function refcounts, as well as optional data args
226- fixed suspend callback ref counts
227
228* Mon Aug 23 1999 Matt Wilson <msw@redhat.com>
229- added buttons argument to entrywindow
230
231* Thu Aug 12 1999 Bill Nottingham <notting@redhat.com>
232- multi-state checkboxtrees. Woohoo.
233
234* Mon Aug  9 1999 Matt Wilson <msw@redhat.com>
235- added snack wrappings for checkbox flag setting
236
237* Thu Aug  5 1999 Matt Wilson <msw@redhat.com>
238- added snack bindings for setting current listbox selection
239- added argument to set default selection in snack ListboxChoiceWindow
240
241* Mon Aug  2 1999 Matt Wilson <msw@redhat.com>
242- added checkboxtree
243- improved snack binding
244
245* Fri Apr  9 1999 Matt Wilson <msw@redhat.com>
246- fixed a glibc related bug in reflow that was truncating all text to 1000
247chars
248
249* Fri Apr 09 1999 Matt Wilson <msw@redhat.com>
250- fixed bug that made newt apps crash when you hit <insert> followed by lots
251of keys
252
253* Mon Mar 15 1999 Matt Wilson <msw@redhat.com>
254- fix from Jakub Jelinek for listbox keypresses
255
256* Fri Feb 27 1999 Matt Wilson <msw@redhat.com>
257- fixed support for navigating listboxes with alphabetical keypresses
258
259* Thu Feb 25 1999 Matt Wilson <msw@redhat.com>
260- updated descriptions
261- added support for navigating listboxes with alphabetical keypresses
262
263* Mon Feb  8 1999 Matt Wilson <msw@redhat.com>
264- made grid wrapped windows at least the size of their title bars
265
266* Fri Feb  5 1999 Matt Wilson <msw@redhat.com>
267- Function to set checkbox flags.  This will go away later when I have
268  a generic flag setting function and signals to comps to go insensitive.
269
270* Tue Jan 19 1999 Matt Wilson <msw@redhat.com>
271- Stopped using libgpm, internalized all gpm calls.  Still need some cleanups.
272
273* Thu Jan  7 1999 Matt Wilson <msw@redhat.com>
274- Added GPM mouse support
275- Moved to autoconf to allow compiling without GPM support
276- Changed revision to 0.40
277
278* Wed Oct 21 1998 Bill Nottingham <notting@redhat.com>
279- built against slang-1.2.2
280
281* Wed Aug 19 1998 Bill Nottingham <notting@redhat.com>
282- bugfixes for text reflow
283- added docs
284
285* Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
286- devel package moved to Development/Libraries
287
288* Thu Apr 30 1998 Erik Troan <ewt@redhat.com>
289- removed whiptcl.so -- it should be in a separate package
290
291* Mon Feb 16 1998 Erik Troan <ewt@redhat.com>
292- added newtWinMenu()
293- many bug fixes in grid code
294
295* Wed Jan 21 1998 Erik Troan <ewt@redhat.com>
296- removed newtWinTernary()
297- made newtWinChoice() return codes consistent with newtWinTernary()
298
299* Fri Jan 16 1998 Erik Troan <ewt@redhat.com>
300- added changes from Bruce Perens
301    - small cleanups
302    - lets whiptail automatically resize windows
303- the order of placing a grid and adding components to a form no longer
304  matters
305- added newtGridAddComponentsToForm()
306
307* Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
308- added newtWinTernary()
309
310* Tue Oct 07 1997 Erik Troan <ewt@redhat.com>
311- made Make/spec files use a buildroot
312- added grid support (for newt 0.11 actually)
313
314* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
315- Added patched from Clarence Smith for setting the size of a listbox
316- Version 0.9
317
318* Tue May 28 1997 Elliot Lee <sopwith@redhat.com> 0.8-2
319- Touchups on Makefile
320- Cleaned up NEWT_FLAGS_*
321
322* Tue Mar 18 1997 Erik Troan <ewt@redhat.com>
323- Cleaned up listbox
324- Added whiptail
325- Added newtButtonCompact button type and associated colors
326- Added newtTextboxGetNumLines() and newtTextboxSetHeight()
327
328* Tue Feb 25 1997 Erik Troan <ewt@redhat.com>
329- Added changes from sopwith for C++ cleanliness and some listbox fixes.
330
Note: See TracBrowser for help on using the repository browser.