source: projects/specs/trunk/n/newt/newt-vl.spec @ 4006

Revision 4006, 10.2 KB checked in by daisuke, 13 years ago (diff)

newt: update to 0.52.12

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Summary: A development library for text mode user interfaces.
5Summary(ja): テキストモードインターフェースのための開発ライブラリ
6Name: newt
7Version: 0.52.12
8Release: 1%{?_dist_release}
9License: LGPL
10Group: System Environment/Libraries
11URL: https://fedorahosted.org/newt/
12
13Source: https://fedorahosted.org/releases/n/e/newt/newt-%{version}.tar.gz
14Patch0: newt-0.52.12-nostdin.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17Vendor: Project Vine
18Distribution: Vine Linux
19Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
20BuildRequires: python-devel, popt-devel, slang-devel
21Provides: snack = %{version}-%{release}
22
23
24%description
25Newt is a programming library for color text mode, widget based user
26interfaces.  Newt can be used to add stacked windows, entry widgets,
27checkboxes, radio buttons, labels, plain text fields, scrollbars,
28etc., to text mode user interfaces.  This package also contains the
29shared library needed by programs built with newt, as well as a
30/usr/bin/dialog replacement called whiptail.  Newt is based on the
31slang library.
32
33
34%package devel
35Summary: Newt windowing toolkit development files.
36Summary(ja): Newt ウィンドウツールキット開発ファイル集
37Requires: slang-devel %{name} = %{version}
38Group: Development/Libraries
39
40
41%description devel
42The newt-devel package contains the header files and libraries
43necessary for developing applications which use newt.  Newt is a
44development library for text mode user interfaces.  Newt is based on
45the slang library.
46
47Install newt-devel if you want to develop applications which will use
48newt.
49
50
51## to build compat32 for x86_64 architecture support
52%package -n compat32-%{name}
53Summary: A development library for text mode user interfaces.
54Group: System Environment/Libraries
55%description -n compat32-%{name}
56Newt is a programming library for color text mode, widget based user
57interfaces.  Newt can be used to add stacked windows, entry widgets,
58checkboxes, radio buttons, labels, plain text fields, scrollbars,
59etc., to text mode user interfaces.  This package also contains the
60shared library needed by programs built with newt, as well as a
61/usr/bin/dialog replacement called whiptail.  Newt is based on the
62slang library.
63
64%package -n compat32-%{name}-devel
65Summary: Newt windowing toolkit development files.
66Group: Development/Libraries
67Requires: compat32-%{name} = %{version}
68%description -n compat32-%{name}-devel
69The newt-devel package contains the header files and libraries
70necessary for developing applications which use newt.  Newt is a
71development library for text mode user interfaces.  Newt is based on
72the slang library.
73
74Install newt-devel if you want to develop applications which will use
75newt.
76
77
78%prep
79%setup -q -n %{name}-%{version}
80%patch0 -p1 -b .nostdin
81
82%build
83%if %{build_compat32}
84export CC='gcc -m32'
85%configure --without-tcl
86make CC='gcc -m32'
87#make CC='gcc -m32' shared
88%else
89%configure --without-tcl
90make
91make shared
92%endif
93chmod 0644 peanuts.py popcorn.py
94
95%install
96rm -rf $RPM_BUILD_ROOT
97make instroot=$RPM_BUILD_ROOT install
98
99%find_lang %{name}
100
101%post -p /sbin/ldconfig
102
103%postun -p /sbin/ldconfig
104
105%if %{build_compat32}
106%post -n compat32-%{name} -p /sbin/ldconfig
107%postun -n compat32-%{name} -p /sbin/ldconfig
108%endif
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%files -f %{name}.lang
114%defattr (-,root,root)
115%doc CHANGES COPYING
116%{_libdir}/libnewt.so.*
117%{_bindir}/whiptail
118%{python_sitearch}/*.py*
119%{python_sitearch}/*.so
120%{_mandir}/man1/whiptail.1*
121
122%files devel
123%defattr (-,root,root)
124%doc tutorial.sgml peanuts.py popcorn.py
125%{_includedir}/newt.h
126%{_libdir}/libnewt.a
127%{_libdir}/libnewt.so
128%{_libdir}/pkgconfig/libnewt.pc
129
130%if %{build_compat32}
131%files -n compat32-%{name}
132%defattr (-,root,root)
133%{_libdir}/libnewt.so.*
134%{python_sitearch}/*.py*
135%{python_sitearch}/*.so
136
137%files -n compat32-%{name}-devel
138%defattr (-,root,root)
139%{_libdir}/libnewt.a
140%{_libdir}/libnewt.so
141%endif
142
143
144%changelog
145* Tue May 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.12-1
146- update to 0.52.12
147- add patch0: don't hang in form when stdin disappears
148- remove patch100, fixed in upstream
149
150* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.52.10-7
151- rebuilt with recent environment.
152
153* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-6
154- rebuilt with gcc-4.4.3-3 on ppc
155
156* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-5
157- rebuilt with rpm-4.8.0-3 (on ppc)
158
159* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.52.10-4
160- rebuilt with python-2.6.4
161
162* Thu Oct  8 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-3
163- fix build_compat32 if-endif
164
165* Sat Sep 26 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-2
166- add patch100 for fix CVE-2009-2905 (textbox BoF) from fc10
167
168* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.10-1
169- new upstream release
170- use %%python_sitearch macro
171- remove --with-gpm-support
172- drop obsolete patches
173
174* Sun Aug 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.35-0vl6
175- rebuild to fix dependency problem on x86_64 architecture
176
177* Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl5
178- added BuildRequires: slang-devel
179- added newt-0.50.35-Makefile.in.patch
180- updated newt-0.50.35-make.patch
181- changed /usr/lib to %%{_libdir}
182- added compat32-* packages for x86_64 architecture support
183
184* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl4
185- rebuild with python-2.4.1-0vl1
186
187* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl3
188- rebuild with python-2.3.3-0vl1
189
190* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl2.1
191- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
192
193* Wed Jan 29 2003 Tomoya TAKA <taka@vinelinux.org> 0.50.35-0vl2
194- build against python-2.2
195- drop Patch20
196
197* Thu Oct 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.35-0vl1
198- updated to new upstream release 0.50.35
199- updated Patch11 and added Patch20
200  (Patch20 is for python 1.5: REMOVE IT WHEN WE DECIDED TO GO WITH PYTHON2)
201
202* Sat Mar 09 2002 Tomoya TAKA <taka@vinelinux.org> 0.50.33-0vl1
203- update to new upstream release
204
205* Mon Jul  2 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
206- 0.50.22-0vl1
207- updated to 0.50.22
208- use Release No for Vine Linux
209- use better macros
210- bytecompile the snack python module
211
212* Wed Sep 29 1999 Norihito Ohmori <ohmori@flatout.rog>
213- fix spec file
214
215* Sun Sep 11 1999 Norihito Ohmori <ohmori@flatout.org>
216- added Japanese support patch
217
218* Wed Sep 01 1999 Erik Troan <ewt@redhat.com>
219- added suspend/resume to snack
220
221* Tue Aug 31 1999 Matt Wilson <msw@redhat.com>
222- enable gpm support
223
224* Fri Aug 27 1999 Matt Wilson <msw@redhat.com>
225- added hotkey assignment for gridforms, changed listbox.setcurrent to
226  take the item key
227
228* Wed Aug 25 1999 Matt Wilson <msw@redhat.com>
229- fixed snack callback function refcounts, as well as optional data args
230- fixed suspend callback ref counts
231
232* Mon Aug 23 1999 Matt Wilson <msw@redhat.com>
233- added buttons argument to entrywindow
234
235* Thu Aug 12 1999 Bill Nottingham <notting@redhat.com>
236- multi-state checkboxtrees. Woohoo.
237
238* Mon Aug  9 1999 Matt Wilson <msw@redhat.com>
239- added snack wrappings for checkbox flag setting
240
241* Thu Aug  5 1999 Matt Wilson <msw@redhat.com>
242- added snack bindings for setting current listbox selection
243- added argument to set default selection in snack ListboxChoiceWindow
244
245* Mon Aug  2 1999 Matt Wilson <msw@redhat.com>
246- added checkboxtree
247- improved snack binding
248
249* Fri Apr  9 1999 Matt Wilson <msw@redhat.com>
250- fixed a glibc related bug in reflow that was truncating all text to 1000
251chars
252
253* Fri Apr 09 1999 Matt Wilson <msw@redhat.com>
254- fixed bug that made newt apps crash when you hit <insert> followed by lots
255of keys
256
257* Mon Mar 15 1999 Matt Wilson <msw@redhat.com>
258- fix from Jakub Jelinek for listbox keypresses
259
260* Fri Feb 27 1999 Matt Wilson <msw@redhat.com>
261- fixed support for navigating listboxes with alphabetical keypresses
262
263* Thu Feb 25 1999 Matt Wilson <msw@redhat.com>
264- updated descriptions
265- added support for navigating listboxes with alphabetical keypresses
266
267* Mon Feb  8 1999 Matt Wilson <msw@redhat.com>
268- made grid wrapped windows at least the size of their title bars
269
270* Fri Feb  5 1999 Matt Wilson <msw@redhat.com>
271- Function to set checkbox flags.  This will go away later when I have
272  a generic flag setting function and signals to comps to go insensitive.
273
274* Tue Jan 19 1999 Matt Wilson <msw@redhat.com>
275- Stopped using libgpm, internalized all gpm calls.  Still need some cleanups.
276
277* Thu Jan  7 1999 Matt Wilson <msw@redhat.com>
278- Added GPM mouse support
279- Moved to autoconf to allow compiling without GPM support
280- Changed revision to 0.40
281
282* Wed Oct 21 1998 Bill Nottingham <notting@redhat.com>
283- built against slang-1.2.2
284
285* Wed Aug 19 1998 Bill Nottingham <notting@redhat.com>
286- bugfixes for text reflow
287- added docs
288
289* Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
290- devel package moved to Development/Libraries
291
292* Thu Apr 30 1998 Erik Troan <ewt@redhat.com>
293- removed whiptcl.so -- it should be in a separate package
294
295* Mon Feb 16 1998 Erik Troan <ewt@redhat.com>
296- added newtWinMenu()
297- many bug fixes in grid code
298
299* Wed Jan 21 1998 Erik Troan <ewt@redhat.com>
300- removed newtWinTernary()
301- made newtWinChoice() return codes consistent with newtWinTernary()
302
303* Fri Jan 16 1998 Erik Troan <ewt@redhat.com>
304- added changes from Bruce Perens
305    - small cleanups
306    - lets whiptail automatically resize windows
307- the order of placing a grid and adding components to a form no longer
308  matters
309- added newtGridAddComponentsToForm()
310
311* Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
312- added newtWinTernary()
313
314* Tue Oct 07 1997 Erik Troan <ewt@redhat.com>
315- made Make/spec files use a buildroot
316- added grid support (for newt 0.11 actually)
317
318* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
319- Added patched from Clarence Smith for setting the size of a listbox
320- Version 0.9
321
322* Tue May 28 1997 Elliot Lee <sopwith@redhat.com> 0.8-2
323- Touchups on Makefile
324- Cleaned up NEWT_FLAGS_*
325
326* Tue Mar 18 1997 Erik Troan <ewt@redhat.com>
327- Cleaned up listbox
328- Added whiptail
329- Added newtButtonCompact button type and associated colors
330- Added newtTextboxGetNumLines() and newtTextboxSetHeight()
331
332* Tue Feb 25 1997 Erik Troan <ewt@redhat.com>
333- Added changes from sopwith for C++ cleanliness and some listbox fixes.
334
Note: See TracBrowser for help on using the repository browser.