source: projects/specs/trunk/n/nettle/nettle-vl.spec @ 5238

Revision 5238, 4.3 KB checked in by kudoh, 12 years ago (diff)

nettle-vl.spec

Line 
1Name:           nettle
2Version:        2.4
3Release:        1%{?_dist_release}
4Summary:        A low-level cryptographic library
5Summary(ja):     低レベル暗号化ライブラリ
6
7Group:          Development/Libraries
8License:        LGPLv2+
9URL:            http://www.lysator.liu.se/~nisse/nettle/
10Source0:        http://www.lysator.liu.se/~nisse/archive/%{name}-%{version}.tar.gz
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
13BuildRequires:  gmp-devel
14BuildRequires:  m4
15
16Requires(post): /sbin/install-info
17Requires(preun): /sbin/install-info
18
19Vendor:         Project Vine
20Distribution:   Vine Linux
21
22%package devel
23Summary:        Development headers for a low-level cryptographic library
24Summary(ja):     低レベル暗号化ライブラリの開発ヘッダ
25Group:          Development/Libraries
26Requires:       %{name} = %{version}-%{release}
27
28#%package static
29#Summary:        Static libraries for a low-level cryptographic library
30#Group:          Development/Libraries
31#Requires:       %{name}-devel = %{version}-%{release}
32
33%description
34Nettle is a cryptographic library that is designed to fit easily in more
35or less any context: In crypto toolkits for object-oriented languages
36(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
37kernel space.
38
39%description devel
40Nettle is a cryptographic library that is designed to fit easily in more
41or less any context: In crypto toolkits for object-oriented languages
42(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
43kernel space.  This package contains kernel headers.
44
45#%description static
46#Nettle is a cryptographic library that is designed to fit easily in more
47#or less any context: In crypto toolkits for object-oriented languages
48#(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
49#kernel space.  This package contains a static library.
50
51
52%prep
53%setup -q
54
55
56%build
57%configure --enable-shared
58make %{?_smp_mflags}
59
60
61%install
62rm -rf $RPM_BUILD_ROOT
63make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
64make install-shared DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
65#/usr/bin/iconv -f iso8859-1 -t utf-8 README > README.conv && /bin/mv -f README.conv README
66#/usr/bin/iconv -f iso8859-1 -t utf-8 ChangeLog > ChangeLog.conv && /bin/mv -f ChangeLog.conv ChangeLog
67#/usr/bin/iconv -f iso8859-1 -t utf-8 nettle.info > nettle.info.conv && /bin/mv -f nettle.info.conv nettle.info
68mkdir -p $RPM_BUILD_ROOT%{_infodir}
69install -p -m 644 nettle.info $RPM_BUILD_ROOT%{_infodir}/
70
71rm -rf %{buildroot}/%{_libdir}/*.a
72rm -rf %{buildroot}/%{_infodir}/dir
73
74%check
75make check
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80
81%files
82%defattr(-,root,root,-)
83%doc AUTHORS ChangeLog COPYING.LIB NEWS README TODO
84%{_infodir}/nettle.info.gz
85%{_bindir}/nettle-hash
86%{_bindir}/nettle-lfib-stream
87%{_bindir}/pkcs1-conv
88%{_bindir}/sexp-conv
89%{_libdir}/libhogweed.so*
90%{_libdir}/libnettle.so*
91
92
93%files devel
94%defattr(-,root,root,-)
95%doc descore.README nettle.html nettle.pdf COPYING.LIB
96%{_includedir}/nettle
97%{_libdir}/pkgconfig/
98
99#%files static
100#%defattr(-,root,root,-)
101#%doc COPYING
102#%{_libdir}/libhogweed.a
103#%{_libdir}/libnettle.a
104
105%post
106/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
107/sbin/ldconfig
108
109%preun
110if [ $1 = 0 ]; then
111  /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
112fi
113
114%postun -p /sbin/ldconfig
115
116
117
118%changelog
119* Fri Dec 02 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.4-1
120- initial build for VineSeed
121
122* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-7
123- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
124
125* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-6
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
127
128* Thu Apr 10 2008 Ian Weller <ianweller@gmail.com> 1.15-5
129- Moved static lib to -static
130
131* Mon Mar 24 2008 Ian Weller <ianweller@gmail.com> 1.15-4
132- Added libraries and ldconfig
133
134* Mon Feb 18 2008 Ian Weller <ianweller@gmail.com> 1.15-3
135- Added provides -static to -devel
136
137* Sun Feb 17 2008 Ian Weller <ianweller@gmail.com> 1.15-2
138- Removed redundant requires
139- Removed redundant documentation between packages
140- Fixed license tag
141- Fixed -devel description
142- Added the static library back to -devel
143- Added make clean
144
145* Fri Feb 08 2008 Ian Weller <ianweller@gmail.com> 1.15-1
146- First package build.
Note: See TracBrowser for help on using the repository browser.