source: projects/specs/trunk/n/nettle/nettle-vl.spec @ 8152

Revision 8152, 4.5 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1Name:           nettle
2Version:        2.7.1
3Release:        1%{?_dist_release}
4Summary:        A low-level cryptographic library
5Summary(ja):     低レベル暗号化ライブラリ
6
7Group:          Development/Libraries
8License:        LGPLv2+
9URL:            http://www.lysator.liu.se/~nisse/nettle/
10Source0:        http://www.lysator.liu.se/~nisse/archive/%{name}-%{version}.tar.gz
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
13BuildRequires:  gmp-devel
14BuildRequires:  m4
15
16Requires(post): /sbin/install-info
17Requires(preun): /sbin/install-info
18
19Vendor:         Project Vine
20Distribution:   Vine Linux
21
22%package devel
23Summary:        Development headers for a low-level cryptographic library
24Summary(ja):     低レベル暗号化ライブラリの開発ヘッダ
25Group:          Development/Libraries
26Requires:       %{name} = %{version}-%{release}
27
28#%package static
29#Summary:        Static libraries for a low-level cryptographic library
30#Group:          Development/Libraries
31#Requires:       %{name}-devel = %{version}-%{release}
32
33%description
34Nettle is a cryptographic library that is designed to fit easily in more
35or less any context: In crypto toolkits for object-oriented languages
36(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
37kernel space.
38
39%description devel
40Nettle is a cryptographic library that is designed to fit easily in more
41or less any context: In crypto toolkits for object-oriented languages
42(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
43kernel space.  This package contains kernel headers.
44
45#%description static
46#Nettle is a cryptographic library that is designed to fit easily in more
47#or less any context: In crypto toolkits for object-oriented languages
48#(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
49#kernel space.  This package contains a static library.
50
51
52%prep
53%setup -q
54
55
56%build
57%configure --enable-shared
58make %{?_smp_mflags}
59
60
61%install
62rm -rf $RPM_BUILD_ROOT
63make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
64make install-shared DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
65#/usr/bin/iconv -f iso8859-1 -t utf-8 README > README.conv && /bin/mv -f README.conv README
66#/usr/bin/iconv -f iso8859-1 -t utf-8 ChangeLog > ChangeLog.conv && /bin/mv -f ChangeLog.conv ChangeLog
67#/usr/bin/iconv -f iso8859-1 -t utf-8 nettle.info > nettle.info.conv && /bin/mv -f nettle.info.conv nettle.info
68mkdir -p $RPM_BUILD_ROOT%{_infodir}
69install -p -m 644 nettle.info $RPM_BUILD_ROOT%{_infodir}/
70
71chmod 755 $RPM_BUILD_ROOT%{_libdir}/libhogweed.so.*
72chmod 755 $RPM_BUILD_ROOT%{_libdir}/libnettle.so.*
73
74rm -rf %{buildroot}/%{_libdir}/*.a
75rm -rf %{buildroot}/%{_infodir}/dir
76
77%check
78make check
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83
84%files
85%defattr(-,root,root,-)
86%doc AUTHORS ChangeLog COPYING.LIB NEWS README TODO
87%{_infodir}/nettle.info.gz
88%{_bindir}/nettle-hash
89%{_bindir}/nettle-lfib-stream
90%{_bindir}/pkcs1-conv
91%{_bindir}/sexp-conv
92%{_libdir}/libhogweed.so.*
93%{_libdir}/libnettle.so.*
94
95
96%files devel
97%defattr(-,root,root,-)
98%doc descore.README nettle.html nettle.pdf COPYING.LIB
99%{_libdir}/libhogweed.so
100%{_libdir}/libnettle.so
101%{_includedir}/nettle
102%{_libdir}/pkgconfig/
103
104#%files static
105#%defattr(-,root,root,-)
106#%doc COPYING
107#%{_libdir}/libhogweed.a
108#%{_libdir}/libnettle.a
109
110%post
111/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
112/sbin/ldconfig
113
114%preun
115if [ $1 = 0 ]; then
116  /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
117fi
118
119%postun -p /sbin/ldconfig
120
121
122
123%changelog
124* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.7.1-1
125- update to 2.7.1
126
127* Fri Dec 02 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.4-1
128- initial build for VineSeed
129
130* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-7
131- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
132
133* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-6
134- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
135
136* Thu Apr 10 2008 Ian Weller <ianweller@gmail.com> 1.15-5
137- Moved static lib to -static
138
139* Mon Mar 24 2008 Ian Weller <ianweller@gmail.com> 1.15-4
140- Added libraries and ldconfig
141
142* Mon Feb 18 2008 Ian Weller <ianweller@gmail.com> 1.15-3
143- Added provides -static to -devel
144
145* Sun Feb 17 2008 Ian Weller <ianweller@gmail.com> 1.15-2
146- Removed redundant requires
147- Removed redundant documentation between packages
148- Fixed license tag
149- Fixed -devel description
150- Added the static library back to -devel
151- Added make clean
152
153* Fri Feb 08 2008 Ian Weller <ianweller@gmail.com> 1.15-1
154- First package build.
Note: See TracBrowser for help on using the repository browser.