source: projects/specs/trunk/n/netcdf/netcdf-vl.spec @ 9304

Revision 9304, 4.2 KB checked in by inagaki, 9 years ago (diff)

2015-01-28 Ryoichi INAGAKI <ryo1@…>

  • lapack, netcdf: updated
  • netcdf-cxx: new


Line 
1Summary:        Libraries for the Unidata network Common Data Form
2Name:           netcdf
3Version:        4.3.2
4Release:        1%{?_dist_release}
5
6License:        NetCDF
7Group:          System Environment/Libraries
8URL:            http://www.unidata.ucar.edu/downloads/netcdf/index.jsp
9
10Source0:        ftp://ftp.unidata.ucar.edu/pub/netcdf/%{name}-%{version}.tar.gz
11# Use pkgconfig in nc-config to avoid multi-lib issues
12Patch0:         netcdf-pkgconfig.patch
13# Upstream patch to support hdf5 1.8.13 mpio change
14Patch1:         netcdf-mpio.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildRequires:  chrpath
18BuildRequires:  curl-devel
19BuildRequires:  doxygen
20BuildRequires:  gawk
21BuildRequires:  hdf-devel
22BuildRequires:  hdf5-devel
23BuildRequires:  m4
24BuildRequires:  zlib-devel
25Requires:       hdf5
26
27%description
28NetCDF (network Common Data Form) is an interface for array-oriented
29data access and a freely-distributed collection of software libraries
30for C, Fortran, C++, and perl that provides an implementation of the
31interface.  The NetCDF library also defines a machine-independent
32format for representing scientific data.  Together, the interface,
33library, and format support the creation, access, and sharing of
34scientific data. The NetCDF software was developed at the Unidata
35Program Center in Boulder, Colorado.
36
37NetCDF data is:
38
39   o Self-Describing: A NetCDF file includes information about the
40     data it contains.
41
42   o Network-transparent:  A NetCDF file is represented in a form that
43     can be accessed by computers with different ways of storing
44     integers, characters, and floating-point numbers.
45
46   o Direct-access:  A small subset of a large dataset may be accessed
47     efficiently, without first reading through all the preceding
48     data.
49
50   o Appendable:  Data can be appended to a NetCDF dataset along one
51     dimension without copying the dataset or redefining its
52     structure. The structure of a NetCDF dataset can be changed,
53     though this sometimes causes the dataset to be copied.
54
55   o Sharable:  One writer and multiple readers may simultaneously
56     access the same NetCDF file.
57
58
59%package devel
60Summary:        Development files for netcdf
61Group:          Development/Libraries
62Requires:       %{name} = %{version}-%{release}
63
64%description devel
65This package contains the netCDF header files, libs, and man
66pages.
67
68
69%package static
70Summary:        Static libs for netcdf
71Group:          Development/Libraries
72Requires:       %{name} = %{version}-%{release}
73
74%description static
75This package contains the netCDF C static libs.
76
77
78%prep
79%setup -q -n %{name}-%{version}
80%patch0 -p1 -b .pkgconfig
81%patch1 -p1 -b .mpio
82
83
84%build
85export LDFLAGS="-L%{_libdir}/hdf"
86export CPPFLAGS=-I%{_includedir}/hdf
87export LIBS="-ldf -ljpeg"
88%configure \
89    --enable-shared \
90    --enable-netcdf-4 \
91    --enable-dap \
92    --enable-extra-example-tests \
93    --enable-hdf4 \
94    --disable-dap-remote-tests
95
96make %{?_smp_mflags}
97
98
99%install
100rm -rf $RPM_BUILD_ROOT
101make install DESTDIR=$RPM_BUILD_ROOT
102
103chrpath --delete $RPM_BUILD_ROOT/%{_bindir}/nc{copy,dump,gen,gen3}
104rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
105rm -f $RPM_BUILD_ROOT%{_infodir}/dir
106
107%check
108make check
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114
115%postun -p /sbin/ldconfig
116
117
118%files
119%defattr(-,root,root,-)
120%doc COPYRIGHT README.md RELEASE_NOTES.md
121%{_bindir}/*
122%{_libdir}/*.so.*
123%{_mandir}/man1/*
124
125%files devel
126%defattr(-,root,root,-)
127%{_includedir}/*
128%{_libdir}/*.so
129%{_libdir}/pkgconfig/*
130%{_mandir}/man3/*
131
132%files static
133%{_libdir}/*.a
134
135
136%changelog
137* Sun Jan 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.3.2-1
138- updated to 4.3.2
139- built with hdf and hdf5
140
141* Sun May 12 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.1.1-2
142- add configure options (--enable-netcdf-4, --enable-dap)
143- add BuildRequires: curl-devel
144
145* Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.1.1-1
146- update to 4.2.1.1
147- add BuildRequires: zlib-devel, hdf5-devel
148
149* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.1-1
150- new upstream release
151
152* Sun Oct  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.0.p1-1
153- new versioning policy
154
155* Sat Aug 25 2007 Shu KONNO <owa@bg.wakwak.com> 3.6.0.p1-0vl2
156- changed BuildRequires gcc-g77 to gcc-gfortran
157
158* Fri Oct 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.0.p1-0vl1
159- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.