source: projects/specs/trunk/n/netcdf/netcdf-vl.spec @ 11732

Revision 11732, 4.4 KB checked in by ara_t, 6 years ago (diff)

netcdf: rebuild with hdf5-1.8.20

Line 
1%define pkg_name    netcdf
2%define pkg_version 4.3.2
3%define pkg_release 2%{?_dist_release}
4
5Summary: Libraries for the Unidata network Common Data Form
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: NetCDF
11Group:   System Environment/Libraries
12URL:     http://www.unidata.ucar.edu/downloads/netcdf/index.jsp
13
14Source0: ftp://ftp.unidata.ucar.edu/pub/netcdf/%{name}-%{version}.tar.gz
15
16# Use pkgconfig in nc-config to avoid multi-lib issues
17Patch0: netcdf-pkgconfig.patch
18# Upstream patch to support hdf5 1.8.13 mpio change
19Patch1: netcdf-mpio.patch
20
21BuildRoot:     %{_tmppath}/%{name}-%{version}-root
22
23BuildRequires: chrpath
24BuildRequires: curl-devel
25BuildRequires: doxygen
26BuildRequires: gawk
27BuildRequires: hdf-devel
28BuildRequires: hdf5-devel
29BuildRequires: m4
30BuildRequires: libjpeg-turbo-devel
31BuildRequires: zlib-devel
32
33Requires: hdf5
34
35
36%description
37NetCDF (network Common Data Form) is an interface for array-oriented
38data access and a freely-distributed collection of software libraries
39for C, Fortran, C++, and perl that provides an implementation of the
40interface.  The NetCDF library also defines a machine-independent
41format for representing scientific data.  Together, the interface,
42library, and format support the creation, access, and sharing of
43scientific data. The NetCDF software was developed at the Unidata
44Program Center in Boulder, Colorado.
45
46NetCDF data is:
47
48   o Self-Describing: A NetCDF file includes information about the
49     data it contains.
50
51   o Network-transparent:  A NetCDF file is represented in a form that
52     can be accessed by computers with different ways of storing
53     integers, characters, and floating-point numbers.
54
55   o Direct-access:  A small subset of a large dataset may be accessed
56     efficiently, without first reading through all the preceding
57     data.
58
59   o Appendable:  Data can be appended to a NetCDF dataset along one
60     dimension without copying the dataset or redefining its
61     structure. The structure of a NetCDF dataset can be changed,
62     though this sometimes causes the dataset to be copied.
63
64   o Sharable:  One writer and multiple readers may simultaneously
65     access the same NetCDF file.
66
67
68%package devel
69Summary:  Development files for netcdf
70Group:    Development/Libraries
71Requires: %{name} = %{version}-%{release}
72
73%description devel
74This package contains the netCDF header files, libs, and man pages.
75
76
77%package static
78Summary:  Static libs for netcdf
79Group:    Development/Libraries
80Requires: %{name} = %{version}-%{release}
81
82%description static
83This package contains the netCDF C static libs.
84
85
86%prep
87%setup -q -n %{name}-%{version}
88%patch0 -p1 -b .pkgconfig
89%patch1 -p1 -b .mpio
90
91%build
92export LDFLAGS="-L%{_libdir}/hdf"
93export CPPFLAGS=-I%{_includedir}/hdf
94export LIBS="-ldf -ljpeg"
95%configure \
96    --enable-shared \
97    --enable-netcdf-4 \
98    --enable-dap \
99    --enable-extra-example-tests \
100    --enable-hdf4 \
101    --disable-dap-remote-tests
102
103%{__make} %{?_smp_mflags}
104
105
106%install
107%{__rm} -rf ${RPM_BUILD_ROOT}
108%{__make} install DESTDIR=${RPM_BUILD_ROOT}
109
110chrpath --delete ${RPM_BUILD_ROOT}%{_bindir}/nc{copy,dump,gen,gen3}
111%{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
112%{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
113
114%check
115%{__make} check
116
117%clean
118%{__rm} -rf ${RPM_BUILD_ROOT}
119
120%post -p %{_syssbindir}/ldconfig
121
122%postun -p %{_syssbindir}/ldconfig
123
124
125%files
126%defattr(-,root,root,-)
127%doc COPYRIGHT README.md RELEASE_NOTES.md
128%{_bindir}/*
129%{_libdir}/*.so.*
130%{_mandir}/man1/*
131
132%files devel
133%defattr(-,root,root,-)
134%{_includedir}/*
135%{_libdir}/*.so
136%{_libdir}/pkgconfig/*
137%{_mandir}/man3/*
138
139%files static
140%{_libdir}/*.a
141
142
143%changelog
144* Sun Jul 01 2018 Toshiaki Ara <ara_t@384.jp> 4.3.2-2
145- rebuild under hdf5-1.8.20
146
147* Sun Jan 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.3.2-1
148- updated to 4.3.2
149- built with hdf and hdf5
150
151* Sun May 12 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.1.1-2
152- add configure options (--enable-netcdf-4, --enable-dap)
153- add BuildRequires: curl-devel
154
155* Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.1.1-1
156- update to 4.2.1.1
157- add BuildRequires: zlib-devel, hdf5-devel
158
159* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.1-1
160- new upstream release
161
162* Sun Oct  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.0.p1-1
163- new versioning policy
164
165* Sat Aug 25 2007 Shu KONNO <owa@bg.wakwak.com> 3.6.0.p1-0vl2
166- changed BuildRequires gcc-g77 to gcc-gfortran
167
168* Fri Oct 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.0.p1-0vl1
169- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.