source: projects/specs/trunk/n/netatalk/netatalk-vl.spec @ 9606

Revision 9606, 11.8 KB checked in by tomop, 9 years ago (diff)

netatalk-3.1.7-1

Line 
1%define _sysconfdir     /etc
2
3################################################# BASIC PACKAGE INFORMATION
4Summary:       AFP fileserver for Macintosh clients
5Summary(ja):   Macintoshクライアント向けのAFPファイルサーバー
6Name:          netatalk
7Version:       3.1.7
8Release:       1%{_dist_release}
9License:       GPLv2+
10Group:         System Environment/Daemons
11URL:           http://netatalk.sourceforge.net/
12
13Source0:       %{name}-%{version}.tar.bz2
14
15Source1:       netatalk.pam-system-auth
16Patch0:        netatalk-3.0.1-basedir.patch
17
18############################################################## REQUIREMENTS
19Requires(post): /sbin/chkconfig /sbin/ldconfig
20Requires(preun): /sbin/chkconfig
21Requires(preun): /sbin/service
22Requires(postun): /sbin/service /sbin/ldconfig
23BuildRequires: cracklib openssl-devel pam quota libtool automake
24BuildRequires: autoconf libdb-devel pam-devel tcp_wrappers libgcrypt-devel
25BuildRequires: avahi-devel libacl-devel openldap-devel
26BuildRequires: dbus-devel dbus-glib-devel glib2-devel systemtap-sdt-devel
27BuildRequires: libevent-devel libtdb-devel libmysqlclient-devel
28
29BuildRoot:     %{_tmppath}/%{name}-%{version}-root
30
31Vendor:        Project Vine
32Distribution:  Vine Linux
33Packager:      shaolin, tomop
34
35%description
36Netatalk is a freely-available Open Source AFP fileserver. A *NIX/*BSD
37system running Netatalk is capable of serving many Macintosh clients
38simultaneously as an AppleShare file server (AFP).
39
40%description -l ja
41 Netatalkは自由に利用可能なオープンソースAFPファイルサーバーです。
42Netatalkを実行している*NIX/*BSDシステムでは、多くのMacintoshクライ
43アントに対してAppleShareファイルサーバー(AFP)としてサービスを提供
44可能です。
45
46%package devel
47Group:         Development/Libraries
48Summary:       Headers for Netatalk development
49Summary(ja):   Netatalk開発用ヘッダファイル
50
51%description devel
52This package contains the header files for Netatalk.
53
54
55%prep
56%setup -q
57
58%patch0  -p1 -b .basedir
59
60ln -s ./NEWS ChangeLog
61
62%build
63
64export CFLAGS="$RPM_OPT_FLAGS"
65%ifnarch x86_64
66# XXX : enable for x86_64 when glibc bug 149284 is fixed!
67export CFLAGS="$CFLAGS -fPIE"
68export LDFLAGS="-pie -Wl,-z,relro,-z,now,-z,noexecstack"
69#"export LDFLAGS="-pie -Wl,-z,relro,-z,now,-z,noexecstack,-z,nodlopen"
70#Also in case of i686, nodlopen causes the problem.
71%endif
72
73%configure \
74        --with-pkgconfdir=%{_sysconfdir}/netatalk \
75        --with-cracklib \
76        --with-pam \
77        --with-shadow \
78        --with-uams-path=%{_libdir}/netatalk \
79        --enable-shared \
80        --enable-krbV-uam \
81        --enable-overwrite \
82        --with-gnu-ld \
83        --with-init-style=redhat-sysv \
84        --with-libgcrypt \
85        --without-libevent \
86        --without-tdb \
87        --with-pam-confdir=%{_sysconfdir}/pam.d \
88        --with-dbus-sysconf-dir=%{_sysconfdir}/dbus-1/system.d
89
90make %{?_smp_mflags} all
91
92%install
93### INSTALL (USING "make install") ###
94rm -rf ${RPM_BUILD_ROOT}
95
96make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
97
98# install example config files in doc
99mkdir config.example
100cp -fp config/afp.conf config.example
101cp -fp config/extmap.conf config.example
102mkdir -p $RPM_BUILD_ROOT/usr/share/netatalk
103
104cp -fp %{SOURCE1} config.example
105# XXX bad hack until this file is updated in glibc-headers:
106rm -f $RPM_BUILD_ROOT/usr/include/netatalk/at.h
107
108# Clean up .a and .la files
109find $RPM_BUILD_ROOT -name \*.a -exec rm {} \;
110find $RPM_BUILD_ROOT -name \*.la -exec rm {} \;
111
112%post
113if [ -e /etc/netatalk/afp_signature.conf -a ! -e /var/netatalk/afp_signature.conf ]; then
114        mv -f /etc/netatalk/afp_signature.conf /var/netatalk/
115fi
116if [ -e /etc/netatalk/afp_voluuid.conf -a ! -e /var/netatalk/afp_voluuid.conf ]; then
117        mv -f /etc/netatalk/afp_voluuid.conf /var/netatalk/
118fi
119/sbin/chkconfig --add netatalk
120/sbin/ldconfig
121
122%preun
123if [ "$1" = "0" ] ; then
124  # check for existence due to renaming initscript
125  if [ -x  %{_initrddir}/netatalk ] ; then
126    /sbin/service netatalk stop > /dev/null 2>&1
127    /sbin/chkconfig --del netatalk
128  fi
129fi
130
131%postun
132if [ "$1" -ge "1" ]; then
133        # Package upgrade, not uninstall
134        if [ -e /etc/netatalk/afp_signature.conf -a ! -e /var/netatalk/afp_signature.conf ]; then
135                mv -f /etc/netatalk/afp_signature.conf /var/netatalk/
136        fi
137        if [ -e /etc/netatalk/afp_voluuid.conf -a ! -e /var/netatalk/afp_voluuid.conf ]; then
138                mv -f /etc/netatalk/afp_voluuid.conf /var/netatalk/
139        fi
140  /sbin/service netatalk condrestart > /dev/null 2>&1 || :
141fi
142/sbin/ldconfig
143
144%clean
145rm -rf ${RPM_BUILD_ROOT}
146
147
148%files
149%defattr(-,root,root)
150%doc COPYRIGHT COPYING ChangeLog VERSION NEWS
151%doc config.example
152%attr(755,root,root) %{_initrddir}/netatalk
153%dir %{_sysconfdir}/netatalk
154%config(noreplace) %{_sysconfdir}/netatalk/afp.conf
155%config(noreplace) %{_sysconfdir}/netatalk/extmap.conf
156%config(noreplace) %{_sysconfdir}/netatalk/dbus-session.conf
157%config(noreplace) %{_sysconfdir}/pam.d/netatalk
158%config(noreplace) %{_sysconfdir}/dbus-1/system.d/netatalk-dbus.conf
159%{_sbindir}/*
160%{_bindir}/*
161%exclude %{_bindir}/netatalk-config
162%{_mandir}/man*/*
163%exclude %{_mandir}/man*/netatalk-config*
164%{_datadir}/netatalk
165%{_libdir}/*.so
166%{_libdir}/*.so.*
167%dir %{_libdir}/netatalk
168%{_libdir}/netatalk/*.so
169%{_localstatedir}/netatalk
170
171%files devel
172%defattr(-,root,root)
173%doc COPYRIGHT COPYING
174%dir %{_includedir}/atalk
175%attr(0644,root,root) %{_includedir}/atalk/*
176%{_datadir}/aclocal/netatalk.m4
177%{_bindir}/netatalk-config
178%{_mandir}/man*/netatalk-config.1*
179
180%changelog
181* Tue Jun 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.7-1
182- new upstream release.
183
184* Mon Dec  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.2.2-2
185- rebuilt with libgcrypt 1.6.0 and libdb 5.3.28
186
187* Thu Apr 26 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.2.2-1
188- new upstream release.
189- added build option 'force_uidgid'.
190
191* Sun Sep 18 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.1-1
192- new upstream release
193- fix configure options; add missing BRs
194
195* Thu Jul 28 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-3
196- now back from the upstream confusion (and one more or two...)
197  new upstream release 2.2.0 at the official site
198
199* Mon Jul 25 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-2
200- fix Patch10 to follow HAT-san's strong and confident objection
201  (no need to set ATALK_NAME explicitly in netatalk.conf)
202
203* Sat Jul 23 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-1
204- new upstream release (at http://www003.upp.so-net.ne.jp/hat/netatalk/)
205- add Source100 to add one missing header file in the tarball
206- revise Patch10
207- explicitly specify --disable-ddp for the first time
208
209* Wed May 04 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.5-1
210- new upstream release
211
212* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.3-3
213- rebuild with openssl-1.0.0c
214
215* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-2
216- fix Patch10 & update description - upon HAT-san's suggestions
217
218* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-1
219- new upstream release
220- update Vine patch
221
222* Thu Feb 11 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.5-1
223- new upstream release
224
225* Sun May 31 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
226- new upstream release
227
228* Sun Mar  8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.3-7
229- rebuilt both for VineSeed / VinePlus-4.0
230
231* Fri Jul 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-6
232- updated to the cjk-6 patch
233- Patch11/12 updated - VineSeed is now set with ja_JP.UTF-8 locale
234- Patch14 updated for db46
235
236* Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-5
237- remove openslp dependency
238
239* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-4
240- add Patch11 for Vine's default setting (volcharset:EUC-JP, etc.)
241- TODO: remember to revise this fix after VineSeed changes default locale
242        from ja_JP.eucJP (current) to ja_JP.UTF-8 (near future)
243
244* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-3
245- revise description (thanks HAT-san for pointing this out)
246- run libtoolize/aclocal/auto{make,conf,header} before doing configure
247  (without this, uams_* modules won't get .so suffix)
248
249* Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-2
250- Patch10 updated; dropped Patch11, Patch12, Source10 and Source11
251  (Patch10 now includes all the modifications and more fixes)
252
253* Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.3-1
254- add patch13 and patch14 for db-4.3.
255- move files in %%_libexecdir to %%libdir.
256
257* Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-0vl1
258- updated to 2.0.3 release w/ cjk patches (see the above Patch section)
259
260* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
261- security fix: added Patch10 (CAN-2004-0974)
262
263* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
264- configure --with-cnid-default-backend=dbd (cdb seems to be unstable)
265
266* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl1
267- updated to 2.0 with cjk patch
268  (see the above Patch section for details)
269
270* Tue May 28 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl4
271- merge the patch repairing bug for System 7.5.5
272- (patch6 netatalk-1.5.3.oldsys.patch)
273- made by Akihiro Okamaoto <med012@art.osaka-med.ac.jp>
274- patch6 addupted no matter noeuc is, license GPL, URL in comment
275
276* Sat Apr 27 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl3
277- euc and kana patch originally by
278- Akihiro Okamoto <med012@art.osaka-med.ac.jp> against netatalk-1.4b2+asun2.1.3
279- applied to netatalk-1.5.2 by me
280- README.vine
281- omit VERSION from doc, omit perl from require
282
283* Wed Apr 24 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl2
284- this package is removed because the release number duplicated
285
286* Mon Apr 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl2
287- move acleandir.rc to the doc directory, remove executable flag.
288
289* Sun Mar 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl1
290- updated to new upstream release
291
292* Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 1.5.2-0vl3
293- added Japanese Summary for devel and corrected Group
294
295* Thu Feb 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl2
296- Oops, check /var/lock/atalkd instead of /var/run/atd.pid
297  (say atd.pid doesn't have anything to do with netatalk!!)
298
299* Tue Feb 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl1
300- updated to new upstream release
301
302* Thu Feb 07 2002 Toru Sagami <sagami@vinelinux.org> 1.5.1.1-0vl3
303- install man pages into %%{_mandir}
304- PreReq: /sbin/chkconfig /sbin/ldconfig grep textutils
305- let pre script exit 0
306
307* Thu Feb 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.1.1-0vl2
308- spec cleanup
309- backup old prefs directory (/etc/atalk -> /etc/netatalk/00OLD_VERSION_PREFS)
310- restart atalk daemons in the %%post section
311
312* Sun Feb 3 2002  k hanai <hanai@koto.kpu-m.ac.jp>
313 - v1.5.1.1-0vl1
314
315* Fri Jan 25 2002 k hanai <hanai@koto.kpu-m.ac.jp>
316  - v1.5.0-0vl1
317  - release 1.5.0 for sourceforge
318
319* Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
320  - v1.5pre6-1rh7
321  - pre-release 6 for sourceforge
322
323* Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
324  - v1.5pre5-1
325  - pre-release 5 for sourceforge
326
327* Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
328  - v1.5pre5-0
329  - pre-release 5 for sourceforge (prebuild)
330
331* Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
332  - v1.5pre4-1
333  - pre-release 4 for sourceforge
334  - modified/split mandrake spec for redhat 7 build
335
336* Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
337  - v1.5pre3-1mdk
338  - pre-release 3 for sourceforge
339  - moved away from 1.4.99 ...
340
341* Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
342  - v1.4.99-0.20001108mdk
343  - pre-release 2 for sourceforge
344
345* Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
346  - v1.4.99-0.20000927mdk
347  - pre-release 1 for sourceforge
Note: See TracBrowser for help on using the repository browser.