source: projects/specs/trunk/n/netatalk/netatalk-vl.spec @ 9127

Revision 9127, 11.0 KB checked in by inagaki, 9 years ago (diff)

2014-12-01 Ryoichi INAGAKI <ryo1@…>

  • iksemel, netatalk: rebuilt
  • samba: updated Group


Line 
1%bcond_with force_uidgid
2%define rel_suffix %{?with_force_uidgid:.force_uidgid}
3
4%define _sysconfdir     /etc
5
6################################################# BASIC PACKAGE INFORMATION
7Summary:       AppleTalk and AppleShare/IP services for Linux
8Summary(ja):   Linux 用 AppleTalk, AppleShare/IP サービス
9Name:          netatalk
10Version:       2.2.2
11Release:       2%{_dist_release}%{rel_suffix}
12License:       GPLv2+
13Group:         System Environment/Daemons
14URL:           http://netatalk.sourceforge.net/
15
16Source0:       %{name}-%{version}.tar.bz2
17# patch for default config file
18Patch10:       netatalk-2.2.0-config-utf8.patch
19
20############################################################## REQUIREMENTS
21Requires(pre): chkconfig, /sbin/ldconfig, grep, textutils
22Requires:      cracklib, openssl, tcp_wrappers, pam, perl
23BuildRequires: openssl-devel, avahi-devel, pam-devel, libdb-devel,
24BuildRequires: quota, libgcrypt-devel, libacl-devel
25
26BuildRoot:     %{_tmppath}/%{name}-%{version}-root
27
28Obsoletes:     netatalk-1.4b2+asun
29
30Vendor:        Project Vine
31Distribution:  Vine Linux
32Packager:      shaolin
33
34
35%description
36Netatalk is a freely-available Open Source AFP fileserver. It also provides a
37kernel level implementation of the AppleTalk Protocol Suite. A *NIX/*BSD system
38running Netatalk is capable of serving many Macintosh clients simultaneously
39as an AppleShare file server (AFP), AppleTalk router, *NIX/*BSD print server,
40and for accessing AppleTalk printers via Printer Access Protocol (PAP).
41Included are a number of minor printing and debugging utilities.
42
43%description -l ja
44このパッケージを使うことで, Linux 上で AppleTalk プロトコルを
45扱うことができ, Macintosh と通信が可能になります.
46Linux 上で AppleTalk や AFP over TCP の Mac 向けファイルサーバを
47稼働させることができるデーモンプログラムが収められています.
48
49
50%package devel
51Group:         Development/Libraries
52Summary:       Headers for AppleTalk development
53Summary(ja):   AppleTalk 開発用ヘッダファイル
54
55%description devel
56This package contains the header files for building AppleTalk networking
57programs.
58
59
60%prep
61%setup -q
62
63%patch10 -p1 -b .cjk-config
64
65%if %{with force_uidgid}
66perl -pi -e 's/uid_t uid$/uid_t uid;/' etc/afpd/uid.c
67%endif
68
69%build
70touch AUTHORS
71ln -s NEWS ChangeLog
72rm -f README.cjk4.cjk
73
74libtoolize --force
75aclocal -I macros
76automake --add-missing
77autoconf
78autoheader
79CFLAGS="${RPM_OPT_FLAGS} -fomit-frame-pointer -fsigned-char" \
80./configure \
81        --prefix=%{_prefix} \
82        --libdir=%{_libdir} \
83        --libexecdir=%{_libdir}/netatalk \
84        --sysconfdir=%{_sysconfdir} \
85        --mandir=%{_mandir} \
86        --localstatedir=%{_var} \
87        --enable-shared \
88        --enable-zeroconf \
89        --disable-srvloc \
90        --disable-ddp \
91        --with-cnid-dbd-backend \
92        --with-cnid-cdb-backend \
93        --with-cnid-default-backend=dbd \
94        --with-uams-path=%{_libdir}/netatalk \
95        --enable-redhat-sysv \
96        --with-cracklib \
97        --with-pam \
98        --with-shadow \
99        --enable-tcp-wrappers \
100        --with-acls \
101        --enable-pgp-uam \
102%if %{with force_uidgid}
103        --enable-force-uidgid
104%endif
105
106
107make all
108
109
110%install
111### INSTALL (USING "make install") ###
112rm -rf ${RPM_BUILD_ROOT}
113mkdir -p ${RPM_BUILD_ROOT}{%{_prefix},%{_sysconfdir}/netatalk/msg}
114make DESTDIR=$RPM_BUILD_ROOT install
115
116## netatalk/at.h is now provided by glibc
117rm -f $RPM_BUILD_ROOT%{_prefix}/include/netatalk/at.h
118
119## for Bonjour (requires nss-mdns)
120#install -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services
121#install -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services/
122
123
124%pre
125### COPY OLD PREFERENCE FILES ###
126
127if [ -d /etc/atalk ] ; then
128    mkdir -p /etc/netatalk/
129    cp -a /etc/atalk /etc/netatalk/00_OLD_VERSION_PREFS
130fi
131exit 0
132
133
134%post
135
136### RUN CHKCONFIG ###
137/sbin/chkconfig --add netatalk
138
139/sbin/ldconfig
140
141if test -r /var/lock/atalkd ; then
142        /etc/rc.d/init.d/netatalk restart >&2
143fi
144
145
146%preun
147
148### RUN CHKCONFIG ###
149/sbin/chkconfig --del netatalk
150
151
152%triggerpostun -- netatalk <= 1.4b2+asun2.1.3-7vl6
153/sbin/chkconfig --add netatalk
154
155
156%clean
157rm -rf ${RPM_BUILD_ROOT}
158
159
160%files
161%defattr(-,root,root)
162%doc AUTHORS CONTRIBUTORS COPYING COPYRIGHT
163%doc ChangeLog NEWS
164%doc doc/[A-L,N-Z]*
165%config(noreplace) /etc/netatalk/Apple*
166%config(noreplace) /etc/netatalk/*.conf
167%config /etc/pam.d/netatalk
168%config /etc/rc.d/init.d/netatalk
169%dir %{_sysconfdir}/netatalk
170%dir %{_sysconfdir}/netatalk/msg
171#%{_sysconfdir}/avahi/services/afpd.service
172%{_bindir}/*
173%{_sbindir}/*
174%{_libdir}/netatalk/*
175%exclude %{_libdir}/netatalk/*.a
176%exclude %{_libdir}/netatalk/*.la
177%{_mandir}/*/*
178
179
180%files devel
181%defattr(-,root,root)
182%{_libdir}/*.a
183%{_libdir}/*.la
184%{_libdir}/netatalk/*.a
185%{_libdir}/netatalk/*.la
186%dir %{_includedir}/atalk
187%{_includedir}/atalk/*.h
188%dir %{_includedir}/netatalk
189%{_includedir}/netatalk/*.h
190%{_datadir}/aclocal/netatalk.m4
191
192
193%changelog
194* Mon Dec  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.2.2-2
195- rebuilt with libgcrypt 1.6.0 and libdb 5.3.28
196
197* Thu Apr 26 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.2.2-1
198- new upstream release.
199- added build option 'force_uidgid'.
200
201* Sun Sep 18 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.1-1
202- new upstream release
203- fix configure options; add missing BRs
204
205* Thu Jul 28 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-3
206- now back from the upstream confusion (and one more or two...)
207  new upstream release 2.2.0 at the official site
208
209* Mon Jul 25 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-2
210- fix Patch10 to follow HAT-san's strong and confident objection
211  (no need to set ATALK_NAME explicitly in netatalk.conf)
212
213* Sat Jul 23 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-1
214- new upstream release (at http://www003.upp.so-net.ne.jp/hat/netatalk/)
215- add Source100 to add one missing header file in the tarball
216- revise Patch10
217- explicitly specify --disable-ddp for the first time
218
219* Wed May 04 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.5-1
220- new upstream release
221
222* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.3-3
223- rebuild with openssl-1.0.0c
224
225* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-2
226- fix Patch10 & update description - upon HAT-san's suggestions
227
228* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-1
229- new upstream release
230- update Vine patch
231
232* Thu Feb 11 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.5-1
233- new upstream release
234
235* Sun May 31 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
236- new upstream release
237
238* Sun Mar  8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.3-7
239- rebuilt both for VineSeed / VinePlus-4.0
240
241* Fri Jul 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-6
242- updated to the cjk-6 patch
243- Patch11/12 updated - VineSeed is now set with ja_JP.UTF-8 locale
244- Patch14 updated for db46
245
246* Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-5
247- remove openslp dependency
248
249* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-4
250- add Patch11 for Vine's default setting (volcharset:EUC-JP, etc.)
251- TODO: remember to revise this fix after VineSeed changes default locale
252        from ja_JP.eucJP (current) to ja_JP.UTF-8 (near future)
253
254* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-3
255- revise description (thanks HAT-san for pointing this out)
256- run libtoolize/aclocal/auto{make,conf,header} before doing configure
257  (without this, uams_* modules won't get .so suffix)
258
259* Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-2
260- Patch10 updated; dropped Patch11, Patch12, Source10 and Source11
261  (Patch10 now includes all the modifications and more fixes)
262
263* Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.3-1
264- add patch13 and patch14 for db-4.3.
265- move files in %%_libexecdir to %%libdir.
266
267* Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-0vl1
268- updated to 2.0.3 release w/ cjk patches (see the above Patch section)
269
270* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
271- security fix: added Patch10 (CAN-2004-0974)
272
273* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
274- configure --with-cnid-default-backend=dbd (cdb seems to be unstable)
275
276* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl1
277- updated to 2.0 with cjk patch
278  (see the above Patch section for details)
279
280* Tue May 28 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl4
281- merge the patch repairing bug for System 7.5.5
282- (patch6 netatalk-1.5.3.oldsys.patch)
283- made by Akihiro Okamaoto <med012@art.osaka-med.ac.jp>
284- patch6 addupted no matter noeuc is, license GPL, URL in comment
285
286* Sat Apr 27 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl3
287- euc and kana patch originally by
288- Akihiro Okamoto <med012@art.osaka-med.ac.jp> against netatalk-1.4b2+asun2.1.3
289- applied to netatalk-1.5.2 by me
290- README.vine
291- omit VERSION from doc, omit perl from require
292
293* Wed Apr 24 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl2
294- this package is removed because the release number duplicated
295
296* Mon Apr 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl2
297- move acleandir.rc to the doc directory, remove executable flag.
298
299* Sun Mar 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl1
300- updated to new upstream release
301
302* Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 1.5.2-0vl3
303- added Japanese Summary for devel and corrected Group
304
305* Thu Feb 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl2
306- Oops, check /var/lock/atalkd instead of /var/run/atd.pid
307  (say atd.pid doesn't have anything to do with netatalk!!)
308
309* Tue Feb 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl1
310- updated to new upstream release
311
312* Thu Feb 07 2002 Toru Sagami <sagami@vinelinux.org> 1.5.1.1-0vl3
313- install man pages into %%{_mandir}
314- PreReq: /sbin/chkconfig /sbin/ldconfig grep textutils
315- let pre script exit 0
316
317* Thu Feb 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.1.1-0vl2
318- spec cleanup
319- backup old prefs directory (/etc/atalk -> /etc/netatalk/00OLD_VERSION_PREFS)
320- restart atalk daemons in the %%post section
321
322* Sun Feb 3 2002  k hanai <hanai@koto.kpu-m.ac.jp>
323 - v1.5.1.1-0vl1
324
325* Fri Jan 25 2002 k hanai <hanai@koto.kpu-m.ac.jp>
326  - v1.5.0-0vl1
327  - release 1.5.0 for sourceforge
328
329* Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
330  - v1.5pre6-1rh7
331  - pre-release 6 for sourceforge
332
333* Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
334  - v1.5pre5-1
335  - pre-release 5 for sourceforge
336
337* Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
338  - v1.5pre5-0
339  - pre-release 5 for sourceforge (prebuild)
340
341* Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
342  - v1.5pre4-1
343  - pre-release 4 for sourceforge
344  - modified/split mandrake spec for redhat 7 build
345
346* Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
347  - v1.5pre3-1mdk
348  - pre-release 3 for sourceforge
349  - moved away from 1.4.99 ...
350
351* Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
352  - v1.4.99-0.20001108mdk
353  - pre-release 2 for sourceforge
354
355* Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
356  - v1.4.99-0.20000927mdk
357  - pre-release 1 for sourceforge
Note: See TracBrowser for help on using the repository browser.