source: projects/specs/trunk/n/netatalk/netatalk-vl.spec @ 4776

Revision 4776, 10.5 KB checked in by shaolin, 13 years ago (diff)
  • netatalk: new upstream release; fix configure options; add missing BRs
Line 
1%define _sysconfdir     /etc
2
3################################################# BASIC PACKAGE INFORMATION
4Summary:       AppleTalk and AppleShare/IP services for Linux
5Summary(ja):   Linux 用 AppleTalk, AppleShare/IP サービス
6Name:          netatalk
7Version:       2.2.1
8Release:       1%{_dist_release}
9License:       GPLv2+
10Group:         System Environment/Daemons
11Source0:       %{name}-%{version}.tar.bz2
12URL:           http://netatalk.sourceforge.net/
13Obsoletes:     netatalk-1.4b2+asun
14
15# patch for default config file
16Patch10:       netatalk-2.2.0-config-utf8.patch
17
18
19############################################################## REQUIREMENTS
20Requires(pre): chkconfig, /sbin/ldconfig, grep, textutils
21Requires:      cracklib, openssl, tcp_wrappers, pam, perl
22BuildRequires: openssl-devel, avahi-devel, pam-devel, db4-devel,
23BuildRequires: quota, libgcrypt-devel, libacl-devel
24
25BuildRoot:     %{_tmppath}/%{name}-%{version}-root
26
27Vendor:        Project Vine
28Distribution:  Vine Linux
29Packager:      shaolin
30
31
32%description
33Netatalk is a freely-available Open Source AFP fileserver. It also provides a
34kernel level implementation of the AppleTalk Protocol Suite. A *NIX/*BSD system
35running Netatalk is capable of serving many Macintosh clients simultaneously
36as an AppleShare file server (AFP), AppleTalk router, *NIX/*BSD print server,
37and for accessing AppleTalk printers via Printer Access Protocol (PAP).
38Included are a number of minor printing and debugging utilities.
39
40%description -l ja
41このパッケージを使うことで, Linux 上で AppleTalk プロトコルを
42扱うことができ, Macintosh と通信が可能になります.
43Linux 上で AppleTalk や AFP over TCP の Mac 向けファイルサーバを
44稼働させることができるデーモンプログラムが収められています.
45
46
47%package devel
48Group:         Development/Libraries
49Summary:       Headers for AppleTalk development
50Summary(ja):   AppleTalk 開発用ヘッダファイル
51
52%description devel
53This package contains the header files for building AppleTalk networking
54programs.
55
56
57%prep
58%setup -q
59
60%patch10 -p1 -b .cjk-config
61
62
63%build
64touch AUTHORS
65ln -s NEWS ChangeLog
66rm -f README.cjk4.cjk
67
68libtoolize --force
69aclocal -I macros
70automake --add-missing
71autoconf
72autoheader
73CFLAGS="${RPM_OPT_FLAGS} -fomit-frame-pointer -fsigned-char" \
74./configure \
75        --prefix=%{_prefix} \
76        --libdir=%{_libdir} \
77        --libexecdir=%{_libdir}/netatalk \
78        --sysconfdir=%{_sysconfdir} \
79        --mandir=%{_mandir} \
80        --localstatedir=%{_var} \
81        --enable-shared \
82        --enable-zeroconf \
83        --disable-srvloc \
84        --disable-ddp \
85        --with-cnid-dbd-backend \
86        --with-cnid-cdb-backend \
87        --with-cnid-default-backend=dbd \
88        --with-uams-path=%{_libdir}/netatalk \
89        --enable-redhat-sysv \
90        --with-cracklib \
91        --with-pam \
92        --with-shadow \
93        --enable-tcp-wrappers \
94        --with-acls \
95        --enable-pgp-uam
96
97make all
98
99
100%install
101### INSTALL (USING "make install") ###
102rm -rf ${RPM_BUILD_ROOT}
103mkdir -p ${RPM_BUILD_ROOT}{%{_prefix},%{_sysconfdir}/netatalk/msg}
104make DESTDIR=$RPM_BUILD_ROOT install
105
106## netatalk/at.h is now provided by glibc
107rm -f $RPM_BUILD_ROOT%{_prefix}/include/netatalk/at.h
108
109## for Bonjour (requires nss-mdns)
110#install -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services
111#install -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services/
112
113
114%pre
115### COPY OLD PREFERENCE FILES ###
116
117if [ -d /etc/atalk ] ; then
118    mkdir -p /etc/netatalk/
119    cp -a /etc/atalk /etc/netatalk/00_OLD_VERSION_PREFS
120fi
121exit 0
122
123
124%post
125
126### RUN CHKCONFIG ###
127/sbin/chkconfig --add netatalk
128
129/sbin/ldconfig
130
131if test -r /var/lock/atalkd ; then
132        /etc/rc.d/init.d/netatalk restart >&2
133fi
134
135
136%preun
137
138### RUN CHKCONFIG ###
139/sbin/chkconfig --del netatalk
140
141
142%triggerpostun -- netatalk <= 1.4b2+asun2.1.3-7vl6
143/sbin/chkconfig --add netatalk
144
145
146%clean
147rm -rf ${RPM_BUILD_ROOT}
148
149
150%files
151%defattr(-,root,root)
152%doc AUTHORS CONTRIBUTORS COPYING COPYRIGHT
153%doc ChangeLog NEWS
154%doc doc/[A-L,N-Z]*
155%config(noreplace) /etc/netatalk/Apple*
156%config(noreplace) /etc/netatalk/*.conf
157%config /etc/pam.d/netatalk
158%config /etc/rc.d/init.d/netatalk
159%dir %{_sysconfdir}/netatalk
160%dir %{_sysconfdir}/netatalk/msg
161#%{_sysconfdir}/avahi/services/afpd.service
162%{_bindir}/*
163%{_sbindir}/*
164%{_libdir}/netatalk/*
165%exclude %{_libdir}/netatalk/*.a
166%exclude %{_libdir}/netatalk/*.la
167%{_mandir}/*/*
168
169
170%files devel
171%defattr(-,root,root)
172%{_libdir}/*.a
173%{_libdir}/*.la
174%{_libdir}/netatalk/*.a
175%{_libdir}/netatalk/*.la
176%dir %{_includedir}/atalk
177%{_includedir}/atalk/*.h
178%dir %{_includedir}/netatalk
179%{_includedir}/netatalk/*.h
180%{_datadir}/aclocal/netatalk.m4
181
182
183%changelog
184* Sun Sep 18 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.1-1
185- new upstream release
186- fix configure options; add missing BRs
187
188* Thu Jul 28 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-3
189- now back from the upstream confusion (and one more or two...)
190  new upstream release 2.2.0 at the official site
191
192* Mon Jul 25 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-2
193- fix Patch10 to follow HAT-san's strong and confident objection
194  (no need to set ATALK_NAME explicitly in netatalk.conf)
195
196* Sat Jul 23 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-1
197- new upstream release (at http://www003.upp.so-net.ne.jp/hat/netatalk/)
198- add Source100 to add one missing header file in the tarball
199- revise Patch10
200- explicitly specify --disable-ddp for the first time
201
202* Wed May 04 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.5-1
203- new upstream release
204
205* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.3-3
206- rebuild with openssl-1.0.0c
207
208* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-2
209- fix Patch10 & update description - upon HAT-san's suggestions
210
211* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-1
212- new upstream release
213- update Vine patch
214
215* Thu Feb 11 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.5-1
216- new upstream release
217
218* Sun May 31 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
219- new upstream release
220
221* Sun Mar  8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.3-7
222- rebuilt both for VineSeed / VinePlus-4.0
223
224* Fri Jul 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-6
225- updated to the cjk-6 patch
226- Patch11/12 updated - VineSeed is now set with ja_JP.UTF-8 locale
227- Patch14 updated for db46
228
229* Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-5
230- remove openslp dependency
231
232* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-4
233- add Patch11 for Vine's default setting (volcharset:EUC-JP, etc.)
234- TODO: remember to revise this fix after VineSeed changes default locale
235        from ja_JP.eucJP (current) to ja_JP.UTF-8 (near future)
236
237* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-3
238- revise description (thanks HAT-san for pointing this out)
239- run libtoolize/aclocal/auto{make,conf,header} before doing configure
240  (without this, uams_* modules won't get .so suffix)
241
242* Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-2
243- Patch10 updated; dropped Patch11, Patch12, Source10 and Source11
244  (Patch10 now includes all the modifications and more fixes)
245
246* Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.3-1
247- add patch13 and patch14 for db-4.3.
248- move files in %%_libexecdir to %%libdir.
249
250* Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-0vl1
251- updated to 2.0.3 release w/ cjk patches (see the above Patch section)
252
253* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
254- security fix: added Patch10 (CAN-2004-0974)
255
256* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
257- configure --with-cnid-default-backend=dbd (cdb seems to be unstable)
258
259* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl1
260- updated to 2.0 with cjk patch
261  (see the above Patch section for details)
262
263* Tue May 28 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl4
264- merge the patch repairing bug for System 7.5.5
265- (patch6 netatalk-1.5.3.oldsys.patch)
266- made by Akihiro Okamaoto <med012@art.osaka-med.ac.jp>
267- patch6 addupted no matter noeuc is, license GPL, URL in comment
268
269* Sat Apr 27 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl3
270- euc and kana patch originally by
271- Akihiro Okamoto <med012@art.osaka-med.ac.jp> against netatalk-1.4b2+asun2.1.3
272- applied to netatalk-1.5.2 by me
273- README.vine
274- omit VERSION from doc, omit perl from require
275
276* Wed Apr 24 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl2
277- this package is removed because the release number duplicated
278
279* Mon Apr 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl2
280- move acleandir.rc to the doc directory, remove executable flag.
281
282* Sun Mar 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl1
283- updated to new upstream release
284
285* Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 1.5.2-0vl3
286- added Japanese Summary for devel and corrected Group
287
288* Thu Feb 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl2
289- Oops, check /var/lock/atalkd instead of /var/run/atd.pid
290  (say atd.pid doesn't have anything to do with netatalk!!)
291
292* Tue Feb 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl1
293- updated to new upstream release
294
295* Thu Feb 07 2002 Toru Sagami <sagami@vinelinux.org> 1.5.1.1-0vl3
296- install man pages into %%{_mandir}
297- PreReq: /sbin/chkconfig /sbin/ldconfig grep textutils
298- let pre script exit 0
299
300* Thu Feb 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.1.1-0vl2
301- spec cleanup
302- backup old prefs directory (/etc/atalk -> /etc/netatalk/00OLD_VERSION_PREFS)
303- restart atalk daemons in the %%post section
304
305* Sun Feb 3 2002  k hanai <hanai@koto.kpu-m.ac.jp>
306 - v1.5.1.1-0vl1
307
308* Fri Jan 25 2002 k hanai <hanai@koto.kpu-m.ac.jp>
309  - v1.5.0-0vl1
310  - release 1.5.0 for sourceforge
311
312* Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
313  - v1.5pre6-1rh7
314  - pre-release 6 for sourceforge
315
316* Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
317  - v1.5pre5-1
318  - pre-release 5 for sourceforge
319
320* Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
321  - v1.5pre5-0
322  - pre-release 5 for sourceforge (prebuild)
323
324* Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
325  - v1.5pre4-1
326  - pre-release 4 for sourceforge
327  - modified/split mandrake spec for redhat 7 build
328
329* Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
330  - v1.5pre3-1mdk
331  - pre-release 3 for sourceforge
332  - moved away from 1.4.99 ...
333
334* Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
335  - v1.4.99-0.20001108mdk
336  - pre-release 2 for sourceforge
337
338* Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
339  - v1.4.99-0.20000927mdk
340  - pre-release 1 for sourceforge
Note: See TracBrowser for help on using the repository browser.