source: projects/specs/trunk/n/netatalk/netatalk-vl.spec @ 4407

Revision 4407, 10.6 KB checked in by shaolin, 13 years ago (diff)
  • netatalk: update Patch10
Line 
1%define _sysconfdir     /etc
2
3################################################# BASIC PACKAGE INFORMATION
4Summary:       AppleTalk and AppleShare/IP services for Linux
5Summary(ja):   Linux 用 AppleTalk, AppleShare/IP サービス
6Name:          netatalk
7Version:       2.2.0
8Release:       2%{_dist_release}
9License:       GPLv2+
10Group:         System Environment/Daemons
11## this version 2.2.0 obtained at:
12## http://www003.upp.so-net.ne.jp/hat/netatalk/
13Source0:       %{name}-%{version}.tar.bz2
14## the above tarball somewhat misses the following header file
15## this extracted from https://github.com/jrmithdobbs/netatalk-2-2-0-p6
16## commit 6e40f7d3bdf47b6356e0
17Source100:     jrmithdobbs-netatalk-2-2-0-p6-6e40f7d_fce_api_internal.h
18URL:           http://netatalk.sourceforge.net/
19Obsoletes:     netatalk-1.4b2+asun
20
21# patch for default config file
22Patch10:       netatalk-2.2.0-config-utf8.patch
23
24
25############################################################## REQUIREMENTS
26Requires(pre): chkconfig, /sbin/ldconfig, grep, textutils
27Requires:      cracklib, openssl, tcp_wrappers, pam, perl
28BuildRequires: openssl-devel, avahi-devel, pam-devel, db4-devel, quota
29
30BuildRoot:     %{_tmppath}/%{name}-%{version}-root
31
32Vendor:        Project Vine
33Distribution:  Vine Linux
34Packager:      shaolin
35
36
37%description
38Netatalk is a freely-available Open Source AFP fileserver. It also provides a
39kernel level implementation of the AppleTalk Protocol Suite. A *NIX/*BSD system
40running Netatalk is capable of serving many Macintosh clients simultaneously
41as an AppleShare file server (AFP), AppleTalk router, *NIX/*BSD print server,
42and for accessing AppleTalk printers via Printer Access Protocol (PAP).
43Included are a number of minor printing and debugging utilities.
44
45%description -l ja
46このパッケージを使うことで, Linux 上で AppleTalk プロトコルを
47扱うことができ, Macintosh と通信が可能になります.
48Linux 上で AppleTalk や AFP over TCP の Mac 向けファイルサーバを
49稼働させることができるデーモンプログラムが収められています.
50
51
52%package devel
53Group:         Development/Libraries
54Summary:       Headers for AppleTalk development
55Summary(ja):   AppleTalk 開発用ヘッダファイル
56
57%description devel
58This package contains the header files for building AppleTalk networking
59programs.
60
61
62%prep
63%setup -q
64
65%patch10 -p1 -b .cjk-config
66
67if [ ! -f "etc/afpd/fce_api_internal.h" ] ; then
68  install -m 0644 %{SOURCE100} etc/afpd/fce_api_internal.h
69fi
70
71
72%build
73touch AUTHORS
74ln -s NEWS ChangeLog
75rm -f README.cjk4.cjk
76
77libtoolize --force
78aclocal -I macros
79automake --add-missing
80autoconf
81autoheader
82CFLAGS="${RPM_OPT_FLAGS} -fomit-frame-pointer -fsigned-char" \
83./configure \
84        --prefix=%{_prefix} \
85        --libdir=%{_libdir} \
86        --libexecdir=%{_libdir}/netatalk \
87        --sysconfdir=%{_sysconfdir} \
88        --mandir=%{_mandir} \
89        --localstatedir=%{_var} \
90        --enable-shared \
91        --enable-zeroconf \
92        --disable-srvloc \
93        --enable-afp3 --disable-ddp \
94        --with-cnid-dbd-backend \
95        --with-cnid-cdb-backend \
96        --with-cnid-default-backend=dbd \
97        --with-uams-path=%{_libdir}/netatalk \
98        --enable-redhat \
99        --with-cracklib \
100        --with-pam \
101        --with-shadow \
102        --with-tcp-wrappers \
103        --with-ssl \
104        --enable-pgp-uam
105
106make all
107
108
109%install
110### INSTALL (USING "make install") ###
111rm -rf ${RPM_BUILD_ROOT}
112mkdir -p ${RPM_BUILD_ROOT}{%{_prefix},%{_sysconfdir}/netatalk/msg}
113make DESTDIR=$RPM_BUILD_ROOT install
114
115## netatalk/at.h is now provided by glibc
116rm -f $RPM_BUILD_ROOT%{_prefix}/include/netatalk/at.h
117
118## for Bonjour (requires nss-mdns)
119#install -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services
120#install -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}%{_sysconfdir}/avahi/services/
121
122
123%pre
124### COPY OLD PREFERENCE FILES ###
125
126if [ -d /etc/atalk ] ; then
127    mkdir -p /etc/netatalk/
128    cp -a /etc/atalk /etc/netatalk/00_OLD_VERSION_PREFS
129fi
130exit 0
131
132
133%post
134
135### RUN CHKCONFIG ###
136/sbin/chkconfig --add netatalk
137
138/sbin/ldconfig
139
140if test -r /var/lock/atalkd ; then
141        /etc/rc.d/init.d/netatalk restart >&2
142fi
143
144
145%preun
146
147### RUN CHKCONFIG ###
148/sbin/chkconfig --del netatalk
149
150
151%triggerpostun -- netatalk <= 1.4b2+asun2.1.3-7vl6
152/sbin/chkconfig --add netatalk
153
154
155%clean
156rm -rf ${RPM_BUILD_ROOT}
157
158
159%files
160%defattr(-,root,root)
161%doc AUTHORS CONTRIBUTORS COPYING COPYRIGHT
162%doc ChangeLog NEWS README* TODO
163%doc doc/[A-L,N-Z]*
164%config(noreplace) /etc/netatalk/Apple*
165%config(noreplace) /etc/netatalk/*.conf
166%config /etc/pam.d/netatalk
167%config /etc/rc.d/init.d/netatalk
168%dir %{_sysconfdir}/netatalk
169%dir %{_sysconfdir}/netatalk/msg
170#%{_sysconfdir}/avahi/services/afpd.service
171%{_bindir}/*
172%{_sbindir}/*
173%{_libdir}/netatalk/*
174%exclude %{_libdir}/netatalk/*.a
175%exclude %{_libdir}/netatalk/*.la
176%{_mandir}/*/*
177
178
179%files devel
180%defattr(-,root,root)
181%{_libdir}/*.a
182%{_libdir}/*.la
183%{_libdir}/netatalk/*.a
184%{_libdir}/netatalk/*.la
185%dir %{_includedir}/atalk
186%{_includedir}/atalk/*.h
187%dir %{_includedir}/netatalk
188%{_includedir}/netatalk/*.h
189%{_datadir}/aclocal/netatalk.m4
190
191
192%changelog
193* Mon Jul 25 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-2
194- fix Patch10 to follow HAT-san's strong and confident objection
195  (no need to set ATALK_NAME explicitly in netatalk.conf)
196
197* Sat Jul 23 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-1
198- new upstream release (at http://www003.upp.so-net.ne.jp/hat/netatalk/)
199- add Source100 to add one missing header file in the tarball
200- revise Patch10
201- explicitly specify --disable-ddp for the first time
202
203* Wed May 04 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.5-1
204- new upstream release
205
206* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.3-3
207- rebuild with openssl-1.0.0c
208
209* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-2
210- fix Patch10 & update description - upon HAT-san's suggestions
211
212* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-1
213- new upstream release
214- update Vine patch
215
216* Thu Feb 11 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.5-1
217- new upstream release
218
219* Sun May 31 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
220- new upstream release
221
222* Sun Mar  8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.3-7
223- rebuilt both for VineSeed / VinePlus-4.0
224
225* Fri Jul 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-6
226- updated to the cjk-6 patch
227- Patch11/12 updated - VineSeed is now set with ja_JP.UTF-8 locale
228- Patch14 updated for db46
229
230* Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-5
231- remove openslp dependency
232
233* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-4
234- add Patch11 for Vine's default setting (volcharset:EUC-JP, etc.)
235- TODO: remember to revise this fix after VineSeed changes default locale
236        from ja_JP.eucJP (current) to ja_JP.UTF-8 (near future)
237
238* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-3
239- revise description (thanks HAT-san for pointing this out)
240- run libtoolize/aclocal/auto{make,conf,header} before doing configure
241  (without this, uams_* modules won't get .so suffix)
242
243* Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-2
244- Patch10 updated; dropped Patch11, Patch12, Source10 and Source11
245  (Patch10 now includes all the modifications and more fixes)
246
247* Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.3-1
248- add patch13 and patch14 for db-4.3.
249- move files in %%_libexecdir to %%libdir.
250
251* Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-0vl1
252- updated to 2.0.3 release w/ cjk patches (see the above Patch section)
253
254* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
255- security fix: added Patch10 (CAN-2004-0974)
256
257* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
258- configure --with-cnid-default-backend=dbd (cdb seems to be unstable)
259
260* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl1
261- updated to 2.0 with cjk patch
262  (see the above Patch section for details)
263
264* Tue May 28 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl4
265- merge the patch repairing bug for System 7.5.5
266- (patch6 netatalk-1.5.3.oldsys.patch)
267- made by Akihiro Okamaoto <med012@art.osaka-med.ac.jp>
268- patch6 addupted no matter noeuc is, license GPL, URL in comment
269
270* Sat Apr 27 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl3
271- euc and kana patch originally by
272- Akihiro Okamoto <med012@art.osaka-med.ac.jp> against netatalk-1.4b2+asun2.1.3
273- applied to netatalk-1.5.2 by me
274- README.vine
275- omit VERSION from doc, omit perl from require
276
277* Wed Apr 24 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl2
278- this package is removed because the release number duplicated
279
280* Mon Apr 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl2
281- move acleandir.rc to the doc directory, remove executable flag.
282
283* Sun Mar 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl1
284- updated to new upstream release
285
286* Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 1.5.2-0vl3
287- added Japanese Summary for devel and corrected Group
288
289* Thu Feb 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl2
290- Oops, check /var/lock/atalkd instead of /var/run/atd.pid
291  (say atd.pid doesn't have anything to do with netatalk!!)
292
293* Tue Feb 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl1
294- updated to new upstream release
295
296* Thu Feb 07 2002 Toru Sagami <sagami@vinelinux.org> 1.5.1.1-0vl3
297- install man pages into %%{_mandir}
298- PreReq: /sbin/chkconfig /sbin/ldconfig grep textutils
299- let pre script exit 0
300
301* Thu Feb 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.1.1-0vl2
302- spec cleanup
303- backup old prefs directory (/etc/atalk -> /etc/netatalk/00OLD_VERSION_PREFS)
304- restart atalk daemons in the %%post section
305
306* Sun Feb 3 2002  k hanai <hanai@koto.kpu-m.ac.jp>
307 - v1.5.1.1-0vl1
308
309* Fri Jan 25 2002 k hanai <hanai@koto.kpu-m.ac.jp>
310  - v1.5.0-0vl1
311  - release 1.5.0 for sourceforge
312
313* Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
314  - v1.5pre6-1rh7
315  - pre-release 6 for sourceforge
316
317* Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
318  - v1.5pre5-1
319  - pre-release 5 for sourceforge
320
321* Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
322  - v1.5pre5-0
323  - pre-release 5 for sourceforge (prebuild)
324
325* Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
326  - v1.5pre4-1
327  - pre-release 4 for sourceforge
328  - modified/split mandrake spec for redhat 7 build
329
330* Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
331  - v1.5pre3-1mdk
332  - pre-release 3 for sourceforge
333  - moved away from 1.4.99 ...
334
335* Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
336  - v1.4.99-0.20001108mdk
337  - pre-release 2 for sourceforge
338
339* Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
340  - v1.4.99-0.20000927mdk
341  - pre-release 1 for sourceforge
Note: See TracBrowser for help on using the repository browser.