source: projects/specs/trunk/n/netatalk/netatalk-vl.spec @ 12014

Revision 12014, 12.4 KB checked in by tomop, 5 years ago (diff)

netatalk-3.1.12-1

Line 
1%define _sysconfdir     /etc
2
3################################################# BASIC PACKAGE INFORMATION
4Summary:       AFP fileserver for Macintosh clients
5Summary(ja):   Macintoshクライアント向けのAFPファイルサーバー
6Name:          netatalk
7Version:       3.1.12
8Release:       1%{_dist_release}
9License:       GPLv2+
10Group:         System Environment/Daemons
11URL:           http://netatalk.sourceforge.net/
12
13Source0:       %{name}-%{version}.tar.bz2
14
15Source1:       netatalk.pam-system-auth
16Patch0:        netatalk-3.0.1-basedir.patch
17
18############################################################## REQUIREMENTS
19Requires(post): /sbin/chkconfig /sbin/ldconfig
20Requires(preun): /sbin/chkconfig
21Requires(preun): /sbin/service
22Requires(postun): /sbin/service /sbin/ldconfig
23BuildRequires: cracklib openssl-devel pam quota libtool automake
24BuildRequires: autoconf libdb-devel pam-devel tcp_wrappers libgcrypt-devel
25BuildRequires: avahi-devel libacl-devel openldap-devel
26BuildRequires: dbus-devel dbus-glib-devel glib2-devel systemtap-sdt-devel
27BuildRequires: libevent-devel libtdb-devel libmysqlclient-devel
28
29BuildRoot:     %{_tmppath}/%{name}-%{version}-root
30
31Vendor:        Project Vine
32Distribution:  Vine Linux
33Packager:      shaolin, tomop
34
35%description
36Netatalk is a freely-available Open Source AFP fileserver. A *NIX/*BSD
37system running Netatalk is capable of serving many Macintosh clients
38simultaneously as an AppleShare file server (AFP).
39
40%description -l ja
41 Netatalkは自由に利用可能なオープンソースAFPファイルサーバーです。
42Netatalkを実行している*NIX/*BSDシステムでは、多くのMacintoshクライ
43アントに対してAppleShareファイルサーバー(AFP)としてサービスを提供
44可能です。
45
46%package devel
47Group:         Development/Libraries
48Summary:       Headers for Netatalk development
49Summary(ja):   Netatalk開発用ヘッダファイル
50
51%description devel
52This package contains the header files for Netatalk.
53
54
55%prep
56%setup -q
57
58%patch0 -p1 -b .basedir
59
60ln -s ./NEWS ChangeLog
61
62%build
63
64export CFLAGS="$RPM_OPT_FLAGS"
65%ifnarch x86_64
66# XXX : enable for x86_64 when glibc bug 149284 is fixed!
67export CFLAGS="$CFLAGS -fPIE"
68export LDFLAGS="-pie -Wl,-z,relro,-z,now,-z,noexecstack"
69#"export LDFLAGS="-pie -Wl,-z,relro,-z,now,-z,noexecstack,-z,nodlopen"
70#Also in case of i686, nodlopen causes the problem.
71%endif
72
73%configure \
74        --with-pkgconfdir=%{_sysconfdir}/netatalk \
75        --with-cracklib \
76        --with-pam \
77        --with-shadow \
78        --with-uams-path=%{_libdir}/netatalk \
79        --enable-shared \
80        --enable-krbV-uam \
81        --enable-overwrite \
82        --with-gnu-ld \
83        --with-init-style=redhat-sysv \
84        --with-libgcrypt \
85        --without-libevent \
86        --without-tdb \
87        --with-pam-confdir=%{_sysconfdir}/pam.d \
88        --with-dbus-sysconf-dir=%{_sysconfdir}/dbus-1/system.d
89
90make %{?_smp_mflags} all
91
92%install
93### INSTALL (USING "make install") ###
94rm -rf ${RPM_BUILD_ROOT}
95
96make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
97
98# install example config files in doc
99mkdir config.example
100cp -fp config/afp.conf config.example
101cp -fp config/extmap.conf config.example
102mkdir -p $RPM_BUILD_ROOT/usr/share/netatalk
103
104cp -fp %{SOURCE1} config.example
105# XXX bad hack until this file is updated in glibc-headers:
106rm -f $RPM_BUILD_ROOT/usr/include/netatalk/at.h
107
108# Clean up .a and .la files
109find $RPM_BUILD_ROOT -name \*.a -exec rm {} \;
110find $RPM_BUILD_ROOT -name \*.la -exec rm {} \;
111
112%post
113if [ -e /etc/netatalk/afp_signature.conf -a ! -e /var/netatalk/afp_signature.conf ]; then
114        mv -f /etc/netatalk/afp_signature.conf /var/netatalk/
115fi
116if [ -e /etc/netatalk/afp_voluuid.conf -a ! -e /var/netatalk/afp_voluuid.conf ]; then
117        mv -f /etc/netatalk/afp_voluuid.conf /var/netatalk/
118fi
119/sbin/chkconfig --add netatalk
120/sbin/ldconfig
121
122%preun
123if [ "$1" = "0" ] ; then
124  # check for existence due to renaming initscript
125  if [ -x  %{_initrddir}/netatalk ] ; then
126    /sbin/service netatalk stop > /dev/null 2>&1
127    /sbin/chkconfig --del netatalk
128  fi
129fi
130
131%postun
132if [ "$1" -ge "1" ]; then
133        # Package upgrade, not uninstall
134        if [ -e /etc/netatalk/afp_signature.conf -a ! -e /var/netatalk/afp_signature.conf ]; then
135                mv -f /etc/netatalk/afp_signature.conf /var/netatalk/
136        fi
137        if [ -e /etc/netatalk/afp_voluuid.conf -a ! -e /var/netatalk/afp_voluuid.conf ]; then
138                mv -f /etc/netatalk/afp_voluuid.conf /var/netatalk/
139        fi
140  /sbin/service netatalk condrestart > /dev/null 2>&1 || :
141fi
142/sbin/ldconfig
143
144%clean
145rm -rf ${RPM_BUILD_ROOT}
146
147
148%files
149%defattr(-,root,root)
150%license COPYING COPYRIGHT
151%doc NEWS
152%doc config.example
153%attr(755,root,root) %{_initrddir}/netatalk
154%dir %{_sysconfdir}/netatalk
155%config(noreplace) %{_sysconfdir}/netatalk/afp.conf
156%config(noreplace) %{_sysconfdir}/netatalk/extmap.conf
157%config(noreplace) %{_sysconfdir}/netatalk/dbus-session.conf
158%config(noreplace) %{_sysconfdir}/pam.d/netatalk
159%config(noreplace) %{_sysconfdir}/dbus-1/system.d/netatalk-dbus.conf
160%{_sbindir}/*
161%{_bindir}/*
162%exclude %{_bindir}/netatalk-config
163%{_mandir}/man*/*
164%exclude %{_mandir}/man*/netatalk-config*
165%{_datadir}/netatalk
166%{_libdir}/*.so
167%{_libdir}/*.so.*
168%dir %{_libdir}/netatalk
169%{_libdir}/netatalk/*.so
170%{_localstatedir}/netatalk
171
172%files devel
173%defattr(-,root,root)
174%license COPYING COPYRIGHT
175%dir %{_includedir}/atalk
176%attr(0644,root,root) %{_includedir}/atalk/*
177%{_datadir}/aclocal/netatalk.m4
178%{_bindir}/netatalk-config
179%{_mandir}/man*/netatalk-config.1*
180
181%changelog
182* Mon Jan 07 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.12-1
183- new upstream release.
184
185* Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.11-2
186- rebuilt with openssl-1.1.1 and libevent-2.1.8.
187
188* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.11-1
189- new upstream release.
190
191* Wed Jul 20 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.9-1
192- new upstream release.
193- dropped Patch1: fixed in upstream.
194
195* Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.8-2
196- added Patch1.
197
198* Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.8-1
199- new upstream release.
200
201* Tue Jun 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.7-1
202- new upstream release.
203
204* Mon Dec  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.2.2-2
205- rebuilt with libgcrypt 1.6.0 and libdb 5.3.28
206
207* Thu Apr 26 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.2.2-1
208- new upstream release.
209- added build option 'force_uidgid'.
210
211* Sun Sep 18 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.1-1
212- new upstream release
213- fix configure options; add missing BRs
214
215* Thu Jul 28 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-3
216- now back from the upstream confusion (and one more or two...)
217  new upstream release 2.2.0 at the official site
218
219* Mon Jul 25 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-2
220- fix Patch10 to follow HAT-san's strong and confident objection
221  (no need to set ATALK_NAME explicitly in netatalk.conf)
222
223* Sat Jul 23 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-1
224- new upstream release (at http://www003.upp.so-net.ne.jp/hat/netatalk/)
225- add Source100 to add one missing header file in the tarball
226- revise Patch10
227- explicitly specify --disable-ddp for the first time
228
229* Wed May 04 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.5-1
230- new upstream release
231
232* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.3-3
233- rebuild with openssl-1.0.0c
234
235* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-2
236- fix Patch10 & update description - upon HAT-san's suggestions
237
238* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-1
239- new upstream release
240- update Vine patch
241
242* Thu Feb 11 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.5-1
243- new upstream release
244
245* Sun May 31 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
246- new upstream release
247
248* Sun Mar  8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.3-7
249- rebuilt both for VineSeed / VinePlus-4.0
250
251* Fri Jul 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-6
252- updated to the cjk-6 patch
253- Patch11/12 updated - VineSeed is now set with ja_JP.UTF-8 locale
254- Patch14 updated for db46
255
256* Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-5
257- remove openslp dependency
258
259* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-4
260- add Patch11 for Vine's default setting (volcharset:EUC-JP, etc.)
261- TODO: remember to revise this fix after VineSeed changes default locale
262        from ja_JP.eucJP (current) to ja_JP.UTF-8 (near future)
263
264* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-3
265- revise description (thanks HAT-san for pointing this out)
266- run libtoolize/aclocal/auto{make,conf,header} before doing configure
267  (without this, uams_* modules won't get .so suffix)
268
269* Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-2
270- Patch10 updated; dropped Patch11, Patch12, Source10 and Source11
271  (Patch10 now includes all the modifications and more fixes)
272
273* Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.3-1
274- add patch13 and patch14 for db-4.3.
275- move files in %%_libexecdir to %%libdir.
276
277* Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-0vl1
278- updated to 2.0.3 release w/ cjk patches (see the above Patch section)
279
280* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
281- security fix: added Patch10 (CAN-2004-0974)
282
283* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
284- configure --with-cnid-default-backend=dbd (cdb seems to be unstable)
285
286* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl1
287- updated to 2.0 with cjk patch
288  (see the above Patch section for details)
289
290* Tue May 28 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl4
291- merge the patch repairing bug for System 7.5.5
292- (patch6 netatalk-1.5.3.oldsys.patch)
293- made by Akihiro Okamaoto <med012@art.osaka-med.ac.jp>
294- patch6 addupted no matter noeuc is, license GPL, URL in comment
295
296* Sat Apr 27 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl3
297- euc and kana patch originally by
298- Akihiro Okamoto <med012@art.osaka-med.ac.jp> against netatalk-1.4b2+asun2.1.3
299- applied to netatalk-1.5.2 by me
300- README.vine
301- omit VERSION from doc, omit perl from require
302
303* Wed Apr 24 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl2
304- this package is removed because the release number duplicated
305
306* Mon Apr 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl2
307- move acleandir.rc to the doc directory, remove executable flag.
308
309* Sun Mar 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl1
310- updated to new upstream release
311
312* Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 1.5.2-0vl3
313- added Japanese Summary for devel and corrected Group
314
315* Thu Feb 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl2
316- Oops, check /var/lock/atalkd instead of /var/run/atd.pid
317  (say atd.pid doesn't have anything to do with netatalk!!)
318
319* Tue Feb 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl1
320- updated to new upstream release
321
322* Thu Feb 07 2002 Toru Sagami <sagami@vinelinux.org> 1.5.1.1-0vl3
323- install man pages into %%{_mandir}
324- PreReq: /sbin/chkconfig /sbin/ldconfig grep textutils
325- let pre script exit 0
326
327* Thu Feb 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.1.1-0vl2
328- spec cleanup
329- backup old prefs directory (/etc/atalk -> /etc/netatalk/00OLD_VERSION_PREFS)
330- restart atalk daemons in the %%post section
331
332* Sun Feb 3 2002  k hanai <hanai@koto.kpu-m.ac.jp>
333 - v1.5.1.1-0vl1
334
335* Fri Jan 25 2002 k hanai <hanai@koto.kpu-m.ac.jp>
336  - v1.5.0-0vl1
337  - release 1.5.0 for sourceforge
338
339* Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
340  - v1.5pre6-1rh7
341  - pre-release 6 for sourceforge
342
343* Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
344  - v1.5pre5-1
345  - pre-release 5 for sourceforge
346
347* Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
348  - v1.5pre5-0
349  - pre-release 5 for sourceforge (prebuild)
350
351* Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
352  - v1.5pre4-1
353  - pre-release 4 for sourceforge
354  - modified/split mandrake spec for redhat 7 build
355
356* Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
357  - v1.5pre3-1mdk
358  - pre-release 3 for sourceforge
359  - moved away from 1.4.99 ...
360
361* Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
362  - v1.4.99-0.20001108mdk
363  - pre-release 2 for sourceforge
364
365* Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
366  - v1.4.99-0.20000927mdk
367  - pre-release 1 for sourceforge
Note: See TracBrowser for help on using the repository browser.