source: projects/specs/trunk/n/netatalk/netatalk-vl.spec @ 10008

Revision 10008, 12.1 KB checked in by tomop, 8 years ago (diff)

netatalk-3.1.8-2

Line 
1%define _sysconfdir     /etc
2
3################################################# BASIC PACKAGE INFORMATION
4Summary:       AFP fileserver for Macintosh clients
5Summary(ja):   Macintoshクライアント向けのAFPファイルサーバー
6Name:          netatalk
7Version:       3.1.8
8Release:       2%{_dist_release}
9License:       GPLv2+
10Group:         System Environment/Daemons
11URL:           http://netatalk.sourceforge.net/
12
13Source0:       %{name}-%{version}.tar.bz2
14
15Source1:       netatalk.pam-system-auth
16Patch0:        netatalk-3.0.1-basedir.patch
17Patch1:        netatalk-3.1.8-ipv6.patch
18
19############################################################## REQUIREMENTS
20Requires(post): /sbin/chkconfig /sbin/ldconfig
21Requires(preun): /sbin/chkconfig
22Requires(preun): /sbin/service
23Requires(postun): /sbin/service /sbin/ldconfig
24BuildRequires: cracklib openssl-devel pam quota libtool automake
25BuildRequires: autoconf libdb-devel pam-devel tcp_wrappers libgcrypt-devel
26BuildRequires: avahi-devel libacl-devel openldap-devel
27BuildRequires: dbus-devel dbus-glib-devel glib2-devel systemtap-sdt-devel
28BuildRequires: libevent-devel libtdb-devel libmysqlclient-devel
29
30BuildRoot:     %{_tmppath}/%{name}-%{version}-root
31
32Vendor:        Project Vine
33Distribution:  Vine Linux
34Packager:      shaolin, tomop
35
36%description
37Netatalk is a freely-available Open Source AFP fileserver. A *NIX/*BSD
38system running Netatalk is capable of serving many Macintosh clients
39simultaneously as an AppleShare file server (AFP).
40
41%description -l ja
42 Netatalkは自由に利用可能なオープンソースAFPファイルサーバーです。
43Netatalkを実行している*NIX/*BSDシステムでは、多くのMacintoshクライ
44アントに対してAppleShareファイルサーバー(AFP)としてサービスを提供
45可能です。
46
47%package devel
48Group:         Development/Libraries
49Summary:       Headers for Netatalk development
50Summary(ja):   Netatalk開発用ヘッダファイル
51
52%description devel
53This package contains the header files for Netatalk.
54
55
56%prep
57%setup -q
58
59%patch0 -p1 -b .basedir
60%patch1 -p1 -b .ipv6
61
62ln -s ./NEWS ChangeLog
63
64%build
65
66export CFLAGS="$RPM_OPT_FLAGS"
67%ifnarch x86_64
68# XXX : enable for x86_64 when glibc bug 149284 is fixed!
69export CFLAGS="$CFLAGS -fPIE"
70export LDFLAGS="-pie -Wl,-z,relro,-z,now,-z,noexecstack"
71#"export LDFLAGS="-pie -Wl,-z,relro,-z,now,-z,noexecstack,-z,nodlopen"
72#Also in case of i686, nodlopen causes the problem.
73%endif
74
75%configure \
76        --with-pkgconfdir=%{_sysconfdir}/netatalk \
77        --with-cracklib \
78        --with-pam \
79        --with-shadow \
80        --with-uams-path=%{_libdir}/netatalk \
81        --enable-shared \
82        --enable-krbV-uam \
83        --enable-overwrite \
84        --with-gnu-ld \
85        --with-init-style=redhat-sysv \
86        --with-libgcrypt \
87        --without-libevent \
88        --without-tdb \
89        --with-pam-confdir=%{_sysconfdir}/pam.d \
90        --with-dbus-sysconf-dir=%{_sysconfdir}/dbus-1/system.d
91
92make %{?_smp_mflags} all
93
94%install
95### INSTALL (USING "make install") ###
96rm -rf ${RPM_BUILD_ROOT}
97
98make DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
99
100# install example config files in doc
101mkdir config.example
102cp -fp config/afp.conf config.example
103cp -fp config/extmap.conf config.example
104mkdir -p $RPM_BUILD_ROOT/usr/share/netatalk
105
106cp -fp %{SOURCE1} config.example
107# XXX bad hack until this file is updated in glibc-headers:
108rm -f $RPM_BUILD_ROOT/usr/include/netatalk/at.h
109
110# Clean up .a and .la files
111find $RPM_BUILD_ROOT -name \*.a -exec rm {} \;
112find $RPM_BUILD_ROOT -name \*.la -exec rm {} \;
113
114%post
115if [ -e /etc/netatalk/afp_signature.conf -a ! -e /var/netatalk/afp_signature.conf ]; then
116        mv -f /etc/netatalk/afp_signature.conf /var/netatalk/
117fi
118if [ -e /etc/netatalk/afp_voluuid.conf -a ! -e /var/netatalk/afp_voluuid.conf ]; then
119        mv -f /etc/netatalk/afp_voluuid.conf /var/netatalk/
120fi
121/sbin/chkconfig --add netatalk
122/sbin/ldconfig
123
124%preun
125if [ "$1" = "0" ] ; then
126  # check for existence due to renaming initscript
127  if [ -x  %{_initrddir}/netatalk ] ; then
128    /sbin/service netatalk stop > /dev/null 2>&1
129    /sbin/chkconfig --del netatalk
130  fi
131fi
132
133%postun
134if [ "$1" -ge "1" ]; then
135        # Package upgrade, not uninstall
136        if [ -e /etc/netatalk/afp_signature.conf -a ! -e /var/netatalk/afp_signature.conf ]; then
137                mv -f /etc/netatalk/afp_signature.conf /var/netatalk/
138        fi
139        if [ -e /etc/netatalk/afp_voluuid.conf -a ! -e /var/netatalk/afp_voluuid.conf ]; then
140                mv -f /etc/netatalk/afp_voluuid.conf /var/netatalk/
141        fi
142  /sbin/service netatalk condrestart > /dev/null 2>&1 || :
143fi
144/sbin/ldconfig
145
146%clean
147rm -rf ${RPM_BUILD_ROOT}
148
149
150%files
151%defattr(-,root,root)
152%doc COPYRIGHT COPYING ChangeLog VERSION NEWS
153%doc config.example
154%attr(755,root,root) %{_initrddir}/netatalk
155%dir %{_sysconfdir}/netatalk
156%config(noreplace) %{_sysconfdir}/netatalk/afp.conf
157%config(noreplace) %{_sysconfdir}/netatalk/extmap.conf
158%config(noreplace) %{_sysconfdir}/netatalk/dbus-session.conf
159%config(noreplace) %{_sysconfdir}/pam.d/netatalk
160%config(noreplace) %{_sysconfdir}/dbus-1/system.d/netatalk-dbus.conf
161%{_sbindir}/*
162%{_bindir}/*
163%exclude %{_bindir}/netatalk-config
164%{_mandir}/man*/*
165%exclude %{_mandir}/man*/netatalk-config*
166%{_datadir}/netatalk
167%{_libdir}/*.so
168%{_libdir}/*.so.*
169%dir %{_libdir}/netatalk
170%{_libdir}/netatalk/*.so
171%{_localstatedir}/netatalk
172
173%files devel
174%defattr(-,root,root)
175%doc COPYRIGHT COPYING
176%dir %{_includedir}/atalk
177%attr(0644,root,root) %{_includedir}/atalk/*
178%{_datadir}/aclocal/netatalk.m4
179%{_bindir}/netatalk-config
180%{_mandir}/man*/netatalk-config.1*
181
182%changelog
183* Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.8-2
184- added Patch1.
185
186* Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.8-1
187- new upstream release.
188
189* Tue Jun 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.7-1
190- new upstream release.
191
192* Mon Dec  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.2.2-2
193- rebuilt with libgcrypt 1.6.0 and libdb 5.3.28
194
195* Thu Apr 26 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.2.2-1
196- new upstream release.
197- added build option 'force_uidgid'.
198
199* Sun Sep 18 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.1-1
200- new upstream release
201- fix configure options; add missing BRs
202
203* Thu Jul 28 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-3
204- now back from the upstream confusion (and one more or two...)
205  new upstream release 2.2.0 at the official site
206
207* Mon Jul 25 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-2
208- fix Patch10 to follow HAT-san's strong and confident objection
209  (no need to set ATALK_NAME explicitly in netatalk.conf)
210
211* Sat Jul 23 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.0-1
212- new upstream release (at http://www003.upp.so-net.ne.jp/hat/netatalk/)
213- add Source100 to add one missing header file in the tarball
214- revise Patch10
215- explicitly specify --disable-ddp for the first time
216
217* Wed May 04 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.5-1
218- new upstream release
219
220* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.3-3
221- rebuild with openssl-1.0.0c
222
223* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-2
224- fix Patch10 & update description - upon HAT-san's suggestions
225
226* Sun Jul 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.3-1
227- new upstream release
228- update Vine patch
229
230* Thu Feb 11 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.5-1
231- new upstream release
232
233* Sun May 31 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.4-1
234- new upstream release
235
236* Sun Mar  8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.3-7
237- rebuilt both for VineSeed / VinePlus-4.0
238
239* Fri Jul 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-6
240- updated to the cjk-6 patch
241- Patch11/12 updated - VineSeed is now set with ja_JP.UTF-8 locale
242- Patch14 updated for db46
243
244* Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-5
245- remove openslp dependency
246
247* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-4
248- add Patch11 for Vine's default setting (volcharset:EUC-JP, etc.)
249- TODO: remember to revise this fix after VineSeed changes default locale
250        from ja_JP.eucJP (current) to ja_JP.UTF-8 (near future)
251
252* Tue Apr 15 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-3
253- revise description (thanks HAT-san for pointing this out)
254- run libtoolize/aclocal/auto{make,conf,header} before doing configure
255  (without this, uams_* modules won't get .so suffix)
256
257* Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-2
258- Patch10 updated; dropped Patch11, Patch12, Source10 and Source11
259  (Patch10 now includes all the modifications and more fixes)
260
261* Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.3-1
262- add patch13 and patch14 for db-4.3.
263- move files in %%_libexecdir to %%libdir.
264
265* Sat Oct 21 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.3-0vl1
266- updated to 2.0.3 release w/ cjk patches (see the above Patch section)
267
268* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
269- security fix: added Patch10 (CAN-2004-0974)
270
271* Tue Oct 19 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
272- configure --with-cnid-default-backend=dbd (cdb seems to be unstable)
273
274* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl1
275- updated to 2.0 with cjk patch
276  (see the above Patch section for details)
277
278* Tue May 28 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl4
279- merge the patch repairing bug for System 7.5.5
280- (patch6 netatalk-1.5.3.oldsys.patch)
281- made by Akihiro Okamaoto <med012@art.osaka-med.ac.jp>
282- patch6 addupted no matter noeuc is, license GPL, URL in comment
283
284* Sat Apr 27 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl3
285- euc and kana patch originally by
286- Akihiro Okamoto <med012@art.osaka-med.ac.jp> against netatalk-1.4b2+asun2.1.3
287- applied to netatalk-1.5.2 by me
288- README.vine
289- omit VERSION from doc, omit perl from require
290
291* Wed Apr 24 2002 Masaki Shinomiya <shino@pos.to> 1.5.3.1-0vl2
292- this package is removed because the release number duplicated
293
294* Mon Apr 01 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl2
295- move acleandir.rc to the doc directory, remove executable flag.
296
297* Sun Mar 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.3.1-0vl1
298- updated to new upstream release
299
300* Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 1.5.2-0vl3
301- added Japanese Summary for devel and corrected Group
302
303* Thu Feb 28 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl2
304- Oops, check /var/lock/atalkd instead of /var/run/atd.pid
305  (say atd.pid doesn't have anything to do with netatalk!!)
306
307* Tue Feb 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-0vl1
308- updated to new upstream release
309
310* Thu Feb 07 2002 Toru Sagami <sagami@vinelinux.org> 1.5.1.1-0vl3
311- install man pages into %%{_mandir}
312- PreReq: /sbin/chkconfig /sbin/ldconfig grep textutils
313- let pre script exit 0
314
315* Thu Feb 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.1.1-0vl2
316- spec cleanup
317- backup old prefs directory (/etc/atalk -> /etc/netatalk/00OLD_VERSION_PREFS)
318- restart atalk daemons in the %%post section
319
320* Sun Feb 3 2002  k hanai <hanai@koto.kpu-m.ac.jp>
321 - v1.5.1.1-0vl1
322
323* Fri Jan 25 2002 k hanai <hanai@koto.kpu-m.ac.jp>
324  - v1.5.0-0vl1
325  - release 1.5.0 for sourceforge
326
327* Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
328  - v1.5pre6-1rh7
329  - pre-release 6 for sourceforge
330
331* Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
332  - v1.5pre5-1
333  - pre-release 5 for sourceforge
334
335* Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
336  - v1.5pre5-0
337  - pre-release 5 for sourceforge (prebuild)
338
339* Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
340  - v1.5pre4-1
341  - pre-release 4 for sourceforge
342  - modified/split mandrake spec for redhat 7 build
343
344* Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
345  - v1.5pre3-1mdk
346  - pre-release 3 for sourceforge
347  - moved away from 1.4.99 ...
348
349* Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
350  - v1.4.99-0.20001108mdk
351  - pre-release 2 for sourceforge
352
353* Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
354  - v1.4.99-0.20000927mdk
355  - pre-release 1 for sourceforge
Note: See TracBrowser for help on using the repository browser.