source: projects/specs/trunk/n/net-tools/net-tools-vl.spec @ 12534

Revision 12534, 8.0 KB checked in by tomop, 3 years ago (diff)

updated 7 packages

freetype2-2.10.4-1

iproute-5.10.0-1

kmod-28-1

libunwind-1.5.0-1

net-tools-2.10-1

screen-4.8.0-2

util-linux-2.36.2-1

Line 
1%bcond_with systemd
2
3Summary: The basic tools for setting up networking.
4Summary(ja): ネットワークをセットアップするための基本的なツール
5Name: net-tools
6Version: 2.10
7Release: 1%{?_dist_release}%{?with_systemd:.systemd}
8Group: system,network,admin-tools
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: GPL
13URL: https://sourceforge.net/projects/net-tools/
14Source0: https://downloads.sourceforge.net/project/net-tools/net-tools-%{version}.tar.xz
15Source1: net-tools-config.h
16Source2: net-tools-config.make
17Source3: ether-wake.c
18Source4: ether-wake.8
19Source5: mii-diag.c
20Source6: mii-diag.8
21Source7: iptunnel.8
22Source8: ipmaddr.8
23Source9: arp-ethers.service
24
25# source for Vine
26Source100: net-tools-2.10-ja.po
27
28# adds <delay> option that allows netstat to cycle printing through statistics every delay seconds.
29Patch1: net-tools-cycle.patch
30
31# various man page fixes merged into one patch
32Patch2: net-tools-man.patch
33
34# linux-4.8
35Patch3: net-tools-linux48.patch
36
37# use all interfaces instead of default (#1003875)
38Patch20: ether-wake-interfaces.patch
39
40Patch24: net-tools-correct-exit-code.patch
41
42BuildRoot: %{_tmppath}/%{name}-root
43BuildRequires: bluez-libs-devel
44%if %{with systemd}
45%{?systemd_requires}
46%endif
47
48
49%description
50The net-tools package contains the basic tools needed for setting up
51networking:  ethers, route and others.
52
53%description -l ja
54net-tools パッケージはネットワークをセットアップする基本的なツールを
55含んでいます: イーサーネット, ルーティングやその他
56
57
58%debug_package
59
60
61%prep
62%setup -q
63%patch1 -p1 -b .cycle
64%patch2 -p1 -b .man
65#patch3 -p1 -b .linux48
66
67cp %SOURCE1 ./config.h
68cp %SOURCE2 ./config.make
69cp %SOURCE3 .
70cp %SOURCE4 ./man/en_US
71cp %SOURCE5 .
72cp %SOURCE6 ./man/en_US
73cp %SOURCE7 ./man/en_US
74cp %SOURCE8 ./man/en_US
75
76%patch20 -p1 -b .interfaces
77%patch24 -p1 -b .exit-codes
78
79touch ./config.h
80cp %SOURCE100 po/ja.po
81
82
83%build
84export CFLAGS="${RPM_OPT_FLAGS} -fpie"
85export LDFLAGS="${RPM_LD_FLAGS} -pie -Wl,-z,now"
86
87make
88make ether-wake
89gcc ${RPM_OPT_FLAGS} ${RPM_LD_FLAGS} -o mii-diag mii-diag.c
90
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95mv man/de_DE man/de
96mv man/fr_FR man/fr
97mv man/pt_BR man/pt
98
99make BASEDIR=%{buildroot} mandir=%{_mandir} install
100
101install -m 755 ether-wake %{buildroot}/sbin
102install -m 755 mii-diag %{buildroot}/sbin
103
104mv -f %{buildroot}/bin/{ifconfig,route} %{buildroot}/sbin/
105
106rm %{buildroot}/sbin/rarp
107rm %{buildroot}%{_mandir}/man8/rarp.8*
108rm %{buildroot}%{_mandir}/de*/man8/rarp.8*
109rm %{buildroot}%{_mandir}/fr*/man8/rarp.8*
110rm %{buildroot}%{_mandir}/pt*/man8/rarp.8*
111
112# otherwise %%find_lang finds them even they're empty
113rm -rf %{buildroot}%{_mandir}/de/man1
114rm -rf %{buildroot}%{_mandir}/fr/man1
115rm -rf %{buildroot}%{_mandir}/man1
116rm -rf %{buildroot}%{_mandir}/pt/man1
117rm -rf %{buildroot}%{_mandir}/pt/man5
118
119mkdir -p %{buildroot}%{_sysconfdir}
120touch %{buildroot}%{_sysconfdir}/ethers
121echo "# see man ethers for syntax" > %{buildroot}%{_sysconfdir}/ethers
122
123%if %{with systemd}
124# install systemd unit file
125install -D -p -m 644 %{SOURCE9} %{buildroot}%{_unitdir}/arp-ethers.service
126%endif
127
128%find_lang %{name}
129
130
131%clean
132rm -rf $RPM_BUILD_ROOT
133
134
135%if %{with systemd}
136%post
137%systemd_post arp-ethers.service
138%endif
139
140
141%files -f %{name}.lang
142%defattr(-,root,root)
143%license COPYING
144/bin/*
145/sbin/*
146%{_mandir}/man[58]/*
147%{_mandir}/de/man[58]/*
148%{_mandir}/fr/man[58]/*
149%{_mandir}/pt/man8/*
150%config(noreplace) %{_sysconfdir}/ethers
151%if %{with systemd}
152%attr(0644,root,root)   %{_unitdir}/arp-ethers.service
153%endif
154
155
156%changelog
157* Thu Feb 18 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10-1
158- new upstream release.
159- updated Source100 (ja.po).
160- dropped Patch100.
161- added systemd support (disabled as default).
162
163* Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.60-17
164- replace all patches from CentOS 6 (included previous patches).
165- added Patch99 to build with new kernel-headers.
166
167* Mon Jul 21 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.60-16
168- update config.{h,make}
169  - CONFIG_HWSTRIP=0, CONFIG_HWTR=0
170
171* Sat Aug 11 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.60-15vl6
172- add patch22, 65 to fix <BTS:1329>
173
174* Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.60-14
175- rebuild for Vine 6
176
177* Wed Sep 10 2008 Shu KONNO <owa@bg.wakwak.com> 1.60-13vl5
178- applied new versioning policy, spec in utf-8
179- added net-tools-1.60-label.patch
180
181* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.60-12vl2
182- add patches to build with current environment
183  - x25_sr.patch (patch9)
184  - gcc33.patch (patch10)
185  - update ether-wake.c (source3)
186
187* Sat May 31 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.60-12vl1
188- update and replaced ja.po
189- sync with RedHat Rawhide 1.60-12
190
191  - Fri Feb 07 2003 Phil Knirsch <pknirsch@redhat.com>
192  - Fixed -s parameter.
193  - Fix /proc statistics for -nic operation.
194  - Fixed -i operation in general.
195
196  - Tue Dec 17 2002 Phil Knirsch <pknirsch@redhat.com> 1.60-9
197  - Copyright -> License.
198
199  - Tue Aug 06 2002 Phil Knirsch <pknirsch@redhat.com>
200  - Added patch from Norm for a corrected output.
201
202  - Fri Apr 12 2002 Jeremy Katz <katzj@redhat.com>
203  - fix nstrcmp() to be correct in the case where there are many devices
204    of the same type, eg, "eth10" > "eth1"  (#61436)
205
206  - Tue Jul 31 2001 Bill Nottingham <notting@redhat.com>
207  - do *not* use SIOCDEVPRIVATE for MII ioctls
208
209  - Fri Jun  1 2001 Preston Brown <pbrown@redhat.com>
210  - include wake-on-lan wakeup utility, ether-wake by Donald Becker
211
212* Sat May 12 2001 <sagami@vinelinux.org>
213- 1.60-4vl1: follow up with RH 1.60-1
214
215* Tue May 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
216- sync with RH 6.2
217
218* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
219- rebuild for sparc baud rates > 38400.
220
221* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
222- fix description
223
224* Fri Jan 14 2000 Jeff Johnson <jbj@redhat.com>
225- fix "netstat -ci" (#6904).
226- document more netstat options (#7429).
227
228* Thu Jan 13 2000 Jeff Johnson <jbj@redhat.com>
229- update to 1.54.
230- enable "everything but DECnet" including IPv6.
231
232* Mon Oct 11 1999 Norihito Ohmori <ohmori@flatout.org>
233- ported from net-tools-1.51 with Japanese catalog
234  by Yasuyuki Furukawa
235
236* Sun Aug 29 1999 Jeff Johnson <jbj@redhat.com>
237- update to 1.53.
238
239* Wed Jul 28 1999 Jeff Johnson <jbj@redhat.com>
240- plug "netstat -c" fd leak (#3620).
241
242* Thu Jun 17 1999 Jeff Johnson <jbj@redhat.com>
243- plug potential buffer overruns.
244
245* Sat Jun 12 1999 John Hardin <jhardin@wolfenet.com>
246- patch to recognize ESP and GRE protocols for VPN masquerade
247
248* Fri Apr 23 1999 Jeff Johnson <jbj@redhat.com>
249- update to 1.52.
250
251* Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
252- update interface statistics continuously (#1323)
253
254* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
255- auto rebuild in the new build environment (release 2)
256
257* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
258- update to 1.51.
259- strip binaries.
260
261* Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
262- update to 1.50.
263- added slattach/plipconfig/ipmaddr/iptunnel commands.
264- enabled translated man pages.
265
266* Tue Dec 15 1998 Jakub Jelinek <jj@ultra.linux.cz>
267- update to 1.49.
268
269* Sat Dec  5 1998 Jeff Johnson <jbj@redhat.com>
270- update to 1.48.
271
272* Thu Nov 12 1998 Jeff Johnson <jbj@redhat.com>
273- update to 1.47.
274
275* Wed Sep  2 1998 Jeff Johnson <jbj@redhat.com>
276- update to 1.46
277
278* Thu Jul  9 1998 Jeff Johnson <jbj@redhat.com>
279- build root
280- include ethers.5
281
282* Thu Jun 11 1998 Aron Griffis <agriffis@coat.com>
283- upgraded to 1.45
284- patched hostname.c to initialize buffer
285- patched ax25.c to use kernel headers
286
287* Fri May 01 1998 Prospector System <bugs@redhat.com>
288- translations modified for de, fr, tr
289
290* Fri Feb 27 1998 Jason Spangler <jasons@usemail.com>
291- added config patch
292
293* Fri Feb 27 1998 Jason Spangler <jasons@usemail.com>
294- changed to net-tools 1.432
295- removed old glibc 2.1 patch
296 
297* Wed Oct 22 1997 Erik Troan <ewt@redhat.com>
298- added extra patches for glibc 2.1
299
300* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
301- included complete set of network protocols (some were removed for
302  initial glibc work)
303
304* Wed Sep 03 1997 Erik Troan <ewt@redhat.com>
305- updated glibc patch for glibc 2.0.5
306
307* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
308- built against glibc
309- updated to 1.33
Note: See TracBrowser for help on using the repository browser.