source: projects/specs/trunk/n/neon/neon-vl.spec @ 8278

Revision 8278, 8.8 KB checked in by kenta, 10 years ago (diff)

neon: update to 0.30.0

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: neon
4Summary: An HTTP and WebDAV client library.
5Summary(ja): HTTP と WebDAV クライアントのライブラリ
6Version: 0.30.0
7Release: 1%{?_dist_release}
8License: LGPLv2+
9Group: System Environment/Libraries
10URL: http://www.webdav.org/neon/
11Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: expat
14Requires: zlib >= 1.1.4
15Requires: krb5-libs
16BuildRequires: expat-devel
17BuildRequires: gnutls-devel
18BuildRequires: krb5-devel
19BuildRequires: libxml2-devel
20BuildRequires: sed
21BuildRequires: zlib-devel
22BuildRequires: keyutils-libs-devel
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27%description
28neon is an HTTP and WebDAV client library, with a C interface;
29providing a high-level interface to HTTP and WebDAV methods along
30with a low-level interface for HTTP request handling.  neon
31supports persistent connections, proxy servers, basic, digest and
32Kerberos authentication, and has complete SSL support.
33
34%package devel
35Summary: Development libraries and C header files for the neon library
36Summary(ja): neon の開発用ライブラリおよび C言語ヘッダファイル
37Group: Development/Libraries
38Requires: %{name} = %{version}
39Requires: zlib-devel
40#Requires: openssl-devel
41Requires: expat-devel
42Requires: gnutls-devel
43Requires: krb5-devel
44Requires: keyutils-libs-devel
45
46%description devel
47The development library for the C language HTTP and WebDAV client library.
48
49%description devel -l ja
50C言語による HTTP と WebDAV クライアントのライブラリの開発用パッケージ
51
52## to build compat32 for x86_64 architecture support
53%package -n compat32-%{name}
54Summary: C language HTTP and WebDAV client library.
55Group: System Environment/Libraries
56Requires: expat
57Requires: zlib >= 1.1.4
58
59%description -n compat32-%{name}
60A C language HTTP and WebDAV client library.
61
62%package -n compat32-%{name}-devel
63Summary: A C language HTTP and WebDAV client library.
64Group: Development/Libraries
65Requires: compat32-%{name} = %{version}
66Requires: compat32-zlib-devel
67#Requires: compat32-openssl-devel
68Requires: compat32-expat-devel
69Requires: compat32-keyutils-libs-devel
70Requires: compat32-krb5-devel
71
72%description -n compat32-%{name}-devel
73The development library for the C language HTTP and WebDAV client library.
74
75%prep
76%setup -q
77
78%build
79%configure \
80        --with-expat \
81        --with-ssl=gnutls \
82        --enable-threadsafe-ssl=posix \
83        --enable-shared \
84        --disable-static \
85        --with-force-ssl
86%__make %{?_smp_mflags}
87
88%install
89%__rm -rf %{buildroot}
90%makeinstall
91
92sed -ri "/^dependency_libs/{s,-l[^ ']*,,g}" \
93      $RPM_BUILD_ROOT%{_libdir}/libneon.la
94
95%find_lang %{name}
96
97## remove unuse files
98rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
99
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%post -p /sbin/ldconfig
105
106%postun -p /sbin/ldconfig
107
108%post -n compat32-%{name} -p /sbin/ldconfig
109
110%postun -n compat32-%{name} -p /sbin/ldconfig
111
112%files -f %{name}.lang
113%defattr(-,root,root)
114%doc AUTHORS BUGS ChangeLog INSTALL.win32 NEWS README THANKS TODO
115%doc doc/html
116%{_libdir}/*.so.*
117
118%files devel
119%defattr(-,root,root)
120%{_bindir}/*
121%{_includedir}/*
122%{_mandir}/man1/*
123%{_mandir}/man3/*
124#{_libdir}/*.a
125#{_libdir}/*.la
126%{_libdir}/*.so
127%{_libdir}/pkgconfig/*.pc
128
129%if %{build_compat32}
130%files -n compat32-%{name}
131%defattr(-,root,root)
132%{_libdir}/*.so.*
133
134%files -n compat32-%{name}-devel
135%defattr(-,root,root)
136#{_libdir}/*.a
137#{_libdir}/*.la
138%{_libdir}/pkgconfig/*.pc
139%endif
140
141%changelog
142* Tue Feb 25 2014 NAKAMURA Kenta <kenta@vinelinux.org> 0.30.0-1
143- update to 0.30.0
144
145* Sun Jan 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-2
146- rebuild with VineSeed environment
147
148* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-1
149- update to 0.29.6
150
151* Mon May 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.3-2
152- add BuildRequires: keyutils-libs-devel
153- add Requires: krb5-devel, keyutils-libs-devel (-devel package)
154
155* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 0.29.3-1
156- new upstream release
157
158* Thu Mar 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.6-3
159- rebuilt with krb5-libs-1.8.2
160- removed BR: openssl-devel
161- removed static library from devel package
162
163* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.28.6-2
164- rebuilt with rpm-4.8.1 for pkg-config
165
166* Tue Aug 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.6-1
167- new upstream release with security fix (CVE-2009-2473, 2474)
168
169* Sat Jan 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.28.3-3vl5
170- rebuild with gnutls-2.6.3
171
172* Sun Oct 19 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-2vl5
173- add Requires/BuildRequires krb5-libs/krb5-devel tags
174- add _smp_mflags into make section
175
176* Fri Oct 17 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-1vl5
177- new upstream release with security fix (CVE-2008-3746)
178
179* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.28.2-3vl5
180- removed *.la
181- spec in utf-8
182
183* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-2vl5
184- added --with-ssl=gnutls --enable-threadsafe-ssl
185- added BuildRequires: gnutls-devel
186
187* Fri Apr 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-1vl5
188- new upstream release
189
190* Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.26.3-0vl3
191- removed %%if !%%{build_compat32} case condition
192
193* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.26.3-0vl2
194- rebuild with expat-2.0.1
195
196* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.26.3-0vl1
197- new upstream release
198
199* Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl3
200- add Requires: zlib-devel, openssl-devel, expat-devel
201
202* Mon May 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl2
203- move %%configure from %%prep to %%build
204- remove unneeded locales.patch (for neon-0.26.x or later)
205
206* Wed Apr 05 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl1
207- new upstream release
208- drop doc.patch (patch0)
209- use more macros
210- drop BuildRequires: autoconf, automake
211- add *.pc to -devel (and compat32's) package
212- change group
213- add Requires: %%{name} = %%{version} to -devel (and compat32's) package
214- add doc/html instead of doc/* to %%doc
215- move %%{_mandir}/man1/* and %%{_bindir}/* to -devel package
216- run ldconfig in %%post,postun
217- add locales.patch (patch0)
218
219* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl3
220- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
221
222* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl2
223- added compat32- packages for x86_64 architecture support
224- added --libdir=%{_libdir} option to configure
225
226* Sun Sep  5 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.24.7-0vl1
227- new upstream release
228
229* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.4-0vl1
230- upstream release
231- update URL and Source0 tag: valid URL
232
233* Fri Sep 19 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.2-0vl1
234- upstream release
235- add BuildRequires: openssl-devel, libxml2-devel, zlib-devel
236- add Japanese Summary and %%description
237
238* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.23.5-1vl1
239- build VineLinux
240
241* Mon Nov 04 2002 David Summers <david@summersoft.fay.ar.us> 0.23.5-1
242- Updated to 0.23.5.
243
244* Tue Aug 27 2002 David Summers <david@summersoft.fay.ar.us> 0.23.2-1
245- Upgraded to 0.23.2.
246
247* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.22.0-1
248- Upgraded to 0.22.0.
249- Fixed compilation from CVS.
250- Took out man pages until I can figure out xmlto program.
251
252* Sat Aug 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-3
253- Fixed compilation on RedHat 7.2 by upgrading libtool and auto* packages
254  to RedHat 7.3 versions and fixing bug in spec file.
255- Gave up on CVS version of neon until we can figure out why autogen.sh doesn't
256  work.
257
258* Wed Jul 24 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-2
259- Fixed file ownership problems.  Made them owned by root.
260
261* Fri Jul 19 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-1
262- Updated to neon 0.21.3.
263
264* Sun Jun 16 2002 David Summers <david@summersoft.fay.ar.us> 0.21.2-1
265- Updated to neon 0.21.2.
266
267* Mon Jun 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.1-1
268- Updated to neon 0.21.1.
269- Now requires zlib >= 1.1.4.
270- Broke into zlib and zlib-devel.
271- Now builds shared library.
272
273* Sat Apr 27 2002 David Summers <david@summersoft.fay.ar.us> 0.19.4-1
274- Updated to neon 0.19.4.
275
276* Fri Feb 22 2002 David Summers <david@summersoft.fay.ar.us> 0.19.2-1
277- Updated to neon 0.19.2.
278
279* Thu Dec 20 2001 David Summers <david@summersoft.fay.ar.us> 0.18.2-1
280- Updated to neon 0.18.2.
281
282* Wed Oct 31 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-2
283- Took out dependency on libxml and w3c-libwww packages.
284- Added dependency on expat.
285
286* Sat Oct 27 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-1
287- Release 0.17.2-1: Updated neon.
288
289* Wed Oct 24 2001 David Summers <david@summersoft.fay.ar.us>
290- Release 2: Fixed prefix to be /usr instead of /usr/local.
291
292* Sat Oct 20 2001 David Summers <david@summersoft.fay.ar.us>
293- Release 2001-10-20: Initial Version.
294
Note: See TracBrowser for help on using the repository browser.