source: projects/specs/trunk/n/neon/neon-vl.spec @ 8120

Revision 8120, 8.7 KB checked in by Takemikaduchi, 10 years ago (diff)

fix typo

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: neon
4Summary: An HTTP and WebDAV client library.
5Summary(ja): HTTP と WebDAV クライアントのライブラリ
6Version: 0.29.6
7Release: 2%{?_dist_release}
8License: LGPLv2+
9Group: System Environment/Libraries
10URL: http://www.webdav.org/neon/
11Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: expat
14Requires: zlib >= 1.1.4
15Requires: krb5-libs
16BuildRequires: expat-devel
17BuildRequires: gnutls-devel
18BuildRequires: krb5-devel
19BuildRequires: libxml2-devel
20#BuildRequires: openssl-devel
21BuildRequires: sed
22BuildRequires: zlib-devel
23BuildRequires: keyutils-libs-devel
24
25Vendor: Project Vine
26Distribution: Vine Linux
27
28%description
29neon is an HTTP and WebDAV client library, with a C interface;
30providing a high-level interface to HTTP and WebDAV methods along
31with a low-level interface for HTTP request handling.  neon
32supports persistent connections, proxy servers, basic, digest and
33Kerberos authentication, and has complete SSL support.
34
35%package devel
36Summary: Development libraries and C header files for the neon library
37Summary(ja): neon の開発用ライブラリおよび C言語ヘッダファイル
38Group: Development/Libraries
39Requires: %{name} = %{version}
40Requires: zlib-devel
41#Requires: openssl-devel
42Requires: expat-devel
43Requires: gnutls-devel
44Requires: krb5-devel
45Requires: keyutils-libs-devel
46
47%description devel
48The development library for the C language HTTP and WebDAV client library.
49
50%description devel -l ja
51C言語による HTTP と WebDAV クライアントのライブラリの開発用パッケージ
52
53## to build compat32 for x86_64 architecture support
54%package -n compat32-%{name}
55Summary: C language HTTP and WebDAV client library.
56Group: System Environment/Libraries
57Requires: expat
58Requires: zlib >= 1.1.4
59
60%description -n compat32-%{name}
61A C language HTTP and WebDAV client library.
62
63%package -n compat32-%{name}-devel
64Summary: A C language HTTP and WebDAV client library.
65Group: Development/Libraries
66Requires: compat32-%{name} = %{version}
67Requires: compat32-zlib-devel
68#Requires: compat32-openssl-devel
69Requires: compat32-expat-devel
70Requires: compat32-keyutils-libs-devel
71Requires: compat32-krb5-devel
72
73%description -n compat32-%{name}-devel
74The development library for the C language HTTP and WebDAV client library.
75
76%prep
77%setup -q
78
79%build
80%configure \
81        --with-expat \
82        --with-ssl=gnutls \
83        --enable-threadsafe-ssl=posix \
84        --enable-shared \
85        --disable-static \
86        --with-force-ssl
87%__make %{?_smp_mflags}
88
89%install
90%__rm -rf %{buildroot}
91%makeinstall
92
93sed -ri "/^dependency_libs/{s,-l[^ ']*,,g}" \
94      $RPM_BUILD_ROOT%{_libdir}/libneon.la
95
96%find_lang %{name}
97
98## remove unuse files
99rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
100
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%post -p /sbin/ldconfig
106
107%postun -p /sbin/ldconfig
108
109%post -n compat32-%{name} -p /sbin/ldconfig
110
111%postun -n compat32-%{name} -p /sbin/ldconfig
112
113%files -f %{name}.lang
114%defattr(-,root,root)
115%doc AUTHORS BUGS ChangeLog INSTALL.win32 NEWS README THANKS TODO
116%doc doc/html
117%{_libdir}/*.so.*
118
119%files devel
120%defattr(-,root,root)
121%{_bindir}/*
122%{_includedir}/*
123%{_mandir}/man1/*
124%{_mandir}/man3/*
125#{_libdir}/*.a
126#{_libdir}/*.la
127%{_libdir}/*.so
128%{_libdir}/pkgconfig/*.pc
129
130%if %{build_compat32}
131%files -n compat32-%{name}
132%defattr(-,root,root)
133%{_libdir}/*.so.*
134
135%files -n compat32-%{name}-devel
136%defattr(-,root,root)
137#{_libdir}/*.a
138#{_libdir}/*.la
139%{_libdir}/pkgconfig/*.pc
140%endif
141
142%changelog
143* Sun Jan 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-2
144- rebuild with VineSeed environment
145
146* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-1
147- update to 0.29.6
148
149* Mon May 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.3-2
150- add BuildRequires: keyutils-libs-devel
151- add Requires: krb5-devel, keyutils-libs-devel (-devel package)
152
153* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 0.29.3-1
154- new upstream release
155
156* Thu Mar 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.6-3
157- rebuilt with krb5-libs-1.8.2
158- removed BR: openssl-devel
159- removed static library from devel package
160
161* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.28.6-2
162- rebuilt with rpm-4.8.1 for pkg-config
163
164* Tue Aug 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.6-1
165- new upstream release with security fix (CVE-2009-2473, 2474)
166
167* Sat Jan 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.28.3-3vl5
168- rebuild with gnutls-2.6.3
169
170* Sun Oct 19 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-2vl5
171- add Requires/BuildRequires krb5-libs/krb5-devel tags
172- add _smp_mflags into make section
173
174* Fri Oct 17 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-1vl5
175- new upstream release with security fix (CVE-2008-3746)
176
177* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.28.2-3vl5
178- removed *.la
179- spec in utf-8
180
181* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-2vl5
182- added --with-ssl=gnutls --enable-threadsafe-ssl
183- added BuildRequires: gnutls-devel
184
185* Fri Apr 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-1vl5
186- new upstream release
187
188* Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.26.3-0vl3
189- removed %%if !%%{build_compat32} case condition
190
191* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.26.3-0vl2
192- rebuild with expat-2.0.1
193
194* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.26.3-0vl1
195- new upstream release
196
197* Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl3
198- add Requires: zlib-devel, openssl-devel, expat-devel
199
200* Mon May 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl2
201- move %%configure from %%prep to %%build
202- remove unneeded locales.patch (for neon-0.26.x or later)
203
204* Wed Apr 05 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl1
205- new upstream release
206- drop doc.patch (patch0)
207- use more macros
208- drop BuildRequires: autoconf, automake
209- add *.pc to -devel (and compat32's) package
210- change group
211- add Requires: %%{name} = %%{version} to -devel (and compat32's) package
212- add doc/html instead of doc/* to %%doc
213- move %%{_mandir}/man1/* and %%{_bindir}/* to -devel package
214- run ldconfig in %%post,postun
215- add locales.patch (patch0)
216
217* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl3
218- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
219
220* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl2
221- added compat32- packages for x86_64 architecture support
222- added --libdir=%{_libdir} option to configure
223
224* Sun Sep  5 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.24.7-0vl1
225- new upstream release
226
227* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.4-0vl1
228- upstream release
229- update URL and Source0 tag: valid URL
230
231* Fri Sep 19 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.2-0vl1
232- upstream release
233- add BuildRequires: openssl-devel, libxml2-devel, zlib-devel
234- add Japanese Summary and %%description
235
236* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.23.5-1vl1
237- build VineLinux
238
239* Mon Nov 04 2002 David Summers <david@summersoft.fay.ar.us> 0.23.5-1
240- Updated to 0.23.5.
241
242* Tue Aug 27 2002 David Summers <david@summersoft.fay.ar.us> 0.23.2-1
243- Upgraded to 0.23.2.
244
245* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.22.0-1
246- Upgraded to 0.22.0.
247- Fixed compilation from CVS.
248- Took out man pages until I can figure out xmlto program.
249
250* Sat Aug 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-3
251- Fixed compilation on RedHat 7.2 by upgrading libtool and auto* packages
252  to RedHat 7.3 versions and fixing bug in spec file.
253- Gave up on CVS version of neon until we can figure out why autogen.sh doesn't
254  work.
255
256* Wed Jul 24 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-2
257- Fixed file ownership problems.  Made them owned by root.
258
259* Fri Jul 19 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-1
260- Updated to neon 0.21.3.
261
262* Sun Jun 16 2002 David Summers <david@summersoft.fay.ar.us> 0.21.2-1
263- Updated to neon 0.21.2.
264
265* Mon Jun 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.1-1
266- Updated to neon 0.21.1.
267- Now requires zlib >= 1.1.4.
268- Broke into zlib and zlib-devel.
269- Now builds shared library.
270
271* Sat Apr 27 2002 David Summers <david@summersoft.fay.ar.us> 0.19.4-1
272- Updated to neon 0.19.4.
273
274* Fri Feb 22 2002 David Summers <david@summersoft.fay.ar.us> 0.19.2-1
275- Updated to neon 0.19.2.
276
277* Thu Dec 20 2001 David Summers <david@summersoft.fay.ar.us> 0.18.2-1
278- Updated to neon 0.18.2.
279
280* Wed Oct 31 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-2
281- Took out dependency on libxml and w3c-libwww packages.
282- Added dependency on expat.
283
284* Sat Oct 27 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-1
285- Release 0.17.2-1: Updated neon.
286
287* Wed Oct 24 2001 David Summers <david@summersoft.fay.ar.us>
288- Release 2: Fixed prefix to be /usr instead of /usr/local.
289
290* Sat Oct 20 2001 David Summers <david@summersoft.fay.ar.us>
291- Release 2001-10-20: Initial Version.
292
Note: See TracBrowser for help on using the repository browser.