source: projects/specs/trunk/n/neon/neon-vl.spec @ 3682

Revision 3682, 8.2 KB checked in by iwaim, 13 years ago (diff)

neon-0.29.3-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: neon
4Summary: An HTTP and WebDAV client library.
5Summary(ja): HTTP と WebDAV クライアントのライブラリ
6Version: 0.29.3
7Release: 1%{?_dist_release}
8License: LGPLv2+
9Group: System Environment/Libraries
10URL: http://www.webdav.org/neon/
11Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: expat
14Requires: zlib >= 1.1.4
15Requires: krb5-libs
16BuildRequires: expat-devel
17BuildRequires: gnutls-devel
18BuildRequires: krb5-devel
19BuildRequires: libxml2-devel
20#BuildRequires: openssl-devel
21BuildRequires: sed
22BuildRequires: zlib-devel
23
24%description
25neon is an HTTP and WebDAV client library, with a C interface;
26providing a high-level interface to HTTP and WebDAV methods along
27with a low-level interface for HTTP request handling.  neon
28supports persistent connections, proxy servers, basic, digest and
29Kerberos authentication, and has complete SSL support.
30
31%package devel
32Summary: Development libraries and C header files for the neon library
33Summary(ja): neon の開発用ライブラリおよび C言語ヘッダファイル
34Group: Development/Libraries
35Requires: %{name} = %{version}
36Requires: zlib-devel
37#Requires: openssl-devel
38Requires: expat-devel
39Requires: gnutls-devel
40
41%description devel
42The development library for the C language HTTP and WebDAV client library.
43
44%description devel -l ja
45C言語による HTTP と WebDAV クライアントのライブラリの開発用パッケージ
46
47## to build compat32 for x86_64 architecture support
48%package -n compat32-%{name}
49Summary: C language HTTP and WebDAV client library.
50Group: System Environment/Libraries
51Requires: expat
52Requires: zlib >= 1.1.4
53
54%description -n compat32-%{name}
55A C language HTTP and WebDAV client library.
56
57%package -n compat32-%{name}-devel
58Summary: A C language HTTP and WebDAV client library.
59Group: Development/Libraries
60Requires: compat32-%{name} = %{version}
61Requires: compat32-zlib-devel
62#Requires: compat32-openssl-devel
63Requires: compat32-expat-devel
64
65%description -n compat32-%{name}-devel
66The development library for the C language HTTP and WebDAV client library.
67
68%prep
69%setup -q
70
71%build
72%configure \
73        --with-expat \
74        --with-ssl=gnutls \
75        --enable-threadsafe-ssl=posix \
76        --enable-shared \
77        --disable-static \
78        --with-force-ssl
79%__make %{?_smp_mflags}
80
81%install
82%__rm -rf %{buildroot}
83%makeinstall
84
85sed -ri "/^dependency_libs/{s,-l[^ ']*,,g}" \
86      $RPM_BUILD_ROOT%{_libdir}/libneon.la
87
88%find_lang %{name}
89
90## remove unuse files
91rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
92
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%post -p /sbin/ldconfig
98
99%postun -p /sbin/ldconfig
100
101%post -n compat32-%{name} -p /sbin/ldconfig
102
103%postun -n compat32-%{name} -p /sbin/ldconfig
104
105%files -f %{name}.lang
106%defattr(-,root,root)
107%doc AUTHORS BUGS ChangeLog INSTALL.win32 NEWS README THANKS TODO
108%doc doc/html
109%{_libdir}/*.so.*
110
111%files devel
112%defattr(-,root,root)
113%{_bindir}/*
114%{_includedir}/*
115%{_mandir}/man1/*
116%{_mandir}/man3/*
117#{_libdir}/*.a
118#{_libdir}/*.la
119%{_libdir}/*.so
120%{_libdir}/pkgconfig/*.pc
121
122%if %{build_compat32}
123%files -n compat32-%{name}
124%defattr(-,root,root)
125%{_libdir}/*.so.*
126
127%files -n compat32-%{name}-devel
128%defattr(-,root,root)
129#{_libdir}/*.a
130#{_libdir}/*.la
131%{_libdir}/pkgconfig/*.pc
132%endif
133
134%changelog
135* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 0.29.3-1
136- new upstream release
137
138* Thu Mar 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.6-3
139- rebuilt with krb5-libs-1.8.2
140- removed BR: openssl-devel
141- removed static library from devel package
142
143* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.28.6-2
144- rebuilt with rpm-4.8.1 for pkg-config
145
146* Tue Aug 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.6-1
147- new upstream release with security fix (CVE-2009-2473, 2474)
148
149* Sat Jan 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.28.3-3vl5
150- rebuild with gnutls-2.6.3
151
152* Sun Oct 19 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-2vl5
153- add Requires/BuildRequires krb5-libs/krb5-devel tags
154- add _smp_mflags into make section
155
156* Fri Oct 17 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-1vl5
157- new upstream release with security fix (CVE-2008-3746)
158
159* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.28.2-3vl5
160- removed *.la
161- spec in utf-8
162
163* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-2vl5
164- added --with-ssl=gnutls --enable-threadsafe-ssl
165- added BuildRequires: gnutls-devel
166
167* Fri Apr 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-1vl5
168- new upstream release
169
170* Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.26.3-0vl3
171- removed %%if !%%{build_compat32} case condition
172
173* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.26.3-0vl2
174- rebuild with expat-2.0.1
175
176* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.26.3-0vl1
177- new upstream release
178
179* Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl3
180- add Requires: zlib-devel, openssl-devel, expat-devel
181
182* Mon May 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl2
183- move %%configure from %%prep to %%build
184- remove unneeded locales.patch (for neon-0.26.x or later)
185
186* Wed Apr 05 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl1
187- new upstream release
188- drop doc.patch (patch0)
189- use more macros
190- drop BuildRequires: autoconf, automake
191- add *.pc to -devel (and compat32's) package
192- change group
193- add Requires: %%{name} = %%{version} to -devel (and compat32's) package
194- add doc/html instead of doc/* to %%doc
195- move %%{_mandir}/man1/* and %%{_bindir}/* to -devel package
196- run ldconfig in %%post,postun
197- add locales.patch (patch0)
198
199* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl3
200- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
201
202* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl2
203- added compat32- packages for x86_64 architecture support
204- added --libdir=%{_libdir} option to configure
205
206* Sun Sep  5 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.24.7-0vl1
207- new upstream release
208
209* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.4-0vl1
210- upstream release
211- update URL and Source0 tag: valid URL
212
213* Fri Sep 19 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.2-0vl1
214- upstream release
215- add BuildRequires: openssl-devel, libxml2-devel, zlib-devel
216- add Japanese Summary and %%description
217
218* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.23.5-1vl1
219- build VineLinux
220
221* Mon Nov 04 2002 David Summers <david@summersoft.fay.ar.us> 0.23.5-1
222- Updated to 0.23.5.
223
224* Tue Aug 27 2002 David Summers <david@summersoft.fay.ar.us> 0.23.2-1
225- Upgraded to 0.23.2.
226
227* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.22.0-1
228- Upgraded to 0.22.0.
229- Fixed compilation from CVS.
230- Took out man pages until I can figure out xmlto program.
231
232* Sat Aug 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-3
233- Fixed compilation on RedHat 7.2 by upgrading libtool and auto* packages
234  to RedHat 7.3 versions and fixing bug in spec file.
235- Gave up on CVS version of neon until we can figure out why autogen.sh doesn't
236  work.
237
238* Wed Jul 24 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-2
239- Fixed file ownership problems.  Made them owned by root.
240
241* Fri Jul 19 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-1
242- Updated to neon 0.21.3.
243
244* Tue Jun 16 2002 David Summers <david@summersoft.fay.ar.us> 0.21.2-1
245- Updated to neon 0.21.2.
246
247* Mon Jun 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.1-1
248- Updated to neon 0.21.1.
249- Now requires zlib >= 1.1.4.
250- Broke into zlib and zlib-devel.
251- Now builds shared library.
252
253* Sat Apr 27 2002 David Summers <david@summersoft.fay.ar.us> 0.19.4-1
254- Updated to neon 0.19.4.
255
256* Fri Feb 22 2002 David Summers <david@summersoft.fay.ar.us> 0.19.2-1
257- Updated to neon 0.19.2.
258
259* Thu Dec 20 2001 David Summers <david@summersoft.fay.ar.us> 0.18.2-1
260- Updated to neon 0.18.2.
261
262* Wed Oct 31 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-2
263- Took out dependency on libxml and w3c-libwww packages.
264- Added dependency on expat.
265
266* Sat Oct 27 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-1
267- Release 0.17.2-1: Updated neon.
268
269* Thu Oct 24 2001 David Summers <david@summersoft.fay.ar.us>
270- Release 2: Fixed prefix to be /usr instead of /usr/local.
271
272* Sat Oct 20 2001 David Summers <david@summersoft.fay.ar.us>
273- Release 2001-10-20: Initial Version.
274
Note: See TracBrowser for help on using the repository browser.