source: projects/specs/trunk/n/neon/neon-vl.spec @ 12120

Revision 12120, 9.1 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: neon
4Summary: An HTTP and WebDAV client library.
5Summary(ja): HTTP と WebDAV クライアントのライブラリ
6Version: 0.30.2
7Release: 1%{?_dist_release}
8License: LGPLv2+
9Group: System Environment/Libraries
10URL: http://www.webdav.org/neon/
11Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: expat
14Requires: zlib >= 1.1.4
15Requires: krb5-libs
16BuildRequires: expat-devel
17BuildRequires: gnutls-devel
18BuildRequires: krb5-devel
19BuildRequires: libxml2-devel
20BuildRequires: sed
21BuildRequires: zlib-devel
22BuildRequires: keyutils-libs-devel
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27%description
28neon is an HTTP and WebDAV client library, with a C interface;
29providing a high-level interface to HTTP and WebDAV methods along
30with a low-level interface for HTTP request handling.  neon
31supports persistent connections, proxy servers, basic, digest and
32Kerberos authentication, and has complete SSL support.
33
34%package devel
35Summary: Development libraries and C header files for the neon library
36Summary(ja): neon の開発用ライブラリおよび C言語ヘッダファイル
37Group: Development/Libraries
38Requires: %{name} = %{version}
39Requires: zlib-devel
40#Requires: openssl-devel
41Requires: expat-devel
42Requires: gnutls-devel
43Requires: krb5-devel
44Requires: keyutils-libs-devel
45
46%description devel
47The development library for the C language HTTP and WebDAV client library.
48
49%description devel -l ja
50C言語による HTTP と WebDAV クライアントのライブラリの開発用パッケージ
51
52## to build compat32 for x86_64 architecture support
53%package -n compat32-%{name}
54Summary: C language HTTP and WebDAV client library.
55Group: System Environment/Libraries
56Requires: expat
57Requires: zlib >= 1.1.4
58
59%description -n compat32-%{name}
60A C language HTTP and WebDAV client library.
61
62%package -n compat32-%{name}-devel
63Summary: A C language HTTP and WebDAV client library.
64Group: Development/Libraries
65Requires: compat32-%{name} = %{version}
66Requires: compat32-zlib-devel
67#Requires: compat32-openssl-devel
68Requires: compat32-expat-devel
69Requires: compat32-keyutils-libs-devel
70Requires: compat32-krb5-devel
71
72%description -n compat32-%{name}-devel
73The development library for the C language HTTP and WebDAV client library.
74
75%prep
76%setup -q
77
78# for GnuTLS 3.4
79
80sed -e 's/client_set/set/'  \
81        -e 's/gnutls_retr/&2/'  \
82        -e 's/type = t/cert_&/' \
83        -i src/ne_gnutls.c
84
85%build
86%configure \
87        --with-expat \
88        --with-ssl=gnutls \
89        --enable-threadsafe-ssl=posix \
90        --enable-shared \
91        --disable-static \
92        --with-force-ssl
93%__make %{?_smp_mflags}
94
95%install
96%__rm -rf %{buildroot}
97%makeinstall
98
99sed -ri "/^dependency_libs/{s,-l[^ ']*,,g}" \
100      $RPM_BUILD_ROOT%{_libdir}/libneon.la
101
102%find_lang %{name}
103
104## remove unuse files
105rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
106
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%post -p /sbin/ldconfig
112
113%postun -p /sbin/ldconfig
114
115%post -n compat32-%{name} -p /sbin/ldconfig
116
117%postun -n compat32-%{name} -p /sbin/ldconfig
118
119%files -f %{name}.lang
120%defattr(-,root,root)
121%doc AUTHORS BUGS ChangeLog INSTALL.win32 NEWS README THANKS TODO
122%doc doc/html
123%{_libdir}/*.so.*
124
125%files devel
126%defattr(-,root,root)
127%{_bindir}/*
128%{_includedir}/*
129%{_mandir}/man1/*
130%{_mandir}/man3/*
131#{_libdir}/*.a
132#{_libdir}/*.la
133%{_libdir}/*.so
134%{_libdir}/pkgconfig/*.pc
135
136%if %{build_compat32}
137%files -n compat32-%{name}
138%defattr(-,root,root)
139%{_libdir}/*.so.*
140
141%files -n compat32-%{name}-devel
142%defattr(-,root,root)
143#{_libdir}/*.a
144#{_libdir}/*.la
145%{_libdir}/pkgconfig/*.pc
146%endif
147
148%changelog
149* Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.30.2-1
150- new upstream release.
151
152* Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.30.1-1
153- new upstream release.
154- built with gnutls-3.4.x.
155
156* Tue Feb 25 2014 NAKAMURA Kenta <kenta@vinelinux.org> 0.30.0-1
157- update to 0.30.0
158
159* Sun Jan 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-2
160- rebuild with VineSeed environment
161
162* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-1
163- update to 0.29.6
164
165* Mon May 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.3-2
166- add BuildRequires: keyutils-libs-devel
167- add Requires: krb5-devel, keyutils-libs-devel (-devel package)
168
169* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 0.29.3-1
170- new upstream release
171
172* Thu Mar 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.6-3
173- rebuilt with krb5-libs-1.8.2
174- removed BR: openssl-devel
175- removed static library from devel package
176
177* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.28.6-2
178- rebuilt with rpm-4.8.1 for pkg-config
179
180* Tue Aug 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.6-1
181- new upstream release with security fix (CVE-2009-2473, 2474)
182
183* Sat Jan 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.28.3-3vl5
184- rebuild with gnutls-2.6.3
185
186* Sun Oct 19 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-2vl5
187- add Requires/BuildRequires krb5-libs/krb5-devel tags
188- add _smp_mflags into make section
189
190* Fri Oct 17 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-1vl5
191- new upstream release with security fix (CVE-2008-3746)
192
193* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.28.2-3vl5
194- removed *.la
195- spec in utf-8
196
197* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-2vl5
198- added --with-ssl=gnutls --enable-threadsafe-ssl
199- added BuildRequires: gnutls-devel
200
201* Fri Apr 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-1vl5
202- new upstream release
203
204* Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.26.3-0vl3
205- removed %%if !%%{build_compat32} case condition
206
207* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.26.3-0vl2
208- rebuild with expat-2.0.1
209
210* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.26.3-0vl1
211- new upstream release
212
213* Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl3
214- add Requires: zlib-devel, openssl-devel, expat-devel
215
216* Mon May 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl2
217- move %%configure from %%prep to %%build
218- remove unneeded locales.patch (for neon-0.26.x or later)
219
220* Wed Apr 05 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl1
221- new upstream release
222- drop doc.patch (patch0)
223- use more macros
224- drop BuildRequires: autoconf, automake
225- add *.pc to -devel (and compat32's) package
226- change group
227- add Requires: %%{name} = %%{version} to -devel (and compat32's) package
228- add doc/html instead of doc/* to %%doc
229- move %%{_mandir}/man1/* and %%{_bindir}/* to -devel package
230- run ldconfig in %%post,postun
231- add locales.patch (patch0)
232
233* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl3
234- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
235
236* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl2
237- added compat32- packages for x86_64 architecture support
238- added --libdir=%{_libdir} option to configure
239
240* Sun Sep  5 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.24.7-0vl1
241- new upstream release
242
243* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.4-0vl1
244- upstream release
245- update URL and Source0 tag: valid URL
246
247* Fri Sep 19 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.2-0vl1
248- upstream release
249- add BuildRequires: openssl-devel, libxml2-devel, zlib-devel
250- add Japanese Summary and %%description
251
252* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.23.5-1vl1
253- build VineLinux
254
255* Mon Nov 04 2002 David Summers <david@summersoft.fay.ar.us> 0.23.5-1
256- Updated to 0.23.5.
257
258* Tue Aug 27 2002 David Summers <david@summersoft.fay.ar.us> 0.23.2-1
259- Upgraded to 0.23.2.
260
261* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.22.0-1
262- Upgraded to 0.22.0.
263- Fixed compilation from CVS.
264- Took out man pages until I can figure out xmlto program.
265
266* Sat Aug 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-3
267- Fixed compilation on RedHat 7.2 by upgrading libtool and auto* packages
268  to RedHat 7.3 versions and fixing bug in spec file.
269- Gave up on CVS version of neon until we can figure out why autogen.sh doesn't
270  work.
271
272* Wed Jul 24 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-2
273- Fixed file ownership problems.  Made them owned by root.
274
275* Fri Jul 19 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-1
276- Updated to neon 0.21.3.
277
278* Sun Jun 16 2002 David Summers <david@summersoft.fay.ar.us> 0.21.2-1
279- Updated to neon 0.21.2.
280
281* Mon Jun 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.1-1
282- Updated to neon 0.21.1.
283- Now requires zlib >= 1.1.4.
284- Broke into zlib and zlib-devel.
285- Now builds shared library.
286
287* Sat Apr 27 2002 David Summers <david@summersoft.fay.ar.us> 0.19.4-1
288- Updated to neon 0.19.4.
289
290* Fri Feb 22 2002 David Summers <david@summersoft.fay.ar.us> 0.19.2-1
291- Updated to neon 0.19.2.
292
293* Thu Dec 20 2001 David Summers <david@summersoft.fay.ar.us> 0.18.2-1
294- Updated to neon 0.18.2.
295
296* Wed Oct 31 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-2
297- Took out dependency on libxml and w3c-libwww packages.
298- Added dependency on expat.
299
300* Sat Oct 27 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-1
301- Release 0.17.2-1: Updated neon.
302
303* Wed Oct 24 2001 David Summers <david@summersoft.fay.ar.us>
304- Release 2: Fixed prefix to be /usr instead of /usr/local.
305
306* Sat Oct 20 2001 David Summers <david@summersoft.fay.ar.us>
307- Release 2001-10-20: Initial Version.
308
Note: See TracBrowser for help on using the repository browser.