source: projects/specs/trunk/n/neon/neon-vl.spec @ 9911

Revision 9911, 9.0 KB checked in by tomop, 8 years ago (diff)

neon-0.30.1-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: neon
4Summary: An HTTP and WebDAV client library.
5Summary(ja): HTTP と WebDAV クライアントのライブラリ
6Version: 0.30.1
7Release: 1%{?_dist_release}
8License: LGPLv2+
9Group: System Environment/Libraries
10URL: http://www.webdav.org/neon/
11Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: expat
14Requires: zlib >= 1.1.4
15Requires: krb5-libs
16BuildRequires: expat-devel
17BuildRequires: gnutls-devel
18BuildRequires: krb5-devel
19BuildRequires: libxml2-devel
20BuildRequires: sed
21BuildRequires: zlib-devel
22BuildRequires: keyutils-libs-devel
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27%description
28neon is an HTTP and WebDAV client library, with a C interface;
29providing a high-level interface to HTTP and WebDAV methods along
30with a low-level interface for HTTP request handling.  neon
31supports persistent connections, proxy servers, basic, digest and
32Kerberos authentication, and has complete SSL support.
33
34%package devel
35Summary: Development libraries and C header files for the neon library
36Summary(ja): neon の開発用ライブラリおよび C言語ヘッダファイル
37Group: Development/Libraries
38Requires: %{name} = %{version}
39Requires: zlib-devel
40#Requires: openssl-devel
41Requires: expat-devel
42Requires: gnutls-devel
43Requires: krb5-devel
44Requires: keyutils-libs-devel
45
46%description devel
47The development library for the C language HTTP and WebDAV client library.
48
49%description devel -l ja
50C言語による HTTP と WebDAV クライアントのライブラリの開発用パッケージ
51
52## to build compat32 for x86_64 architecture support
53%package -n compat32-%{name}
54Summary: C language HTTP and WebDAV client library.
55Group: System Environment/Libraries
56Requires: expat
57Requires: zlib >= 1.1.4
58
59%description -n compat32-%{name}
60A C language HTTP and WebDAV client library.
61
62%package -n compat32-%{name}-devel
63Summary: A C language HTTP and WebDAV client library.
64Group: Development/Libraries
65Requires: compat32-%{name} = %{version}
66Requires: compat32-zlib-devel
67#Requires: compat32-openssl-devel
68Requires: compat32-expat-devel
69Requires: compat32-keyutils-libs-devel
70Requires: compat32-krb5-devel
71
72%description -n compat32-%{name}-devel
73The development library for the C language HTTP and WebDAV client library.
74
75%prep
76%setup -q
77
78# for GnuTLS 3.4
79
80sed -e 's/client_set/set/'  \
81        -e 's/gnutls_retr/&2/'  \
82        -e 's/type = t/cert_&/' \
83        -i src/ne_gnutls.c
84
85%build
86%configure \
87        --with-expat \
88        --with-ssl=gnutls \
89        --enable-threadsafe-ssl=posix \
90        --enable-shared \
91        --disable-static \
92        --with-force-ssl
93%__make %{?_smp_mflags}
94
95%install
96%__rm -rf %{buildroot}
97%makeinstall
98
99sed -ri "/^dependency_libs/{s,-l[^ ']*,,g}" \
100      $RPM_BUILD_ROOT%{_libdir}/libneon.la
101
102%find_lang %{name}
103
104## remove unuse files
105rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
106
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%post -p /sbin/ldconfig
112
113%postun -p /sbin/ldconfig
114
115%post -n compat32-%{name} -p /sbin/ldconfig
116
117%postun -n compat32-%{name} -p /sbin/ldconfig
118
119%files -f %{name}.lang
120%defattr(-,root,root)
121%doc AUTHORS BUGS ChangeLog INSTALL.win32 NEWS README THANKS TODO
122%doc doc/html
123%{_libdir}/*.so.*
124
125%files devel
126%defattr(-,root,root)
127%{_bindir}/*
128%{_includedir}/*
129%{_mandir}/man1/*
130%{_mandir}/man3/*
131#{_libdir}/*.a
132#{_libdir}/*.la
133%{_libdir}/*.so
134%{_libdir}/pkgconfig/*.pc
135
136%if %{build_compat32}
137%files -n compat32-%{name}
138%defattr(-,root,root)
139%{_libdir}/*.so.*
140
141%files -n compat32-%{name}-devel
142%defattr(-,root,root)
143#{_libdir}/*.a
144#{_libdir}/*.la
145%{_libdir}/pkgconfig/*.pc
146%endif
147
148%changelog
149* Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.30.1-1
150- new upstream release.
151- built with gnutls-3.4.x.
152
153* Tue Feb 25 2014 NAKAMURA Kenta <kenta@vinelinux.org> 0.30.0-1
154- update to 0.30.0
155
156* Sun Jan 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-2
157- rebuild with VineSeed environment
158
159* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-1
160- update to 0.29.6
161
162* Mon May 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.3-2
163- add BuildRequires: keyutils-libs-devel
164- add Requires: krb5-devel, keyutils-libs-devel (-devel package)
165
166* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 0.29.3-1
167- new upstream release
168
169* Thu Mar 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.6-3
170- rebuilt with krb5-libs-1.8.2
171- removed BR: openssl-devel
172- removed static library from devel package
173
174* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.28.6-2
175- rebuilt with rpm-4.8.1 for pkg-config
176
177* Tue Aug 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.6-1
178- new upstream release with security fix (CVE-2009-2473, 2474)
179
180* Sat Jan 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.28.3-3vl5
181- rebuild with gnutls-2.6.3
182
183* Sun Oct 19 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-2vl5
184- add Requires/BuildRequires krb5-libs/krb5-devel tags
185- add _smp_mflags into make section
186
187* Fri Oct 17 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-1vl5
188- new upstream release with security fix (CVE-2008-3746)
189
190* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.28.2-3vl5
191- removed *.la
192- spec in utf-8
193
194* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-2vl5
195- added --with-ssl=gnutls --enable-threadsafe-ssl
196- added BuildRequires: gnutls-devel
197
198* Fri Apr 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-1vl5
199- new upstream release
200
201* Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.26.3-0vl3
202- removed %%if !%%{build_compat32} case condition
203
204* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.26.3-0vl2
205- rebuild with expat-2.0.1
206
207* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.26.3-0vl1
208- new upstream release
209
210* Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl3
211- add Requires: zlib-devel, openssl-devel, expat-devel
212
213* Mon May 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl2
214- move %%configure from %%prep to %%build
215- remove unneeded locales.patch (for neon-0.26.x or later)
216
217* Wed Apr 05 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl1
218- new upstream release
219- drop doc.patch (patch0)
220- use more macros
221- drop BuildRequires: autoconf, automake
222- add *.pc to -devel (and compat32's) package
223- change group
224- add Requires: %%{name} = %%{version} to -devel (and compat32's) package
225- add doc/html instead of doc/* to %%doc
226- move %%{_mandir}/man1/* and %%{_bindir}/* to -devel package
227- run ldconfig in %%post,postun
228- add locales.patch (patch0)
229
230* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl3
231- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
232
233* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl2
234- added compat32- packages for x86_64 architecture support
235- added --libdir=%{_libdir} option to configure
236
237* Sun Sep  5 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.24.7-0vl1
238- new upstream release
239
240* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.4-0vl1
241- upstream release
242- update URL and Source0 tag: valid URL
243
244* Fri Sep 19 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.2-0vl1
245- upstream release
246- add BuildRequires: openssl-devel, libxml2-devel, zlib-devel
247- add Japanese Summary and %%description
248
249* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.23.5-1vl1
250- build VineLinux
251
252* Mon Nov 04 2002 David Summers <david@summersoft.fay.ar.us> 0.23.5-1
253- Updated to 0.23.5.
254
255* Tue Aug 27 2002 David Summers <david@summersoft.fay.ar.us> 0.23.2-1
256- Upgraded to 0.23.2.
257
258* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.22.0-1
259- Upgraded to 0.22.0.
260- Fixed compilation from CVS.
261- Took out man pages until I can figure out xmlto program.
262
263* Sat Aug 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-3
264- Fixed compilation on RedHat 7.2 by upgrading libtool and auto* packages
265  to RedHat 7.3 versions and fixing bug in spec file.
266- Gave up on CVS version of neon until we can figure out why autogen.sh doesn't
267  work.
268
269* Wed Jul 24 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-2
270- Fixed file ownership problems.  Made them owned by root.
271
272* Fri Jul 19 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-1
273- Updated to neon 0.21.3.
274
275* Sun Jun 16 2002 David Summers <david@summersoft.fay.ar.us> 0.21.2-1
276- Updated to neon 0.21.2.
277
278* Mon Jun 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.1-1
279- Updated to neon 0.21.1.
280- Now requires zlib >= 1.1.4.
281- Broke into zlib and zlib-devel.
282- Now builds shared library.
283
284* Sat Apr 27 2002 David Summers <david@summersoft.fay.ar.us> 0.19.4-1
285- Updated to neon 0.19.4.
286
287* Fri Feb 22 2002 David Summers <david@summersoft.fay.ar.us> 0.19.2-1
288- Updated to neon 0.19.2.
289
290* Thu Dec 20 2001 David Summers <david@summersoft.fay.ar.us> 0.18.2-1
291- Updated to neon 0.18.2.
292
293* Wed Oct 31 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-2
294- Took out dependency on libxml and w3c-libwww packages.
295- Added dependency on expat.
296
297* Sat Oct 27 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-1
298- Release 0.17.2-1: Updated neon.
299
300* Wed Oct 24 2001 David Summers <david@summersoft.fay.ar.us>
301- Release 2: Fixed prefix to be /usr instead of /usr/local.
302
303* Sat Oct 20 2001 David Summers <david@summersoft.fay.ar.us>
304- Release 2001-10-20: Initial Version.
305
Note: See TracBrowser for help on using the repository browser.