source: projects/specs/trunk/n/ncurses/ncurses-vl.spec @ 12277

Revision 12277, 20.3 KB checked in by tomop, 5 years ago (diff)

updated 22 packages

Cython-0.29.13-1

alsa-lib-1.1.9-1

alsa-plugins-1.1.9-1

alsa-tools-1.1.7-1

alsa-utils-1.1.9-1

cairo-1.16.0-1

evince-3.30.3-1

expat-2.2.9-1

file-roller-3.30.1-1

gtk-doc-1.32-2

libplist-2.0.0-1

libsndfile-1.0.28-1

ncurses-6.1-2

openssh-8.1p1-1

python-2.7.16-5

python3-3.5.7-4

rsync-3.1.3-1

samba-4.10.9-1

sudo-1.8.28-1

sysstat-12.1.7-1

tix-8.4.3-5

zabbix-4.0.13-1

Line 
1%global revision 20191015
2
3Summary: A screen handling and optimization package.
4Summary(ja): スクリーンの操作と最適化を行うパッケージ
5Name: ncurses
6Version: 6.1
7%define includedirw %{_includedir}/ncursesw
8%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
9Release: 2%{?_dist_release}
10License: distributable
11Group: System Environment/Libraries
12URL: https://invisible-island.net/ncurses/ncurses.html
13Source0: https://invisible-mirror.net/archives/ncurses/current/ncurses-6.1-%{revision}.tgz
14Patch8: ncurses-config.patch
15Patch9: ncurses-libs.patch
16Patch11: ncurses-urxvt.patch
17Patch12: ncurses-kbs.patch
18
19Requires(post): /sbin/ldconfig
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: pkgconfig
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: daisuke
27
28%description
29The curses library routines are a terminal-independent method of
30updating character screens with reasonable optimization.  The ncurses
31(new curses) library is a freely distributable replacement for the
32discontinued 4.4 BSD classic curses library.
33
34
35%package devel
36Summary: The development files for applications which use ncurses.
37Summary(ja): ncurses を用いるアプリケーション開発用のファイル
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40Obsoletes: libtermcap-devel <= 2.0.8-46vl1
41Provides: libtermcap-devel = 2.0.8-47
42
43%description devel
44The header files and libraries for developing applications that use
45the ncurses CRT screen handling and optimization package.
46
47Install the ncurses-devel package if you want to develop applications
48which will use ncurses.
49
50Use the following compiler flags to build against the ncurses library:
51                                                                               
52-lncurses
53(compile and link against the regular ncurses library)
54                                                                               
55-I %{includedirw} -lncursesw
56(compile and link against the wide-character, UTF-8, library)
57
58
59%package c++-devel
60Summary: C++ bindings to ncurses
61Group: Development/Libraries
62Requires: %{name} = %{version}-%{release}
63Requires: %{name}-devel = %{version}-%{release}
64 
65%description c++-devel
66C++ bindings to ncurses
67
68
69%package -n compat32-%{name}
70Summary: A screen handling and optimization package.
71Summary(ja): スクリーンの操作と最適化を行うパッケージ
72Group: System Environment/Libraries
73Requires: %{name} = %{version}-%{release}
74
75%description -n compat32-%{name}
76The curses library routines are a terminal-independent method of
77updating character screens with reasonable optimization.  The ncurses
78(new curses) library is a freely distributable replacement for the
79discontinued 4.4 BSD classic curses library.
80
81
82%package -n compat32-%{name}-devel
83Summary: The development files for applications which use ncurses.
84Summary(ja): ncurses を用いるアプリケーション開発用のファイル
85Group: Development/Libraries
86Requires: compat32-%{name} = %{version}-%{release}
87Requires: %{name}-devel = %{version}-%{release}
88Obsoletes: compat32-libtermcap-devel <= 2.0.8-46vl1
89Provides: compat32-libtermcap-devel = 2.0.8-47
90
91%description -n compat32-%{name}-devel
92The header files and libraries for developing applications that use
93the ncurses CRT screen handling and optimization package.
94
95Install the ncurses-devel package if you want to develop applications
96which will use ncurses.
97
98Use the following compiler flags to build against the ncurses library:
99                                                                               
100-lncurses
101(compile and link against the regular ncurses library)
102                                                                               
103-I %{includedirw} -lncursesw
104(compile and link against the wide-character, UTF-8, library)
105
106
107%package -n compat32-%{name}-c++-devel
108Summary: C++ bindings to ncurses
109Group: System Environment/Libraries
110Requires: compat32-%{name} = %{version}-%{release}
111Requires: compat32-%{name}-devel = %{version}-%{release}
112Requires: %{name}-c++-devel = %{version}-%{release}
113 
114%description -n compat32-%{name}-c++-devel
115C++ bindings to ncurses
116
117
118%prep
119%setup -q -n %{name}-%{version}-%{revision}
120
121%patch8 -p1 -b .config
122%patch9 -p1 -b .libs
123%patch11 -p1 -b .urxvt
124%patch12 -p1 -b .kbs
125
126for f in ANNOUNCE; do
127    iconv -f iso8859-1 -t utf8 -o ${f}{_,} &&
128        touch -r ${f}{,_} && mv -f ${f}{_,}
129done
130
131%build
132%define rootdatadir /lib
133common_options=" \
134    --enable-colorfgbg \
135    --enable-hard-tabs \
136    --enable-overwrite \
137    --enable-pc-files \
138    --enable-xmc-glitch \
139    --disable-stripping \
140    --disable-wattr-macros \
141    --with-ospeed=unsigned \
142    --with-pkg-config-libdir=%{_libdir}/pkgconfig \
143    --with-shared \
144    --with-terminfo-dirs=%{_sysconfdir}/terminfo:%{_datadir}/terminfo:%{rootdatadir}/terminfo \
145    --with-termlib=tinfo \
146    --with-ticlib=tic \
147    --with-xterm-kbs=DEL \
148    --without-ada"
149abi5_options="--with-chtype=long"
150
151for abi in 5 6; do
152    for char in narrowc widec; do
153        mkdir $char$abi
154        pushd $char$abi
155        ln -s ../configure .
156
157        [ $abi = 6 -a $char = widec ] && progs=yes || progs=no
158
159        %configure $(
160            echo $common_options --with-abi-version=$abi
161            [ $abi = 5 ] && echo $abi5_options
162            [ $char = widec ] && echo --enable-widec
163            [ $progs = yes ] || echo --without-progs
164        )
165
166        make %{?_smp_mflags} libs
167        [ $progs = yes ] && make %{?_smp_mflags} -C progs
168
169        popd
170    done
171done
172
173
174%install
175rm -rf ${RPM_BUILD_ROOT}
176
177make -C narrowc5 DESTDIR=$RPM_BUILD_ROOT install.libs
178rm ${RPM_BUILD_ROOT}%{_libdir}/lib{tic,tinfo}.so.5*
179make -C widec5 DESTDIR=$RPM_BUILD_ROOT install.libs
180make -C narrowc6 DESTDIR=$RPM_BUILD_ROOT install.libs
181rm ${RPM_BUILD_ROOT}%{_libdir}/lib{tic,tinfo}.so.6*
182make -C widec6 DESTDIR=$RPM_BUILD_ROOT install.{libs,progs,data,includes,man}
183
184chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/lib*.so.*.*
185chmod 644 ${RPM_BUILD_ROOT}%{_libdir}/lib*.a
186
187# move lib{ncurses{,w},tinfo}.so.* to /lib*
188mkdir $RPM_BUILD_ROOT/%{_lib}
189mv $RPM_BUILD_ROOT%{_libdir}/lib{ncurses{,w},tinfo}.so.* $RPM_BUILD_ROOT/%{_lib}
190for l in $RPM_BUILD_ROOT%{_libdir}/lib{ncurses{,w},tinfo}.so; do
191    ln -sf $(echo %{_libdir} | \
192        sed 's,\(^/\|\)[^/][^/]*,..,g')/%{_lib}/$(readlink $l) $l
193done
194
195mkdir -p $RPM_BUILD_ROOT{%{rootdatadir},%{_sysconfdir}}/terminfo
196
197# move few basic terminfo entries to /lib
198baseterms=
199for termname in \
200        ansi dumb linux vt100 vt100-nav vt102 vt220 vt52
201do
202    for t in $(find $RPM_BUILD_ROOT%{_datadir}/terminfo \
203        -samefile $RPM_BUILD_ROOT%{_datadir}/terminfo/${termname::1}/$termname)
204    do
205        baseterms="$baseterms $(basename $t)"
206    done
207done
208for termname in $baseterms; do
209    termpath=terminfo/${termname::1}/$termname
210    mkdir $RPM_BUILD_ROOT%{rootdatadir}/terminfo/${termname::1} &> /dev/null || :
211    mv $RPM_BUILD_ROOT%{_datadir}/$termpath $RPM_BUILD_ROOT%{rootdatadir}/$termpath
212    ln -s $(dirname %{_datadir}/$termpath | \
213        sed 's,\(^/\|\)[^/][^/]*,..,g')%{rootdatadir}/$termpath \
214        $RPM_BUILD_ROOT%{_datadir}/$termpath
215done
216
217# prepare -base and -term file lists
218for termname in \
219    ansi dumb linux vt100 vt100-nav vt102 vt220 vt52 \
220    Eterm\* aterm bterm cons25 cygwin eterm\* gnome gnome-256color hurd jfbterm \
221    konsole konsole-256color mach\* mlterm mrxvt nsterm putty{,-256color} pcansi \
222    rxvt{,-\*} screen{,-\*color,.[^mlp]\*,.linux,.mlterm\*,.putty{,-256color},.mrxvt} \
223    st{,-\*color} sun teraterm teraterm2.3 tmux{,-\*} vte vte-256color vwmterm \
224    wsvt25\* xfce xterm xterm-\*
225do
226    for i in $RPM_BUILD_ROOT%{_datadir}/terminfo/?/$termname; do
227        for t in $(find $RPM_BUILD_ROOT%{_datadir}/terminfo -samefile $i); do
228            baseterms="$baseterms $(basename $t)"
229        done
230    done
231done 2> /dev/null
232for t in $baseterms; do
233    echo "%dir %{_datadir}/terminfo/${t::1}"
234    echo %{_datadir}/terminfo/${t::1}/$t
235done 2> /dev/null | sort -u > terms.base
236find $RPM_BUILD_ROOT%{_datadir}/terminfo \! -type d | \
237    sed "s|^$RPM_BUILD_ROOT||" | while read t
238do
239    echo "%dir $(dirname $t)"
240    echo $t
241done 2> /dev/null | sort -u | comm -2 -3 - terms.base > terms.term
242
243cat terms.base terms.term |sort -u > terms.all
244
245# can't replace directory with symlink (rpm bug), symlink all headers
246mkdir $RPM_BUILD_ROOT%{_includedir}/ncurses{,w}
247for l in $RPM_BUILD_ROOT%{_includedir}/*.h; do
248    ln -s ../$(basename $l) $RPM_BUILD_ROOT%{_includedir}/ncurses
249    ln -s ../$(basename $l) $RPM_BUILD_ROOT%{_includedir}/ncursesw
250done
251
252# don't require -ltinfo when linking with --no-add-needed
253for l in $RPM_BUILD_ROOT%{_libdir}/libncurses{,w}.so; do
254    soname=$(basename $(readlink $l))
255    rm -f $l
256    echo "INPUT($soname -ltinfo)" > $l
257done
258             
259rm -f $RPM_BUILD_ROOT%{_libdir}/libcurses{,w}.so
260echo "INPUT(-lncurses)" > $RPM_BUILD_ROOT%{_libdir}/libcurses.so
261echo "INPUT(-lncursesw)" > $RPM_BUILD_ROOT%{_libdir}/libcursesw.so
262
263echo "INPUT(-ltinfo)" > $RPM_BUILD_ROOT%{_libdir}/libtermcap.so
264
265rm -f ${RPM_BUILD_ROOT}%{_libdir}/terminfo
266#rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/{*_g,ncurses++*}.pc
267
268
269%post -p /sbin/ldconfig
270
271%postun -p /sbin/ldconfig
272
273%post -n compat32-%{name} -p /sbin/ldconfig
274
275%postun -n compat32-%{name} -p /sbin/ldconfig
276
277
278%files -f terms.all
279%defattr(-,root,root)
280%doc ANNOUNCE AUTHORS README TO-DO
281%{_bindir}/[cirt]*
282%{_mandir}/man1/*
283%{_mandir}/man5/*
284%{_mandir}/man7/*
285/%{_lib}/lib*.so.*
286%{_libdir}/lib*.so.*
287%dir %{_sysconfdir}/terminfo
288%{rootdatadir}/terminfo
289%{_datadir}/tabset
290%dir %{_datadir}/terminfo
291
292%files devel
293%defattr(-,root,root)
294%doc test
295%doc doc/html/hackguide.html
296%doc doc/html/ncurses-intro.html
297%doc c++/README*
298%{_bindir}/ncurses*-config
299%{_libdir}/lib*.so
300%{_libdir}/lib*.a
301 %dir %{_includedir}/ncurses
302%dir %{_includedir}/ncursesw
303%{_includedir}/ncurses/*.h
304%{_includedir}/ncursesw/*.h
305%{_includedir}/*.h
306%{_mandir}/man3/*
307%{_libdir}/pkgconfig/*.pc
308%exclude %{_libdir}/pkgconfig/ncurses++*.pc
309
310%files c++-devel
311%defattr(-,root,root)
312%doc c++/NEWS c++/PROBLEMS c++/README*
313%{_includedir}/ncurses/cursesapp.h
314%{_includedir}/ncurses/curses?.h
315%{_includedir}/ncurses/etip.h
316%{_libdir}/libncurses++.a
317%{_libdir}/libncurses++w.a
318%{_libdir}/pkgconfig/ncurses++*.pc
319
320%if %{build_compat32}
321%files -n compat32-%{name}
322%defattr(-,root,root)
323%attr(755,root,root) %{_libdir}/lib*.so.*
324/%{_lib}/lib*.so.*
325%{_libdir}/lib*.so.*
326
327
328%files -n compat32-%{name}-devel
329%defattr(-,root,root)
330%{_libdir}/lib*.so
331%{_libdir}/lib*.a
332%{_libdir}/pkgconfig/*.pc
333%exclude %{_libdir}/pkgconfig/ncurses++*.pc
334 
335
336%files -n compat32-%{name}-c++-devel
337%defattr(-,root,root)
338%{_libdir}/libncurses++.a
339%{_libdir}/libncurses++w.a
340%{_libdir}/pkgconfig/ncurses++*.pc
341%endif
342
343
344%clean
345rm -rf $RPM_BUILD_ROOT
346
347
348%changelog
349* Fri Oct 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.1-2
350- updated to 6.1 + 20191015.
351- updated Patch8.
352
353* Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.1-1
354- updated to 6.1 + 20190824.
355
356* Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.9-3
357- rebuild with VineSeed environment
358
359* Wed Dec 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.9-2
360- don't require -ltinfo when linking with --no-add-needed
361
362* Fri Sep 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.9-1
363- update to 5.9 + 20110716
364- update all patches
365- add pkgconfig file
366
367* Sun Mar 27 2011 IWAI, Masaharu <iwai@alib.jp> 5.6-5
368- build with new toolchain
369
370* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.6-4
371- rebuilt with new toolchain
372- add Requires(post,pre): /sbin/ldconfig
373
374* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 5.6-3
375- updated %%files section on compat32-* packages
376
377* Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.6-2
378- changed c++-devel Group to Development/Libraries
379- changelog of 5.6-1 is missing... seemed to be updated on Aug 10 2008
380
381* Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 5.4-0vl3
382- added compat32- packages for x86_64 architecture support
383
384* Mon May 17 2004 Tomoya TAKA <taka@vinelinux.org> 5.4-0vl2
385- add patch10 taken from fedora's 5.4-4
386
387* Sun May  9 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4-0vl1
388- new upstream release
389- remove obsolete patches
390
391* Mon Mar 22 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.3-9vl1
392- synced up with Fedora 5.3-9
393  - Thu Sep 11 2003 Adrian Havill <havill@redhat.com> 5.3-9
394  - remove not-so safe-sprintf configure option because the code does
395    not appear to be stable enough for some apps. (#103790)
396 
397  - Wed Aug 20 2003 Adrian Havill <havill@redhat.com> 5.3-8.1
398  - RHEL bump
399 
400  - Wed Aug 20 2003 Adrian Havill <havill@redhat.com> 5.3-8
401  - multilib patch (#91211)
402 
403  - Mon Aug 11 2003 Adrian Havill <havill@redhat.com> 5.3-7
404  - fixed the safe sprintf code that was enabled in the previous release
405    by the configure parameter. (#101486)
406 
407  - Mon Jun 16 2003 Elliot Lee <sopwith@redhat.com> 5.3-6.1
408  - Fix ac25 patch, make it easy to turn off GPM support
409 
410  - Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
411  - rebuilt
412 
413  - Thu May 22 2003 Adrian Havill <havill@redhat.com> 5.3-5
414  - added latest rollup patch with widec/UTF8 centric weekly (20030517)
415  - added --enable-widec to configure (#86311)
416    original work done by Mr. Sam <sam@email-scan.com>
417  - require sharutils (#86605)
418  - add gpm, xmc support
419  - add debug syms back into package
420  - updated autoconf/configure patch
421
422* Thu Mar 27 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.3-4vl1
423- synced Rawhide 5.3-4
424
425* Fri Feb 08 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.2-16vl2
426- revert to patch13 from 14 for XF86-4
427
428* Wed Feb 06 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.2-16vl1
429- synced Rawhide 5.2-16
430
431* Tue Aug 28 2001 Shoji Matsumoto <shom@vinelinux.org> 5.2-12vl2
432- patch 3 (xterm) disabled. this patch is for XF86-4???
433
434* Wed Aug 22 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.2-12vl1
435- added kon patch for Vine
436
437* Fri Jul 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.2-12
438- Sync terminfo with termcap 11.0.1-10
439
440* Sun Jun 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.2-11
441- Update to patchlevel 20010623, fixes some lynx issues
442 
443* Mon Jun 18 2001 Helge Deller <hdeller@redhat.de>
444- fixed tput -S segfaulting bug (#44669)
445- use _tmppath for BuildRoot:
446- Copyright -> License
447
448* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
449- Update to patchlevel 20010407
450
451* Tue Mar  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
452- Fix up some terminfo entries containing includes to
453  "/var/tmp/ncurses-root/something" (#30771)
454
455* Thu Feb 22 2001 Harald Hoyer <harald@redhat.de>
456- fixed rxvt backspace setting
457
458* Fri Feb  9 2001 Yukihiro Nakai <ynakai@redhat.com>
459- Update Japanese kterm patch
460
461* Mon Jan 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
462- Update
463- Add japanese patch from termcap
464- Fix ospeed handling
465
466* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
467- Add libcurses.a -> libncurses.a symlink (RFE #23023)
468
469* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
470- Use --with-ospeed='unsigned int'
471
472* Fri Nov 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
473- Fix alpha and ia64
474- Rebuild with gcc 2.96-64
475
476* Thu Nov  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
477- 5.2
478- Fix typo in man page (Bug #20205)
479- update the "screen" terminfo entries to the version supplied with
480  screen 3.9.8
481
482* Mon Oct  9 2000 Bernhard Rosenkraenzer <bero@redhat.com>
483- Update (fixes the "make menuconfig" bug introduced by the security fix)
484
485* Tue Oct  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
486- Fix security problem (possible buffer overrun)
487
488* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
489- Add the bugfix patches from the ncurses maintainer
490
491* Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
492- 5.1
493
494* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
495- automatic rebuild
496
497* Mon Jun  5 2000 Matt Wilson <msw@redhat.com>
498- *don't ship symlinks from lib*.so.5 to lib*.so.4!
499- use FHS macros
500
501* Fri Jun  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
502- rebuild for 7.0
503- /usr/share/man
504- update URL for patches
505- misc. fixes to spec file
506
507* Mon Mar 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
508- use the real library version number
509- update to 20000319
510
511* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
512- rebuild for sparc baud rates > 38400.
513
514* Fri Feb 18 2000 Preston Brown <pbrown@redhat.com>
515- xterm terminfo entries from XFree86 3.3.6
516- final round of xterm fixes, follow debian policy.
517
518* Sat Feb  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
519- strip libraries
520
521* Thu Feb  3 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
522- More xterm fixes (Bug #9087)
523
524* Thu Jan 27 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
525- More xterm fixes from Hans de Goede (Bug #8633)
526
527* Sat Jan 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
528- remove some broken symlinks (leftovers from libncurses.so.5)
529- Use %configure (Bug #8484)
530
531* Tue Jan 11 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
532- Add xterm patch from Hans de Goede <hans@highrise.nl>
533- Patch 20000108, this fixes a problem with a header file.
534
535* Wed Jan  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
536- Add 20000101 patch, hopefully finally fixing the xterm description
537
538* Wed Dec 22 1999 Cristian Gafton <gafton@redhat.com>
539- revert to the old major number - because the ABI is not changed (and we
540  should be handling the changes via symbol versioning anyway)
541
542* Fri Nov 12 1999 Bernhard Rosenkraenzer <bero@redhat.com>
543- Fix a typo in spec
544- Add the 19991006 patch, fixing some C++ STL compatibility problems.
545- get rid of profiling and debugging versions - we need to save space...
546
547* Thu Nov  4 1999 Bernhard Rosenkraenzer <bero@redhat.com>
548- 5.0
549- some spec cleanups to make updating easier
550- add links *.so.5 to *.so.4 - they are fully binary compatible.
551  (Why did they change the invocation number???)
552
553* Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
554- make clean in the test dir - don't ship any binaries at all.
555
556* Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
557- fixed stripping of test programs.
558
559* Sun Aug 29 1999 Preston Brown <pbrown@redhat.com>
560- removed 'flash' capability for xterm; see bug #2820 for details.
561
562* Fri Aug 27 1999 Cristian Gafton <gafton@redhat.com>
563- add the resetall script from Marc Merlin <marc@merlins.org>
564
565* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
566- added iris-ansi-net as alias for iris-ansi (bug #2561)
567
568* Fri Jul 30 1999 Michael K. Johnson <johnsonm@redhat.com>
569- added ncurses-intro.hmtl and hackguide.html to -devel package [bug #3929]
570
571* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
572- make sure ALL binaries are stripped (incl. test binaries)
573
574* Thu Mar 25 1999 Preston Brown <pbrown@redhat.com>
575- made xterm terminfo stuff MUCH better.
576
577* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
578- auto rebuild in the new build environment (release 16)
579
580* Sat Mar 13 1999 Cristian Gafton <gafton@redhat.com>
581- fixed header for C++ compiles
582
583* Fri Mar 12 1999 Jeff Johnson <jbj@redhat.com>
584- add terminfo entries for linux/linux-m on sparc (obsolete termfile_sparc).
585
586* Thu Feb 18 1999 Cristian Gafton <gafton@redhat.com>
587- updated patchset from original site
588
589* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
590- don't build the C++ demo code
591- update patch set to the current as of today (redid all the individual
592  patches in a single one)
593
594* Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
595- make sure to strip the binaries
596
597* Wed Sep 23 1998 Cristian Gafton <gafton@redhat.com>
598- added another zillion of patches. The spec file *is* ugly
599- defattr
600
601* Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
602- added lots of patches. This spec file is starting to look ugly
603
604* Wed Jul 01 1998 Alan Cox <alan@redhat.com>
605- Fix setuid trusting. Open termcap/info files as the real user.
606
607* Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
608- added terminfo entry for the poor guys using lat1 and/or lat-2 on their
609  consoles... Enjoy linux-lat ! Thanks, Erik !
610
611* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
612- new patch to get xterm-color and nxterm terminfo entries
613- aliased them to rxvt, as that seems to satisfy everybody
614
615* Sun Apr 12 1998 Cristian Gafton <gafton@redhat.com>
616- added %clean section
617
618* Tue Apr 07 1998 Cristian Gafton <gafton@redhat.com>
619- removed /usr/lib/terminfo symlink - we shouldn't need that
620
621* Mon Apr 06 1998 Cristian Gafton <gafton@redhat.com>
622- updated to 4.2 + patches
623- added BuildRoot
624
625* Sat Apr 04 1998 Cristian Gafton <gafton@redhat.com>
626- rebuilt with egcs on alpha
627
628* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
629- version 7 didn't rebuild properly on the Alpha somehow -- no real changes
630  are in this version
631
632* Tue Dec 09 1997 Erik Troan <ewt@redhat.com>
633- TIOCGWINSZ wasn't used properly
634
635* Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
636- built against glibc, linked shared libs against -lc
637
Note: See TracBrowser for help on using the repository browser.