source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 9806

Revision 9806, 31.6 KB checked in by Takemikaduchi, 9 years ago (diff)

fnew upstream release

Line 
1%define glib2_version 2.46.0
2%define pango_version 1.38.1
3%define gtk3_version 3.18.0
4%define libxml2_version 2.9.1
5%define eog_version 3.18.0
6%define gnome_desktop3_version 3.18.0
7%define vine_menus_version 3.0
8%define startup_notification_version 0.10
9%define libexif_version 0.6.19
10%define tracker_version 1.6.0
11%define gobject_introspection_version 0.9.8
12
13Name:           nautilus
14Summary:        Nautilus is a file manager for GNOME
15Summary(ja):    Nautilus - GNOME ファイルマネージャ
16Version:        3.18.2
17Release:        1%{?_dist_release}
18License:        GPLv2+
19Group:          User Interface/Desktops
20URL:            http://www.gnome.org/projects/nautilus/
21
22Vendor:         Project Vine
23Distribution:   Vine Linux
24Packager:       Takemikaduchi
25
26Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.18/%{name}-%{version}.tar.xz
27
28# vine
29Patch102:       run_in_gnome.patch
30Patch2000:      nautilus-vine-settings.patch
31
32BuildRoot:      %{_tmppath}/%{name}-%{version}-root
33Requires:       gamin
34Requires:       vine-menus >= %{vine_menus_version}
35Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
36Requires:       libexif >= %{libexif_version}
37Requires:       %{name}-libs = %{version}-%{release}
38
39BuildRequires:  intltool
40BuildRequires:  libtool >= 1.4.2-10
41BuildRequires:  automake, autoconf
42BuildRequires:  desktop-file-utils
43
44BuildRequires:  glib2-devel >= %{glib2_version}
45BuildRequires:  pango-devel >= %{pango_version}
46BuildRequires:  gtk3-devel >= %{gtk3_version}
47BuildRequires:  libxml2-devel >= %{libxml2_version}
48BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
49BuildRequires:  gamin-devel
50BuildRequires:  startup-notification-devel >= %{startup_notification_version}
51BuildRequires:  tracker-devel >= %{tracker_version}
52BuildRequires:  libexif-devel >= %{libexif_version}
53BuildRequires:  unique3-devel
54BuildRequires:  libnotify-devel
55BuildRequires:  libSM-devel
56BuildRequires:  exempi-devel
57BuildRequires:  tracker-devel
58BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
59BuildRequires:  gsettings-desktop-schemas
60
61Obsoletes:      nautilus-extras
62Obsoletes:      nautilus-suggested
63Obsoletes:      nautilus-mozilla < 2.0
64Obsoletes:      eel2 <= 2.24.1
65
66Provides:       eel2 <= 2.24.1
67
68
69%description
70Nautilus integrates access to files, applications, media,
71Internet-based resources and the Web. Nautilus delivers a dynamic and
72rich user experience. Nautilus is an free software project developed
73under the GNU General Public License and is a core component of the
74GNOME desktop project.
75
76%description -l ja
77Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
78リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
79豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
80のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
81プロジェクトのコア・コンポーネントです。
82
83
84%package        devel
85Summary:        Support for developing nautilus extensions
86Summary(ja):    Nautilus 拡張機能開発のためのサポート
87License:        LGPLv2+
88Group:          Development/Libraries
89Requires:       %{name}-libs = %{version}-%{release}
90Requires:       pkgconfig
91
92%description    devel
93This package provides libraries and header files needed
94for developing nautilus extensions.
95
96%description -l ja devel
97このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
98ヘッダファイルを提供します。
99
100
101%package        libs
102Summary:        Libraries for use in nautilus extentions
103Summary(ja):    Nautilus 拡張機能で利用するライブラリ
104Group:          System Environment/Libraries
105
106%description    libs
107This package provides libraries required by nautilus extention
108module.
109
110%description -l ja libs
111このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
112
113
114%package        docs
115Summary:        Documentation for %{name}
116Summary(ja):    %{name} 用のドキュメント
117Group:          Documentation
118BuildArch:      noarch
119
120%description    docs
121This package contains documentation for %{name}.
122
123
124%prep
125%setup -q -n %{name}-%{version}
126
127%patch102 -p1 -b .vine
128%patch2000 -p1 -b .vine
129
130%build
131gtkdocize
132libtoolize --force --copy
133autoreconf -f -i
134CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
135%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
136
137make %{?_smp_mflags}
138
139%install
140rm -rf $RPM_BUILD_ROOT
141
142make install DESTDIR=$RPM_BUILD_ROOT
143
144# make sure desktop files validate by ignoring sr@Latn
145perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
146# desktop-file-install can't handle empty OnlyShowIn correctly
147perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
148
149desktop-file-install --vendor "" --delete-original       \
150  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
151  --add-only-show-in GNOME                                  \
152  $RPM_BUILD_ROOT%{_datadir}/applications/*
153
154find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
155
156%find_lang %name
157
158%clean
159rm -rf $RPM_BUILD_ROOT
160
161%postun
162if [ $1 -eq 0 ] ; then
163    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
164fi
165
166%posttrans
167glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
168
169%post libs -p /sbin/ldconfig
170%postun libs -p /sbin/ldconfig
171
172
173%files  -f %{name}.lang
174%defattr(-,root,root,-)
175%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
176%dir %{_libdir}/nautilus
177%dir %{_libdir}/nautilus/extensions-3.0
178%{_libdir}/nautilus/extensions-3.0/*.so
179%{_libexecdir}/nautilus-convert-metadata
180%{_datadir}/GConf/gsettings/nautilus.convert
181%{_datadir}/appdata/org.gnome.Nautilus.appdata.xml
182%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
183%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
184%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
185%{_datadir}/applications/*.desktop
186%{_bindir}/*
187%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
188%{_datadir}/glib-2.0/schemas/
189%{_mandir}/man1/*
190
191%files devel
192%defattr(-,root,root,-)
193%{_includedir}/nautilus
194%{_libdir}/pkgconfig/*
195%{_libdir}/*.so
196%{_datadir}/gir-1.0
197
198%files libs
199%defattr(-,root,root,-)
200%{_libdir}/*.so.*
201%{_libdir}/girepository-1.0/*.typelib
202
203%files docs
204%defattr(-,root,root,-)
205%{_datadir}/gtk-doc/html/libnautilus-extension/*
206
207
208%changelog
209* Sat Nov 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
210- new upstream release
211
212* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
213- new upstream release
214
215* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
216- new upstream release
217
218* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
219- new upstream release
220
221* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
222- new upstream release
223- update Patch2000 (nautilus-vine-settings.patch)
224- create %%{name}-docs subpackage
225
226* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.2-2
227- moved libs subpackage to System Environment/Libraries Group
228
229* Wed Nov 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
230- new upstream release
231
232* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
233- new upstream release
234- remove Patch0 (nautilus-3.14.0-git20141015.patch)
235
236* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
237- new upstream release
238- add Patch0 (nautilus-3.14.0-git20141015.patch)
239
240* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
241- new upstream release
242
243* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
244- new upstream release
245
246* Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
247- new upstream release
248
249* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
250- new upstream release
251- add Patch2000 (nautilus-vine-settings.patch)
252
253* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
254- new upstream release
255
256* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
257- new upstream release
258
259* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
260- new upstream release
261
262* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
263- new upstream release
264
265* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
266- new upstream release
267
268* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
269- new upstream release
270- remove Patch0,7
271- add BuildRequires: exempi-devel, tracker-devel
272
273* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
274- add Patch0 (nautilus-3.4.2-ja.po.patch)
275
276* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
277- new upstream release
278
279* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
280- new upstream release
281
282* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
283- added patch102 to fix autostart in other desktop environments
284  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
285
286* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
287- new upstream release
288
289* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
290- new upstream release
291
292* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
293- new upstream release
294
295* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
296- new upstream release
297
298* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
299- new upstream release
300- drop Patch101
301- change BuildRequires: gtk3-devel instread of gtk2-devel
302- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
303- change BuildRequires: unique3-devel instread of unique-devel
304- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
305
306* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
307- fixed group of libs
308- add translation of summary and description.
309- add Vendor, Distribution and Packager tags.
310
311* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
312- new upstream release
313
314* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
315- new upstream release
316
317* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
318 - new upstream release
319
320* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
321- new upstream release
322- add BuildRequires: gobject-introspection-devel
323- remove BuildRequires: libgnomeui-devel
324- add configure option (--enable-introspection=yes)
325
326* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
327- rebuild with rpm-4.8.1 for pkg-config file
328
329* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
330- split nautilus extention libraries to -libs subpackage.
331
332* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
333- new upstream release
334
335* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
336- new upstream release
337- drop Patch100
338- add Patch101
339- add Obsoletes: eel2 <= 2.24.1
340- add Provides: eel2 <= 2.24.1
341
342* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
343- new upstream release
344- add BuildRequires: libSM-devel
345
346* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
347- removed Requires: eel2
348- added %%posttrans section
349
350* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
351- new upstream release
352
353* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
354- new upstream release
355
356* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
357- new upstream release
358
359* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
360- new upstream release
361- split -devel subpackage
362
363* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
364- new upstream release
365
366* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
367- patch6 needs autoreconf
368
369* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
370- new upstream release
371
372* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
373- new upstream release
374
375* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
376- new upstream release
377- added Requires: gvfs
378
379* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
380- new upstream release
381- added Patches from FC
382  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
383  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
384  - Fix a crash in the Properties dialog while changing owner (patch from head)
385  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
386  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
387
388* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
389- new upstream release
390- dropped Patch11-13 and added Patch7-9 from Fedora
391  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
392  - Add patch from upstream to get audio preview working again
393    (#332251)
394  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
395  - Fix a crash with small fonts (#242350)
396  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
397  - Backport fixes for async thumbnail loading from svn
398
399* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
400- run autoreconf for Patch11 changes
401
402* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
403- remove tracker dependancy, Patch13 detects tracker dynamically.
404
405* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
406- add Patch13 to support user-dirs
407
408* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
409- new upstream release
410- enable tracker support
411- add BuildRequires: tracker-devel, Requires: tracker
412
413* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
414- new upstream release
415
416* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
417- add BuildRequires: gamin-devel, Requires: gamin
418- remove fam dependency (replaced by gamin)
419
420* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
421- new upsteram release
422
423* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
424- really applied Patch110...
425
426* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
427- add Patch110 to fix corruption of help option message.
428
429* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
430- new upstream release
431
432* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
433- fix typo in ja.po
434
435* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
436- update ja.po to translate patch50 related message.
437
438* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
439- add Patch50 to show progressbar on umounting
440  (ubuntu patch in Bug 313639)
441
442* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
443- new upstream release
444
445* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
446- add Patch10 to avoid background rendering delay
447
448* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
449- new upstream release
450
451* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
452- add fix-non-UTF-8-encoding.patch (patch0)
453  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
454
455* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
456- new upstream release
457
458* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
459- new upstream release
460
461* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
462- new upstream release
463
464* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
465- new upstream release
466
467* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
468- rebuild
469
470* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
471- new upstream version
472
473* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
474- new upstream version
475
476* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
477- add vine patch to change some defaults.
478  - change default zoom sine
479  - set always_use_browser
480
481* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
482- new upstream release
483
484* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
485- add Patch110 to fix libegg(egg-recent-model.c)
486  save old umask value before create ".recently-used" file.
487 
488* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
489- change default desktop font to Sans 9 (from Sans 10)
490- add patch10 to build with gtk+-2.4
491
492* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
493- new upstream release
494
495* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
496- new upstream release
497
498* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
499- add backport patch from rawhide (Patch10)
500
501* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
502- modified vine patch
503  - change default zoom level to small
504  - change desktop font to Sans 10
505
506* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
507- new upstream release
508
509* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
510- add desktop icon patch from rawhide
511
512* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
513- remove obsolete ja.po
514
515* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
516- new upstream release
517
518* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
519- new upstream release
520
521* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
522- new upstream release
523
524* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
525- update ja.po
526
527* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
528- new upstream release
529
530* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
531- new upstream release
532
533* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
534- new upstream release
535
536* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
537- new upstream release
538
539* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
540- new upstream release
541
542* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
543- new upstream release
544
545* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
546- add nautilus-cd-burner patch
547
548* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
549- new upstream release
550
551* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
552- discard scrollkeeper outputs.
553- update PreReq tags.
554
555* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
556- change icon for nautilus-file-management-properties
557- update ja.po
558
559* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
560- update ja.po
561- add translation for .desktop files.
562
563* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
564- add Requires: vine-menus
565
566* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
567- new upstream release
568
569* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
570- remove redhatize patch
571
572* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
573- rebuild to remove unneeded dependancy.
574
575* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
576- build for Vine Linux
577
578* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
579- add explicit startup-notification dependency because build system is
580  dumb
581- 2.1.3
582
583* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
584- 2.1.2
585
586* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
587- 2.0.7
588- remove patches that are upstream
589
590* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
591- Add badhack to make weblinks on desktop work
592
593* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
594- fix #70667 assertion failures
595- fix triple click patch
596
597* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
598- don't activate on double click
599
600* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
601- put button press mask in triple-click patch, maybe it will work
602- remove html-hack patch as it does nothing useful
603
604* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
605- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
606  bogus bug reports
607- add hack for HTML mime type handling in a web browser, not
608  nautilus
609
610* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
611- Updated to 2.0.6. Removed the patches I put upstream.
612- Added patch that fixes #72410
613
614* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
615- Add a simple patch so that redhat-config-packages can disable
616  the new window behavior for mounted CDs behavior.
617
618* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
619- Add patch to fix bug #70667
620
621* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
622- remove mp3
623
624* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
625- ignore the "add_to_session" preference as it only broke stuff
626- pad the left margin a bit to cope with poor word wrapping
627
628* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
629- Update to 2.0.5, remove topleft icon patch
630
631* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
632- Add patch to fix the bug where desktop icons get
633  stuck in the top left corner on startup
634
635* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
636- 2.0.4
637
638* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
639- obsolete nautilus-mozilla < 2.0 #69839
640
641* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
642- add rhconfig patch to Bluecurve theme and disable sidebar by default
643
644* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
645- drop start here files, require redhat-menus that has them
646
647* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
648- 2.0.3
649
650* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
651- build for new eel2, gail
652
653* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
654- and add the libexec components, mumble
655
656* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
657- put the components in the file list, were moved upstream
658
659* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
660- 2.0.1
661
662* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
663- Relibtoolize to fix relink problems for solib components
664- Add LANG=en_US to %makeinstall as well
665- Back out previous change, force locale to en_US to prevent UTF-8 problems
666- Add workaround for intltool-merge bug on ia64
667
668* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
669- automated rebuild
670
671* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
672- 2.0.0
673- use desktop-file-install
674- require desktop-backgrounds-basic
675
676* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
677- add wacky hack in hopes of fixing the hang-on-login thing
678
679* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
680- add build requires on new gail
681- rebuild to try to lose broken libgailutil.so.13 dependency
682
683* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
684- rebuild in different environment
685
686* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
687- 1.1.19
688
689* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
690- rebuild in different environment
691
692* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
693- really remove nautilus-devel if we are going to obsolete it
694- don't require hwbrowser
695
696* Sun May 26 2002 Tim Powers <timp@redhat.com>
697- automated rebuild
698
699* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
700- rebuild in different environment
701
702* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
703- 1.1.17
704
705* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
706- 1.1.14
707
708* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
709- require eog
710- obsolete nautilus-devel
711- fix name of schemas file in post
712
713* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
714- Update to 1.1.13
715
716* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
717- put tree view in file list
718
719* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
720- nautilus for gnome 2
721- clean up the spec file and file list a bit
722
723* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
724- merge translations
725
726* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
727- Add patch to fix trash crash
728
729* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
730- fix for metadata tmp race
731- backport thumbnail speed fix and thumbnail inf. loop fix
732
733* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
734- add some fixes from CVS version, including one for #61819 and a couple segfaults
735
736* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
737- fix thumbnails for files with future timestamp, #56862
738
739* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
740- buildrequires intltool #60633
741- apply Alex's pixbuf cache patch to save a few megs #60581
742
743* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
744- drop Milan-specific features, including png10 and ac25 patches
745- copy in 1.0.5 help component to avoid large risky patch
746- remove .la files
747- drop mozilla from ia64 again
748- remove oaf file from nautilus-mozilla that was also in the base
749  package
750
751* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
752- enable mozilla support on ia64
753
754* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
755- require Mozilla 0.9.7
756- Add patch that puts mozilla profile startup before embedding is initialized
757
758* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
759- 1.0.6, require Mozilla 0.9.6
760
761* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
762- Update to 1.0.5
763
764* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
765- Fix handling of GnomeVFSFileInfo structure (#53315)
766
767* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
768- Change handling of names on unmount to fix #52325
769
770* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
771- put nautilus-help.desktop in file list; #53109
772
773* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
774- Add po files from sources.redhat.com
775
776* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
777- Add po files from sources.redhat.com
778
779* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
780- Added patch to fix the .directory issuer
781
782* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
783- I screwed up the build yesterday, so it didn't actually contain the
784  fixes mentioned. This build should contain them.
785
786* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
787- fix bug causing 32000 stats or so in large directories,
788  should speed things up somewhat
789- fix #52104 via gruesome kdesktop-detection hack and setting
790  window type hint on our desktop window
791- fix so Start Here icon displays in sidebar
792- don't load non-local .desktop files
793
794* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
795- make Programs icon into a link, to match the other .desktop files
796- own various directories #51164
797- web page titles in Japanese, #51709
798- tree defaults to only directories #51850
799
800* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
801- make start here icon work again
802- kill some warning spew, #51661
803- cache getpwnam() results to speed things up a bit
804
805* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
806- Fix problem with missing desktop starthere.desktop file
807- New snapshot from our branch, fixes:
808  - On upgrade, icons migrated from GNOME desktop are not properly lined up
809    (#51436)
810  - icons dropped on the desktop don't end up where dropped. (#51441)
811  - Nautilus shouldn't have fam monitor read-only windows. This
812    keeps CDROMS from being unmounted until you close all
813
814    nautilus windows pointing to them. (#51442)
815  - Warnings about 'cannot statfs...' when moving items to trash.
816- Use separate start-here.desktop for panel, since the one used
817  for the root window only works from Nautilus.
818
819* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
820- Changed starthere .desktop files to be links instead
821- of spawning a new nautilus. This makes start-here:
822- much faster.
823
824* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
825- Added hwbrowser dependency
826- New snapshot, fixes the mozilla-view submit form problem
827
828* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
829- Rebuild with new xml-i18n-tools
830- fix crash in creating new desktop files
831
832* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
833- Fix up DnD code some more
834
835* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
836- Sync our CVS version; fixes some MUSTFIX
837  (the one about drawing background on startup,
838   properly translate desktop files, etc.)
839
840* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
841- Fix 64bit cleanness issue
842- Fix NULL mimetype crash
843- Disable additional_text for .desktop files
844
845* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
846- Fix unmounting devices.
847
848* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
849- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
850- mimetype sniffing.
851
852* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
853- Remove the "don't run as root" warning.
854- Remove eazel from bookmarks
855- langified (again? did someone change it?)
856
857* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
858- Apply a patch that makes nautilus dnd reset work with the latest
859- eel release.
860
861* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
862- Build on ia64 without the mozilla component.
863
864* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
865- Fix crash-on-startup showstopper
866- Fix can't-find-images bug (this one was only showing up
867  when built with debug symbols, since it was an uninitialized memory
868  read)
869
870* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
871- sync new tarball from our CVS branch,
872  fixes some drag-and-drop, changes URI scheme names,
873  etc.
874
875* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
876- Add BuildRequires (#49539, 49537)
877- Fix %%post, %%postun (#49720)
878- Background efficiency improvements and hacks
879
880* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
881- Don't launch esd on each mouseover.
882
883* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
884- move first time druid patch into my "CVS outstanding" patch
885- try to really remove Help/Feedback
886- try to really fix Help/Community Support
887- try again to get Start Here in the Go menu
888- try again to get Start Here on the desktop
889- don't show file sizes for .desktop files
890
891* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
892- add newline to ends of .desktop files that were missing them
893
894* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
895- update to my latest 'cvs diff -u' (adds default
896  Start Here link, displays .directory name in sidebar)
897- include /etc/X11/* links (starthere, sysconfig, serverconfig)
898
899* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
900- Patch to remove firsttime druid and flash
901
902* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
903- add hacks for displaying desktop files
904- add hack to turn off the "unwriteable" emblem
905
906* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
907- added defattr to the files lists to be (-,root,root)
908- languified
909
910* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
911- Need to run autoheader too.
912
913* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
914- Make the fam dependency a real runtime dependency
915- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
916- Cleaned up specfile.
917
918* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
919- Change default background and rubberband color.
920- Use the sidebar tabs from the default theme
921- BuildDepend on fam-devel, depend on fam
922- Disable the eazel update pages in the first-time druid.
923- Remove the eazel logo from the first-time druid
924
925* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
926- 1.0.4, removes eazel services icon and wizard page
927- Eazel logo is still in startup wizard for now, needs fixing
928
929* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
930- fix group (s/Desktop/Desktops/) #47134
931- remove ammonite dependency
932
933* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
934- add a different default theme
935- clean up file list overspecificity a bit
936
937* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
938- move to a CVS snapshot of nautilus for now
939  (Darin is my hero for having distcheck work out of CVS)
940
941* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
942- clean up defaults a bit
943
944* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
945- New version
946
947* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
948- Added BuildRequires lines
949- Changed Source to point to ftp.gnome.org instead of just the tarball name
950- Moved %description sections closer to their %package sections
951- Moved %changelog to the end, where so that it's not in the way
952- Changed configure and make install options to allow moving of
953  libraries, includes, binaries more easily
954- Removed hard-coded paths (don't define %prefix or %docdir)
955- replace %{prefix}/bin with %{_bindir}
956- replace %{prefix}/share with %{_datadir}
957- replace %{prefix}/lib with %{_libdir}
958- replace %{prefix}/include with %{_includedir}
959
960* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
961- removed obsoletes from sub packages and added mozilla and trilobite
962subpackages
963
964* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
965- created this thing
Note: See TracBrowser for help on using the repository browser.