source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 9791

Revision 9791, 31.5 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1%define glib2_version 2.46.0
2%define pango_version 1.38.1
3%define gtk3_version 3.18.0
4%define libxml2_version 2.9.1
5%define eog_version 3.18.0
6%define gnome_desktop3_version 3.18.0
7%define vine_menus_version 3.0
8%define startup_notification_version 0.10
9%define libexif_version 0.6.19
10%define tracker_version 1.6.0
11%define gobject_introspection_version 0.9.8
12
13Name:           nautilus
14Summary:        Nautilus is a file manager for GNOME
15Summary(ja):    Nautilus - GNOME ファイルマネージャ
16Version:        3.18.1
17Release:        1%{?_dist_release}
18License:        GPLv2+
19Group:          User Interface/Desktops
20URL:            http://www.gnome.org/projects/nautilus/
21
22Vendor:         Project Vine
23Distribution:   Vine Linux
24Packager:       Takemikaduchi
25
26Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.18/%{name}-%{version}.tar.xz
27
28# vine
29Patch102:       run_in_gnome.patch
30Patch2000:      nautilus-vine-settings.patch
31
32BuildRoot:      %{_tmppath}/%{name}-%{version}-root
33Requires:       gamin
34Requires:       vine-menus >= %{vine_menus_version}
35Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
36Requires:       libexif >= %{libexif_version}
37Requires:       %{name}-libs = %{version}-%{release}
38
39BuildRequires:  intltool
40BuildRequires:  libtool >= 1.4.2-10
41BuildRequires:  automake, autoconf
42BuildRequires:  desktop-file-utils
43
44BuildRequires:  glib2-devel >= %{glib2_version}
45BuildRequires:  pango-devel >= %{pango_version}
46BuildRequires:  gtk3-devel >= %{gtk3_version}
47BuildRequires:  libxml2-devel >= %{libxml2_version}
48BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
49BuildRequires:  gamin-devel
50BuildRequires:  startup-notification-devel >= %{startup_notification_version}
51BuildRequires:  tracker-devel >= %{tracker_version}
52BuildRequires:  libexif-devel >= %{libexif_version}
53BuildRequires:  unique3-devel
54BuildRequires:  libnotify-devel
55BuildRequires:  libSM-devel
56BuildRequires:  exempi-devel
57BuildRequires:  tracker-devel
58BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
59BuildRequires:  gsettings-desktop-schemas
60
61Obsoletes:      nautilus-extras
62Obsoletes:      nautilus-suggested
63Obsoletes:      nautilus-mozilla < 2.0
64Obsoletes:      eel2 <= 2.24.1
65
66Provides:       eel2 <= 2.24.1
67
68
69%description
70Nautilus integrates access to files, applications, media,
71Internet-based resources and the Web. Nautilus delivers a dynamic and
72rich user experience. Nautilus is an free software project developed
73under the GNU General Public License and is a core component of the
74GNOME desktop project.
75
76%description -l ja
77Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
78リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
79豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
80のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
81プロジェクトのコア・コンポーネントです。
82
83
84%package        devel
85Summary:        Support for developing nautilus extensions
86Summary(ja):    Nautilus 拡張機能開発のためのサポート
87License:        LGPLv2+
88Group:          Development/Libraries
89Requires:       %{name}-libs = %{version}-%{release}
90Requires:       pkgconfig
91
92%description    devel
93This package provides libraries and header files needed
94for developing nautilus extensions.
95
96%description -l ja devel
97このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
98ヘッダファイルを提供します。
99
100
101%package        libs
102Summary:        Libraries for use in nautilus extentions
103Summary(ja):    Nautilus 拡張機能で利用するライブラリ
104Group:          System Environment/Libraries
105
106%description    libs
107This package provides libraries required by nautilus extention
108module.
109
110%description -l ja libs
111このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
112
113
114%package        docs
115Summary:        Documentation for %{name}
116Summary(ja):    %{name} 用のドキュメント
117Group:          Documentation
118BuildArch:      noarch
119
120%description    docs
121This package contains documentation for %{name}.
122
123
124%prep
125%setup -q -n %{name}-%{version}
126
127%patch102 -p1 -b .vine
128%patch2000 -p1 -b .vine
129
130%build
131gtkdocize
132libtoolize --force --copy
133autoreconf -f -i
134CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
135%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
136
137make %{?_smp_mflags}
138
139%install
140rm -rf $RPM_BUILD_ROOT
141
142make install DESTDIR=$RPM_BUILD_ROOT
143
144# make sure desktop files validate by ignoring sr@Latn
145perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
146# desktop-file-install can't handle empty OnlyShowIn correctly
147perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
148
149desktop-file-install --vendor "" --delete-original       \
150  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
151  --add-only-show-in GNOME                                  \
152  $RPM_BUILD_ROOT%{_datadir}/applications/*
153
154find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
155
156%find_lang %name
157
158%clean
159rm -rf $RPM_BUILD_ROOT
160
161%postun
162if [ $1 -eq 0 ] ; then
163    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
164fi
165
166%posttrans
167glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
168
169%post libs -p /sbin/ldconfig
170%postun libs -p /sbin/ldconfig
171
172
173%files  -f %{name}.lang
174%defattr(-,root,root,-)
175%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
176%dir %{_libdir}/nautilus
177%dir %{_libdir}/nautilus/extensions-3.0
178%{_libdir}/nautilus/extensions-3.0/*.so
179%{_libexecdir}/nautilus-convert-metadata
180%{_datadir}/GConf/gsettings/nautilus.convert
181%{_datadir}/appdata/org.gnome.Nautilus.appdata.xml
182%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
183%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
184%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
185%{_datadir}/applications/*.desktop
186%{_bindir}/*
187%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
188%{_datadir}/glib-2.0/schemas/
189%{_mandir}/man1/*
190
191%files devel
192%defattr(-,root,root,-)
193%{_includedir}/nautilus
194%{_libdir}/pkgconfig/*
195%{_libdir}/*.so
196%{_datadir}/gir-1.0
197
198%files libs
199%defattr(-,root,root,-)
200%{_libdir}/*.so.*
201%{_libdir}/girepository-1.0/*.typelib
202
203%files docs
204%defattr(-,root,root,-)
205%{_datadir}/gtk-doc/html/libnautilus-extension/*
206
207
208%changelog
209* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
210- new upstream release
211
212* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
213- new upstream release
214
215* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
216- new upstream release
217
218* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
219- new upstream release
220- update Patch2000 (nautilus-vine-settings.patch)
221- create %%{name}-docs subpackage
222
223* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.2-2
224- moved libs subpackage to System Environment/Libraries Group
225
226* Wed Nov 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
227- new upstream release
228
229* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
230- new upstream release
231- remove Patch0 (nautilus-3.14.0-git20141015.patch)
232
233* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
234- new upstream release
235- add Patch0 (nautilus-3.14.0-git20141015.patch)
236
237* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
238- new upstream release
239
240* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
241- new upstream release
242
243* Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
244- new upstream release
245
246* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
247- new upstream release
248- add Patch2000 (nautilus-vine-settings.patch)
249
250* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
251- new upstream release
252
253* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
254- new upstream release
255
256* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
257- new upstream release
258
259* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
260- new upstream release
261
262* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
263- new upstream release
264
265* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
266- new upstream release
267- remove Patch0,7
268- add BuildRequires: exempi-devel, tracker-devel
269
270* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
271- add Patch0 (nautilus-3.4.2-ja.po.patch)
272
273* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
274- new upstream release
275
276* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
277- new upstream release
278
279* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
280- added patch102 to fix autostart in other desktop environments
281  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
282
283* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
284- new upstream release
285
286* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
287- new upstream release
288
289* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
290- new upstream release
291
292* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
293- new upstream release
294
295* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
296- new upstream release
297- drop Patch101
298- change BuildRequires: gtk3-devel instread of gtk2-devel
299- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
300- change BuildRequires: unique3-devel instread of unique-devel
301- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
302
303* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
304- fixed group of libs
305- add translation of summary and description.
306- add Vendor, Distribution and Packager tags.
307
308* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
309- new upstream release
310
311* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
312- new upstream release
313
314* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
315 - new upstream release
316
317* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
318- new upstream release
319- add BuildRequires: gobject-introspection-devel
320- remove BuildRequires: libgnomeui-devel
321- add configure option (--enable-introspection=yes)
322
323* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
324- rebuild with rpm-4.8.1 for pkg-config file
325
326* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
327- split nautilus extention libraries to -libs subpackage.
328
329* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
330- new upstream release
331
332* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
333- new upstream release
334- drop Patch100
335- add Patch101
336- add Obsoletes: eel2 <= 2.24.1
337- add Provides: eel2 <= 2.24.1
338
339* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
340- new upstream release
341- add BuildRequires: libSM-devel
342
343* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
344- removed Requires: eel2
345- added %%posttrans section
346
347* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
348- new upstream release
349
350* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
351- new upstream release
352
353* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
354- new upstream release
355
356* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
357- new upstream release
358- split -devel subpackage
359
360* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
361- new upstream release
362
363* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
364- patch6 needs autoreconf
365
366* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
367- new upstream release
368
369* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
370- new upstream release
371
372* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
373- new upstream release
374- added Requires: gvfs
375
376* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
377- new upstream release
378- added Patches from FC
379  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
380  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
381  - Fix a crash in the Properties dialog while changing owner (patch from head)
382  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
383  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
384
385* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
386- new upstream release
387- dropped Patch11-13 and added Patch7-9 from Fedora
388  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
389  - Add patch from upstream to get audio preview working again
390    (#332251)
391  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
392  - Fix a crash with small fonts (#242350)
393  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
394  - Backport fixes for async thumbnail loading from svn
395
396* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
397- run autoreconf for Patch11 changes
398
399* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
400- remove tracker dependancy, Patch13 detects tracker dynamically.
401
402* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
403- add Patch13 to support user-dirs
404
405* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
406- new upstream release
407- enable tracker support
408- add BuildRequires: tracker-devel, Requires: tracker
409
410* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
411- new upstream release
412
413* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
414- add BuildRequires: gamin-devel, Requires: gamin
415- remove fam dependency (replaced by gamin)
416
417* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
418- new upsteram release
419
420* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
421- really applied Patch110...
422
423* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
424- add Patch110 to fix corruption of help option message.
425
426* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
427- new upstream release
428
429* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
430- fix typo in ja.po
431
432* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
433- update ja.po to translate patch50 related message.
434
435* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
436- add Patch50 to show progressbar on umounting
437  (ubuntu patch in Bug 313639)
438
439* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
440- new upstream release
441
442* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
443- add Patch10 to avoid background rendering delay
444
445* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
446- new upstream release
447
448* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
449- add fix-non-UTF-8-encoding.patch (patch0)
450  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
451
452* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
453- new upstream release
454
455* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
456- new upstream release
457
458* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
459- new upstream release
460
461* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
462- new upstream release
463
464* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
465- rebuild
466
467* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
468- new upstream version
469
470* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
471- new upstream version
472
473* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
474- add vine patch to change some defaults.
475  - change default zoom sine
476  - set always_use_browser
477
478* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
479- new upstream release
480
481* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
482- add Patch110 to fix libegg(egg-recent-model.c)
483  save old umask value before create ".recently-used" file.
484 
485* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
486- change default desktop font to Sans 9 (from Sans 10)
487- add patch10 to build with gtk+-2.4
488
489* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
490- new upstream release
491
492* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
493- new upstream release
494
495* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
496- add backport patch from rawhide (Patch10)
497
498* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
499- modified vine patch
500  - change default zoom level to small
501  - change desktop font to Sans 10
502
503* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
504- new upstream release
505
506* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
507- add desktop icon patch from rawhide
508
509* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
510- remove obsolete ja.po
511
512* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
513- new upstream release
514
515* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
516- new upstream release
517
518* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
519- new upstream release
520
521* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
522- update ja.po
523
524* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
525- new upstream release
526
527* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
528- new upstream release
529
530* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
531- new upstream release
532
533* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
534- new upstream release
535
536* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
537- new upstream release
538
539* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
540- new upstream release
541
542* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
543- add nautilus-cd-burner patch
544
545* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
546- new upstream release
547
548* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
549- discard scrollkeeper outputs.
550- update PreReq tags.
551
552* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
553- change icon for nautilus-file-management-properties
554- update ja.po
555
556* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
557- update ja.po
558- add translation for .desktop files.
559
560* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
561- add Requires: vine-menus
562
563* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
564- new upstream release
565
566* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
567- remove redhatize patch
568
569* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
570- rebuild to remove unneeded dependancy.
571
572* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
573- build for Vine Linux
574
575* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
576- add explicit startup-notification dependency because build system is
577  dumb
578- 2.1.3
579
580* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
581- 2.1.2
582
583* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
584- 2.0.7
585- remove patches that are upstream
586
587* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
588- Add badhack to make weblinks on desktop work
589
590* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
591- fix #70667 assertion failures
592- fix triple click patch
593
594* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
595- don't activate on double click
596
597* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
598- put button press mask in triple-click patch, maybe it will work
599- remove html-hack patch as it does nothing useful
600
601* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
602- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
603  bogus bug reports
604- add hack for HTML mime type handling in a web browser, not
605  nautilus
606
607* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
608- Updated to 2.0.6. Removed the patches I put upstream.
609- Added patch that fixes #72410
610
611* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
612- Add a simple patch so that redhat-config-packages can disable
613  the new window behavior for mounted CDs behavior.
614
615* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
616- Add patch to fix bug #70667
617
618* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
619- remove mp3
620
621* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
622- ignore the "add_to_session" preference as it only broke stuff
623- pad the left margin a bit to cope with poor word wrapping
624
625* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
626- Update to 2.0.5, remove topleft icon patch
627
628* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
629- Add patch to fix the bug where desktop icons get
630  stuck in the top left corner on startup
631
632* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
633- 2.0.4
634
635* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
636- obsolete nautilus-mozilla < 2.0 #69839
637
638* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
639- add rhconfig patch to Bluecurve theme and disable sidebar by default
640
641* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
642- drop start here files, require redhat-menus that has them
643
644* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
645- 2.0.3
646
647* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
648- build for new eel2, gail
649
650* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
651- and add the libexec components, mumble
652
653* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
654- put the components in the file list, were moved upstream
655
656* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
657- 2.0.1
658
659* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
660- Relibtoolize to fix relink problems for solib components
661- Add LANG=en_US to %makeinstall as well
662- Back out previous change, force locale to en_US to prevent UTF-8 problems
663- Add workaround for intltool-merge bug on ia64
664
665* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
666- automated rebuild
667
668* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
669- 2.0.0
670- use desktop-file-install
671- require desktop-backgrounds-basic
672
673* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
674- add wacky hack in hopes of fixing the hang-on-login thing
675
676* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
677- add build requires on new gail
678- rebuild to try to lose broken libgailutil.so.13 dependency
679
680* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
681- rebuild in different environment
682
683* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
684- 1.1.19
685
686* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
687- rebuild in different environment
688
689* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
690- really remove nautilus-devel if we are going to obsolete it
691- don't require hwbrowser
692
693* Sun May 26 2002 Tim Powers <timp@redhat.com>
694- automated rebuild
695
696* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
697- rebuild in different environment
698
699* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
700- 1.1.17
701
702* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
703- 1.1.14
704
705* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
706- require eog
707- obsolete nautilus-devel
708- fix name of schemas file in post
709
710* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
711- Update to 1.1.13
712
713* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
714- put tree view in file list
715
716* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
717- nautilus for gnome 2
718- clean up the spec file and file list a bit
719
720* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
721- merge translations
722
723* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
724- Add patch to fix trash crash
725
726* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
727- fix for metadata tmp race
728- backport thumbnail speed fix and thumbnail inf. loop fix
729
730* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
731- add some fixes from CVS version, including one for #61819 and a couple segfaults
732
733* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
734- fix thumbnails for files with future timestamp, #56862
735
736* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
737- buildrequires intltool #60633
738- apply Alex's pixbuf cache patch to save a few megs #60581
739
740* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
741- drop Milan-specific features, including png10 and ac25 patches
742- copy in 1.0.5 help component to avoid large risky patch
743- remove .la files
744- drop mozilla from ia64 again
745- remove oaf file from nautilus-mozilla that was also in the base
746  package
747
748* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
749- enable mozilla support on ia64
750
751* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
752- require Mozilla 0.9.7
753- Add patch that puts mozilla profile startup before embedding is initialized
754
755* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
756- 1.0.6, require Mozilla 0.9.6
757
758* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
759- Update to 1.0.5
760
761* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
762- Fix handling of GnomeVFSFileInfo structure (#53315)
763
764* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
765- Change handling of names on unmount to fix #52325
766
767* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
768- put nautilus-help.desktop in file list; #53109
769
770* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
771- Add po files from sources.redhat.com
772
773* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
774- Add po files from sources.redhat.com
775
776* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
777- Added patch to fix the .directory issuer
778
779* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
780- I screwed up the build yesterday, so it didn't actually contain the
781  fixes mentioned. This build should contain them.
782
783* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
784- fix bug causing 32000 stats or so in large directories,
785  should speed things up somewhat
786- fix #52104 via gruesome kdesktop-detection hack and setting
787  window type hint on our desktop window
788- fix so Start Here icon displays in sidebar
789- don't load non-local .desktop files
790
791* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
792- make Programs icon into a link, to match the other .desktop files
793- own various directories #51164
794- web page titles in Japanese, #51709
795- tree defaults to only directories #51850
796
797* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
798- make start here icon work again
799- kill some warning spew, #51661
800- cache getpwnam() results to speed things up a bit
801
802* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
803- Fix problem with missing desktop starthere.desktop file
804- New snapshot from our branch, fixes:
805  - On upgrade, icons migrated from GNOME desktop are not properly lined up
806    (#51436)
807  - icons dropped on the desktop don't end up where dropped. (#51441)
808  - Nautilus shouldn't have fam monitor read-only windows. This
809    keeps CDROMS from being unmounted until you close all
810
811    nautilus windows pointing to them. (#51442)
812  - Warnings about 'cannot statfs...' when moving items to trash.
813- Use separate start-here.desktop for panel, since the one used
814  for the root window only works from Nautilus.
815
816* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
817- Changed starthere .desktop files to be links instead
818- of spawning a new nautilus. This makes start-here:
819- much faster.
820
821* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
822- Added hwbrowser dependency
823- New snapshot, fixes the mozilla-view submit form problem
824
825* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
826- Rebuild with new xml-i18n-tools
827- fix crash in creating new desktop files
828
829* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
830- Fix up DnD code some more
831
832* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
833- Sync our CVS version; fixes some MUSTFIX
834  (the one about drawing background on startup,
835   properly translate desktop files, etc.)
836
837* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
838- Fix 64bit cleanness issue
839- Fix NULL mimetype crash
840- Disable additional_text for .desktop files
841
842* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
843- Fix unmounting devices.
844
845* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
846- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
847- mimetype sniffing.
848
849* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
850- Remove the "don't run as root" warning.
851- Remove eazel from bookmarks
852- langified (again? did someone change it?)
853
854* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
855- Apply a patch that makes nautilus dnd reset work with the latest
856- eel release.
857
858* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
859- Build on ia64 without the mozilla component.
860
861* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
862- Fix crash-on-startup showstopper
863- Fix can't-find-images bug (this one was only showing up
864  when built with debug symbols, since it was an uninitialized memory
865  read)
866
867* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
868- sync new tarball from our CVS branch,
869  fixes some drag-and-drop, changes URI scheme names,
870  etc.
871
872* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
873- Add BuildRequires (#49539, 49537)
874- Fix %%post, %%postun (#49720)
875- Background efficiency improvements and hacks
876
877* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
878- Don't launch esd on each mouseover.
879
880* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
881- move first time druid patch into my "CVS outstanding" patch
882- try to really remove Help/Feedback
883- try to really fix Help/Community Support
884- try again to get Start Here in the Go menu
885- try again to get Start Here on the desktop
886- don't show file sizes for .desktop files
887
888* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
889- add newline to ends of .desktop files that were missing them
890
891* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
892- update to my latest 'cvs diff -u' (adds default
893  Start Here link, displays .directory name in sidebar)
894- include /etc/X11/* links (starthere, sysconfig, serverconfig)
895
896* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
897- Patch to remove firsttime druid and flash
898
899* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
900- add hacks for displaying desktop files
901- add hack to turn off the "unwriteable" emblem
902
903* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
904- added defattr to the files lists to be (-,root,root)
905- languified
906
907* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
908- Need to run autoheader too.
909
910* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
911- Make the fam dependency a real runtime dependency
912- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
913- Cleaned up specfile.
914
915* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
916- Change default background and rubberband color.
917- Use the sidebar tabs from the default theme
918- BuildDepend on fam-devel, depend on fam
919- Disable the eazel update pages in the first-time druid.
920- Remove the eazel logo from the first-time druid
921
922* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
923- 1.0.4, removes eazel services icon and wizard page
924- Eazel logo is still in startup wizard for now, needs fixing
925
926* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
927- fix group (s/Desktop/Desktops/) #47134
928- remove ammonite dependency
929
930* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
931- add a different default theme
932- clean up file list overspecificity a bit
933
934* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
935- move to a CVS snapshot of nautilus for now
936  (Darin is my hero for having distcheck work out of CVS)
937
938* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
939- clean up defaults a bit
940
941* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
942- New version
943
944* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
945- Added BuildRequires lines
946- Changed Source to point to ftp.gnome.org instead of just the tarball name
947- Moved %description sections closer to their %package sections
948- Moved %changelog to the end, where so that it's not in the way
949- Changed configure and make install options to allow moving of
950  libraries, includes, binaries more easily
951- Removed hard-coded paths (don't define %prefix or %docdir)
952- replace %{prefix}/bin with %{_bindir}
953- replace %{prefix}/share with %{_datadir}
954- replace %{prefix}/lib with %{_libdir}
955- replace %{prefix}/include with %{_includedir}
956
957* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
958- removed obsoletes from sub packages and added mozilla and trilobite
959subpackages
960
961* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
962- created this thing
Note: See TracBrowser for help on using the repository browser.