source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 8447

Revision 8447, 30.5 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.2

Line 
1%define glib2_version 2.40.0
2%define pango_version 1.36.3
3%define gtk3_version 3.12.0
4%define libxml2_version 2.9.1
5%define eog_version 3.12.0
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.12.0
8%define vine_menus_version 3.0
9%define startup_notification_version 0.10
10%define libexif_version 0.6.19
11%define tracker_version 1.0.0
12%define gobject_introspection_version 0.9.8
13
14Name:                   nautilus
15Summary:                Nautilus is a file manager for GNOME
16Summary(ja):    Nautilus - GNOME ファイルマネージャ
17Version:                3.12.2
18Release:                1%{?_dist_release}
19License:                GPLv2+
20Group:                  User Interface/Desktops
21URL:                    http://www.gnome.org/projects/nautilus/
22
23Vendor:                 Project Vine
24Distribution:   Vine Linux
25Packager:               Takemikaduchi
26
27Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.12/%{name}-%{version}.tar.xz
28
29# Some changes to default config
30Patch1:         nautilus-2.5.7-rhconfig.patch
31
32# vine
33Patch102:       run_in_gnome.patch
34Patch2000:      nautilus-vine-settings.patch
35
36BuildRoot:      %{_tmppath}/%{name}-%{version}-root
37Requires:       gamin
38Requires:       vine-menus >= %{vine_menus_version}
39Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
40Requires:       libexif >= %{libexif_version}
41Requires:       %{name}-libs = %{version}-%{release}
42
43BuildRequires:  intltool
44BuildRequires:  libtool >= 1.4.2-10
45BuildRequires:  automake, autoconf
46BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
47
48BuildRequires:  glib2-devel >= %{glib2_version}
49BuildRequires:  pango-devel >= %{pango_version}
50BuildRequires:  gtk3-devel >= %{gtk3_version}
51BuildRequires:  libxml2-devel >= %{libxml2_version}
52BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
53BuildRequires:  gamin-devel
54BuildRequires:  startup-notification-devel >= %{startup_notification_version}
55BuildRequires:  tracker-devel >= %{tracker_version}
56BuildRequires:  libexif-devel >= %{libexif_version}
57BuildRequires:  unique3-devel
58BuildRequires:  libnotify-devel
59BuildRequires:  libSM-devel
60BuildRequires:  exempi-devel
61BuildRequires:  tracker-devel
62BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
63BuildRequires:  gsettings-desktop-schemas
64
65Obsoletes:      nautilus-extras
66Obsoletes:      nautilus-suggested
67Obsoletes:      nautilus-mozilla < 2.0
68Obsoletes:      eel2 <= 2.24.1
69
70Provides:       eel2 <= 2.24.1
71
72
73%description
74Nautilus integrates access to files, applications, media,
75Internet-based resources and the Web. Nautilus delivers a dynamic and
76rich user experience. Nautilus is an free software project developed
77under the GNU General Public License and is a core component of the
78GNOME desktop project.
79
80%description -l ja
81Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
82リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
83豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
84のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
85プロジェクトのコア・コンポーネントです。
86
87%package devel
88Summary: Support for developing nautilus extensions
89Summary(ja): Nautilus 拡張機能開発のためのサポート
90License: LGPLv2+
91Group: Development/Libraries
92Requires: %{name}-libs = %{version}-%{release}
93Requires: pkgconfig
94
95%description devel
96This package provides libraries and header files needed
97for developing nautilus extensions.
98
99%description -l ja devel
100このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
101ヘッダファイルを提供します。
102
103%package libs
104Summary: Libraries for use in nautilus extentions
105Summary(ja): Nautilus 拡張機能で利用するライブラリ
106Group: User Interface/Desktops
107
108%description libs
109This package provides libraries required by nautilus extention
110module.
111
112%description -l ja libs
113このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
114
115%prep
116%setup -q -n %{name}-%{version}
117
118%patch102 -p1 -b .vine
119
120%patch2000 -p1 -b .vine
121
122%build
123gtkdocize
124libtoolize --force --copy
125autoreconf -f -i
126CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
127%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
128
129make %{?_smp_mflags}
130
131%install
132rm -rf $RPM_BUILD_ROOT
133
134make install DESTDIR=$RPM_BUILD_ROOT
135
136# make sure desktop files validate by ignoring sr@Latn
137perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
138# desktop-file-install can't handle empty OnlyShowIn correctly
139perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
140
141desktop-file-install --vendor gnome --delete-original       \
142  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
143  --add-only-show-in GNOME                                  \
144  $RPM_BUILD_ROOT%{_datadir}/applications/*
145
146find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
147
148%find_lang %name
149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
153%postun
154if [ $1 -eq 0 ] ; then
155    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
156fi
157
158%posttrans
159update-mime-database %{_datadir}/mime &> /dev/null ||:
160glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
161
162%post libs -p /sbin/ldconfig
163%postun libs -p /sbin/ldconfig
164
165
166%files  -f %{name}.lang
167%defattr(-,root,root)
168%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
169%dir %{_libdir}/nautilus
170%dir %{_libdir}/nautilus/extensions-3.0
171%{_libdir}/nautilus/extensions-3.0/*.so
172%{_libexecdir}/nautilus-convert-metadata
173%{_datadir}/GConf/gsettings/nautilus.convert
174%{_datadir}/appdata/nautilus.appdata.xml
175%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
176%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
177%{_datadir}/dbus-1/services/org.gnome.Nautilus.SearchProvider.service
178%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
179%{_datadir}/nautilus
180%{_datadir}/applications
181%{_datadir}/mime/*
182%{_bindir}/*
183%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
184%{_datadir}/glib-2.0/schemas/
185%{_mandir}/man1/*
186
187%files devel
188%defattr(-, root, root)
189%{_includedir}/nautilus
190%{_libdir}/pkgconfig/*
191%{_libdir}/*.so
192%{_datadir}/gir-1.0
193%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
194
195%files libs
196%defattr(-, root, root)
197%{_libdir}/*.so.*
198%{_libdir}/girepository-1.0/*.typelib
199
200
201%changelog
202* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
203- new upstream release
204
205* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
206- new upstream release
207
208* Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
209- new upstream release
210
211* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
212- new upstream release
213- add Patch2000 (nautilus-vine-settings.patch)
214
215* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
216- new upstream release
217
218* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
219- new upstream release
220
221* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
222- new upstream release
223
224* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
225- new upstream release
226
227* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
228- new upstream release
229
230* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
231- new upstream release
232- remove Patch0,7
233- add BuildRequires: exempi-devel, tracker-devel
234
235* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
236- add Patch0 (nautilus-3.4.2-ja.po.patch)
237
238* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
239- new upstream release
240
241* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
242- new upstream release
243
244* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
245- added patch102 to fix autostart in other desktop environments
246  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
247
248* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
249- new upstream release
250
251* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
252- new upstream release
253
254* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
255- new upstream release
256
257* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
258- new upstream release
259
260* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
261- new upstream release
262- drop Patch101
263- change BuildRequires: gtk3-devel instread of gtk2-devel
264- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
265- change BuildRequires: unique3-devel instread of unique-devel
266- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
267
268* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
269- fixed group of libs
270- add translation of summary and description.
271- add Vendor, Distribution and Packager tags.
272
273* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
274- new upstream release
275
276* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
277- new upstream release
278
279* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
280 - new upstream release
281
282* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
283- new upstream release
284- add BuildRequires: gobject-introspection-devel
285- remove BuildRequires: libgnomeui-devel
286- add configure option (--enable-introspection=yes)
287
288* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
289- rebuild with rpm-4.8.1 for pkg-config file
290
291* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
292- split nautilus extention libraries to -libs subpackage.
293
294* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
295- new upstream release
296
297* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
298- new upstream release
299- drop Patch100
300- add Patch101
301- add Obsoletes: eel2 <= 2.24.1
302- add Provides: eel2 <= 2.24.1
303
304* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
305- new upstream release
306- add BuildRequires: libSM-devel
307
308* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
309- removed Requires: eel2
310- added %%posttrans section
311
312* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
313- new upstream release
314
315* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
316- new upstream release
317
318* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
319- new upstream release
320
321* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
322- new upstream release
323- split -devel subpackage
324
325* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
326- new upstream release
327
328* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
329- patch6 needs autoreconf
330
331* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
332- new upstream release
333
334* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
335- new upstream release
336
337* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
338- new upstream release
339- added Requires: gvfs
340
341* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
342- new upstream release
343- added Patches from FC
344  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
345  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
346  - Fix a crash in the Properties dialog while changing owner (patch from head)
347  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
348  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
349
350* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
351- new upstream release
352- dropped Patch11-13 and added Patch7-9 from Fedora
353  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
354  - Add patch from upstream to get audio preview working again
355    (#332251)
356  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
357  - Fix a crash with small fonts (#242350)
358  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
359  - Backport fixes for async thumbnail loading from svn
360
361* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
362- run autoreconf for Patch11 changes
363
364* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
365- remove tracker dependancy, Patch13 detects tracker dynamically.
366
367* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
368- add Patch13 to support user-dirs
369
370* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
371- new upstream release
372- enable tracker support
373- add BuildRequires: tracker-devel, Requires: tracker
374
375* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
376- new upstream release
377
378* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
379- add BuildRequires: gamin-devel, Requires: gamin
380- remove fam dependency (replaced by gamin)
381
382* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
383- new upsteram release
384
385* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
386- really applied Patch110...
387
388* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
389- add Patch110 to fix corruption of help option message.
390
391* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
392- new upstream release
393
394* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
395- fix typo in ja.po
396
397* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
398- update ja.po to translate patch50 related message.
399
400* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
401- add Patch50 to show progressbar on umounting
402  (ubuntu patch in Bug 313639)
403
404* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
405- new upstream release
406
407* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
408- add Patch10 to avoid background rendering delay
409
410* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
411- new upstream release
412
413* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
414- add fix-non-UTF-8-encoding.patch (patch0)
415  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
416
417* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
418- new upstream release
419
420* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
421- new upstream release
422
423* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
424- new upstream release
425
426* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
427- new upstream release
428
429* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
430- rebuild
431
432* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
433- new upstream version
434
435* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
436- new upstream version
437
438* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
439- add vine patch to change some defaults.
440  - change default zoom sine
441  - set always_use_browser
442
443* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
444- new upstream release
445
446* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
447- add Patch110 to fix libegg(egg-recent-model.c)
448  save old umask value before create ".recently-used" file.
449 
450* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
451- change default desktop font to Sans 9 (from Sans 10)
452- add patch10 to build with gtk+-2.4
453
454* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
455- new upstream release
456
457* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
458- new upstream release
459
460* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
461- add backport patch from rawhide (Patch10)
462
463* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
464- modified vine patch
465  - change default zoom level to small
466  - change desktop font to Sans 10
467
468* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
469- new upstream release
470
471* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
472- add desktop icon patch from rawhide
473
474* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
475- remove obsolete ja.po
476
477* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
478- new upstream release
479
480* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
481- new upstream release
482
483* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
484- new upstream release
485
486* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
487- update ja.po
488
489* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
490- new upstream release
491
492* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
493- new upstream release
494
495* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
496- new upstream release
497
498* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
499- new upstream release
500
501* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
502- new upstream release
503
504* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
505- new upstream release
506
507* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
508- add nautilus-cd-burner patch
509
510* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
511- new upstream release
512
513* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
514- discard scrollkeeper outputs.
515- update PreReq tags.
516
517* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
518- change icon for nautilus-file-management-properties
519- update ja.po
520
521* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
522- update ja.po
523- add translation for .desktop files.
524
525* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
526- add Requires: vine-menus
527
528* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
529- new upstream release
530
531* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
532- remove redhatize patch
533
534* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
535- rebuild to remove unneeded dependancy.
536
537* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
538- build for Vine Linux
539
540* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
541- add explicit startup-notification dependency because build system is
542  dumb
543- 2.1.3
544
545* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
546- 2.1.2
547
548* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
549- 2.0.7
550- remove patches that are upstream
551
552* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
553- Add badhack to make weblinks on desktop work
554
555* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
556- fix #70667 assertion failures
557- fix triple click patch
558
559* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
560- don't activate on double click
561
562* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
563- put button press mask in triple-click patch, maybe it will work
564- remove html-hack patch as it does nothing useful
565
566* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
567- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
568  bogus bug reports
569- add hack for HTML mime type handling in a web browser, not
570  nautilus
571
572* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
573- Updated to 2.0.6. Removed the patches I put upstream.
574- Added patch that fixes #72410
575
576* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
577- Add a simple patch so that redhat-config-packages can disable
578  the new window behavior for mounted CDs behavior.
579
580* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
581- Add patch to fix bug #70667
582
583* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
584- remove mp3
585
586* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
587- ignore the "add_to_session" preference as it only broke stuff
588- pad the left margin a bit to cope with poor word wrapping
589
590* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
591- Update to 2.0.5, remove topleft icon patch
592
593* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
594- Add patch to fix the bug where desktop icons get
595  stuck in the top left corner on startup
596
597* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
598- 2.0.4
599
600* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
601- obsolete nautilus-mozilla < 2.0 #69839
602
603* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
604- add rhconfig patch to Bluecurve theme and disable sidebar by default
605
606* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
607- drop start here files, require redhat-menus that has them
608
609* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
610- 2.0.3
611
612* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
613- build for new eel2, gail
614
615* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
616- and add the libexec components, mumble
617
618* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
619- put the components in the file list, were moved upstream
620
621* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
622- 2.0.1
623
624* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
625- Relibtoolize to fix relink problems for solib components
626- Add LANG=en_US to %makeinstall as well
627- Back out previous change, force locale to en_US to prevent UTF-8 problems
628- Add workaround for intltool-merge bug on ia64
629
630* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
631- automated rebuild
632
633* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
634- 2.0.0
635- use desktop-file-install
636- require desktop-backgrounds-basic
637
638* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
639- add wacky hack in hopes of fixing the hang-on-login thing
640
641* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
642- add build requires on new gail
643- rebuild to try to lose broken libgailutil.so.13 dependency
644
645* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
646- rebuild in different environment
647
648* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
649- 1.1.19
650
651* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
652- rebuild in different environment
653
654* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
655- really remove nautilus-devel if we are going to obsolete it
656- don't require hwbrowser
657
658* Sun May 26 2002 Tim Powers <timp@redhat.com>
659- automated rebuild
660
661* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
662- rebuild in different environment
663
664* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
665- 1.1.17
666
667* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
668- 1.1.14
669
670* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
671- require eog
672- obsolete nautilus-devel
673- fix name of schemas file in post
674
675* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
676- Update to 1.1.13
677
678* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
679- put tree view in file list
680
681* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
682- nautilus for gnome 2
683- clean up the spec file and file list a bit
684
685* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
686- merge translations
687
688* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
689- Add patch to fix trash crash
690
691* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
692- fix for metadata tmp race
693- backport thumbnail speed fix and thumbnail inf. loop fix
694
695* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
696- add some fixes from CVS version, including one for #61819 and a couple segfaults
697
698* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
699- fix thumbnails for files with future timestamp, #56862
700
701* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
702- buildrequires intltool #60633
703- apply Alex's pixbuf cache patch to save a few megs #60581
704
705* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
706- drop Milan-specific features, including png10 and ac25 patches
707- copy in 1.0.5 help component to avoid large risky patch
708- remove .la files
709- drop mozilla from ia64 again
710- remove oaf file from nautilus-mozilla that was also in the base
711  package
712
713* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
714- enable mozilla support on ia64
715
716* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
717- require Mozilla 0.9.7
718- Add patch that puts mozilla profile startup before embedding is initialized
719
720* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
721- 1.0.6, require Mozilla 0.9.6
722
723* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
724- Update to 1.0.5
725
726* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
727- Fix handling of GnomeVFSFileInfo structure (#53315)
728
729* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
730- Change handling of names on unmount to fix #52325
731
732* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
733- put nautilus-help.desktop in file list; #53109
734
735* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
736- Add po files from sources.redhat.com
737
738* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
739- Add po files from sources.redhat.com
740
741* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
742- Added patch to fix the .directory issuer
743
744* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
745- I screwed up the build yesterday, so it didn't actually contain the
746  fixes mentioned. This build should contain them.
747
748* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
749- fix bug causing 32000 stats or so in large directories,
750  should speed things up somewhat
751- fix #52104 via gruesome kdesktop-detection hack and setting
752  window type hint on our desktop window
753- fix so Start Here icon displays in sidebar
754- don't load non-local .desktop files
755
756* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
757- make Programs icon into a link, to match the other .desktop files
758- own various directories #51164
759- web page titles in Japanese, #51709
760- tree defaults to only directories #51850
761
762* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
763- make start here icon work again
764- kill some warning spew, #51661
765- cache getpwnam() results to speed things up a bit
766
767* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
768- Fix problem with missing desktop starthere.desktop file
769- New snapshot from our branch, fixes:
770  - On upgrade, icons migrated from GNOME desktop are not properly lined up
771    (#51436)
772  - icons dropped on the desktop don't end up where dropped. (#51441)
773  - Nautilus shouldn't have fam monitor read-only windows. This
774    keeps CDROMS from being unmounted until you close all
775
776    nautilus windows pointing to them. (#51442)
777  - Warnings about 'cannot statfs...' when moving items to trash.
778- Use separate start-here.desktop for panel, since the one used
779  for the root window only works from Nautilus.
780
781* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
782- Changed starthere .desktop files to be links instead
783- of spawning a new nautilus. This makes start-here:
784- much faster.
785
786* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
787- Added hwbrowser dependency
788- New snapshot, fixes the mozilla-view submit form problem
789
790* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
791- Rebuild with new xml-i18n-tools
792- fix crash in creating new desktop files
793
794* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
795- Fix up DnD code some more
796
797* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
798- Sync our CVS version; fixes some MUSTFIX
799  (the one about drawing background on startup,
800   properly translate desktop files, etc.)
801
802* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
803- Fix 64bit cleanness issue
804- Fix NULL mimetype crash
805- Disable additional_text for .desktop files
806
807* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
808- Fix unmounting devices.
809
810* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
811- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
812- mimetype sniffing.
813
814* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
815- Remove the "don't run as root" warning.
816- Remove eazel from bookmarks
817- langified (again? did someone change it?)
818
819* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
820- Apply a patch that makes nautilus dnd reset work with the latest
821- eel release.
822
823* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
824- Build on ia64 without the mozilla component.
825
826* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
827- Fix crash-on-startup showstopper
828- Fix can't-find-images bug (this one was only showing up
829  when built with debug symbols, since it was an uninitialized memory
830  read)
831
832* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
833- sync new tarball from our CVS branch,
834  fixes some drag-and-drop, changes URI scheme names,
835  etc.
836
837* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
838- Add BuildRequires (#49539, 49537)
839- Fix %%post, %%postun (#49720)
840- Background efficiency improvements and hacks
841
842* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
843- Don't launch esd on each mouseover.
844
845* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
846- move first time druid patch into my "CVS outstanding" patch
847- try to really remove Help/Feedback
848- try to really fix Help/Community Support
849- try again to get Start Here in the Go menu
850- try again to get Start Here on the desktop
851- don't show file sizes for .desktop files
852
853* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
854- add newline to ends of .desktop files that were missing them
855
856* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
857- update to my latest 'cvs diff -u' (adds default
858  Start Here link, displays .directory name in sidebar)
859- include /etc/X11/* links (starthere, sysconfig, serverconfig)
860
861* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
862- Patch to remove firsttime druid and flash
863
864* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
865- add hacks for displaying desktop files
866- add hack to turn off the "unwriteable" emblem
867
868* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
869- added defattr to the files lists to be (-,root,root)
870- languified
871
872* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
873- Need to run autoheader too.
874
875* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
876- Make the fam dependency a real runtime dependency
877- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
878- Cleaned up specfile.
879
880* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
881- Change default background and rubberband color.
882- Use the sidebar tabs from the default theme
883- BuildDepend on fam-devel, depend on fam
884- Disable the eazel update pages in the first-time druid.
885- Remove the eazel logo from the first-time druid
886
887* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
888- 1.0.4, removes eazel services icon and wizard page
889- Eazel logo is still in startup wizard for now, needs fixing
890
891* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
892- fix group (s/Desktop/Desktops/) #47134
893- remove ammonite dependency
894
895* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
896- add a different default theme
897- clean up file list overspecificity a bit
898
899* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
900- move to a CVS snapshot of nautilus for now
901  (Darin is my hero for having distcheck work out of CVS)
902
903* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
904- clean up defaults a bit
905
906* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
907- New version
908
909* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
910- Added BuildRequires lines
911- Changed Source to point to ftp.gnome.org instead of just the tarball name
912- Moved %description sections closer to their %package sections
913- Moved %changelog to the end, where so that it's not in the way
914- Changed configure and make install options to allow moving of
915  libraries, includes, binaries more easily
916- Removed hard-coded paths (don't define %prefix or %docdir)
917- replace %{prefix}/bin with %{_bindir}
918- replace %{prefix}/share with %{_datadir}
919- replace %{prefix}/lib with %{_libdir}
920- replace %{prefix}/include with %{_includedir}
921
922* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
923- removed obsoletes from sub packages and added mozilla and trilobite
924subpackages
925
926* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
927- created this thing
Note: See TracBrowser for help on using the repository browser.