source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 9073

Revision 9073, 30.5 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME 3.14.1

Line 
1%define glib2_version 2.42.0
2%define pango_version 1.36.3
3%define gtk3_version 3.14.0
4%define libxml2_version 2.9.1
5%define eog_version 3.14.0
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.14.0
8%define vine_menus_version 3.0
9%define startup_notification_version 0.10
10%define libexif_version 0.6.19
11%define tracker_version 1.0.0
12%define gobject_introspection_version 0.9.8
13
14Name:                   nautilus
15Summary:                Nautilus is a file manager for GNOME
16Summary(ja):    Nautilus - GNOME ファイルマネージャ
17Version:                3.14.0
18Release:                1%{?_dist_release}
19License:                GPLv2+
20Group:                  User Interface/Desktops
21URL:                    http://www.gnome.org/projects/nautilus/
22
23Vendor:                 Project Vine
24Distribution:   Vine Linux
25Packager:               Takemikaduchi
26
27Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.14/%{name}-%{version}.tar.xz
28
29Patch0:         nautilus-3.14.0-git20141015.patch
30
31# vine
32Patch102:       run_in_gnome.patch
33Patch2000:      nautilus-vine-settings.patch
34
35BuildRoot:      %{_tmppath}/%{name}-%{version}-root
36Requires:       gamin
37Requires:       vine-menus >= %{vine_menus_version}
38Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
39Requires:       libexif >= %{libexif_version}
40Requires:       %{name}-libs = %{version}-%{release}
41
42BuildRequires:  intltool
43BuildRequires:  libtool >= 1.4.2-10
44BuildRequires:  automake, autoconf
45BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
46
47BuildRequires:  glib2-devel >= %{glib2_version}
48BuildRequires:  pango-devel >= %{pango_version}
49BuildRequires:  gtk3-devel >= %{gtk3_version}
50BuildRequires:  libxml2-devel >= %{libxml2_version}
51BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
52BuildRequires:  gamin-devel
53BuildRequires:  startup-notification-devel >= %{startup_notification_version}
54BuildRequires:  tracker-devel >= %{tracker_version}
55BuildRequires:  libexif-devel >= %{libexif_version}
56BuildRequires:  unique3-devel
57BuildRequires:  libnotify-devel
58BuildRequires:  libSM-devel
59BuildRequires:  exempi-devel
60BuildRequires:  tracker-devel
61BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
62BuildRequires:  gsettings-desktop-schemas
63
64Obsoletes:      nautilus-extras
65Obsoletes:      nautilus-suggested
66Obsoletes:      nautilus-mozilla < 2.0
67Obsoletes:      eel2 <= 2.24.1
68
69Provides:       eel2 <= 2.24.1
70
71
72%description
73Nautilus integrates access to files, applications, media,
74Internet-based resources and the Web. Nautilus delivers a dynamic and
75rich user experience. Nautilus is an free software project developed
76under the GNU General Public License and is a core component of the
77GNOME desktop project.
78
79%description -l ja
80Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
81リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
82豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
83のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
84プロジェクトのコア・コンポーネントです。
85
86%package devel
87Summary: Support for developing nautilus extensions
88Summary(ja): Nautilus 拡張機能開発のためのサポート
89License: LGPLv2+
90Group: Development/Libraries
91Requires: %{name}-libs = %{version}-%{release}
92Requires: pkgconfig
93
94%description devel
95This package provides libraries and header files needed
96for developing nautilus extensions.
97
98%description -l ja devel
99このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
100ヘッダファイルを提供します。
101
102%package libs
103Summary: Libraries for use in nautilus extentions
104Summary(ja): Nautilus 拡張機能で利用するライブラリ
105Group: User Interface/Desktops
106
107%description libs
108This package provides libraries required by nautilus extention
109module.
110
111%description -l ja libs
112このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
113
114%prep
115%setup -q -n %{name}-%{version}
116
117%patch0 -p1
118
119%patch102 -p1 -b .vine
120%patch2000 -p1 -b .vine
121
122%build
123gtkdocize
124libtoolize --force --copy
125autoreconf -f -i
126CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
127%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
128
129make %{?_smp_mflags}
130
131%install
132rm -rf $RPM_BUILD_ROOT
133
134make install DESTDIR=$RPM_BUILD_ROOT
135
136# make sure desktop files validate by ignoring sr@Latn
137perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
138# desktop-file-install can't handle empty OnlyShowIn correctly
139perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
140
141desktop-file-install --vendor gnome --delete-original       \
142  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
143  --add-only-show-in GNOME                                  \
144  $RPM_BUILD_ROOT%{_datadir}/applications/*
145
146find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
147
148%find_lang %name
149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
153%postun
154if [ $1 -eq 0 ] ; then
155    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
156fi
157
158%posttrans
159update-mime-database %{_datadir}/mime &> /dev/null ||:
160glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
161
162%post libs -p /sbin/ldconfig
163%postun libs -p /sbin/ldconfig
164
165
166%files  -f %{name}.lang
167%defattr(-,root,root)
168%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
169%dir %{_libdir}/nautilus
170%dir %{_libdir}/nautilus/extensions-3.0
171%{_libdir}/nautilus/extensions-3.0/*.so
172%{_libexecdir}/nautilus-convert-metadata
173%{_datadir}/GConf/gsettings/nautilus.convert
174%{_datadir}/appdata/org.gnome.Nautilus.appdata.xml
175%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
176%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
177%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
178%{_datadir}/applications
179%{_datadir}/mime/*
180%{_bindir}/*
181%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
182%{_datadir}/glib-2.0/schemas/
183%{_mandir}/man1/*
184
185%files devel
186%defattr(-, root, root)
187%{_includedir}/nautilus
188%{_libdir}/pkgconfig/*
189%{_libdir}/*.so
190%{_datadir}/gir-1.0
191%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
192
193%files libs
194%defattr(-, root, root)
195%{_libdir}/*.so.*
196%{_libdir}/girepository-1.0/*.typelib
197
198
199%changelog
200* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
201- new upstream release
202- add Patch0 (nautilus-3.14.0-git20141015.patch)
203
204* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
205- new upstream release
206
207* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
208- new upstream release
209
210* Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
211- new upstream release
212
213* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
214- new upstream release
215- add Patch2000 (nautilus-vine-settings.patch)
216
217* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
218- new upstream release
219
220* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
221- new upstream release
222
223* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
224- new upstream release
225
226* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
227- new upstream release
228
229* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
230- new upstream release
231
232* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
233- new upstream release
234- remove Patch0,7
235- add BuildRequires: exempi-devel, tracker-devel
236
237* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
238- add Patch0 (nautilus-3.4.2-ja.po.patch)
239
240* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
241- new upstream release
242
243* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
244- new upstream release
245
246* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
247- added patch102 to fix autostart in other desktop environments
248  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
249
250* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
251- new upstream release
252
253* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
254- new upstream release
255
256* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
257- new upstream release
258
259* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
260- new upstream release
261
262* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
263- new upstream release
264- drop Patch101
265- change BuildRequires: gtk3-devel instread of gtk2-devel
266- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
267- change BuildRequires: unique3-devel instread of unique-devel
268- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
269
270* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
271- fixed group of libs
272- add translation of summary and description.
273- add Vendor, Distribution and Packager tags.
274
275* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
276- new upstream release
277
278* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
279- new upstream release
280
281* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
282 - new upstream release
283
284* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
285- new upstream release
286- add BuildRequires: gobject-introspection-devel
287- remove BuildRequires: libgnomeui-devel
288- add configure option (--enable-introspection=yes)
289
290* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
291- rebuild with rpm-4.8.1 for pkg-config file
292
293* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
294- split nautilus extention libraries to -libs subpackage.
295
296* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
297- new upstream release
298
299* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
300- new upstream release
301- drop Patch100
302- add Patch101
303- add Obsoletes: eel2 <= 2.24.1
304- add Provides: eel2 <= 2.24.1
305
306* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
307- new upstream release
308- add BuildRequires: libSM-devel
309
310* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
311- removed Requires: eel2
312- added %%posttrans section
313
314* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
315- new upstream release
316
317* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
318- new upstream release
319
320* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
321- new upstream release
322
323* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
324- new upstream release
325- split -devel subpackage
326
327* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
328- new upstream release
329
330* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
331- patch6 needs autoreconf
332
333* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
334- new upstream release
335
336* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
337- new upstream release
338
339* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
340- new upstream release
341- added Requires: gvfs
342
343* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
344- new upstream release
345- added Patches from FC
346  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
347  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
348  - Fix a crash in the Properties dialog while changing owner (patch from head)
349  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
350  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
351
352* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
353- new upstream release
354- dropped Patch11-13 and added Patch7-9 from Fedora
355  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
356  - Add patch from upstream to get audio preview working again
357    (#332251)
358  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
359  - Fix a crash with small fonts (#242350)
360  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
361  - Backport fixes for async thumbnail loading from svn
362
363* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
364- run autoreconf for Patch11 changes
365
366* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
367- remove tracker dependancy, Patch13 detects tracker dynamically.
368
369* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
370- add Patch13 to support user-dirs
371
372* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
373- new upstream release
374- enable tracker support
375- add BuildRequires: tracker-devel, Requires: tracker
376
377* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
378- new upstream release
379
380* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
381- add BuildRequires: gamin-devel, Requires: gamin
382- remove fam dependency (replaced by gamin)
383
384* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
385- new upsteram release
386
387* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
388- really applied Patch110...
389
390* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
391- add Patch110 to fix corruption of help option message.
392
393* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
394- new upstream release
395
396* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
397- fix typo in ja.po
398
399* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
400- update ja.po to translate patch50 related message.
401
402* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
403- add Patch50 to show progressbar on umounting
404  (ubuntu patch in Bug 313639)
405
406* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
407- new upstream release
408
409* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
410- add Patch10 to avoid background rendering delay
411
412* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
413- new upstream release
414
415* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
416- add fix-non-UTF-8-encoding.patch (patch0)
417  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
418
419* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
420- new upstream release
421
422* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
423- new upstream release
424
425* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
426- new upstream release
427
428* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
429- new upstream release
430
431* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
432- rebuild
433
434* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
435- new upstream version
436
437* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
438- new upstream version
439
440* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
441- add vine patch to change some defaults.
442  - change default zoom sine
443  - set always_use_browser
444
445* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
446- new upstream release
447
448* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
449- add Patch110 to fix libegg(egg-recent-model.c)
450  save old umask value before create ".recently-used" file.
451 
452* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
453- change default desktop font to Sans 9 (from Sans 10)
454- add patch10 to build with gtk+-2.4
455
456* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
457- new upstream release
458
459* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
460- new upstream release
461
462* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
463- add backport patch from rawhide (Patch10)
464
465* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
466- modified vine patch
467  - change default zoom level to small
468  - change desktop font to Sans 10
469
470* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
471- new upstream release
472
473* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
474- add desktop icon patch from rawhide
475
476* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
477- remove obsolete ja.po
478
479* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
480- new upstream release
481
482* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
483- new upstream release
484
485* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
486- new upstream release
487
488* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
489- update ja.po
490
491* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
492- new upstream release
493
494* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
495- new upstream release
496
497* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
498- new upstream release
499
500* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
501- new upstream release
502
503* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
504- new upstream release
505
506* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
507- new upstream release
508
509* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
510- add nautilus-cd-burner patch
511
512* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
513- new upstream release
514
515* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
516- discard scrollkeeper outputs.
517- update PreReq tags.
518
519* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
520- change icon for nautilus-file-management-properties
521- update ja.po
522
523* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
524- update ja.po
525- add translation for .desktop files.
526
527* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
528- add Requires: vine-menus
529
530* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
531- new upstream release
532
533* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
534- remove redhatize patch
535
536* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
537- rebuild to remove unneeded dependancy.
538
539* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
540- build for Vine Linux
541
542* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
543- add explicit startup-notification dependency because build system is
544  dumb
545- 2.1.3
546
547* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
548- 2.1.2
549
550* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
551- 2.0.7
552- remove patches that are upstream
553
554* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
555- Add badhack to make weblinks on desktop work
556
557* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
558- fix #70667 assertion failures
559- fix triple click patch
560
561* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
562- don't activate on double click
563
564* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
565- put button press mask in triple-click patch, maybe it will work
566- remove html-hack patch as it does nothing useful
567
568* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
569- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
570  bogus bug reports
571- add hack for HTML mime type handling in a web browser, not
572  nautilus
573
574* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
575- Updated to 2.0.6. Removed the patches I put upstream.
576- Added patch that fixes #72410
577
578* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
579- Add a simple patch so that redhat-config-packages can disable
580  the new window behavior for mounted CDs behavior.
581
582* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
583- Add patch to fix bug #70667
584
585* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
586- remove mp3
587
588* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
589- ignore the "add_to_session" preference as it only broke stuff
590- pad the left margin a bit to cope with poor word wrapping
591
592* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
593- Update to 2.0.5, remove topleft icon patch
594
595* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
596- Add patch to fix the bug where desktop icons get
597  stuck in the top left corner on startup
598
599* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
600- 2.0.4
601
602* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
603- obsolete nautilus-mozilla < 2.0 #69839
604
605* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
606- add rhconfig patch to Bluecurve theme and disable sidebar by default
607
608* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
609- drop start here files, require redhat-menus that has them
610
611* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
612- 2.0.3
613
614* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
615- build for new eel2, gail
616
617* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
618- and add the libexec components, mumble
619
620* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
621- put the components in the file list, were moved upstream
622
623* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
624- 2.0.1
625
626* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
627- Relibtoolize to fix relink problems for solib components
628- Add LANG=en_US to %makeinstall as well
629- Back out previous change, force locale to en_US to prevent UTF-8 problems
630- Add workaround for intltool-merge bug on ia64
631
632* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
633- automated rebuild
634
635* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
636- 2.0.0
637- use desktop-file-install
638- require desktop-backgrounds-basic
639
640* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
641- add wacky hack in hopes of fixing the hang-on-login thing
642
643* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
644- add build requires on new gail
645- rebuild to try to lose broken libgailutil.so.13 dependency
646
647* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
648- rebuild in different environment
649
650* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
651- 1.1.19
652
653* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
654- rebuild in different environment
655
656* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
657- really remove nautilus-devel if we are going to obsolete it
658- don't require hwbrowser
659
660* Sun May 26 2002 Tim Powers <timp@redhat.com>
661- automated rebuild
662
663* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
664- rebuild in different environment
665
666* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
667- 1.1.17
668
669* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
670- 1.1.14
671
672* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
673- require eog
674- obsolete nautilus-devel
675- fix name of schemas file in post
676
677* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
678- Update to 1.1.13
679
680* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
681- put tree view in file list
682
683* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
684- nautilus for gnome 2
685- clean up the spec file and file list a bit
686
687* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
688- merge translations
689
690* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
691- Add patch to fix trash crash
692
693* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
694- fix for metadata tmp race
695- backport thumbnail speed fix and thumbnail inf. loop fix
696
697* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
698- add some fixes from CVS version, including one for #61819 and a couple segfaults
699
700* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
701- fix thumbnails for files with future timestamp, #56862
702
703* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
704- buildrequires intltool #60633
705- apply Alex's pixbuf cache patch to save a few megs #60581
706
707* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
708- drop Milan-specific features, including png10 and ac25 patches
709- copy in 1.0.5 help component to avoid large risky patch
710- remove .la files
711- drop mozilla from ia64 again
712- remove oaf file from nautilus-mozilla that was also in the base
713  package
714
715* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
716- enable mozilla support on ia64
717
718* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
719- require Mozilla 0.9.7
720- Add patch that puts mozilla profile startup before embedding is initialized
721
722* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
723- 1.0.6, require Mozilla 0.9.6
724
725* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
726- Update to 1.0.5
727
728* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
729- Fix handling of GnomeVFSFileInfo structure (#53315)
730
731* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
732- Change handling of names on unmount to fix #52325
733
734* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
735- put nautilus-help.desktop in file list; #53109
736
737* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
738- Add po files from sources.redhat.com
739
740* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
741- Add po files from sources.redhat.com
742
743* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
744- Added patch to fix the .directory issuer
745
746* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
747- I screwed up the build yesterday, so it didn't actually contain the
748  fixes mentioned. This build should contain them.
749
750* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
751- fix bug causing 32000 stats or so in large directories,
752  should speed things up somewhat
753- fix #52104 via gruesome kdesktop-detection hack and setting
754  window type hint on our desktop window
755- fix so Start Here icon displays in sidebar
756- don't load non-local .desktop files
757
758* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
759- make Programs icon into a link, to match the other .desktop files
760- own various directories #51164
761- web page titles in Japanese, #51709
762- tree defaults to only directories #51850
763
764* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
765- make start here icon work again
766- kill some warning spew, #51661
767- cache getpwnam() results to speed things up a bit
768
769* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
770- Fix problem with missing desktop starthere.desktop file
771- New snapshot from our branch, fixes:
772  - On upgrade, icons migrated from GNOME desktop are not properly lined up
773    (#51436)
774  - icons dropped on the desktop don't end up where dropped. (#51441)
775  - Nautilus shouldn't have fam monitor read-only windows. This
776    keeps CDROMS from being unmounted until you close all
777
778    nautilus windows pointing to them. (#51442)
779  - Warnings about 'cannot statfs...' when moving items to trash.
780- Use separate start-here.desktop for panel, since the one used
781  for the root window only works from Nautilus.
782
783* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
784- Changed starthere .desktop files to be links instead
785- of spawning a new nautilus. This makes start-here:
786- much faster.
787
788* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
789- Added hwbrowser dependency
790- New snapshot, fixes the mozilla-view submit form problem
791
792* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
793- Rebuild with new xml-i18n-tools
794- fix crash in creating new desktop files
795
796* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
797- Fix up DnD code some more
798
799* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
800- Sync our CVS version; fixes some MUSTFIX
801  (the one about drawing background on startup,
802   properly translate desktop files, etc.)
803
804* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
805- Fix 64bit cleanness issue
806- Fix NULL mimetype crash
807- Disable additional_text for .desktop files
808
809* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
810- Fix unmounting devices.
811
812* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
813- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
814- mimetype sniffing.
815
816* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
817- Remove the "don't run as root" warning.
818- Remove eazel from bookmarks
819- langified (again? did someone change it?)
820
821* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
822- Apply a patch that makes nautilus dnd reset work with the latest
823- eel release.
824
825* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
826- Build on ia64 without the mozilla component.
827
828* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
829- Fix crash-on-startup showstopper
830- Fix can't-find-images bug (this one was only showing up
831  when built with debug symbols, since it was an uninitialized memory
832  read)
833
834* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
835- sync new tarball from our CVS branch,
836  fixes some drag-and-drop, changes URI scheme names,
837  etc.
838
839* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
840- Add BuildRequires (#49539, 49537)
841- Fix %%post, %%postun (#49720)
842- Background efficiency improvements and hacks
843
844* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
845- Don't launch esd on each mouseover.
846
847* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
848- move first time druid patch into my "CVS outstanding" patch
849- try to really remove Help/Feedback
850- try to really fix Help/Community Support
851- try again to get Start Here in the Go menu
852- try again to get Start Here on the desktop
853- don't show file sizes for .desktop files
854
855* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
856- add newline to ends of .desktop files that were missing them
857
858* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
859- update to my latest 'cvs diff -u' (adds default
860  Start Here link, displays .directory name in sidebar)
861- include /etc/X11/* links (starthere, sysconfig, serverconfig)
862
863* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
864- Patch to remove firsttime druid and flash
865
866* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
867- add hacks for displaying desktop files
868- add hack to turn off the "unwriteable" emblem
869
870* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
871- added defattr to the files lists to be (-,root,root)
872- languified
873
874* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
875- Need to run autoheader too.
876
877* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
878- Make the fam dependency a real runtime dependency
879- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
880- Cleaned up specfile.
881
882* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
883- Change default background and rubberband color.
884- Use the sidebar tabs from the default theme
885- BuildDepend on fam-devel, depend on fam
886- Disable the eazel update pages in the first-time druid.
887- Remove the eazel logo from the first-time druid
888
889* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
890- 1.0.4, removes eazel services icon and wizard page
891- Eazel logo is still in startup wizard for now, needs fixing
892
893* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
894- fix group (s/Desktop/Desktops/) #47134
895- remove ammonite dependency
896
897* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
898- add a different default theme
899- clean up file list overspecificity a bit
900
901* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
902- move to a CVS snapshot of nautilus for now
903  (Darin is my hero for having distcheck work out of CVS)
904
905* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
906- clean up defaults a bit
907
908* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
909- New version
910
911* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
912- Added BuildRequires lines
913- Changed Source to point to ftp.gnome.org instead of just the tarball name
914- Moved %description sections closer to their %package sections
915- Moved %changelog to the end, where so that it's not in the way
916- Changed configure and make install options to allow moving of
917  libraries, includes, binaries more easily
918- Removed hard-coded paths (don't define %prefix or %docdir)
919- replace %{prefix}/bin with %{_bindir}
920- replace %{prefix}/share with %{_datadir}
921- replace %{prefix}/lib with %{_libdir}
922- replace %{prefix}/include with %{_includedir}
923
924* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
925- removed obsoletes from sub packages and added mozilla and trilobite
926subpackages
927
928* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
929- created this thing
Note: See TracBrowser for help on using the repository browser.