source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 805

Revision 805, 27.4 KB checked in by Takemikaduchi, 14 years ago (diff)

change spec file of gnome-2.30

Line 
1%define glib2_version 2.24.0
2%define pango_version 1.28.0
3%define gtk2_version 2.20.0
4%define libgnomeui_version 2.24.3
5%define libxml2_version 2.5.10
6%define eog_version 2.30.0
7%define desktop_file_utils_version 0.3
8%define gnome_desktop_version 2.30.0
9%define vine_menus_version 3.0
10%define gnome_menus_version 2.30.0
11%define gnome_vfs2_version 2.24.1
12%define startup_notification_version 0.5
13%define libexif_version 0.5.12
14%define gconf_version 2.28.0
15
16Name:           nautilus
17Summary:        Nautilus is a file manager for GNOME
18Summary(ja):    Nautilus - GNOME ファイルマネージャ
19Version:        2.30.0
20Release:        1%{?_dist_release}
21License:        GPLv2+
22Group:          User Interface/Desktops
23URL:            http://www.gnome.org/projects/nautilus/
24
25Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.28/%{name}-%{version}.tar.bz2
26
27# Some changes to default config
28Patch1:         nautilus-2.5.7-rhconfig.patch
29Patch3:         background-no-delay.patch
30
31# Why is this not upstream ?
32Patch6:         nautilus-2.23.5-dynamic-search.patch
33
34Patch7:         rtl-fix.patch
35
36# vine
37Patch100:       nautilus-2.8.2-vine.patch
38Patch101:       nautilus-2.30.0-vine.patch
39
40BuildRoot:      %{_tmppath}/%{name}-%{version}-root
41Requires:       gamin
42Requires:       vine-menus >= %{vine_menus_version}
43Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
44Requires:       libexif >= %{libexif_version}
45
46Requires(pre,preun,post): GConf2 >= %{gconf_version}
47Requires(post,postun): rarian-compat
48
49BuildRequires:  glib2-devel >= %{glib2_version}
50BuildRequires:  pango-devel >= %{pango_version}
51BuildRequires:  gtk2-devel >= %{gtk2_version}
52BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}
53BuildRequires:  libxml2-devel >= %{libxml2_version}
54BuildRequires:  gnome-desktop-devel >= %{gnome_desktop_version}
55BuildRequires:  gamin-devel
56BuildRequires:  intltool
57BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
58BuildRequires:  libtool >= 1.4.2-10
59BuildRequires:  automake, autoconf
60BuildRequires:  startup-notification-devel >= %{startup_notification_version}
61#BuildRequires: tracker-devel >= %{tracker_version}
62BuildRequires:  libexif-devel  >= %{libexif_version}
63BuildRequires:  unique-devel
64BuildRequires:  libtool, autoconf
65BuildRequires:  libSM-devel
66
67Obsoletes:      nautilus-extras
68Obsoletes:      nautilus-suggested
69Obsoletes:      nautilus-mozilla < 2.0
70Obsoletes:      eel2 <= 2.24.1
71
72Provides:       eel2 <= 2.24.1
73
74
75%description
76Nautilus integrates access to files, applications, media,
77Internet-based resources and the Web. Nautilus delivers a dynamic and
78rich user experience. Nautilus is an free software project developed
79under the GNU General Public License and is a core component of the
80GNOME desktop project.
81
82%package devel
83Summary: Support for developing nautilus extensions
84License: LGPLv2+
85Group: Development/Libraries
86Requires: %{name} = %{version}-%{release}
87Requires: pkgconfig
88
89%description devel
90This package provides libraries and header files needed
91for developing nautilus extensions.
92
93%prep
94%setup -q -n %{name}-%{version}
95
96##patch3 -p1 -b .no-delay
97#%patch5 -p1 -b .selinux
98##patch6 -p1 -b .dynamic-search
99%patch7 -p1 -b .rtl-fix
100
101## %patch100 -p1 -b .vine
102%patch101 -p1 -b .vine
103
104%build
105gtkdocize
106libtoolize --force --copy
107autoreconf -f -i
108CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
109%configure --disable-more-warnings --disable-update-mimedb
110
111export tagname=CC
112LANG=en_US make LIBTOOL=/usr/bin/libtool %{?_smp_mflags}
113
114%install
115rm -rf $RPM_BUILD_ROOT
116
117export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
118export tagname=CC
119LANG=en_US %makeinstall LIBTOOL=/usr/bin/libtool
120unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
121
122## these are in desktop-backgrounds-basic
123## (uncomment when we patch the source to look in the right place)
124## /bin/rm -rf $RPM_BUILD_ROOT%{_datadir}/nautilus/patterns
125
126# make sure desktop files validate by ignoring sr@Latn
127perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
128# desktop-file-install can't handle empty OnlyShowIn correctly
129perl -pi -e 's/OnlyShowIn=;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus-folder-default-handler.desktop
130
131desktop-file-install --vendor gnome --delete-original       \
132  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
133  --add-only-show-in GNOME                                  \
134  $RPM_BUILD_ROOT%{_datadir}/applications/*
135
136perl -pi -e 's/OnlyShowIn=GNOME;/OnlyShowIn=;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus-folder-default-handler.desktop
137
138rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{la,a}
139rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
140rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
141
142mkdir -p $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-2.0
143
144%find_lang %name
145
146%clean
147rm -rf $RPM_BUILD_ROOT
148
149%post
150/sbin/ldconfig
151touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
152export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
153gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
154
155%posttrans
156%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null ||:
157gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
158scrollkeeper-update > /dev/null 2>&1 || :
159
160%pre
161if [ "$1" -gt 1 ]; then
162    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
163    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
164fi
165
166%preun
167if [ "$1" -eq 0 ]; then
168    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
169    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
170fi
171
172%postun
173/sbin/ldconfig
174if [ $1 -eq 0 ] ; then
175    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
176    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
177    scrollkeeper-update > /dev/null 2>&1 || :
178fi
179
180%files  -f %{name}.lang
181%defattr(-,root,root)
182%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
183%{_libdir}/*.so.*
184%dir %{_libdir}/nautilus
185%dir %{_libdir}/nautilus/extensions-2.0
186%{_libexecdir}/nautilus-convert-metadata
187%{_datadir}/nautilus
188%{_datadir}/pixmaps
189%{_datadir}/applications
190%{_datadir}/mime/*
191%{_datadir}/icons/hicolor/*
192%{_bindir}/*
193%{_sysconfdir}/gconf/schemas/*
194%{_mandir}/man1/*
195
196%files devel
197%defattr(-, root, root)
198%{_includedir}/nautilus
199%{_libdir}/pkgconfig/*
200%{_libdir}/*.so
201%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
202
203
204%changelog
205* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
206- new upstream release
207- drop Patch100
208- add Patch101
209- add Obsoletes: eel2 <= 2.24.1
210- add Provides: eel2 <= 2.24.1
211
212* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
213- new upstream release
214- add BuildRequires: libSM-devel
215
216* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
217- removed Requires: eel2
218- added %%posttrans section
219
220* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
221- new upstream release
222
223* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
224- new upstream release
225
226* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
227- new upstream release
228
229* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
230- new upstream release
231- split -devel subpackage
232
233* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
234- new upstream release
235
236* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
237- patch6 needs autoreconf
238
239* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
240- new upstream release
241
242* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
243- new upstream release
244
245* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
246- new upstream release
247- added Requires: gvfs
248
249* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
250- new upstream release
251- added Patches from FC
252  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
253  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
254  - Fix a crash in the Properties dialog while changing owner (patch from head)
255  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
256  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
257
258* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
259- new upstream release
260- dropped Patch11-13 and added Patch7-9 from Fedora
261  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
262  - Add patch from upstream to get audio preview working again
263    (#332251)
264  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
265  - Fix a crash with small fonts (#242350)
266  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
267  - Backport fixes for async thumbnail loading from svn
268
269* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
270- run autoreconf for Patch11 changes
271
272* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
273- remove tracker dependancy, Patch13 detects tracker dynamically.
274
275* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
276- add Patch13 to support user-dirs
277
278* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
279- new upstream release
280- enable tracker support
281- add BuildRequires: tracker-devel, Requires: tracker
282
283* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
284- new upstream release
285
286* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
287- add BuildRequires: gamin-devel, Requires: gamin
288- remove fam dependency (replaced by gamin)
289
290* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
291- new upsteram release
292
293* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
294- really applied Patch110...
295
296* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
297- add Patch110 to fix corruption of help option message.
298
299* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
300- new upstream release
301
302* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
303- fix typo in ja.po
304
305* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
306- update ja.po to translate patch50 related message.
307
308* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
309- add Patch50 to show progressbar on umounting
310  (ubuntu patch in Bug 313639)
311
312* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
313- new upstream release
314
315* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
316- add Patch10 to avoid background rendering delay
317
318* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
319- new upstream release
320
321* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
322- add fix-non-UTF-8-encoding.patch (patch0)
323  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
324
325* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
326- new upstream release
327
328* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
329- new upstream release
330
331* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
332- new upstream release
333
334* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
335- new upstream release
336
337* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
338- rebuild
339
340* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
341- new upstream version
342
343* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
344- new upstream version
345
346* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
347- add vine patch to change some defaults.
348  - change default zoom sine
349  - set always_use_browser
350
351* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
352- new upstream release
353
354* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
355- add Patch110 to fix libegg(egg-recent-model.c)
356  save old umask value before create ".recently-used" file.
357 
358* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
359- change default desktop font to Sans 9 (from Sans 10)
360- add patch10 to build with gtk+-2.4
361
362* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
363- new upstream release
364
365* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
366- new upstream release
367
368* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
369- add backport patch from rawhide (Patch10)
370
371* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
372- modified vine patch
373  - change default zoom level to small
374  - change desktop font to Sans 10
375
376* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
377- new upstream release
378
379* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
380- add desktop icon patch from rawhide
381
382* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
383- remove obsolete ja.po
384
385* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
386- new upstream release
387
388* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
389- new upstream release
390
391* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
392- new upstream release
393
394* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
395- update ja.po
396
397* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
398- new upstream release
399
400* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
401- new upstream release
402
403* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
404- new upstream release
405
406* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
407- new upstream release
408
409* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
410- new upstream release
411
412* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
413- new upstream release
414
415* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
416- add nautilus-cd-burner patch
417
418* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
419- new upstream release
420
421* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
422- discard scrollkeeper outputs.
423- update PreReq tags.
424
425* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
426- change icon for nautilus-file-management-properties
427- update ja.po
428
429* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
430- update ja.po
431- add translation for .desktop files.
432
433* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
434- add Requires: vine-menus
435
436* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
437- new upstream release
438
439* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
440- remove redhatize patch
441
442* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
443- rebuild to remove unneeded dependancy.
444
445* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
446- build for Vine Linux
447
448* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
449- add explicit startup-notification dependency because build system is
450  dumb
451- 2.1.3
452
453* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
454- 2.1.2
455
456* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
457- 2.0.7
458- remove patches that are upstream
459
460* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
461- Add badhack to make weblinks on desktop work
462
463* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
464- fix #70667 assertion failures
465- fix triple click patch
466
467* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
468- don't activate on double click
469
470* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
471- put button press mask in triple-click patch, maybe it will work
472- remove html-hack patch as it does nothing useful
473
474* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
475- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
476  bogus bug reports
477- add hack for HTML mime type handling in a web browser, not
478  nautilus
479
480* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
481- Updated to 2.0.6. Removed the patches I put upstream.
482- Added patch that fixes #72410
483
484* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
485- Add a simple patch so that redhat-config-packages can disable
486  the new window behavior for mounted CDs behavior.
487
488* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
489- Add patch to fix bug #70667
490
491* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
492- remove mp3
493
494* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
495- ignore the "add_to_session" preference as it only broke stuff
496- pad the left margin a bit to cope with poor word wrapping
497
498* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
499- Update to 2.0.5, remove topleft icon patch
500
501* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
502- Add patch to fix the bug where desktop icons get
503  stuck in the top left corner on startup
504
505* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
506- 2.0.4
507
508* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
509- obsolete nautilus-mozilla < 2.0 #69839
510
511* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
512- add rhconfig patch to Bluecurve theme and disable sidebar by default
513
514* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
515- drop start here files, require redhat-menus that has them
516
517* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
518- 2.0.3
519
520* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
521- build for new eel2, gail
522
523* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
524- and add the libexec components, mumble
525
526* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
527- put the components in the file list, were moved upstream
528
529* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
530- 2.0.1
531
532* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
533- Relibtoolize to fix relink problems for solib components
534- Add LANG=en_US to %makeinstall as well
535- Back out previous change, force locale to en_US to prevent UTF-8 problems
536- Add workaround for intltool-merge bug on ia64
537
538* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
539- automated rebuild
540
541* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
542- 2.0.0
543- use desktop-file-install
544- require desktop-backgrounds-basic
545
546* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
547- add wacky hack in hopes of fixing the hang-on-login thing
548
549* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
550- add build requires on new gail
551- rebuild to try to lose broken libgailutil.so.13 dependency
552
553* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
554- rebuild in different environment
555
556* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
557- 1.1.19
558
559* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
560- rebuild in different environment
561
562* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
563- really remove nautilus-devel if we are going to obsolete it
564- don't require hwbrowser
565
566* Sun May 26 2002 Tim Powers <timp@redhat.com>
567- automated rebuild
568
569* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
570- rebuild in different environment
571
572* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
573- 1.1.17
574
575* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
576- 1.1.14
577
578* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
579- require eog
580- obsolete nautilus-devel
581- fix name of schemas file in post
582
583* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
584- Update to 1.1.13
585
586* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
587- put tree view in file list
588
589* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
590- nautilus for gnome 2
591- clean up the spec file and file list a bit
592
593* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
594- merge translations
595
596* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
597- Add patch to fix trash crash
598
599* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
600- fix for metadata tmp race
601- backport thumbnail speed fix and thumbnail inf. loop fix
602
603* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
604- add some fixes from CVS version, including one for #61819 and a couple segfaults
605
606* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
607- fix thumbnails for files with future timestamp, #56862
608
609* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
610- buildrequires intltool #60633
611- apply Alex's pixbuf cache patch to save a few megs #60581
612
613* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
614- drop Milan-specific features, including png10 and ac25 patches
615- copy in 1.0.5 help component to avoid large risky patch
616- remove .la files
617- drop mozilla from ia64 again
618- remove oaf file from nautilus-mozilla that was also in the base
619  package
620
621* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
622- enable mozilla support on ia64
623
624* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
625- require Mozilla 0.9.7
626- Add patch that puts mozilla profile startup before embedding is initialized
627
628* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
629- 1.0.6, require Mozilla 0.9.6
630
631* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
632- Update to 1.0.5
633
634* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
635- Fix handling of GnomeVFSFileInfo structure (#53315)
636
637* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
638- Change handling of names on unmount to fix #52325
639
640* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
641- put nautilus-help.desktop in file list; #53109
642
643* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
644- Add po files from sources.redhat.com
645
646* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
647- Add po files from sources.redhat.com
648
649* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
650- Added patch to fix the .directory issuer
651
652* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
653- I screwed up the build yesterday, so it didn't actually contain the
654  fixes mentioned. This build should contain them.
655
656* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
657- fix bug causing 32000 stats or so in large directories,
658  should speed things up somewhat
659- fix #52104 via gruesome kdesktop-detection hack and setting
660  window type hint on our desktop window
661- fix so Start Here icon displays in sidebar
662- don't load non-local .desktop files
663
664* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
665- make Programs icon into a link, to match the other .desktop files
666- own various directories #51164
667- web page titles in Japanese, #51709
668- tree defaults to only directories #51850
669
670* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
671- make start here icon work again
672- kill some warning spew, #51661
673- cache getpwnam() results to speed things up a bit
674
675* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
676- Fix problem with missing desktop starthere.desktop file
677- New snapshot from our branch, fixes:
678  - On upgrade, icons migrated from GNOME desktop are not properly lined up
679    (#51436)
680  - icons dropped on the desktop don't end up where dropped. (#51441)
681  - Nautilus shouldn't have fam monitor read-only windows. This
682    keeps CDROMS from being unmounted until you close all
683
684    nautilus windows pointing to them. (#51442)
685  - Warnings about 'cannot statfs...' when moving items to trash.
686- Use separate start-here.desktop for panel, since the one used
687  for the root window only works from Nautilus.
688
689* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
690- Changed starthere .desktop files to be links instead
691- of spawning a new nautilus. This makes start-here:
692- much faster.
693
694* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
695- Added hwbrowser dependency
696- New snapshot, fixes the mozilla-view submit form problem
697
698* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
699- Rebuild with new xml-i18n-tools
700- fix crash in creating new desktop files
701
702* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
703- Fix up DnD code some more
704
705* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
706- Sync our CVS version; fixes some MUSTFIX
707  (the one about drawing background on startup,
708   properly translate desktop files, etc.)
709
710* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
711- Fix 64bit cleanness issue
712- Fix NULL mimetype crash
713- Disable additional_text for .desktop files
714
715* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
716- Fix unmounting devices.
717
718* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
719- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
720- mimetype sniffing.
721
722* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
723- Remove the "don't run as root" warning.
724- Remove eazel from bookmarks
725- langified (again? did someone change it?)
726
727* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
728- Apply a patch that makes nautilus dnd reset work with the latest
729- eel release.
730
731* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
732- Build on ia64 without the mozilla component.
733
734* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
735- Fix crash-on-startup showstopper
736- Fix can't-find-images bug (this one was only showing up
737  when built with debug symbols, since it was an uninitialized memory
738  read)
739
740* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
741- sync new tarball from our CVS branch,
742  fixes some drag-and-drop, changes URI scheme names,
743  etc.
744
745* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
746- Add BuildRequires (#49539, 49537)
747- Fix %%post, %%postun (#49720)
748- Background efficiency improvements and hacks
749
750* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
751- Don't launch esd on each mouseover.
752
753* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
754- move first time druid patch into my "CVS outstanding" patch
755- try to really remove Help/Feedback
756- try to really fix Help/Community Support
757- try again to get Start Here in the Go menu
758- try again to get Start Here on the desktop
759- don't show file sizes for .desktop files
760
761* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
762- add newline to ends of .desktop files that were missing them
763
764* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
765- update to my latest 'cvs diff -u' (adds default
766  Start Here link, displays .directory name in sidebar)
767- include /etc/X11/* links (starthere, sysconfig, serverconfig)
768
769* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
770- Patch to remove firsttime druid and flash
771
772* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
773- add hacks for displaying desktop files
774- add hack to turn off the "unwriteable" emblem
775
776* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
777- added defattr to the files lists to be (-,root,root)
778- languified
779
780* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
781- Need to run autoheader too.
782
783* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
784- Make the fam dependency a real runtime dependency
785- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
786- Cleaned up specfile.
787
788* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
789- Change default background and rubberband color.
790- Use the sidebar tabs from the default theme
791- BuildDepend on fam-devel, depend on fam
792- Disable the eazel update pages in the first-time druid.
793- Remove the eazel logo from the first-time druid
794
795* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
796- 1.0.4, removes eazel services icon and wizard page
797- Eazel logo is still in startup wizard for now, needs fixing
798
799* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
800- fix group (s/Desktop/Desktops/) #47134
801- remove ammonite dependency
802
803* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
804- add a different default theme
805- clean up file list overspecificity a bit
806
807* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
808- move to a CVS snapshot of nautilus for now
809  (Darin is my hero for having distcheck work out of CVS)
810
811* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
812- clean up defaults a bit
813
814* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
815- New version
816
817* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
818- Added BuildRequires lines
819- Changed Source to point to ftp.gnome.org instead of just the tarball name
820- Moved %description sections closer to their %package sections
821- Moved %changelog to the end, where so that it's not in the way
822- Changed configure and make install options to allow moving of
823  libraries, includes, binaries more easily
824- Removed hard-coded paths (don't define %prefix or %docdir)
825- replace %{prefix}/bin with %{_bindir}
826- replace %{prefix}/share with %{_datadir}
827- replace %{prefix}/lib with %{_libdir}
828- replace %{prefix}/include with %{_includedir}
829
830* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
831- removed obsoletes from sub packages and added mozilla and trilobite
832subpackages
833
834* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
835- created this thing
Note: See TracBrowser for help on using the repository browser.