source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 623

Revision 623, 27.1 KB checked in by Takemikaduchi, 14 years ago (diff)

takemikaduchi fix and add spec file

Line 
1%define glib2_version 2.20.0
2%define pango_version 1.24.0
3%define gtk2_version 2.16.0
4%define libgnomeui_version 2.24.1
5%define libxml2_version 2.5.10
6%define eog_version 2.26.0
7%define desktop_file_utils_version 0.3
8%define gnome_desktop_version 2.26.0
9%define vine_menus_version 3.0
10%define gnome_menus_version 2.26.0
11%define gnome_vfs2_version 2.24.1
12%define startup_notification_version 0.5
13%define libexif_version 0.5.12
14%define gconf_version 2.28.0
15
16Name:           nautilus
17Summary:        Nautilus is a file manager for GNOME
18Summary(ja):    Nautilus - GNOME ファイルマネージャ
19Version:        2.28.4
20Release:        1%{?_dist_release}
21License:        GPLv2+
22Group:          User Interface/Desktops
23URL:            http://www.gnome.org/projects/nautilus/
24
25Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.28/%{name}-%{version}.tar.bz2
26
27# Some changes to default config
28Patch1:         nautilus-2.5.7-rhconfig.patch
29Patch3:         background-no-delay.patch
30
31# Why is this not upstream ?
32Patch6:         nautilus-2.23.5-dynamic-search.patch
33
34Patch7:         rtl-fix.patch
35
36# vine
37Patch100:       nautilus-2.8.2-vine.patch
38
39BuildRoot:      %{_tmppath}/%{name}-%{version}-root
40Requires:       gamin
41Requires:       vine-menus >= %{vine_menus_version}
42Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
43Requires:       libexif >= %{libexif_version}
44
45Requires(pre,preun,post): GConf2 >= %{gconf_version}
46Requires(post,postun): rarian-compat
47
48BuildRequires:  glib2-devel >= %{glib2_version}
49BuildRequires:  pango-devel >= %{pango_version}
50BuildRequires:  gtk2-devel >= %{gtk2_version}
51BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}
52BuildRequires:  libxml2-devel >= %{libxml2_version}
53BuildRequires:  gnome-desktop-devel >= %{gnome_desktop_version}
54BuildRequires:  gamin-devel
55BuildRequires:  intltool
56BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
57BuildRequires:  libtool >= 1.4.2-10
58BuildRequires:  automake, autoconf
59BuildRequires:  startup-notification-devel >= %{startup_notification_version}
60#BuildRequires: tracker-devel >= %{tracker_version}
61BuildRequires:  libexif-devel  >= %{libexif_version}
62BuildRequires:  unique-devel
63BuildRequires:  libtool, autoconf
64BuildRequires:  libSM-devel
65
66Obsoletes:      nautilus-extras
67Obsoletes:      nautilus-suggested
68Obsoletes:      nautilus-mozilla < 2.0
69
70
71%description
72Nautilus integrates access to files, applications, media,
73Internet-based resources and the Web. Nautilus delivers a dynamic and
74rich user experience. Nautilus is an free software project developed
75under the GNU General Public License and is a core component of the
76GNOME desktop project.
77
78%package devel
79Summary: Support for developing nautilus extensions
80License: LGPLv2+
81Group: Development/Libraries
82Requires: %{name} = %{version}-%{release}
83Requires: pkgconfig
84
85%description devel
86This package provides libraries and header files needed
87for developing nautilus extensions.
88
89%prep
90%setup -q -n %{name}-%{version}
91
92##patch3 -p1 -b .no-delay
93#%patch5 -p1 -b .selinux
94##patch6 -p1 -b .dynamic-search
95%patch7 -p1 -b .rtl-fix
96
97%patch100 -p1 -b .vine
98
99%build
100gtkdocize
101libtoolize --force --copy
102autoreconf -f -i
103CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
104%configure --disable-more-warnings --disable-update-mimedb
105
106export tagname=CC
107LANG=en_US make LIBTOOL=/usr/bin/libtool %{?_smp_mflags}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111
112export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
113export tagname=CC
114LANG=en_US %makeinstall LIBTOOL=/usr/bin/libtool
115unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
116
117## these are in desktop-backgrounds-basic
118## (uncomment when we patch the source to look in the right place)
119## /bin/rm -rf $RPM_BUILD_ROOT%{_datadir}/nautilus/patterns
120
121# make sure desktop files validate by ignoring sr@Latn
122perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
123# desktop-file-install can't handle empty OnlyShowIn correctly
124perl -pi -e 's/OnlyShowIn=;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus-folder-default-handler.desktop
125
126desktop-file-install --vendor gnome --delete-original       \
127  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
128  --add-only-show-in GNOME                                  \
129  $RPM_BUILD_ROOT%{_datadir}/applications/*
130
131perl -pi -e 's/OnlyShowIn=GNOME;/OnlyShowIn=;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus-folder-default-handler.desktop
132
133rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{la,a}
134rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
135rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
136
137mkdir -p $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-2.0
138
139%find_lang %name
140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144%post
145/sbin/ldconfig
146touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
147export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
148gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
149
150%posttrans
151%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null ||:
152gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
153scrollkeeper-update > /dev/null 2>&1 || :
154
155%pre
156if [ "$1" -gt 1 ]; then
157    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
158    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
159fi
160
161%preun
162if [ "$1" -eq 0 ]; then
163    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
164    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
165fi
166
167%postun
168/sbin/ldconfig
169if [ $1 -eq 0 ] ; then
170    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
171    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
172    scrollkeeper-update > /dev/null 2>&1 || :
173fi
174
175%files  -f %{name}.lang
176%defattr(-,root,root)
177%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
178%{_libdir}/*.so.*
179%dir %{_libdir}/nautilus
180%dir %{_libdir}/nautilus/extensions-2.0
181%{_libexecdir}/nautilus-convert-metadata
182%{_datadir}/nautilus
183%{_datadir}/pixmaps
184%{_datadir}/applications
185%{_datadir}/mime/*
186%{_datadir}/icons/hicolor/*
187%{_bindir}/*
188%{_sysconfdir}/gconf/schemas/*
189%{_mandir}/man1/*
190
191%files devel
192%defattr(-, root, root)
193%{_includedir}/nautilus
194%{_libdir}/pkgconfig/*
195%{_libdir}/*.so
196%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
197
198
199%changelog
200* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
201- new upstream release
202- add BuildRequires: libSM-devel
203
204* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
205- removed Requires: eel2
206- added %%posttrans section
207
208* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
209- new upstream release
210
211* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
212- new upstream release
213
214* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
215- new upstream release
216
217* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
218- new upstream release
219- split -devel subpackage
220
221* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
222- new upstream release
223
224* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
225- patch6 needs autoreconf
226
227* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
228- new upstream release
229
230* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
231- new upstream release
232
233* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
234- new upstream release
235- added Requires: gvfs
236
237* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
238- new upstream release
239- added Patches from FC
240  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
241  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
242  - Fix a crash in the Properties dialog while changing owner (patch from head)
243  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
244  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
245
246* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
247- new upstream release
248- dropped Patch11-13 and added Patch7-9 from Fedora
249  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
250  - Add patch from upstream to get audio preview working again
251    (#332251)
252  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
253  - Fix a crash with small fonts (#242350)
254  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
255  - Backport fixes for async thumbnail loading from svn
256
257* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
258- run autoreconf for Patch11 changes
259
260* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
261- remove tracker dependancy, Patch13 detects tracker dynamically.
262
263* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
264- add Patch13 to support user-dirs
265
266* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
267- new upstream release
268- enable tracker support
269- add BuildRequires: tracker-devel, Requires: tracker
270
271* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
272- new upstream release
273
274* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
275- add BuildRequires: gamin-devel, Requires: gamin
276- remove fam dependency (replaced by gamin)
277
278* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
279- new upsteram release
280
281* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
282- really applied Patch110...
283
284* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
285- add Patch110 to fix corruption of help option message.
286
287* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
288- new upstream release
289
290* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
291- fix typo in ja.po
292
293* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
294- update ja.po to translate patch50 related message.
295
296* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
297- add Patch50 to show progressbar on umounting
298  (ubuntu patch in Bug 313639)
299
300* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
301- new upstream release
302
303* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
304- add Patch10 to avoid background rendering delay
305
306* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
307- new upstream release
308
309* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
310- add fix-non-UTF-8-encoding.patch (patch0)
311  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
312
313* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
314- new upstream release
315
316* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
317- new upstream release
318
319* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
320- new upstream release
321
322* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
323- new upstream release
324
325* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
326- rebuild
327
328* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
329- new upstream version
330
331* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
332- new upstream version
333
334* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
335- add vine patch to change some defaults.
336  - change default zoom sine
337  - set always_use_browser
338
339* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
340- new upstream release
341
342* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
343- add Patch110 to fix libegg(egg-recent-model.c)
344  save old umask value before create ".recently-used" file.
345 
346* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
347- change default desktop font to Sans 9 (from Sans 10)
348- add patch10 to build with gtk+-2.4
349
350* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
351- new upstream release
352
353* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
354- new upstream release
355
356* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
357- add backport patch from rawhide (Patch10)
358
359* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
360- modified vine patch
361  - change default zoom level to small
362  - change desktop font to Sans 10
363
364* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
365- new upstream release
366
367* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
368- add desktop icon patch from rawhide
369
370* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
371- remove obsolete ja.po
372
373* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
374- new upstream release
375
376* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
377- new upstream release
378
379* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
380- new upstream release
381
382* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
383- update ja.po
384
385* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
386- new upstream release
387
388* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
389- new upstream release
390
391* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
392- new upstream release
393
394* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
395- new upstream release
396
397* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
398- new upstream release
399
400* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
401- new upstream release
402
403* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
404- add nautilus-cd-burner patch
405
406* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
407- new upstream release
408
409* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
410- discard scrollkeeper outputs.
411- update PreReq tags.
412
413* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
414- change icon for nautilus-file-management-properties
415- update ja.po
416
417* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
418- update ja.po
419- add translation for .desktop files.
420
421* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
422- add Requires: vine-menus
423
424* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
425- new upstream release
426
427* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
428- remove redhatize patch
429
430* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
431- rebuild to remove unneeded dependancy.
432
433* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
434- build for Vine Linux
435
436* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
437- add explicit startup-notification dependency because build system is
438  dumb
439- 2.1.3
440
441* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
442- 2.1.2
443
444* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
445- 2.0.7
446- remove patches that are upstream
447
448* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
449- Add badhack to make weblinks on desktop work
450
451* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
452- fix #70667 assertion failures
453- fix triple click patch
454
455* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
456- don't activate on double click
457
458* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
459- put button press mask in triple-click patch, maybe it will work
460- remove html-hack patch as it does nothing useful
461
462* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
463- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
464  bogus bug reports
465- add hack for HTML mime type handling in a web browser, not
466  nautilus
467
468* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
469- Updated to 2.0.6. Removed the patches I put upstream.
470- Added patch that fixes #72410
471
472* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
473- Add a simple patch so that redhat-config-packages can disable
474  the new window behavior for mounted CDs behavior.
475
476* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
477- Add patch to fix bug #70667
478
479* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
480- remove mp3
481
482* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
483- ignore the "add_to_session" preference as it only broke stuff
484- pad the left margin a bit to cope with poor word wrapping
485
486* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
487- Update to 2.0.5, remove topleft icon patch
488
489* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
490- Add patch to fix the bug where desktop icons get
491  stuck in the top left corner on startup
492
493* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
494- 2.0.4
495
496* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
497- obsolete nautilus-mozilla < 2.0 #69839
498
499* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
500- add rhconfig patch to Bluecurve theme and disable sidebar by default
501
502* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
503- drop start here files, require redhat-menus that has them
504
505* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
506- 2.0.3
507
508* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
509- build for new eel2, gail
510
511* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
512- and add the libexec components, mumble
513
514* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
515- put the components in the file list, were moved upstream
516
517* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
518- 2.0.1
519
520* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
521- Relibtoolize to fix relink problems for solib components
522- Add LANG=en_US to %makeinstall as well
523- Back out previous change, force locale to en_US to prevent UTF-8 problems
524- Add workaround for intltool-merge bug on ia64
525
526* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
527- automated rebuild
528
529* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
530- 2.0.0
531- use desktop-file-install
532- require desktop-backgrounds-basic
533
534* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
535- add wacky hack in hopes of fixing the hang-on-login thing
536
537* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
538- add build requires on new gail
539- rebuild to try to lose broken libgailutil.so.13 dependency
540
541* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
542- rebuild in different environment
543
544* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
545- 1.1.19
546
547* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
548- rebuild in different environment
549
550* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
551- really remove nautilus-devel if we are going to obsolete it
552- don't require hwbrowser
553
554* Sun May 26 2002 Tim Powers <timp@redhat.com>
555- automated rebuild
556
557* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
558- rebuild in different environment
559
560* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
561- 1.1.17
562
563* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
564- 1.1.14
565
566* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
567- require eog
568- obsolete nautilus-devel
569- fix name of schemas file in post
570
571* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
572- Update to 1.1.13
573
574* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
575- put tree view in file list
576
577* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
578- nautilus for gnome 2
579- clean up the spec file and file list a bit
580
581* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
582- merge translations
583
584* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
585- Add patch to fix trash crash
586
587* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
588- fix for metadata tmp race
589- backport thumbnail speed fix and thumbnail inf. loop fix
590
591* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
592- add some fixes from CVS version, including one for #61819 and a couple segfaults
593
594* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
595- fix thumbnails for files with future timestamp, #56862
596
597* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
598- buildrequires intltool #60633
599- apply Alex's pixbuf cache patch to save a few megs #60581
600
601* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
602- drop Milan-specific features, including png10 and ac25 patches
603- copy in 1.0.5 help component to avoid large risky patch
604- remove .la files
605- drop mozilla from ia64 again
606- remove oaf file from nautilus-mozilla that was also in the base
607  package
608
609* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
610- enable mozilla support on ia64
611
612* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
613- require Mozilla 0.9.7
614- Add patch that puts mozilla profile startup before embedding is initialized
615
616* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
617- 1.0.6, require Mozilla 0.9.6
618
619* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
620- Update to 1.0.5
621
622* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
623- Fix handling of GnomeVFSFileInfo structure (#53315)
624
625* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
626- Change handling of names on unmount to fix #52325
627
628* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
629- put nautilus-help.desktop in file list; #53109
630
631* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
632- Add po files from sources.redhat.com
633
634* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
635- Add po files from sources.redhat.com
636
637* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
638- Added patch to fix the .directory issuer
639
640* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
641- I screwed up the build yesterday, so it didn't actually contain the
642  fixes mentioned. This build should contain them.
643
644* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
645- fix bug causing 32000 stats or so in large directories,
646  should speed things up somewhat
647- fix #52104 via gruesome kdesktop-detection hack and setting
648  window type hint on our desktop window
649- fix so Start Here icon displays in sidebar
650- don't load non-local .desktop files
651
652* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
653- make Programs icon into a link, to match the other .desktop files
654- own various directories #51164
655- web page titles in Japanese, #51709
656- tree defaults to only directories #51850
657
658* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
659- make start here icon work again
660- kill some warning spew, #51661
661- cache getpwnam() results to speed things up a bit
662
663* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
664- Fix problem with missing desktop starthere.desktop file
665- New snapshot from our branch, fixes:
666  - On upgrade, icons migrated from GNOME desktop are not properly lined up
667    (#51436)
668  - icons dropped on the desktop don't end up where dropped. (#51441)
669  - Nautilus shouldn't have fam monitor read-only windows. This
670    keeps CDROMS from being unmounted until you close all
671
672    nautilus windows pointing to them. (#51442)
673  - Warnings about 'cannot statfs...' when moving items to trash.
674- Use separate start-here.desktop for panel, since the one used
675  for the root window only works from Nautilus.
676
677* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
678- Changed starthere .desktop files to be links instead
679- of spawning a new nautilus. This makes start-here:
680- much faster.
681
682* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
683- Added hwbrowser dependency
684- New snapshot, fixes the mozilla-view submit form problem
685
686* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
687- Rebuild with new xml-i18n-tools
688- fix crash in creating new desktop files
689
690* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
691- Fix up DnD code some more
692
693* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
694- Sync our CVS version; fixes some MUSTFIX
695  (the one about drawing background on startup,
696   properly translate desktop files, etc.)
697
698* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
699- Fix 64bit cleanness issue
700- Fix NULL mimetype crash
701- Disable additional_text for .desktop files
702
703* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
704- Fix unmounting devices.
705
706* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
707- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
708- mimetype sniffing.
709
710* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
711- Remove the "don't run as root" warning.
712- Remove eazel from bookmarks
713- langified (again? did someone change it?)
714
715* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
716- Apply a patch that makes nautilus dnd reset work with the latest
717- eel release.
718
719* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
720- Build on ia64 without the mozilla component.
721
722* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
723- Fix crash-on-startup showstopper
724- Fix can't-find-images bug (this one was only showing up
725  when built with debug symbols, since it was an uninitialized memory
726  read)
727
728* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
729- sync new tarball from our CVS branch,
730  fixes some drag-and-drop, changes URI scheme names,
731  etc.
732
733* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
734- Add BuildRequires (#49539, 49537)
735- Fix %%post, %%postun (#49720)
736- Background efficiency improvements and hacks
737
738* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
739- Don't launch esd on each mouseover.
740
741* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
742- move first time druid patch into my "CVS outstanding" patch
743- try to really remove Help/Feedback
744- try to really fix Help/Community Support
745- try again to get Start Here in the Go menu
746- try again to get Start Here on the desktop
747- don't show file sizes for .desktop files
748
749* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
750- add newline to ends of .desktop files that were missing them
751
752* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
753- update to my latest 'cvs diff -u' (adds default
754  Start Here link, displays .directory name in sidebar)
755- include /etc/X11/* links (starthere, sysconfig, serverconfig)
756
757* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
758- Patch to remove firsttime druid and flash
759
760* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
761- add hacks for displaying desktop files
762- add hack to turn off the "unwriteable" emblem
763
764* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
765- added defattr to the files lists to be (-,root,root)
766- languified
767
768* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
769- Need to run autoheader too.
770
771* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
772- Make the fam dependency a real runtime dependency
773- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
774- Cleaned up specfile.
775
776* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
777- Change default background and rubberband color.
778- Use the sidebar tabs from the default theme
779- BuildDepend on fam-devel, depend on fam
780- Disable the eazel update pages in the first-time druid.
781- Remove the eazel logo from the first-time druid
782
783* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
784- 1.0.4, removes eazel services icon and wizard page
785- Eazel logo is still in startup wizard for now, needs fixing
786
787* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
788- fix group (s/Desktop/Desktops/) #47134
789- remove ammonite dependency
790
791* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
792- add a different default theme
793- clean up file list overspecificity a bit
794
795* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
796- move to a CVS snapshot of nautilus for now
797  (Darin is my hero for having distcheck work out of CVS)
798
799* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
800- clean up defaults a bit
801
802* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
803- New version
804
805* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
806- Added BuildRequires lines
807- Changed Source to point to ftp.gnome.org instead of just the tarball name
808- Moved %description sections closer to their %package sections
809- Moved %changelog to the end, where so that it's not in the way
810- Changed configure and make install options to allow moving of
811  libraries, includes, binaries more easily
812- Removed hard-coded paths (don't define %prefix or %docdir)
813- replace %{prefix}/bin with %{_bindir}
814- replace %{prefix}/share with %{_datadir}
815- replace %{prefix}/lib with %{_libdir}
816- replace %{prefix}/include with %{_includedir}
817
818* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
819- removed obsoletes from sub packages and added mozilla and trilobite
820subpackages
821
822* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
823- created this thing
Note: See TracBrowser for help on using the repository browser.