source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 7978

Revision 7978, 30.3 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1%define glib2_version 2.38.0
2%define pango_version 1.36.0
3%define gtk3_version 3.10.0
4%define libxml2_version 2.9.0
5%define eog_version 3.10.0
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.10.0
8%define vine_menus_version 3.0
9%define startup_notification_version 0.10
10%define libexif_version 0.6.19
11%define tracker_version 0.16
12%define gobject_introspection_version 0.9.8
13
14Name:                   nautilus
15Summary:                Nautilus is a file manager for GNOME
16Summary(ja):    Nautilus - GNOME ファイルマネージャ
17Version:                3.10.1
18Release:                1%{?_dist_release}
19License:                GPLv2+
20Group:                  User Interface/Desktops
21URL:                    http://www.gnome.org/projects/nautilus/
22
23Vendor:                 Project Vine
24Distribution:   Vine Linux
25Packager:               Takemikaduchi
26
27Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.10/%{name}-%{version}.tar.xz
28
29# Some changes to default config
30Patch1:         nautilus-2.5.7-rhconfig.patch
31
32# vine
33Patch102:       run_in_gnome.patch
34Patch2000:      nautilus-vine-settings.patch
35
36BuildRoot:      %{_tmppath}/%{name}-%{version}-root
37Requires:       gamin
38Requires:       vine-menus >= %{vine_menus_version}
39Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
40Requires:       libexif >= %{libexif_version}
41Requires:       %{name}-libs = %{version}-%{release}
42
43BuildRequires:  intltool
44BuildRequires:  libtool >= 1.4.2-10
45BuildRequires:  automake, autoconf
46BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
47
48BuildRequires:  glib2-devel >= %{glib2_version}
49BuildRequires:  pango-devel >= %{pango_version}
50BuildRequires:  gtk3-devel >= %{gtk3_version}
51BuildRequires:  libxml2-devel >= %{libxml2_version}
52BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
53BuildRequires:  gamin-devel
54BuildRequires:  startup-notification-devel >= %{startup_notification_version}
55BuildRequires:  tracker-devel >= %{tracker_version}
56BuildRequires:  libexif-devel >= %{libexif_version}
57BuildRequires:  unique3-devel
58BuildRequires:  libnotify-devel
59BuildRequires:  libSM-devel
60BuildRequires:  exempi-devel
61BuildRequires:  tracker-devel
62BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
63BuildRequires:  gsettings-desktop-schemas
64
65Obsoletes:      nautilus-extras
66Obsoletes:      nautilus-suggested
67Obsoletes:      nautilus-mozilla < 2.0
68Obsoletes:      eel2 <= 2.24.1
69
70Provides:       eel2 <= 2.24.1
71
72
73%description
74Nautilus integrates access to files, applications, media,
75Internet-based resources and the Web. Nautilus delivers a dynamic and
76rich user experience. Nautilus is an free software project developed
77under the GNU General Public License and is a core component of the
78GNOME desktop project.
79
80%description -l ja
81Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
82リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
83豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
84のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
85プロジェクトのコア・コンポーネントです。
86
87%package devel
88Summary: Support for developing nautilus extensions
89Summary(ja): Nautilus 拡張機能開発のためのサポート
90License: LGPLv2+
91Group: Development/Libraries
92Requires: %{name}-libs = %{version}-%{release}
93Requires: pkgconfig
94
95%description devel
96This package provides libraries and header files needed
97for developing nautilus extensions.
98
99%description -l ja devel
100このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
101ヘッダファイルを提供します。
102
103%package libs
104Summary: Libraries for use in nautilus extentions
105Summary(ja): Nautilus 拡張機能で利用するライブラリ
106Group: User Interface/Desktops
107
108%description libs
109This package provides libraries required by nautilus extention
110module.
111
112%description -l ja libs
113このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
114
115%prep
116%setup -q -n %{name}-%{version}
117
118%patch102 -p1 -b .vine
119
120%patch2000 -p1 -b .vine
121
122%build
123gtkdocize
124libtoolize --force --copy
125autoreconf -f -i
126CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
127%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
128
129make %{?_smp_mflags}
130
131%install
132rm -rf $RPM_BUILD_ROOT
133
134make install DESTDIR=$RPM_BUILD_ROOT
135
136# make sure desktop files validate by ignoring sr@Latn
137perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
138# desktop-file-install can't handle empty OnlyShowIn correctly
139perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
140
141desktop-file-install --vendor gnome --delete-original       \
142  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
143  --add-only-show-in GNOME                                  \
144  $RPM_BUILD_ROOT%{_datadir}/applications/*
145
146find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
147
148%find_lang %name
149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
153%postun
154if [ $1 -eq 0 ] ; then
155    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
156fi
157
158%posttrans
159update-mime-database %{_datadir}/mime &> /dev/null ||:
160glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
161
162%post libs -p /sbin/ldconfig
163%postun libs -p /sbin/ldconfig
164
165
166%files  -f %{name}.lang
167%defattr(-,root,root)
168%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
169%dir %{_libdir}/nautilus
170%dir %{_libdir}/nautilus/extensions-3.0
171%{_libdir}/nautilus/extensions-3.0/*.so
172%{_libexecdir}/nautilus-convert-metadata
173%{_datadir}/GConf/gsettings/nautilus.convert
174%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
175%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
176%{_datadir}/dbus-1/services/org.gnome.Nautilus.SearchProvider.service
177%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
178%{_datadir}/nautilus
179%{_datadir}/applications
180%{_datadir}/mime/*
181%{_bindir}/*
182%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
183%{_datadir}/glib-2.0/schemas/
184%{_mandir}/man1/*
185
186%files devel
187%defattr(-, root, root)
188%{_includedir}/nautilus
189%{_libdir}/pkgconfig/*
190%{_libdir}/*.so
191%{_datadir}/gir-1.0
192%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
193
194%files libs
195%defattr(-, root, root)
196%{_libdir}/*.so.*
197%{_libdir}/girepository-1.0/*.typelib
198
199
200%changelog
201* Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
202- new upstream release
203
204* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
205- new upstream release
206- add Patch2000 (nautilus-vine-settings.patch)
207
208* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
209- new upstream release
210
211* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
212- new upstream release
213
214* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
215- new upstream release
216
217* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
218- new upstream release
219
220* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
221- new upstream release
222
223* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
224- new upstream release
225- remove Patch0,7
226- add BuildRequires: exempi-devel, tracker-devel
227
228* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
229- add Patch0 (nautilus-3.4.2-ja.po.patch)
230
231* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
232- new upstream release
233
234* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
235- new upstream release
236
237* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
238- added patch102 to fix autostart in other desktop environments
239  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
240
241* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
242- new upstream release
243
244* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
245- new upstream release
246
247* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
248- new upstream release
249
250* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
251- new upstream release
252
253* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
254- new upstream release
255- drop Patch101
256- change BuildRequires: gtk3-devel instread of gtk2-devel
257- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
258- change BuildRequires: unique3-devel instread of unique-devel
259- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
260
261* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
262- fixed group of libs
263- add translation of summary and description.
264- add Vendor, Distribution and Packager tags.
265
266* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
267- new upstream release
268
269* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
270- new upstream release
271
272* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
273 - new upstream release
274
275* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
276- new upstream release
277- add BuildRequires: gobject-introspection-devel
278- remove BuildRequires: libgnomeui-devel
279- add configure option (--enable-introspection=yes)
280
281* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
282- rebuild with rpm-4.8.1 for pkg-config file
283
284* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
285- split nautilus extention libraries to -libs subpackage.
286
287* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
288- new upstream release
289
290* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
291- new upstream release
292- drop Patch100
293- add Patch101
294- add Obsoletes: eel2 <= 2.24.1
295- add Provides: eel2 <= 2.24.1
296
297* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
298- new upstream release
299- add BuildRequires: libSM-devel
300
301* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
302- removed Requires: eel2
303- added %%posttrans section
304
305* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
306- new upstream release
307
308* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
309- new upstream release
310
311* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
312- new upstream release
313
314* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
315- new upstream release
316- split -devel subpackage
317
318* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
319- new upstream release
320
321* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
322- patch6 needs autoreconf
323
324* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
325- new upstream release
326
327* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
328- new upstream release
329
330* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
331- new upstream release
332- added Requires: gvfs
333
334* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
335- new upstream release
336- added Patches from FC
337  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
338  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
339  - Fix a crash in the Properties dialog while changing owner (patch from head)
340  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
341  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
342
343* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
344- new upstream release
345- dropped Patch11-13 and added Patch7-9 from Fedora
346  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
347  - Add patch from upstream to get audio preview working again
348    (#332251)
349  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
350  - Fix a crash with small fonts (#242350)
351  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
352  - Backport fixes for async thumbnail loading from svn
353
354* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
355- run autoreconf for Patch11 changes
356
357* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
358- remove tracker dependancy, Patch13 detects tracker dynamically.
359
360* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
361- add Patch13 to support user-dirs
362
363* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
364- new upstream release
365- enable tracker support
366- add BuildRequires: tracker-devel, Requires: tracker
367
368* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
369- new upstream release
370
371* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
372- add BuildRequires: gamin-devel, Requires: gamin
373- remove fam dependency (replaced by gamin)
374
375* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
376- new upsteram release
377
378* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
379- really applied Patch110...
380
381* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
382- add Patch110 to fix corruption of help option message.
383
384* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
385- new upstream release
386
387* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
388- fix typo in ja.po
389
390* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
391- update ja.po to translate patch50 related message.
392
393* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
394- add Patch50 to show progressbar on umounting
395  (ubuntu patch in Bug 313639)
396
397* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
398- new upstream release
399
400* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
401- add Patch10 to avoid background rendering delay
402
403* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
404- new upstream release
405
406* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
407- add fix-non-UTF-8-encoding.patch (patch0)
408  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
409
410* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
411- new upstream release
412
413* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
414- new upstream release
415
416* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
417- new upstream release
418
419* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
420- new upstream release
421
422* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
423- rebuild
424
425* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
426- new upstream version
427
428* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
429- new upstream version
430
431* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
432- add vine patch to change some defaults.
433  - change default zoom sine
434  - set always_use_browser
435
436* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
437- new upstream release
438
439* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
440- add Patch110 to fix libegg(egg-recent-model.c)
441  save old umask value before create ".recently-used" file.
442 
443* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
444- change default desktop font to Sans 9 (from Sans 10)
445- add patch10 to build with gtk+-2.4
446
447* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
448- new upstream release
449
450* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
451- new upstream release
452
453* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
454- add backport patch from rawhide (Patch10)
455
456* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
457- modified vine patch
458  - change default zoom level to small
459  - change desktop font to Sans 10
460
461* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
462- new upstream release
463
464* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
465- add desktop icon patch from rawhide
466
467* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
468- remove obsolete ja.po
469
470* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
471- new upstream release
472
473* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
474- new upstream release
475
476* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
477- new upstream release
478
479* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
480- update ja.po
481
482* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
483- new upstream release
484
485* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
486- new upstream release
487
488* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
489- new upstream release
490
491* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
492- new upstream release
493
494* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
495- new upstream release
496
497* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
498- new upstream release
499
500* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
501- add nautilus-cd-burner patch
502
503* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
504- new upstream release
505
506* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
507- discard scrollkeeper outputs.
508- update PreReq tags.
509
510* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
511- change icon for nautilus-file-management-properties
512- update ja.po
513
514* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
515- update ja.po
516- add translation for .desktop files.
517
518* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
519- add Requires: vine-menus
520
521* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
522- new upstream release
523
524* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
525- remove redhatize patch
526
527* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
528- rebuild to remove unneeded dependancy.
529
530* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
531- build for Vine Linux
532
533* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
534- add explicit startup-notification dependency because build system is
535  dumb
536- 2.1.3
537
538* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
539- 2.1.2
540
541* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
542- 2.0.7
543- remove patches that are upstream
544
545* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
546- Add badhack to make weblinks on desktop work
547
548* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
549- fix #70667 assertion failures
550- fix triple click patch
551
552* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
553- don't activate on double click
554
555* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
556- put button press mask in triple-click patch, maybe it will work
557- remove html-hack patch as it does nothing useful
558
559* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
560- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
561  bogus bug reports
562- add hack for HTML mime type handling in a web browser, not
563  nautilus
564
565* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
566- Updated to 2.0.6. Removed the patches I put upstream.
567- Added patch that fixes #72410
568
569* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
570- Add a simple patch so that redhat-config-packages can disable
571  the new window behavior for mounted CDs behavior.
572
573* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
574- Add patch to fix bug #70667
575
576* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
577- remove mp3
578
579* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
580- ignore the "add_to_session" preference as it only broke stuff
581- pad the left margin a bit to cope with poor word wrapping
582
583* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
584- Update to 2.0.5, remove topleft icon patch
585
586* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
587- Add patch to fix the bug where desktop icons get
588  stuck in the top left corner on startup
589
590* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
591- 2.0.4
592
593* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
594- obsolete nautilus-mozilla < 2.0 #69839
595
596* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
597- add rhconfig patch to Bluecurve theme and disable sidebar by default
598
599* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
600- drop start here files, require redhat-menus that has them
601
602* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
603- 2.0.3
604
605* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
606- build for new eel2, gail
607
608* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
609- and add the libexec components, mumble
610
611* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
612- put the components in the file list, were moved upstream
613
614* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
615- 2.0.1
616
617* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
618- Relibtoolize to fix relink problems for solib components
619- Add LANG=en_US to %makeinstall as well
620- Back out previous change, force locale to en_US to prevent UTF-8 problems
621- Add workaround for intltool-merge bug on ia64
622
623* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
624- automated rebuild
625
626* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
627- 2.0.0
628- use desktop-file-install
629- require desktop-backgrounds-basic
630
631* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
632- add wacky hack in hopes of fixing the hang-on-login thing
633
634* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
635- add build requires on new gail
636- rebuild to try to lose broken libgailutil.so.13 dependency
637
638* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
639- rebuild in different environment
640
641* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
642- 1.1.19
643
644* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
645- rebuild in different environment
646
647* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
648- really remove nautilus-devel if we are going to obsolete it
649- don't require hwbrowser
650
651* Sun May 26 2002 Tim Powers <timp@redhat.com>
652- automated rebuild
653
654* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
655- rebuild in different environment
656
657* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
658- 1.1.17
659
660* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
661- 1.1.14
662
663* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
664- require eog
665- obsolete nautilus-devel
666- fix name of schemas file in post
667
668* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
669- Update to 1.1.13
670
671* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
672- put tree view in file list
673
674* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
675- nautilus for gnome 2
676- clean up the spec file and file list a bit
677
678* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
679- merge translations
680
681* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
682- Add patch to fix trash crash
683
684* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
685- fix for metadata tmp race
686- backport thumbnail speed fix and thumbnail inf. loop fix
687
688* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
689- add some fixes from CVS version, including one for #61819 and a couple segfaults
690
691* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
692- fix thumbnails for files with future timestamp, #56862
693
694* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
695- buildrequires intltool #60633
696- apply Alex's pixbuf cache patch to save a few megs #60581
697
698* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
699- drop Milan-specific features, including png10 and ac25 patches
700- copy in 1.0.5 help component to avoid large risky patch
701- remove .la files
702- drop mozilla from ia64 again
703- remove oaf file from nautilus-mozilla that was also in the base
704  package
705
706* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
707- enable mozilla support on ia64
708
709* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
710- require Mozilla 0.9.7
711- Add patch that puts mozilla profile startup before embedding is initialized
712
713* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
714- 1.0.6, require Mozilla 0.9.6
715
716* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
717- Update to 1.0.5
718
719* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
720- Fix handling of GnomeVFSFileInfo structure (#53315)
721
722* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
723- Change handling of names on unmount to fix #52325
724
725* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
726- put nautilus-help.desktop in file list; #53109
727
728* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
729- Add po files from sources.redhat.com
730
731* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
732- Add po files from sources.redhat.com
733
734* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
735- Added patch to fix the .directory issuer
736
737* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
738- I screwed up the build yesterday, so it didn't actually contain the
739  fixes mentioned. This build should contain them.
740
741* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
742- fix bug causing 32000 stats or so in large directories,
743  should speed things up somewhat
744- fix #52104 via gruesome kdesktop-detection hack and setting
745  window type hint on our desktop window
746- fix so Start Here icon displays in sidebar
747- don't load non-local .desktop files
748
749* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
750- make Programs icon into a link, to match the other .desktop files
751- own various directories #51164
752- web page titles in Japanese, #51709
753- tree defaults to only directories #51850
754
755* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
756- make start here icon work again
757- kill some warning spew, #51661
758- cache getpwnam() results to speed things up a bit
759
760* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
761- Fix problem with missing desktop starthere.desktop file
762- New snapshot from our branch, fixes:
763  - On upgrade, icons migrated from GNOME desktop are not properly lined up
764    (#51436)
765  - icons dropped on the desktop don't end up where dropped. (#51441)
766  - Nautilus shouldn't have fam monitor read-only windows. This
767    keeps CDROMS from being unmounted until you close all
768
769    nautilus windows pointing to them. (#51442)
770  - Warnings about 'cannot statfs...' when moving items to trash.
771- Use separate start-here.desktop for panel, since the one used
772  for the root window only works from Nautilus.
773
774* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
775- Changed starthere .desktop files to be links instead
776- of spawning a new nautilus. This makes start-here:
777- much faster.
778
779* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
780- Added hwbrowser dependency
781- New snapshot, fixes the mozilla-view submit form problem
782
783* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
784- Rebuild with new xml-i18n-tools
785- fix crash in creating new desktop files
786
787* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
788- Fix up DnD code some more
789
790* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
791- Sync our CVS version; fixes some MUSTFIX
792  (the one about drawing background on startup,
793   properly translate desktop files, etc.)
794
795* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
796- Fix 64bit cleanness issue
797- Fix NULL mimetype crash
798- Disable additional_text for .desktop files
799
800* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
801- Fix unmounting devices.
802
803* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
804- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
805- mimetype sniffing.
806
807* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
808- Remove the "don't run as root" warning.
809- Remove eazel from bookmarks
810- langified (again? did someone change it?)
811
812* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
813- Apply a patch that makes nautilus dnd reset work with the latest
814- eel release.
815
816* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
817- Build on ia64 without the mozilla component.
818
819* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
820- Fix crash-on-startup showstopper
821- Fix can't-find-images bug (this one was only showing up
822  when built with debug symbols, since it was an uninitialized memory
823  read)
824
825* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
826- sync new tarball from our CVS branch,
827  fixes some drag-and-drop, changes URI scheme names,
828  etc.
829
830* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
831- Add BuildRequires (#49539, 49537)
832- Fix %%post, %%postun (#49720)
833- Background efficiency improvements and hacks
834
835* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
836- Don't launch esd on each mouseover.
837
838* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
839- move first time druid patch into my "CVS outstanding" patch
840- try to really remove Help/Feedback
841- try to really fix Help/Community Support
842- try again to get Start Here in the Go menu
843- try again to get Start Here on the desktop
844- don't show file sizes for .desktop files
845
846* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
847- add newline to ends of .desktop files that were missing them
848
849* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
850- update to my latest 'cvs diff -u' (adds default
851  Start Here link, displays .directory name in sidebar)
852- include /etc/X11/* links (starthere, sysconfig, serverconfig)
853
854* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
855- Patch to remove firsttime druid and flash
856
857* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
858- add hacks for displaying desktop files
859- add hack to turn off the "unwriteable" emblem
860
861* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
862- added defattr to the files lists to be (-,root,root)
863- languified
864
865* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
866- Need to run autoheader too.
867
868* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
869- Make the fam dependency a real runtime dependency
870- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
871- Cleaned up specfile.
872
873* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
874- Change default background and rubberband color.
875- Use the sidebar tabs from the default theme
876- BuildDepend on fam-devel, depend on fam
877- Disable the eazel update pages in the first-time druid.
878- Remove the eazel logo from the first-time druid
879
880* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
881- 1.0.4, removes eazel services icon and wizard page
882- Eazel logo is still in startup wizard for now, needs fixing
883
884* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
885- fix group (s/Desktop/Desktops/) #47134
886- remove ammonite dependency
887
888* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
889- add a different default theme
890- clean up file list overspecificity a bit
891
892* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
893- move to a CVS snapshot of nautilus for now
894  (Darin is my hero for having distcheck work out of CVS)
895
896* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
897- clean up defaults a bit
898
899* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
900- New version
901
902* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
903- Added BuildRequires lines
904- Changed Source to point to ftp.gnome.org instead of just the tarball name
905- Moved %description sections closer to their %package sections
906- Moved %changelog to the end, where so that it's not in the way
907- Changed configure and make install options to allow moving of
908  libraries, includes, binaries more easily
909- Removed hard-coded paths (don't define %prefix or %docdir)
910- replace %{prefix}/bin with %{_bindir}
911- replace %{prefix}/share with %{_datadir}
912- replace %{prefix}/lib with %{_libdir}
913- replace %{prefix}/include with %{_includedir}
914
915* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
916- removed obsoletes from sub packages and added mozilla and trilobite
917subpackages
918
919* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
920- created this thing
Note: See TracBrowser for help on using the repository browser.