source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 7938

Revision 7938, 30.2 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.10.1

Line 
1%define glib2_version 2.38.0
2%define pango_version 1.36.0
3%define gtk3_version 3.10.0
4%define libxml2_version 2.9.0
5%define eog_version 3.10.0
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.10.0
8%define vine_menus_version 3.0
9%define startup_notification_version 0.10
10%define libexif_version 0.6.19
11%define tracker_version 0.16
12%define gobject_introspection_version 0.9.8
13
14Name:                   nautilus
15Summary:                Nautilus is a file manager for GNOME
16Summary(ja):    Nautilus - GNOME ファイルマネージャ
17Version:                3.10.0
18Release:                1%{?_dist_release}
19License:                GPLv2+
20Group:                  User Interface/Desktops
21URL:                    http://www.gnome.org/projects/nautilus/
22
23Vendor:                 Project Vine
24Distribution:   Vine Linux
25Packager:               Takemikaduchi
26
27Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.10/%{name}-%{version}.tar.xz
28
29# Some changes to default config
30Patch1:         nautilus-2.5.7-rhconfig.patch
31
32# vine
33Patch102:       run_in_gnome.patch
34Patch2000:      nautilus-vine-settings.patch
35
36BuildRoot:      %{_tmppath}/%{name}-%{version}-root
37Requires:       gamin
38Requires:       vine-menus >= %{vine_menus_version}
39Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
40Requires:       libexif >= %{libexif_version}
41Requires:       %{name}-libs = %{version}-%{release}
42
43BuildRequires:  intltool
44BuildRequires:  libtool >= 1.4.2-10
45BuildRequires:  automake, autoconf
46BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
47
48BuildRequires:  glib2-devel >= %{glib2_version}
49BuildRequires:  pango-devel >= %{pango_version}
50BuildRequires:  gtk3-devel >= %{gtk3_version}
51BuildRequires:  libxml2-devel >= %{libxml2_version}
52BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
53BuildRequires:  gamin-devel
54BuildRequires:  startup-notification-devel >= %{startup_notification_version}
55BuildRequires:  tracker-devel >= %{tracker_version}
56BuildRequires:  libexif-devel >= %{libexif_version}
57BuildRequires:  unique3-devel
58BuildRequires:  libnotify-devel
59BuildRequires:  libSM-devel
60BuildRequires:  exempi-devel
61BuildRequires:  tracker-devel
62BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
63BuildRequires:  gsettings-desktop-schemas
64
65Obsoletes:      nautilus-extras
66Obsoletes:      nautilus-suggested
67Obsoletes:      nautilus-mozilla < 2.0
68Obsoletes:      eel2 <= 2.24.1
69
70Provides:       eel2 <= 2.24.1
71
72
73%description
74Nautilus integrates access to files, applications, media,
75Internet-based resources and the Web. Nautilus delivers a dynamic and
76rich user experience. Nautilus is an free software project developed
77under the GNU General Public License and is a core component of the
78GNOME desktop project.
79
80%description -l ja
81Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
82リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
83豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
84のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
85プロジェクトのコア・コンポーネントです。
86
87%package devel
88Summary: Support for developing nautilus extensions
89Summary(ja): Nautilus 拡張機能開発のためのサポート
90License: LGPLv2+
91Group: Development/Libraries
92Requires: %{name}-libs = %{version}-%{release}
93Requires: pkgconfig
94
95%description devel
96This package provides libraries and header files needed
97for developing nautilus extensions.
98
99%description -l ja devel
100このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
101ヘッダファイルを提供します。
102
103%package libs
104Summary: Libraries for use in nautilus extentions
105Summary(ja): Nautilus 拡張機能で利用するライブラリ
106Group: User Interface/Desktops
107
108%description libs
109This package provides libraries required by nautilus extention
110module.
111
112%description -l ja libs
113このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
114
115%prep
116%setup -q -n %{name}-%{version}
117
118%patch102 -p1 -b .vine
119
120%patch2000 -p1 -b .vine
121
122%build
123gtkdocize
124libtoolize --force --copy
125autoreconf -f -i
126CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
127%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
128
129make %{?_smp_mflags}
130
131%install
132rm -rf $RPM_BUILD_ROOT
133
134make install DESTDIR=$RPM_BUILD_ROOT
135
136# make sure desktop files validate by ignoring sr@Latn
137perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
138# desktop-file-install can't handle empty OnlyShowIn correctly
139perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
140
141desktop-file-install --vendor gnome --delete-original       \
142  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
143  --add-only-show-in GNOME                                  \
144  $RPM_BUILD_ROOT%{_datadir}/applications/*
145
146find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
147
148%find_lang %name
149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
153%postun
154if [ $1 -eq 0 ] ; then
155    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
156fi
157
158%posttrans
159update-mime-database %{_datadir}/mime &> /dev/null ||:
160glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
161
162%post libs -p /sbin/ldconfig
163%postun libs -p /sbin/ldconfig
164
165
166%files  -f %{name}.lang
167%defattr(-,root,root)
168%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
169%dir %{_libdir}/nautilus
170%dir %{_libdir}/nautilus/extensions-3.0
171%{_libdir}/nautilus/extensions-3.0/*.so
172%{_libexecdir}/nautilus-convert-metadata
173%{_datadir}/GConf/gsettings/nautilus.convert
174%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
175%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
176%{_datadir}/dbus-1/services/org.gnome.Nautilus.SearchProvider.service
177%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
178%{_datadir}/nautilus
179%{_datadir}/applications
180%{_datadir}/mime/*
181%{_bindir}/*
182%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
183%{_datadir}/glib-2.0/schemas/
184%{_mandir}/man1/*
185
186%files devel
187%defattr(-, root, root)
188%{_includedir}/nautilus
189%{_libdir}/pkgconfig/*
190%{_libdir}/*.so
191%{_datadir}/gir-1.0
192%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
193
194%files libs
195%defattr(-, root, root)
196%{_libdir}/*.so.*
197%{_libdir}/girepository-1.0/*.typelib
198
199
200%changelog
201* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
202- new upstream release
203- add Patch2000 (nautilus-vine-settings.patch)
204
205* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
206- new upstream release
207
208* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
209- new upstream release
210
211* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
212- new upstream release
213
214* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
215- new upstream release
216
217* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
218- new upstream release
219
220* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
221- new upstream release
222- remove Patch0,7
223- add BuildRequires: exempi-devel, tracker-devel
224
225* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
226- add Patch0 (nautilus-3.4.2-ja.po.patch)
227
228* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
229- new upstream release
230
231* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
232- new upstream release
233
234* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
235- added patch102 to fix autostart in other desktop environments
236  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
237
238* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
239- new upstream release
240
241* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
242- new upstream release
243
244* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
245- new upstream release
246
247* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
248- new upstream release
249
250* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
251- new upstream release
252- drop Patch101
253- change BuildRequires: gtk3-devel instread of gtk2-devel
254- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
255- change BuildRequires: unique3-devel instread of unique-devel
256- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
257
258* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
259- fixed group of libs
260- add translation of summary and description.
261- add Vendor, Distribution and Packager tags.
262
263* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
264- new upstream release
265
266* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
267- new upstream release
268
269* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
270 - new upstream release
271
272* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
273- new upstream release
274- add BuildRequires: gobject-introspection-devel
275- remove BuildRequires: libgnomeui-devel
276- add configure option (--enable-introspection=yes)
277
278* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
279- rebuild with rpm-4.8.1 for pkg-config file
280
281* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
282- split nautilus extention libraries to -libs subpackage.
283
284* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
285- new upstream release
286
287* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
288- new upstream release
289- drop Patch100
290- add Patch101
291- add Obsoletes: eel2 <= 2.24.1
292- add Provides: eel2 <= 2.24.1
293
294* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
295- new upstream release
296- add BuildRequires: libSM-devel
297
298* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
299- removed Requires: eel2
300- added %%posttrans section
301
302* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
303- new upstream release
304
305* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
306- new upstream release
307
308* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
309- new upstream release
310
311* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
312- new upstream release
313- split -devel subpackage
314
315* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
316- new upstream release
317
318* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
319- patch6 needs autoreconf
320
321* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
322- new upstream release
323
324* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
325- new upstream release
326
327* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
328- new upstream release
329- added Requires: gvfs
330
331* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
332- new upstream release
333- added Patches from FC
334  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
335  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
336  - Fix a crash in the Properties dialog while changing owner (patch from head)
337  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
338  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
339
340* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
341- new upstream release
342- dropped Patch11-13 and added Patch7-9 from Fedora
343  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
344  - Add patch from upstream to get audio preview working again
345    (#332251)
346  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
347  - Fix a crash with small fonts (#242350)
348  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
349  - Backport fixes for async thumbnail loading from svn
350
351* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
352- run autoreconf for Patch11 changes
353
354* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
355- remove tracker dependancy, Patch13 detects tracker dynamically.
356
357* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
358- add Patch13 to support user-dirs
359
360* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
361- new upstream release
362- enable tracker support
363- add BuildRequires: tracker-devel, Requires: tracker
364
365* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
366- new upstream release
367
368* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
369- add BuildRequires: gamin-devel, Requires: gamin
370- remove fam dependency (replaced by gamin)
371
372* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
373- new upsteram release
374
375* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
376- really applied Patch110...
377
378* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
379- add Patch110 to fix corruption of help option message.
380
381* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
382- new upstream release
383
384* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
385- fix typo in ja.po
386
387* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
388- update ja.po to translate patch50 related message.
389
390* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
391- add Patch50 to show progressbar on umounting
392  (ubuntu patch in Bug 313639)
393
394* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
395- new upstream release
396
397* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
398- add Patch10 to avoid background rendering delay
399
400* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
401- new upstream release
402
403* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
404- add fix-non-UTF-8-encoding.patch (patch0)
405  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
406
407* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
408- new upstream release
409
410* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
411- new upstream release
412
413* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
414- new upstream release
415
416* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
417- new upstream release
418
419* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
420- rebuild
421
422* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
423- new upstream version
424
425* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
426- new upstream version
427
428* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
429- add vine patch to change some defaults.
430  - change default zoom sine
431  - set always_use_browser
432
433* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
434- new upstream release
435
436* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
437- add Patch110 to fix libegg(egg-recent-model.c)
438  save old umask value before create ".recently-used" file.
439 
440* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
441- change default desktop font to Sans 9 (from Sans 10)
442- add patch10 to build with gtk+-2.4
443
444* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
445- new upstream release
446
447* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
448- new upstream release
449
450* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
451- add backport patch from rawhide (Patch10)
452
453* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
454- modified vine patch
455  - change default zoom level to small
456  - change desktop font to Sans 10
457
458* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
459- new upstream release
460
461* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
462- add desktop icon patch from rawhide
463
464* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
465- remove obsolete ja.po
466
467* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
468- new upstream release
469
470* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
471- new upstream release
472
473* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
474- new upstream release
475
476* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
477- update ja.po
478
479* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
480- new upstream release
481
482* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
483- new upstream release
484
485* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
486- new upstream release
487
488* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
489- new upstream release
490
491* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
492- new upstream release
493
494* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
495- new upstream release
496
497* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
498- add nautilus-cd-burner patch
499
500* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
501- new upstream release
502
503* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
504- discard scrollkeeper outputs.
505- update PreReq tags.
506
507* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
508- change icon for nautilus-file-management-properties
509- update ja.po
510
511* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
512- update ja.po
513- add translation for .desktop files.
514
515* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
516- add Requires: vine-menus
517
518* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
519- new upstream release
520
521* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
522- remove redhatize patch
523
524* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
525- rebuild to remove unneeded dependancy.
526
527* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
528- build for Vine Linux
529
530* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
531- add explicit startup-notification dependency because build system is
532  dumb
533- 2.1.3
534
535* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
536- 2.1.2
537
538* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
539- 2.0.7
540- remove patches that are upstream
541
542* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
543- Add badhack to make weblinks on desktop work
544
545* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
546- fix #70667 assertion failures
547- fix triple click patch
548
549* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
550- don't activate on double click
551
552* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
553- put button press mask in triple-click patch, maybe it will work
554- remove html-hack patch as it does nothing useful
555
556* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
557- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
558  bogus bug reports
559- add hack for HTML mime type handling in a web browser, not
560  nautilus
561
562* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
563- Updated to 2.0.6. Removed the patches I put upstream.
564- Added patch that fixes #72410
565
566* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
567- Add a simple patch so that redhat-config-packages can disable
568  the new window behavior for mounted CDs behavior.
569
570* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
571- Add patch to fix bug #70667
572
573* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
574- remove mp3
575
576* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
577- ignore the "add_to_session" preference as it only broke stuff
578- pad the left margin a bit to cope with poor word wrapping
579
580* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
581- Update to 2.0.5, remove topleft icon patch
582
583* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
584- Add patch to fix the bug where desktop icons get
585  stuck in the top left corner on startup
586
587* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
588- 2.0.4
589
590* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
591- obsolete nautilus-mozilla < 2.0 #69839
592
593* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
594- add rhconfig patch to Bluecurve theme and disable sidebar by default
595
596* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
597- drop start here files, require redhat-menus that has them
598
599* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
600- 2.0.3
601
602* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
603- build for new eel2, gail
604
605* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
606- and add the libexec components, mumble
607
608* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
609- put the components in the file list, were moved upstream
610
611* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
612- 2.0.1
613
614* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
615- Relibtoolize to fix relink problems for solib components
616- Add LANG=en_US to %makeinstall as well
617- Back out previous change, force locale to en_US to prevent UTF-8 problems
618- Add workaround for intltool-merge bug on ia64
619
620* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
621- automated rebuild
622
623* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
624- 2.0.0
625- use desktop-file-install
626- require desktop-backgrounds-basic
627
628* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
629- add wacky hack in hopes of fixing the hang-on-login thing
630
631* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
632- add build requires on new gail
633- rebuild to try to lose broken libgailutil.so.13 dependency
634
635* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
636- rebuild in different environment
637
638* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
639- 1.1.19
640
641* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
642- rebuild in different environment
643
644* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
645- really remove nautilus-devel if we are going to obsolete it
646- don't require hwbrowser
647
648* Sun May 26 2002 Tim Powers <timp@redhat.com>
649- automated rebuild
650
651* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
652- rebuild in different environment
653
654* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
655- 1.1.17
656
657* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
658- 1.1.14
659
660* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
661- require eog
662- obsolete nautilus-devel
663- fix name of schemas file in post
664
665* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
666- Update to 1.1.13
667
668* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
669- put tree view in file list
670
671* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
672- nautilus for gnome 2
673- clean up the spec file and file list a bit
674
675* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
676- merge translations
677
678* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
679- Add patch to fix trash crash
680
681* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
682- fix for metadata tmp race
683- backport thumbnail speed fix and thumbnail inf. loop fix
684
685* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
686- add some fixes from CVS version, including one for #61819 and a couple segfaults
687
688* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
689- fix thumbnails for files with future timestamp, #56862
690
691* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
692- buildrequires intltool #60633
693- apply Alex's pixbuf cache patch to save a few megs #60581
694
695* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
696- drop Milan-specific features, including png10 and ac25 patches
697- copy in 1.0.5 help component to avoid large risky patch
698- remove .la files
699- drop mozilla from ia64 again
700- remove oaf file from nautilus-mozilla that was also in the base
701  package
702
703* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
704- enable mozilla support on ia64
705
706* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
707- require Mozilla 0.9.7
708- Add patch that puts mozilla profile startup before embedding is initialized
709
710* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
711- 1.0.6, require Mozilla 0.9.6
712
713* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
714- Update to 1.0.5
715
716* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
717- Fix handling of GnomeVFSFileInfo structure (#53315)
718
719* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
720- Change handling of names on unmount to fix #52325
721
722* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
723- put nautilus-help.desktop in file list; #53109
724
725* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
726- Add po files from sources.redhat.com
727
728* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
729- Add po files from sources.redhat.com
730
731* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
732- Added patch to fix the .directory issuer
733
734* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
735- I screwed up the build yesterday, so it didn't actually contain the
736  fixes mentioned. This build should contain them.
737
738* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
739- fix bug causing 32000 stats or so in large directories,
740  should speed things up somewhat
741- fix #52104 via gruesome kdesktop-detection hack and setting
742  window type hint on our desktop window
743- fix so Start Here icon displays in sidebar
744- don't load non-local .desktop files
745
746* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
747- make Programs icon into a link, to match the other .desktop files
748- own various directories #51164
749- web page titles in Japanese, #51709
750- tree defaults to only directories #51850
751
752* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
753- make start here icon work again
754- kill some warning spew, #51661
755- cache getpwnam() results to speed things up a bit
756
757* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
758- Fix problem with missing desktop starthere.desktop file
759- New snapshot from our branch, fixes:
760  - On upgrade, icons migrated from GNOME desktop are not properly lined up
761    (#51436)
762  - icons dropped on the desktop don't end up where dropped. (#51441)
763  - Nautilus shouldn't have fam monitor read-only windows. This
764    keeps CDROMS from being unmounted until you close all
765
766    nautilus windows pointing to them. (#51442)
767  - Warnings about 'cannot statfs...' when moving items to trash.
768- Use separate start-here.desktop for panel, since the one used
769  for the root window only works from Nautilus.
770
771* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
772- Changed starthere .desktop files to be links instead
773- of spawning a new nautilus. This makes start-here:
774- much faster.
775
776* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
777- Added hwbrowser dependency
778- New snapshot, fixes the mozilla-view submit form problem
779
780* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
781- Rebuild with new xml-i18n-tools
782- fix crash in creating new desktop files
783
784* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
785- Fix up DnD code some more
786
787* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
788- Sync our CVS version; fixes some MUSTFIX
789  (the one about drawing background on startup,
790   properly translate desktop files, etc.)
791
792* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
793- Fix 64bit cleanness issue
794- Fix NULL mimetype crash
795- Disable additional_text for .desktop files
796
797* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
798- Fix unmounting devices.
799
800* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
801- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
802- mimetype sniffing.
803
804* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
805- Remove the "don't run as root" warning.
806- Remove eazel from bookmarks
807- langified (again? did someone change it?)
808
809* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
810- Apply a patch that makes nautilus dnd reset work with the latest
811- eel release.
812
813* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
814- Build on ia64 without the mozilla component.
815
816* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
817- Fix crash-on-startup showstopper
818- Fix can't-find-images bug (this one was only showing up
819  when built with debug symbols, since it was an uninitialized memory
820  read)
821
822* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
823- sync new tarball from our CVS branch,
824  fixes some drag-and-drop, changes URI scheme names,
825  etc.
826
827* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
828- Add BuildRequires (#49539, 49537)
829- Fix %%post, %%postun (#49720)
830- Background efficiency improvements and hacks
831
832* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
833- Don't launch esd on each mouseover.
834
835* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
836- move first time druid patch into my "CVS outstanding" patch
837- try to really remove Help/Feedback
838- try to really fix Help/Community Support
839- try again to get Start Here in the Go menu
840- try again to get Start Here on the desktop
841- don't show file sizes for .desktop files
842
843* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
844- add newline to ends of .desktop files that were missing them
845
846* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
847- update to my latest 'cvs diff -u' (adds default
848  Start Here link, displays .directory name in sidebar)
849- include /etc/X11/* links (starthere, sysconfig, serverconfig)
850
851* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
852- Patch to remove firsttime druid and flash
853
854* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
855- add hacks for displaying desktop files
856- add hack to turn off the "unwriteable" emblem
857
858* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
859- added defattr to the files lists to be (-,root,root)
860- languified
861
862* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
863- Need to run autoheader too.
864
865* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
866- Make the fam dependency a real runtime dependency
867- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
868- Cleaned up specfile.
869
870* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
871- Change default background and rubberband color.
872- Use the sidebar tabs from the default theme
873- BuildDepend on fam-devel, depend on fam
874- Disable the eazel update pages in the first-time druid.
875- Remove the eazel logo from the first-time druid
876
877* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
878- 1.0.4, removes eazel services icon and wizard page
879- Eazel logo is still in startup wizard for now, needs fixing
880
881* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
882- fix group (s/Desktop/Desktops/) #47134
883- remove ammonite dependency
884
885* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
886- add a different default theme
887- clean up file list overspecificity a bit
888
889* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
890- move to a CVS snapshot of nautilus for now
891  (Darin is my hero for having distcheck work out of CVS)
892
893* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
894- clean up defaults a bit
895
896* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
897- New version
898
899* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
900- Added BuildRequires lines
901- Changed Source to point to ftp.gnome.org instead of just the tarball name
902- Moved %description sections closer to their %package sections
903- Moved %changelog to the end, where so that it's not in the way
904- Changed configure and make install options to allow moving of
905  libraries, includes, binaries more easily
906- Removed hard-coded paths (don't define %prefix or %docdir)
907- replace %{prefix}/bin with %{_bindir}
908- replace %{prefix}/share with %{_datadir}
909- replace %{prefix}/lib with %{_libdir}
910- replace %{prefix}/include with %{_includedir}
911
912* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
913- removed obsoletes from sub packages and added mozilla and trilobite
914subpackages
915
916* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
917- created this thing
Note: See TracBrowser for help on using the repository browser.