source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 7756

Revision 7756, 30.0 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1%define glib2_version 2.36.0
2%define pango_version 1.34.0
3%define gtk3_version 3.8.0
4%define libxml2_version 2.9.0
5%define eog_version 3.8.0
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.8.0
8%define vine_menus_version 3.0
9%define startup_notification_version 0.10
10%define libexif_version 0.6.19
11%define gconf_version 2.32.0
12%define tracker_version 0.16
13%define gobject_introspection_version 0.9.8
14
15Name:                   nautilus
16Summary:                Nautilus is a file manager for GNOME
17Summary(ja):    Nautilus - GNOME ファイルマネージャ
18Version:                3.8.2
19Release:                1%{?_dist_release}
20License:                GPLv2+
21Group:                  User Interface/Desktops
22URL:                    http://www.gnome.org/projects/nautilus/
23
24Vendor:                 Project Vine
25Distribution:   Vine Linux
26Packager:               Takemikaduchi
27
28Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.8/%{name}-%{version}.tar.xz
29
30# Some changes to default config
31Patch1:         nautilus-2.5.7-rhconfig.patch
32
33# vine
34Patch102:       run_in_gnome.patch
35
36BuildRoot:      %{_tmppath}/%{name}-%{version}-root
37Requires:       gamin
38Requires:       vine-menus >= %{vine_menus_version}
39Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
40Requires:       libexif >= %{libexif_version}
41Requires:       %{name}-libs = %{version}-%{release}
42
43BuildRequires:  intltool
44BuildRequires:  libtool >= 1.4.2-10
45BuildRequires:  automake, autoconf
46BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
47
48BuildRequires:  glib2-devel >= %{glib2_version}
49BuildRequires:  pango-devel >= %{pango_version}
50BuildRequires:  gtk3-devel >= %{gtk3_version}
51BuildRequires:  libxml2-devel >= %{libxml2_version}
52BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
53BuildRequires:  gamin-devel
54BuildRequires:  startup-notification-devel >= %{startup_notification_version}
55BuildRequires:  tracker-devel >= %{tracker_version}
56BuildRequires:  libexif-devel >= %{libexif_version}
57BuildRequires:  unique3-devel
58BuildRequires:  libnotify-devel
59BuildRequires:  libSM-devel
60BuildRequires:  exempi-devel
61BuildRequires:  tracker-devel
62BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
63BuildRequires:  gsettings-desktop-schemas
64
65Obsoletes:      nautilus-extras
66Obsoletes:      nautilus-suggested
67Obsoletes:      nautilus-mozilla < 2.0
68Obsoletes:      eel2 <= 2.24.1
69
70Provides:       eel2 <= 2.24.1
71
72
73%description
74Nautilus integrates access to files, applications, media,
75Internet-based resources and the Web. Nautilus delivers a dynamic and
76rich user experience. Nautilus is an free software project developed
77under the GNU General Public License and is a core component of the
78GNOME desktop project.
79
80%description -l ja
81Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
82リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
83豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
84のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
85プロジェクトのコア・コンポーネントです。
86
87%package devel
88Summary: Support for developing nautilus extensions
89Summary(ja): Nautilus 拡張機能開発のためのサポート
90License: LGPLv2+
91Group: Development/Libraries
92Requires: %{name}-libs = %{version}-%{release}
93Requires: pkgconfig
94
95%description devel
96This package provides libraries and header files needed
97for developing nautilus extensions.
98
99%description -l ja devel
100このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
101ヘッダファイルを提供します。
102
103%package libs
104Summary: Libraries for use in nautilus extentions
105Summary(ja): Nautilus 拡張機能で利用するライブラリ
106Group: User Interface/Desktops
107
108%description libs
109This package provides libraries required by nautilus extention
110module.
111
112%description -l ja libs
113このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
114
115%prep
116%setup -q -n %{name}-%{version}
117
118%patch102 -p1 -b .vine
119
120%build
121gtkdocize
122libtoolize --force --copy
123autoreconf -f -i
124CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
125%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
126
127make %{?_smp_mflags}
128
129%install
130rm -rf $RPM_BUILD_ROOT
131
132make install DESTDIR=$RPM_BUILD_ROOT
133
134# make sure desktop files validate by ignoring sr@Latn
135perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
136# desktop-file-install can't handle empty OnlyShowIn correctly
137perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
138
139desktop-file-install --vendor gnome --delete-original       \
140  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
141  --add-only-show-in GNOME                                  \
142  $RPM_BUILD_ROOT%{_datadir}/applications/*
143
144find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
145
146%find_lang %name
147
148%clean
149rm -rf $RPM_BUILD_ROOT
150
151%postun
152if [ $1 -eq 0 ] ; then
153    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
154fi
155
156%posttrans
157update-mime-database %{_datadir}/mime &> /dev/null ||:
158glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
159
160%post libs -p /sbin/ldconfig
161%postun libs -p /sbin/ldconfig
162
163
164%files  -f %{name}.lang
165%defattr(-,root,root)
166%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
167%dir %{_libdir}/nautilus
168%dir %{_libdir}/nautilus/extensions-3.0
169%{_libdir}/nautilus/extensions-3.0/*.so
170%{_libexecdir}/nautilus-convert-metadata
171%{_datadir}/GConf/gsettings/nautilus.convert
172%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
173%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
174%{_datadir}/dbus-1/services/org.gnome.Nautilus.SearchProvider.service
175%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
176%{_datadir}/nautilus
177%{_datadir}/applications
178%{_datadir}/mime/*
179%{_bindir}/*
180%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
181%{_datadir}/glib-2.0/schemas/
182%{_mandir}/man1/*
183
184%files devel
185%defattr(-, root, root)
186%{_includedir}/nautilus
187%{_libdir}/pkgconfig/*
188%{_libdir}/*.so
189%{_datadir}/gir-1.0
190%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
191
192%files libs
193%defattr(-, root, root)
194%{_libdir}/*.so.*
195%{_libdir}/girepository-1.0/*.typelib
196
197
198%changelog
199* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
200- new upstream release
201
202* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
203- new upstream release
204
205* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
206- new upstream release
207
208* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
209- new upstream release
210
211* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
212- new upstream release
213
214* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
215- new upstream release
216- remove Patch0,7
217- add BuildRequires: exempi-devel, tracker-devel
218
219* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
220- add Patch0 (nautilus-3.4.2-ja.po.patch)
221
222* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
223- new upstream release
224
225* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
226- new upstream release
227
228* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
229- added patch102 to fix autostart in other desktop environments
230  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
231
232* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
233- new upstream release
234
235* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
236- new upstream release
237
238* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
239- new upstream release
240
241* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
242- new upstream release
243
244* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
245- new upstream release
246- drop Patch101
247- change BuildRequires: gtk3-devel instread of gtk2-devel
248- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
249- change BuildRequires: unique3-devel instread of unique-devel
250- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
251
252* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
253- fixed group of libs
254- add translation of summary and description.
255- add Vendor, Distribution and Packager tags.
256
257* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
258- new upstream release
259
260* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
261- new upstream release
262
263* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
264 - new upstream release
265
266* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
267- new upstream release
268- add BuildRequires: gobject-introspection-devel
269- remove BuildRequires: libgnomeui-devel
270- add configure option (--enable-introspection=yes)
271
272* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
273- rebuild with rpm-4.8.1 for pkg-config file
274
275* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
276- split nautilus extention libraries to -libs subpackage.
277
278* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
279- new upstream release
280
281* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
282- new upstream release
283- drop Patch100
284- add Patch101
285- add Obsoletes: eel2 <= 2.24.1
286- add Provides: eel2 <= 2.24.1
287
288* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
289- new upstream release
290- add BuildRequires: libSM-devel
291
292* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
293- removed Requires: eel2
294- added %%posttrans section
295
296* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
297- new upstream release
298
299* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
300- new upstream release
301
302* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
303- new upstream release
304
305* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
306- new upstream release
307- split -devel subpackage
308
309* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
310- new upstream release
311
312* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
313- patch6 needs autoreconf
314
315* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
316- new upstream release
317
318* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
319- new upstream release
320
321* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
322- new upstream release
323- added Requires: gvfs
324
325* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
326- new upstream release
327- added Patches from FC
328  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
329  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
330  - Fix a crash in the Properties dialog while changing owner (patch from head)
331  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
332  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
333
334* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
335- new upstream release
336- dropped Patch11-13 and added Patch7-9 from Fedora
337  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
338  - Add patch from upstream to get audio preview working again
339    (#332251)
340  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
341  - Fix a crash with small fonts (#242350)
342  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
343  - Backport fixes for async thumbnail loading from svn
344
345* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
346- run autoreconf for Patch11 changes
347
348* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
349- remove tracker dependancy, Patch13 detects tracker dynamically.
350
351* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
352- add Patch13 to support user-dirs
353
354* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
355- new upstream release
356- enable tracker support
357- add BuildRequires: tracker-devel, Requires: tracker
358
359* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
360- new upstream release
361
362* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
363- add BuildRequires: gamin-devel, Requires: gamin
364- remove fam dependency (replaced by gamin)
365
366* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
367- new upsteram release
368
369* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
370- really applied Patch110...
371
372* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
373- add Patch110 to fix corruption of help option message.
374
375* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
376- new upstream release
377
378* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
379- fix typo in ja.po
380
381* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
382- update ja.po to translate patch50 related message.
383
384* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
385- add Patch50 to show progressbar on umounting
386  (ubuntu patch in Bug 313639)
387
388* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
389- new upstream release
390
391* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
392- add Patch10 to avoid background rendering delay
393
394* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
395- new upstream release
396
397* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
398- add fix-non-UTF-8-encoding.patch (patch0)
399  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
400
401* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
402- new upstream release
403
404* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
405- new upstream release
406
407* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
408- new upstream release
409
410* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
411- new upstream release
412
413* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
414- rebuild
415
416* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
417- new upstream version
418
419* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
420- new upstream version
421
422* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
423- add vine patch to change some defaults.
424  - change default zoom sine
425  - set always_use_browser
426
427* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
428- new upstream release
429
430* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
431- add Patch110 to fix libegg(egg-recent-model.c)
432  save old umask value before create ".recently-used" file.
433 
434* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
435- change default desktop font to Sans 9 (from Sans 10)
436- add patch10 to build with gtk+-2.4
437
438* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
439- new upstream release
440
441* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
442- new upstream release
443
444* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
445- add backport patch from rawhide (Patch10)
446
447* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
448- modified vine patch
449  - change default zoom level to small
450  - change desktop font to Sans 10
451
452* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
453- new upstream release
454
455* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
456- add desktop icon patch from rawhide
457
458* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
459- remove obsolete ja.po
460
461* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
462- new upstream release
463
464* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
465- new upstream release
466
467* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
468- new upstream release
469
470* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
471- update ja.po
472
473* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
474- new upstream release
475
476* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
477- new upstream release
478
479* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
480- new upstream release
481
482* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
483- new upstream release
484
485* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
486- new upstream release
487
488* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
489- new upstream release
490
491* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
492- add nautilus-cd-burner patch
493
494* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
495- new upstream release
496
497* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
498- discard scrollkeeper outputs.
499- update PreReq tags.
500
501* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
502- change icon for nautilus-file-management-properties
503- update ja.po
504
505* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
506- update ja.po
507- add translation for .desktop files.
508
509* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
510- add Requires: vine-menus
511
512* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
513- new upstream release
514
515* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
516- remove redhatize patch
517
518* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
519- rebuild to remove unneeded dependancy.
520
521* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
522- build for Vine Linux
523
524* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
525- add explicit startup-notification dependency because build system is
526  dumb
527- 2.1.3
528
529* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
530- 2.1.2
531
532* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
533- 2.0.7
534- remove patches that are upstream
535
536* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
537- Add badhack to make weblinks on desktop work
538
539* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
540- fix #70667 assertion failures
541- fix triple click patch
542
543* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
544- don't activate on double click
545
546* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
547- put button press mask in triple-click patch, maybe it will work
548- remove html-hack patch as it does nothing useful
549
550* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
551- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
552  bogus bug reports
553- add hack for HTML mime type handling in a web browser, not
554  nautilus
555
556* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
557- Updated to 2.0.6. Removed the patches I put upstream.
558- Added patch that fixes #72410
559
560* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
561- Add a simple patch so that redhat-config-packages can disable
562  the new window behavior for mounted CDs behavior.
563
564* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
565- Add patch to fix bug #70667
566
567* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
568- remove mp3
569
570* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
571- ignore the "add_to_session" preference as it only broke stuff
572- pad the left margin a bit to cope with poor word wrapping
573
574* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
575- Update to 2.0.5, remove topleft icon patch
576
577* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
578- Add patch to fix the bug where desktop icons get
579  stuck in the top left corner on startup
580
581* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
582- 2.0.4
583
584* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
585- obsolete nautilus-mozilla < 2.0 #69839
586
587* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
588- add rhconfig patch to Bluecurve theme and disable sidebar by default
589
590* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
591- drop start here files, require redhat-menus that has them
592
593* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
594- 2.0.3
595
596* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
597- build for new eel2, gail
598
599* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
600- and add the libexec components, mumble
601
602* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
603- put the components in the file list, were moved upstream
604
605* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
606- 2.0.1
607
608* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
609- Relibtoolize to fix relink problems for solib components
610- Add LANG=en_US to %makeinstall as well
611- Back out previous change, force locale to en_US to prevent UTF-8 problems
612- Add workaround for intltool-merge bug on ia64
613
614* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
615- automated rebuild
616
617* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
618- 2.0.0
619- use desktop-file-install
620- require desktop-backgrounds-basic
621
622* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
623- add wacky hack in hopes of fixing the hang-on-login thing
624
625* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
626- add build requires on new gail
627- rebuild to try to lose broken libgailutil.so.13 dependency
628
629* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
630- rebuild in different environment
631
632* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
633- 1.1.19
634
635* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
636- rebuild in different environment
637
638* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
639- really remove nautilus-devel if we are going to obsolete it
640- don't require hwbrowser
641
642* Sun May 26 2002 Tim Powers <timp@redhat.com>
643- automated rebuild
644
645* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
646- rebuild in different environment
647
648* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
649- 1.1.17
650
651* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
652- 1.1.14
653
654* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
655- require eog
656- obsolete nautilus-devel
657- fix name of schemas file in post
658
659* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
660- Update to 1.1.13
661
662* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
663- put tree view in file list
664
665* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
666- nautilus for gnome 2
667- clean up the spec file and file list a bit
668
669* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
670- merge translations
671
672* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
673- Add patch to fix trash crash
674
675* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
676- fix for metadata tmp race
677- backport thumbnail speed fix and thumbnail inf. loop fix
678
679* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
680- add some fixes from CVS version, including one for #61819 and a couple segfaults
681
682* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
683- fix thumbnails for files with future timestamp, #56862
684
685* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
686- buildrequires intltool #60633
687- apply Alex's pixbuf cache patch to save a few megs #60581
688
689* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
690- drop Milan-specific features, including png10 and ac25 patches
691- copy in 1.0.5 help component to avoid large risky patch
692- remove .la files
693- drop mozilla from ia64 again
694- remove oaf file from nautilus-mozilla that was also in the base
695  package
696
697* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
698- enable mozilla support on ia64
699
700* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
701- require Mozilla 0.9.7
702- Add patch that puts mozilla profile startup before embedding is initialized
703
704* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
705- 1.0.6, require Mozilla 0.9.6
706
707* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
708- Update to 1.0.5
709
710* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
711- Fix handling of GnomeVFSFileInfo structure (#53315)
712
713* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
714- Change handling of names on unmount to fix #52325
715
716* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
717- put nautilus-help.desktop in file list; #53109
718
719* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
720- Add po files from sources.redhat.com
721
722* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
723- Add po files from sources.redhat.com
724
725* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
726- Added patch to fix the .directory issuer
727
728* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
729- I screwed up the build yesterday, so it didn't actually contain the
730  fixes mentioned. This build should contain them.
731
732* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
733- fix bug causing 32000 stats or so in large directories,
734  should speed things up somewhat
735- fix #52104 via gruesome kdesktop-detection hack and setting
736  window type hint on our desktop window
737- fix so Start Here icon displays in sidebar
738- don't load non-local .desktop files
739
740* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
741- make Programs icon into a link, to match the other .desktop files
742- own various directories #51164
743- web page titles in Japanese, #51709
744- tree defaults to only directories #51850
745
746* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
747- make start here icon work again
748- kill some warning spew, #51661
749- cache getpwnam() results to speed things up a bit
750
751* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
752- Fix problem with missing desktop starthere.desktop file
753- New snapshot from our branch, fixes:
754  - On upgrade, icons migrated from GNOME desktop are not properly lined up
755    (#51436)
756  - icons dropped on the desktop don't end up where dropped. (#51441)
757  - Nautilus shouldn't have fam monitor read-only windows. This
758    keeps CDROMS from being unmounted until you close all
759
760    nautilus windows pointing to them. (#51442)
761  - Warnings about 'cannot statfs...' when moving items to trash.
762- Use separate start-here.desktop for panel, since the one used
763  for the root window only works from Nautilus.
764
765* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
766- Changed starthere .desktop files to be links instead
767- of spawning a new nautilus. This makes start-here:
768- much faster.
769
770* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
771- Added hwbrowser dependency
772- New snapshot, fixes the mozilla-view submit form problem
773
774* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
775- Rebuild with new xml-i18n-tools
776- fix crash in creating new desktop files
777
778* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
779- Fix up DnD code some more
780
781* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
782- Sync our CVS version; fixes some MUSTFIX
783  (the one about drawing background on startup,
784   properly translate desktop files, etc.)
785
786* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
787- Fix 64bit cleanness issue
788- Fix NULL mimetype crash
789- Disable additional_text for .desktop files
790
791* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
792- Fix unmounting devices.
793
794* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
795- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
796- mimetype sniffing.
797
798* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
799- Remove the "don't run as root" warning.
800- Remove eazel from bookmarks
801- langified (again? did someone change it?)
802
803* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
804- Apply a patch that makes nautilus dnd reset work with the latest
805- eel release.
806
807* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
808- Build on ia64 without the mozilla component.
809
810* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
811- Fix crash-on-startup showstopper
812- Fix can't-find-images bug (this one was only showing up
813  when built with debug symbols, since it was an uninitialized memory
814  read)
815
816* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
817- sync new tarball from our CVS branch,
818  fixes some drag-and-drop, changes URI scheme names,
819  etc.
820
821* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
822- Add BuildRequires (#49539, 49537)
823- Fix %%post, %%postun (#49720)
824- Background efficiency improvements and hacks
825
826* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
827- Don't launch esd on each mouseover.
828
829* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
830- move first time druid patch into my "CVS outstanding" patch
831- try to really remove Help/Feedback
832- try to really fix Help/Community Support
833- try again to get Start Here in the Go menu
834- try again to get Start Here on the desktop
835- don't show file sizes for .desktop files
836
837* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
838- add newline to ends of .desktop files that were missing them
839
840* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
841- update to my latest 'cvs diff -u' (adds default
842  Start Here link, displays .directory name in sidebar)
843- include /etc/X11/* links (starthere, sysconfig, serverconfig)
844
845* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
846- Patch to remove firsttime druid and flash
847
848* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
849- add hacks for displaying desktop files
850- add hack to turn off the "unwriteable" emblem
851
852* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
853- added defattr to the files lists to be (-,root,root)
854- languified
855
856* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
857- Need to run autoheader too.
858
859* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
860- Make the fam dependency a real runtime dependency
861- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
862- Cleaned up specfile.
863
864* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
865- Change default background and rubberband color.
866- Use the sidebar tabs from the default theme
867- BuildDepend on fam-devel, depend on fam
868- Disable the eazel update pages in the first-time druid.
869- Remove the eazel logo from the first-time druid
870
871* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
872- 1.0.4, removes eazel services icon and wizard page
873- Eazel logo is still in startup wizard for now, needs fixing
874
875* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
876- fix group (s/Desktop/Desktops/) #47134
877- remove ammonite dependency
878
879* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
880- add a different default theme
881- clean up file list overspecificity a bit
882
883* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
884- move to a CVS snapshot of nautilus for now
885  (Darin is my hero for having distcheck work out of CVS)
886
887* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
888- clean up defaults a bit
889
890* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
891- New version
892
893* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
894- Added BuildRequires lines
895- Changed Source to point to ftp.gnome.org instead of just the tarball name
896- Moved %description sections closer to their %package sections
897- Moved %changelog to the end, where so that it's not in the way
898- Changed configure and make install options to allow moving of
899  libraries, includes, binaries more easily
900- Removed hard-coded paths (don't define %prefix or %docdir)
901- replace %{prefix}/bin with %{_bindir}
902- replace %{prefix}/share with %{_datadir}
903- replace %{prefix}/lib with %{_libdir}
904- replace %{prefix}/include with %{_includedir}
905
906* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
907- removed obsoletes from sub packages and added mozilla and trilobite
908subpackages
909
910* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
911- created this thing
Note: See TracBrowser for help on using the repository browser.