source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 6951

Revision 6951, 29.7 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.1

Line 
1%define glib2_version 2.34.0
2%define pango_version 1.32.0
3%define gtk3_version 3.6.0
4%define libxml2_version 2.9.0
5%define eog_version 3.6.0
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.6.0
8%define vine_menus_version 3.0
9%define startup_notification_version 0.10
10%define libexif_version 0.6.19
11%define gconf_version 2.32.0
12%define gobject_introspection_version 0.9.8
13
14Name:           nautilus
15Summary:        Nautilus is a file manager for GNOME
16Summary(ja):    Nautilus - GNOME ファイルマネージャ
17Version:        3.6.1
18Release:        1%{?_dist_release}
19License:        GPLv2+
20Group:          User Interface/Desktops
21URL:            http://www.gnome.org/projects/nautilus/
22
23Vendor:         Project Vine
24Distribution:   Vine Linux
25Packager:       Takemikaduchi
26
27Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.6/%{name}-%{version}.tar.xz
28
29# Some changes to default config
30Patch1:         nautilus-2.5.7-rhconfig.patch
31
32# vine
33Patch102:       run_in_gnome.patch
34
35BuildRoot:      %{_tmppath}/%{name}-%{version}-root
36Requires:       gamin
37Requires:       vine-menus >= %{vine_menus_version}
38Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
39Requires:       libexif >= %{libexif_version}
40Requires:       %{name}-libs = %{version}-%{release}
41
42BuildRequires:  intltool
43BuildRequires:  libtool >= 1.4.2-10
44BuildRequires:  automake, autoconf
45BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
46
47BuildRequires:  glib2-devel >= %{glib2_version}
48BuildRequires:  pango-devel >= %{pango_version}
49BuildRequires:  gtk3-devel >= %{gtk3_version}
50BuildRequires:  libxml2-devel >= %{libxml2_version}
51BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
52BuildRequires:  gamin-devel
53BuildRequires:  startup-notification-devel >= %{startup_notification_version}
54#BuildRequires: tracker-devel
55BuildRequires:  libexif-devel  >= %{libexif_version}
56BuildRequires:  unique3-devel
57BuildRequires:  libnotify-devel
58BuildRequires:  libSM-devel
59BuildRequires:  exempi-devel
60BuildRequires:  tracker-devel
61BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
62BuildRequires:  gsettings-desktop-schemas
63
64Obsoletes:      nautilus-extras
65Obsoletes:      nautilus-suggested
66Obsoletes:      nautilus-mozilla < 2.0
67Obsoletes:      eel2 <= 2.24.1
68
69Provides:       eel2 <= 2.24.1
70
71
72%description
73Nautilus integrates access to files, applications, media,
74Internet-based resources and the Web. Nautilus delivers a dynamic and
75rich user experience. Nautilus is an free software project developed
76under the GNU General Public License and is a core component of the
77GNOME desktop project.
78
79%description -l ja
80Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
81リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
82豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
83のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
84プロジェクトのコア・コンポーネントです。
85
86%package devel
87Summary: Support for developing nautilus extensions
88Summary(ja): Nautilus 拡張機能開発のためのサポート
89License: LGPLv2+
90Group: Development/Libraries
91Requires: %{name}-libs = %{version}-%{release}
92Requires: pkgconfig
93
94%description devel
95This package provides libraries and header files needed
96for developing nautilus extensions.
97
98%description -l ja devel
99このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
100ヘッダファイルを提供します。
101
102%package libs
103Summary: Libraries for use in nautilus extentions
104Summary(ja): Nautilus 拡張機能で利用するライブラリ
105Group: User Interface/Desktops
106
107%description libs
108This package provides libraries required by nautilus extention
109module.
110
111%description -l ja libs
112このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
113
114%prep
115%setup -q -n %{name}-%{version}
116
117%patch102 -p1 -b .vine
118
119%build
120gtkdocize
121libtoolize --force --copy
122autoreconf -f -i
123CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
124%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
125
126make %{?_smp_mflags}
127
128%install
129rm -rf $RPM_BUILD_ROOT
130
131make install DESTDIR=$RPM_BUILD_ROOT
132
133# make sure desktop files validate by ignoring sr@Latn
134perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
135# desktop-file-install can't handle empty OnlyShowIn correctly
136perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
137
138desktop-file-install --vendor gnome --delete-original       \
139  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
140  --add-only-show-in GNOME                                  \
141  $RPM_BUILD_ROOT%{_datadir}/applications/*
142
143find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
144
145%find_lang %name
146
147%clean
148rm -rf $RPM_BUILD_ROOT
149
150%postun
151if [ $1 -eq 0 ] ; then
152    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
153fi
154
155%posttrans
156update-mime-database %{_datadir}/mime &> /dev/null ||:
157glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
158
159%post libs -p /sbin/ldconfig
160%postun libs -p /sbin/ldconfig
161
162
163%files  -f %{name}.lang
164%defattr(-,root,root)
165%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
166%dir %{_libdir}/nautilus
167%dir %{_libdir}/nautilus/extensions-3.0
168%{_libdir}/nautilus/extensions-3.0/*.so
169%{_libexecdir}/nautilus-convert-metadata
170%{_libexecdir}/nautilus-shell-search-provider
171%{_datadir}/GConf/gsettings/nautilus.convert
172%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
173%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
174%{_datadir}/dbus-1/services/org.gnome.Nautilus.SearchProvider.service
175%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
176%{_datadir}/nautilus
177%{_datadir}/applications
178%{_datadir}/mime/*
179%{_bindir}/*
180%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
181%{_datadir}/glib-2.0/schemas/
182%{_mandir}/man1/*
183
184%files devel
185%defattr(-, root, root)
186%{_includedir}/nautilus
187%{_libdir}/pkgconfig/*
188%{_libdir}/*.so
189%{_datadir}/gir-1.0
190%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
191
192%files libs
193%defattr(-, root, root)
194%{_libdir}/*.so.*
195%{_libdir}/girepository-1.0/*.typelib
196
197
198%changelog
199* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
200- new upstream release
201
202* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
203- new upstream release
204- remove Patch0,7
205- add BuildRequires: exempi-devel, tracker-devel
206
207* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
208- add Patch0 (nautilus-3.4.2-ja.po.patch)
209
210* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
211- new upstream release
212
213* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
214- new upstream release
215
216* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
217- added patch102 to fix autostart in other desktop environments
218  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
219
220* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
221- new upstream release
222
223* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
224- new upstream release
225
226* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
227- new upstream release
228
229* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
230- new upstream release
231
232* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
233- new upstream release
234- drop Patch101
235- change BuildRequires: gtk3-devel instread of gtk2-devel
236- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
237- change BuildRequires: unique3-devel instread of unique-devel
238- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
239
240* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
241- fixed group of libs
242- add translation of summary and description.
243- add Vendor, Distribution and Packager tags.
244
245* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
246- new upstream release
247
248* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
249- new upstream release
250
251* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
252 - new upstream release
253
254* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
255- new upstream release
256- add BuildRequires: gobject-introspection-devel
257- remove BuildRequires: libgnomeui-devel
258- add configure option (--enable-introspection=yes)
259
260* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
261- rebuild with rpm-4.8.1 for pkg-config file
262
263* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
264- split nautilus extention libraries to -libs subpackage.
265
266* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
267- new upstream release
268
269* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
270- new upstream release
271- drop Patch100
272- add Patch101
273- add Obsoletes: eel2 <= 2.24.1
274- add Provides: eel2 <= 2.24.1
275
276* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
277- new upstream release
278- add BuildRequires: libSM-devel
279
280* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
281- removed Requires: eel2
282- added %%posttrans section
283
284* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
285- new upstream release
286
287* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
288- new upstream release
289
290* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
291- new upstream release
292
293* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
294- new upstream release
295- split -devel subpackage
296
297* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
298- new upstream release
299
300* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
301- patch6 needs autoreconf
302
303* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
304- new upstream release
305
306* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
307- new upstream release
308
309* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
310- new upstream release
311- added Requires: gvfs
312
313* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
314- new upstream release
315- added Patches from FC
316  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
317  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
318  - Fix a crash in the Properties dialog while changing owner (patch from head)
319  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
320  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
321
322* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
323- new upstream release
324- dropped Patch11-13 and added Patch7-9 from Fedora
325  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
326  - Add patch from upstream to get audio preview working again
327    (#332251)
328  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
329  - Fix a crash with small fonts (#242350)
330  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
331  - Backport fixes for async thumbnail loading from svn
332
333* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
334- run autoreconf for Patch11 changes
335
336* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
337- remove tracker dependancy, Patch13 detects tracker dynamically.
338
339* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
340- add Patch13 to support user-dirs
341
342* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
343- new upstream release
344- enable tracker support
345- add BuildRequires: tracker-devel, Requires: tracker
346
347* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
348- new upstream release
349
350* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
351- add BuildRequires: gamin-devel, Requires: gamin
352- remove fam dependency (replaced by gamin)
353
354* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
355- new upsteram release
356
357* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
358- really applied Patch110...
359
360* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
361- add Patch110 to fix corruption of help option message.
362
363* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
364- new upstream release
365
366* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
367- fix typo in ja.po
368
369* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
370- update ja.po to translate patch50 related message.
371
372* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
373- add Patch50 to show progressbar on umounting
374  (ubuntu patch in Bug 313639)
375
376* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
377- new upstream release
378
379* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
380- add Patch10 to avoid background rendering delay
381
382* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
383- new upstream release
384
385* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
386- add fix-non-UTF-8-encoding.patch (patch0)
387  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
388
389* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
390- new upstream release
391
392* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
393- new upstream release
394
395* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
396- new upstream release
397
398* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
399- new upstream release
400
401* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
402- rebuild
403
404* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
405- new upstream version
406
407* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
408- new upstream version
409
410* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
411- add vine patch to change some defaults.
412  - change default zoom sine
413  - set always_use_browser
414
415* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
416- new upstream release
417
418* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
419- add Patch110 to fix libegg(egg-recent-model.c)
420  save old umask value before create ".recently-used" file.
421 
422* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
423- change default desktop font to Sans 9 (from Sans 10)
424- add patch10 to build with gtk+-2.4
425
426* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
427- new upstream release
428
429* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
430- new upstream release
431
432* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
433- add backport patch from rawhide (Patch10)
434
435* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
436- modified vine patch
437  - change default zoom level to small
438  - change desktop font to Sans 10
439
440* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
441- new upstream release
442
443* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
444- add desktop icon patch from rawhide
445
446* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
447- remove obsolete ja.po
448
449* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
450- new upstream release
451
452* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
453- new upstream release
454
455* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
456- new upstream release
457
458* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
459- update ja.po
460
461* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
462- new upstream release
463
464* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
465- new upstream release
466
467* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
468- new upstream release
469
470* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
471- new upstream release
472
473* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
474- new upstream release
475
476* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
477- new upstream release
478
479* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
480- add nautilus-cd-burner patch
481
482* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
483- new upstream release
484
485* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
486- discard scrollkeeper outputs.
487- update PreReq tags.
488
489* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
490- change icon for nautilus-file-management-properties
491- update ja.po
492
493* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
494- update ja.po
495- add translation for .desktop files.
496
497* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
498- add Requires: vine-menus
499
500* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
501- new upstream release
502
503* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
504- remove redhatize patch
505
506* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
507- rebuild to remove unneeded dependancy.
508
509* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
510- build for Vine Linux
511
512* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
513- add explicit startup-notification dependency because build system is
514  dumb
515- 2.1.3
516
517* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
518- 2.1.2
519
520* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
521- 2.0.7
522- remove patches that are upstream
523
524* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
525- Add badhack to make weblinks on desktop work
526
527* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
528- fix #70667 assertion failures
529- fix triple click patch
530
531* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
532- don't activate on double click
533
534* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
535- put button press mask in triple-click patch, maybe it will work
536- remove html-hack patch as it does nothing useful
537
538* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
539- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
540  bogus bug reports
541- add hack for HTML mime type handling in a web browser, not
542  nautilus
543
544* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
545- Updated to 2.0.6. Removed the patches I put upstream.
546- Added patch that fixes #72410
547
548* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
549- Add a simple patch so that redhat-config-packages can disable
550  the new window behavior for mounted CDs behavior.
551
552* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
553- Add patch to fix bug #70667
554
555* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
556- remove mp3
557
558* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
559- ignore the "add_to_session" preference as it only broke stuff
560- pad the left margin a bit to cope with poor word wrapping
561
562* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
563- Update to 2.0.5, remove topleft icon patch
564
565* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
566- Add patch to fix the bug where desktop icons get
567  stuck in the top left corner on startup
568
569* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
570- 2.0.4
571
572* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
573- obsolete nautilus-mozilla < 2.0 #69839
574
575* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
576- add rhconfig patch to Bluecurve theme and disable sidebar by default
577
578* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
579- drop start here files, require redhat-menus that has them
580
581* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
582- 2.0.3
583
584* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
585- build for new eel2, gail
586
587* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
588- and add the libexec components, mumble
589
590* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
591- put the components in the file list, were moved upstream
592
593* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
594- 2.0.1
595
596* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
597- Relibtoolize to fix relink problems for solib components
598- Add LANG=en_US to %makeinstall as well
599- Back out previous change, force locale to en_US to prevent UTF-8 problems
600- Add workaround for intltool-merge bug on ia64
601
602* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
603- automated rebuild
604
605* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
606- 2.0.0
607- use desktop-file-install
608- require desktop-backgrounds-basic
609
610* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
611- add wacky hack in hopes of fixing the hang-on-login thing
612
613* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
614- add build requires on new gail
615- rebuild to try to lose broken libgailutil.so.13 dependency
616
617* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
618- rebuild in different environment
619
620* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
621- 1.1.19
622
623* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
624- rebuild in different environment
625
626* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
627- really remove nautilus-devel if we are going to obsolete it
628- don't require hwbrowser
629
630* Sun May 26 2002 Tim Powers <timp@redhat.com>
631- automated rebuild
632
633* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
634- rebuild in different environment
635
636* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
637- 1.1.17
638
639* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
640- 1.1.14
641
642* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
643- require eog
644- obsolete nautilus-devel
645- fix name of schemas file in post
646
647* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
648- Update to 1.1.13
649
650* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
651- put tree view in file list
652
653* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
654- nautilus for gnome 2
655- clean up the spec file and file list a bit
656
657* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
658- merge translations
659
660* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
661- Add patch to fix trash crash
662
663* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
664- fix for metadata tmp race
665- backport thumbnail speed fix and thumbnail inf. loop fix
666
667* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
668- add some fixes from CVS version, including one for #61819 and a couple segfaults
669
670* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
671- fix thumbnails for files with future timestamp, #56862
672
673* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
674- buildrequires intltool #60633
675- apply Alex's pixbuf cache patch to save a few megs #60581
676
677* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
678- drop Milan-specific features, including png10 and ac25 patches
679- copy in 1.0.5 help component to avoid large risky patch
680- remove .la files
681- drop mozilla from ia64 again
682- remove oaf file from nautilus-mozilla that was also in the base
683  package
684
685* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
686- enable mozilla support on ia64
687
688* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
689- require Mozilla 0.9.7
690- Add patch that puts mozilla profile startup before embedding is initialized
691
692* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
693- 1.0.6, require Mozilla 0.9.6
694
695* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
696- Update to 1.0.5
697
698* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
699- Fix handling of GnomeVFSFileInfo structure (#53315)
700
701* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
702- Change handling of names on unmount to fix #52325
703
704* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
705- put nautilus-help.desktop in file list; #53109
706
707* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
708- Add po files from sources.redhat.com
709
710* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
711- Add po files from sources.redhat.com
712
713* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
714- Added patch to fix the .directory issuer
715
716* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
717- I screwed up the build yesterday, so it didn't actually contain the
718  fixes mentioned. This build should contain them.
719
720* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
721- fix bug causing 32000 stats or so in large directories,
722  should speed things up somewhat
723- fix #52104 via gruesome kdesktop-detection hack and setting
724  window type hint on our desktop window
725- fix so Start Here icon displays in sidebar
726- don't load non-local .desktop files
727
728* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
729- make Programs icon into a link, to match the other .desktop files
730- own various directories #51164
731- web page titles in Japanese, #51709
732- tree defaults to only directories #51850
733
734* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
735- make start here icon work again
736- kill some warning spew, #51661
737- cache getpwnam() results to speed things up a bit
738
739* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
740- Fix problem with missing desktop starthere.desktop file
741- New snapshot from our branch, fixes:
742  - On upgrade, icons migrated from GNOME desktop are not properly lined up
743    (#51436)
744  - icons dropped on the desktop don't end up where dropped. (#51441)
745  - Nautilus shouldn't have fam monitor read-only windows. This
746    keeps CDROMS from being unmounted until you close all
747
748    nautilus windows pointing to them. (#51442)
749  - Warnings about 'cannot statfs...' when moving items to trash.
750- Use separate start-here.desktop for panel, since the one used
751  for the root window only works from Nautilus.
752
753* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
754- Changed starthere .desktop files to be links instead
755- of spawning a new nautilus. This makes start-here:
756- much faster.
757
758* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
759- Added hwbrowser dependency
760- New snapshot, fixes the mozilla-view submit form problem
761
762* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
763- Rebuild with new xml-i18n-tools
764- fix crash in creating new desktop files
765
766* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
767- Fix up DnD code some more
768
769* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
770- Sync our CVS version; fixes some MUSTFIX
771  (the one about drawing background on startup,
772   properly translate desktop files, etc.)
773
774* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
775- Fix 64bit cleanness issue
776- Fix NULL mimetype crash
777- Disable additional_text for .desktop files
778
779* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
780- Fix unmounting devices.
781
782* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
783- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
784- mimetype sniffing.
785
786* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
787- Remove the "don't run as root" warning.
788- Remove eazel from bookmarks
789- langified (again? did someone change it?)
790
791* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
792- Apply a patch that makes nautilus dnd reset work with the latest
793- eel release.
794
795* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
796- Build on ia64 without the mozilla component.
797
798* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
799- Fix crash-on-startup showstopper
800- Fix can't-find-images bug (this one was only showing up
801  when built with debug symbols, since it was an uninitialized memory
802  read)
803
804* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
805- sync new tarball from our CVS branch,
806  fixes some drag-and-drop, changes URI scheme names,
807  etc.
808
809* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
810- Add BuildRequires (#49539, 49537)
811- Fix %%post, %%postun (#49720)
812- Background efficiency improvements and hacks
813
814* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
815- Don't launch esd on each mouseover.
816
817* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
818- move first time druid patch into my "CVS outstanding" patch
819- try to really remove Help/Feedback
820- try to really fix Help/Community Support
821- try again to get Start Here in the Go menu
822- try again to get Start Here on the desktop
823- don't show file sizes for .desktop files
824
825* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
826- add newline to ends of .desktop files that were missing them
827
828* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
829- update to my latest 'cvs diff -u' (adds default
830  Start Here link, displays .directory name in sidebar)
831- include /etc/X11/* links (starthere, sysconfig, serverconfig)
832
833* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
834- Patch to remove firsttime druid and flash
835
836* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
837- add hacks for displaying desktop files
838- add hack to turn off the "unwriteable" emblem
839
840* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
841- added defattr to the files lists to be (-,root,root)
842- languified
843
844* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
845- Need to run autoheader too.
846
847* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
848- Make the fam dependency a real runtime dependency
849- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
850- Cleaned up specfile.
851
852* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
853- Change default background and rubberband color.
854- Use the sidebar tabs from the default theme
855- BuildDepend on fam-devel, depend on fam
856- Disable the eazel update pages in the first-time druid.
857- Remove the eazel logo from the first-time druid
858
859* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
860- 1.0.4, removes eazel services icon and wizard page
861- Eazel logo is still in startup wizard for now, needs fixing
862
863* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
864- fix group (s/Desktop/Desktops/) #47134
865- remove ammonite dependency
866
867* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
868- add a different default theme
869- clean up file list overspecificity a bit
870
871* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
872- move to a CVS snapshot of nautilus for now
873  (Darin is my hero for having distcheck work out of CVS)
874
875* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
876- clean up defaults a bit
877
878* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
879- New version
880
881* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
882- Added BuildRequires lines
883- Changed Source to point to ftp.gnome.org instead of just the tarball name
884- Moved %description sections closer to their %package sections
885- Moved %changelog to the end, where so that it's not in the way
886- Changed configure and make install options to allow moving of
887  libraries, includes, binaries more easily
888- Removed hard-coded paths (don't define %prefix or %docdir)
889- replace %{prefix}/bin with %{_bindir}
890- replace %{prefix}/share with %{_datadir}
891- replace %{prefix}/lib with %{_libdir}
892- replace %{prefix}/include with %{_includedir}
893
894* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
895- removed obsoletes from sub packages and added mozilla and trilobite
896subpackages
897
898* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
899- created this thing
Note: See TracBrowser for help on using the repository browser.