source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 6890

Revision 6890, 29.6 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1%define glib2_version 2.34.0
2%define pango_version 1.32.0
3%define gtk3_version 3.6.0
4%define libxml2_version 2.9.0
5%define eog_version 3.6.0
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.6.0
8%define vine_menus_version 3.0
9%define startup_notification_version 0.10
10%define libexif_version 0.6.19
11%define gconf_version 2.32.0
12%define gobject_introspection_version 0.9.8
13
14Name:           nautilus
15Summary:        Nautilus is a file manager for GNOME
16Summary(ja):    Nautilus - GNOME ファイルマネージャ
17Version:        3.6.0
18Release:        1%{?_dist_release}
19License:        GPLv2+
20Group:          User Interface/Desktops
21URL:            http://www.gnome.org/projects/nautilus/
22
23Vendor:         Project Vine
24Distribution:   Vine Linux
25Packager:       Takemikaduchi
26
27Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.6/%{name}-%{version}.tar.xz
28
29# Some changes to default config
30Patch1:         nautilus-2.5.7-rhconfig.patch
31
32# vine
33Patch102:       run_in_gnome.patch
34
35BuildRoot:      %{_tmppath}/%{name}-%{version}-root
36Requires:       gamin
37Requires:       vine-menus >= %{vine_menus_version}
38Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
39Requires:       libexif >= %{libexif_version}
40Requires:       %{name}-libs = %{version}-%{release}
41
42BuildRequires:  intltool
43BuildRequires:  libtool >= 1.4.2-10
44BuildRequires:  automake, autoconf
45BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
46
47BuildRequires:  glib2-devel >= %{glib2_version}
48BuildRequires:  pango-devel >= %{pango_version}
49BuildRequires:  gtk3-devel >= %{gtk3_version}
50BuildRequires:  libxml2-devel >= %{libxml2_version}
51BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
52BuildRequires:  gamin-devel
53BuildRequires:  startup-notification-devel >= %{startup_notification_version}
54#BuildRequires: tracker-devel
55BuildRequires:  libexif-devel  >= %{libexif_version}
56BuildRequires:  unique3-devel
57BuildRequires:  libnotify-devel
58BuildRequires:  libSM-devel
59BuildRequires:  exempi-devel
60BuildRequires:  tracker-devel
61BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
62BuildRequires:  gsettings-desktop-schemas
63
64Obsoletes:      nautilus-extras
65Obsoletes:      nautilus-suggested
66Obsoletes:      nautilus-mozilla < 2.0
67Obsoletes:      eel2 <= 2.24.1
68
69Provides:       eel2 <= 2.24.1
70
71
72%description
73Nautilus integrates access to files, applications, media,
74Internet-based resources and the Web. Nautilus delivers a dynamic and
75rich user experience. Nautilus is an free software project developed
76under the GNU General Public License and is a core component of the
77GNOME desktop project.
78
79%description -l ja
80Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
81リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
82豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
83のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
84プロジェクトのコア・コンポーネントです。
85
86%package devel
87Summary: Support for developing nautilus extensions
88Summary(ja): Nautilus 拡張機能開発のためのサポート
89License: LGPLv2+
90Group: Development/Libraries
91Requires: %{name}-libs = %{version}-%{release}
92Requires: pkgconfig
93
94%description devel
95This package provides libraries and header files needed
96for developing nautilus extensions.
97
98%description -l ja devel
99このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
100ヘッダファイルを提供します。
101
102%package libs
103Summary: Libraries for use in nautilus extentions
104Summary(ja): Nautilus 拡張機能で利用するライブラリ
105Group: User Interface/Desktops
106
107%description libs
108This package provides libraries required by nautilus extention
109module.
110
111%description -l ja libs
112このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
113
114%prep
115%setup -q -n %{name}-%{version}
116
117%patch102 -p1 -b .vine
118
119%build
120gtkdocize
121libtoolize --force --copy
122autoreconf -f -i
123CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
124%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
125
126make %{?_smp_mflags}
127
128%install
129rm -rf $RPM_BUILD_ROOT
130
131make install DESTDIR=$RPM_BUILD_ROOT
132
133# make sure desktop files validate by ignoring sr@Latn
134perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
135# desktop-file-install can't handle empty OnlyShowIn correctly
136perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
137
138desktop-file-install --vendor gnome --delete-original       \
139  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
140  --add-only-show-in GNOME                                  \
141  $RPM_BUILD_ROOT%{_datadir}/applications/*
142
143find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
144
145%find_lang %name
146
147%clean
148rm -rf $RPM_BUILD_ROOT
149
150%postun
151if [ $1 -eq 0 ] ; then
152    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
153fi
154
155%posttrans
156update-mime-database %{_datadir}/mime &> /dev/null ||:
157glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
158
159%post libs -p /sbin/ldconfig
160%postun libs -p /sbin/ldconfig
161
162
163%files  -f %{name}.lang
164%defattr(-,root,root)
165%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
166%dir %{_libdir}/nautilus
167%dir %{_libdir}/nautilus/extensions-3.0
168%{_libdir}/nautilus/extensions-3.0/*.so
169%{_libexecdir}/nautilus-convert-metadata
170%{_libexecdir}/nautilus-shell-search-provider
171%{_datadir}/GConf/gsettings/nautilus.convert
172%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
173%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
174%{_datadir}/dbus-1/services/org.gnome.Nautilus.SearchProvider.service
175%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
176%{_datadir}/nautilus
177%{_datadir}/applications
178%{_datadir}/mime/*
179%{_bindir}/*
180%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
181%{_datadir}/glib-2.0/schemas/
182%{_mandir}/man1/*
183
184%files devel
185%defattr(-, root, root)
186%{_includedir}/nautilus
187%{_libdir}/pkgconfig/*
188%{_libdir}/*.so
189%{_datadir}/gir-1.0
190%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
191
192%files libs
193%defattr(-, root, root)
194%{_libdir}/*.so.*
195%{_libdir}/girepository-1.0/*.typelib
196
197
198%changelog
199* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
200- new upstream release
201- remove Patch0,7
202- add BuildRequires: exempi-devel, tracker-devel
203
204* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
205- add Patch0 (nautilus-3.4.2-ja.po.patch)
206
207* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
208- new upstream release
209
210* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
211- new upstream release
212
213* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
214- added patch102 to fix autostart in other desktop environments
215  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
216
217* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
218- new upstream release
219
220* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
221- new upstream release
222
223* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
224- new upstream release
225
226* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
227- new upstream release
228
229* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
230- new upstream release
231- drop Patch101
232- change BuildRequires: gtk3-devel instread of gtk2-devel
233- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
234- change BuildRequires: unique3-devel instread of unique-devel
235- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
236
237* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
238- fixed group of libs
239- add translation of summary and description.
240- add Vendor, Distribution and Packager tags.
241
242* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
243- new upstream release
244
245* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
246- new upstream release
247
248* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
249 - new upstream release
250
251* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
252- new upstream release
253- add BuildRequires: gobject-introspection-devel
254- remove BuildRequires: libgnomeui-devel
255- add configure option (--enable-introspection=yes)
256
257* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
258- rebuild with rpm-4.8.1 for pkg-config file
259
260* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
261- split nautilus extention libraries to -libs subpackage.
262
263* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
264- new upstream release
265
266* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
267- new upstream release
268- drop Patch100
269- add Patch101
270- add Obsoletes: eel2 <= 2.24.1
271- add Provides: eel2 <= 2.24.1
272
273* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
274- new upstream release
275- add BuildRequires: libSM-devel
276
277* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
278- removed Requires: eel2
279- added %%posttrans section
280
281* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
282- new upstream release
283
284* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
285- new upstream release
286
287* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
288- new upstream release
289
290* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
291- new upstream release
292- split -devel subpackage
293
294* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
295- new upstream release
296
297* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
298- patch6 needs autoreconf
299
300* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
301- new upstream release
302
303* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
304- new upstream release
305
306* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
307- new upstream release
308- added Requires: gvfs
309
310* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
311- new upstream release
312- added Patches from FC
313  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
314  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
315  - Fix a crash in the Properties dialog while changing owner (patch from head)
316  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
317  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
318
319* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
320- new upstream release
321- dropped Patch11-13 and added Patch7-9 from Fedora
322  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
323  - Add patch from upstream to get audio preview working again
324    (#332251)
325  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
326  - Fix a crash with small fonts (#242350)
327  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
328  - Backport fixes for async thumbnail loading from svn
329
330* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
331- run autoreconf for Patch11 changes
332
333* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
334- remove tracker dependancy, Patch13 detects tracker dynamically.
335
336* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
337- add Patch13 to support user-dirs
338
339* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
340- new upstream release
341- enable tracker support
342- add BuildRequires: tracker-devel, Requires: tracker
343
344* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
345- new upstream release
346
347* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
348- add BuildRequires: gamin-devel, Requires: gamin
349- remove fam dependency (replaced by gamin)
350
351* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
352- new upsteram release
353
354* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
355- really applied Patch110...
356
357* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
358- add Patch110 to fix corruption of help option message.
359
360* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
361- new upstream release
362
363* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
364- fix typo in ja.po
365
366* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
367- update ja.po to translate patch50 related message.
368
369* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
370- add Patch50 to show progressbar on umounting
371  (ubuntu patch in Bug 313639)
372
373* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
374- new upstream release
375
376* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
377- add Patch10 to avoid background rendering delay
378
379* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
380- new upstream release
381
382* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
383- add fix-non-UTF-8-encoding.patch (patch0)
384  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
385
386* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
387- new upstream release
388
389* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
390- new upstream release
391
392* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
393- new upstream release
394
395* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
396- new upstream release
397
398* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
399- rebuild
400
401* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
402- new upstream version
403
404* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
405- new upstream version
406
407* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
408- add vine patch to change some defaults.
409  - change default zoom sine
410  - set always_use_browser
411
412* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
413- new upstream release
414
415* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
416- add Patch110 to fix libegg(egg-recent-model.c)
417  save old umask value before create ".recently-used" file.
418 
419* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
420- change default desktop font to Sans 9 (from Sans 10)
421- add patch10 to build with gtk+-2.4
422
423* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
424- new upstream release
425
426* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
427- new upstream release
428
429* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
430- add backport patch from rawhide (Patch10)
431
432* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
433- modified vine patch
434  - change default zoom level to small
435  - change desktop font to Sans 10
436
437* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
438- new upstream release
439
440* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
441- add desktop icon patch from rawhide
442
443* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
444- remove obsolete ja.po
445
446* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
447- new upstream release
448
449* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
450- new upstream release
451
452* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
453- new upstream release
454
455* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
456- update ja.po
457
458* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
459- new upstream release
460
461* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
462- new upstream release
463
464* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
465- new upstream release
466
467* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
468- new upstream release
469
470* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
471- new upstream release
472
473* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
474- new upstream release
475
476* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
477- add nautilus-cd-burner patch
478
479* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
480- new upstream release
481
482* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
483- discard scrollkeeper outputs.
484- update PreReq tags.
485
486* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
487- change icon for nautilus-file-management-properties
488- update ja.po
489
490* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
491- update ja.po
492- add translation for .desktop files.
493
494* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
495- add Requires: vine-menus
496
497* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
498- new upstream release
499
500* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
501- remove redhatize patch
502
503* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
504- rebuild to remove unneeded dependancy.
505
506* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
507- build for Vine Linux
508
509* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
510- add explicit startup-notification dependency because build system is
511  dumb
512- 2.1.3
513
514* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
515- 2.1.2
516
517* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
518- 2.0.7
519- remove patches that are upstream
520
521* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
522- Add badhack to make weblinks on desktop work
523
524* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
525- fix #70667 assertion failures
526- fix triple click patch
527
528* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
529- don't activate on double click
530
531* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
532- put button press mask in triple-click patch, maybe it will work
533- remove html-hack patch as it does nothing useful
534
535* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
536- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
537  bogus bug reports
538- add hack for HTML mime type handling in a web browser, not
539  nautilus
540
541* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
542- Updated to 2.0.6. Removed the patches I put upstream.
543- Added patch that fixes #72410
544
545* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
546- Add a simple patch so that redhat-config-packages can disable
547  the new window behavior for mounted CDs behavior.
548
549* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
550- Add patch to fix bug #70667
551
552* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
553- remove mp3
554
555* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
556- ignore the "add_to_session" preference as it only broke stuff
557- pad the left margin a bit to cope with poor word wrapping
558
559* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
560- Update to 2.0.5, remove topleft icon patch
561
562* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
563- Add patch to fix the bug where desktop icons get
564  stuck in the top left corner on startup
565
566* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
567- 2.0.4
568
569* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
570- obsolete nautilus-mozilla < 2.0 #69839
571
572* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
573- add rhconfig patch to Bluecurve theme and disable sidebar by default
574
575* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
576- drop start here files, require redhat-menus that has them
577
578* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
579- 2.0.3
580
581* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
582- build for new eel2, gail
583
584* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
585- and add the libexec components, mumble
586
587* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
588- put the components in the file list, were moved upstream
589
590* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
591- 2.0.1
592
593* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
594- Relibtoolize to fix relink problems for solib components
595- Add LANG=en_US to %makeinstall as well
596- Back out previous change, force locale to en_US to prevent UTF-8 problems
597- Add workaround for intltool-merge bug on ia64
598
599* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
600- automated rebuild
601
602* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
603- 2.0.0
604- use desktop-file-install
605- require desktop-backgrounds-basic
606
607* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
608- add wacky hack in hopes of fixing the hang-on-login thing
609
610* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
611- add build requires on new gail
612- rebuild to try to lose broken libgailutil.so.13 dependency
613
614* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
615- rebuild in different environment
616
617* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
618- 1.1.19
619
620* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
621- rebuild in different environment
622
623* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
624- really remove nautilus-devel if we are going to obsolete it
625- don't require hwbrowser
626
627* Sun May 26 2002 Tim Powers <timp@redhat.com>
628- automated rebuild
629
630* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
631- rebuild in different environment
632
633* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
634- 1.1.17
635
636* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
637- 1.1.14
638
639* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
640- require eog
641- obsolete nautilus-devel
642- fix name of schemas file in post
643
644* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
645- Update to 1.1.13
646
647* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
648- put tree view in file list
649
650* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
651- nautilus for gnome 2
652- clean up the spec file and file list a bit
653
654* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
655- merge translations
656
657* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
658- Add patch to fix trash crash
659
660* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
661- fix for metadata tmp race
662- backport thumbnail speed fix and thumbnail inf. loop fix
663
664* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
665- add some fixes from CVS version, including one for #61819 and a couple segfaults
666
667* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
668- fix thumbnails for files with future timestamp, #56862
669
670* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
671- buildrequires intltool #60633
672- apply Alex's pixbuf cache patch to save a few megs #60581
673
674* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
675- drop Milan-specific features, including png10 and ac25 patches
676- copy in 1.0.5 help component to avoid large risky patch
677- remove .la files
678- drop mozilla from ia64 again
679- remove oaf file from nautilus-mozilla that was also in the base
680  package
681
682* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
683- enable mozilla support on ia64
684
685* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
686- require Mozilla 0.9.7
687- Add patch that puts mozilla profile startup before embedding is initialized
688
689* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
690- 1.0.6, require Mozilla 0.9.6
691
692* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
693- Update to 1.0.5
694
695* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
696- Fix handling of GnomeVFSFileInfo structure (#53315)
697
698* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
699- Change handling of names on unmount to fix #52325
700
701* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
702- put nautilus-help.desktop in file list; #53109
703
704* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
705- Add po files from sources.redhat.com
706
707* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
708- Add po files from sources.redhat.com
709
710* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
711- Added patch to fix the .directory issuer
712
713* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
714- I screwed up the build yesterday, so it didn't actually contain the
715  fixes mentioned. This build should contain them.
716
717* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
718- fix bug causing 32000 stats or so in large directories,
719  should speed things up somewhat
720- fix #52104 via gruesome kdesktop-detection hack and setting
721  window type hint on our desktop window
722- fix so Start Here icon displays in sidebar
723- don't load non-local .desktop files
724
725* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
726- make Programs icon into a link, to match the other .desktop files
727- own various directories #51164
728- web page titles in Japanese, #51709
729- tree defaults to only directories #51850
730
731* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
732- make start here icon work again
733- kill some warning spew, #51661
734- cache getpwnam() results to speed things up a bit
735
736* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
737- Fix problem with missing desktop starthere.desktop file
738- New snapshot from our branch, fixes:
739  - On upgrade, icons migrated from GNOME desktop are not properly lined up
740    (#51436)
741  - icons dropped on the desktop don't end up where dropped. (#51441)
742  - Nautilus shouldn't have fam monitor read-only windows. This
743    keeps CDROMS from being unmounted until you close all
744
745    nautilus windows pointing to them. (#51442)
746  - Warnings about 'cannot statfs...' when moving items to trash.
747- Use separate start-here.desktop for panel, since the one used
748  for the root window only works from Nautilus.
749
750* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
751- Changed starthere .desktop files to be links instead
752- of spawning a new nautilus. This makes start-here:
753- much faster.
754
755* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
756- Added hwbrowser dependency
757- New snapshot, fixes the mozilla-view submit form problem
758
759* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
760- Rebuild with new xml-i18n-tools
761- fix crash in creating new desktop files
762
763* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
764- Fix up DnD code some more
765
766* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
767- Sync our CVS version; fixes some MUSTFIX
768  (the one about drawing background on startup,
769   properly translate desktop files, etc.)
770
771* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
772- Fix 64bit cleanness issue
773- Fix NULL mimetype crash
774- Disable additional_text for .desktop files
775
776* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
777- Fix unmounting devices.
778
779* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
780- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
781- mimetype sniffing.
782
783* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
784- Remove the "don't run as root" warning.
785- Remove eazel from bookmarks
786- langified (again? did someone change it?)
787
788* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
789- Apply a patch that makes nautilus dnd reset work with the latest
790- eel release.
791
792* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
793- Build on ia64 without the mozilla component.
794
795* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
796- Fix crash-on-startup showstopper
797- Fix can't-find-images bug (this one was only showing up
798  when built with debug symbols, since it was an uninitialized memory
799  read)
800
801* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
802- sync new tarball from our CVS branch,
803  fixes some drag-and-drop, changes URI scheme names,
804  etc.
805
806* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
807- Add BuildRequires (#49539, 49537)
808- Fix %%post, %%postun (#49720)
809- Background efficiency improvements and hacks
810
811* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
812- Don't launch esd on each mouseover.
813
814* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
815- move first time druid patch into my "CVS outstanding" patch
816- try to really remove Help/Feedback
817- try to really fix Help/Community Support
818- try again to get Start Here in the Go menu
819- try again to get Start Here on the desktop
820- don't show file sizes for .desktop files
821
822* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
823- add newline to ends of .desktop files that were missing them
824
825* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
826- update to my latest 'cvs diff -u' (adds default
827  Start Here link, displays .directory name in sidebar)
828- include /etc/X11/* links (starthere, sysconfig, serverconfig)
829
830* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
831- Patch to remove firsttime druid and flash
832
833* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
834- add hacks for displaying desktop files
835- add hack to turn off the "unwriteable" emblem
836
837* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
838- added defattr to the files lists to be (-,root,root)
839- languified
840
841* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
842- Need to run autoheader too.
843
844* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
845- Make the fam dependency a real runtime dependency
846- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
847- Cleaned up specfile.
848
849* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
850- Change default background and rubberband color.
851- Use the sidebar tabs from the default theme
852- BuildDepend on fam-devel, depend on fam
853- Disable the eazel update pages in the first-time druid.
854- Remove the eazel logo from the first-time druid
855
856* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
857- 1.0.4, removes eazel services icon and wizard page
858- Eazel logo is still in startup wizard for now, needs fixing
859
860* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
861- fix group (s/Desktop/Desktops/) #47134
862- remove ammonite dependency
863
864* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
865- add a different default theme
866- clean up file list overspecificity a bit
867
868* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
869- move to a CVS snapshot of nautilus for now
870  (Darin is my hero for having distcheck work out of CVS)
871
872* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
873- clean up defaults a bit
874
875* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
876- New version
877
878* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
879- Added BuildRequires lines
880- Changed Source to point to ftp.gnome.org instead of just the tarball name
881- Moved %description sections closer to their %package sections
882- Moved %changelog to the end, where so that it's not in the way
883- Changed configure and make install options to allow moving of
884  libraries, includes, binaries more easily
885- Removed hard-coded paths (don't define %prefix or %docdir)
886- replace %{prefix}/bin with %{_bindir}
887- replace %{prefix}/share with %{_datadir}
888- replace %{prefix}/lib with %{_libdir}
889- replace %{prefix}/include with %{_includedir}
890
891* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
892- removed obsoletes from sub packages and added mozilla and trilobite
893subpackages
894
895* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
896- created this thing
Note: See TracBrowser for help on using the repository browser.