source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 521

Revision 521, 27.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define glib2_version 2.20.0
2%define pango_version 1.24.0
3%define gtk2_version 2.16.0
4%define libgnomeui_version 2.24.1
5%define libxml2_version 2.5.10
6%define eog_version 2.26.0
7%define desktop_file_utils_version 0.3
8%define gnome_desktop_version 2.26.0
9%define vine_menus_version 3.0
10%define gnome_menus_version 2.26.0
11%define gnome_vfs2_version 2.24.1
12%define startup_notification_version 0.5
13%define libexif_version 0.5.12
14%define gconf_version 2.28.0
15
16Name:           nautilus
17Summary:        Nautilus is a file manager for GNOME
18Summary(ja):    Nautilus - GNOME ファイルマネージャ
19Version:        2.28.1
20Release:        2%{?_dist_release}
21License:        GPLv2+
22Group:          User Interface/Desktops
23URL:            http://www.gnome.org/projects/nautilus/
24
25Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.28/%{name}-%{version}.tar.bz2
26
27# Some changes to default config
28Patch1:         nautilus-2.5.7-rhconfig.patch
29Patch3:         background-no-delay.patch
30
31# Why is this not upstream ?
32Patch6:         nautilus-2.23.5-dynamic-search.patch
33
34Patch7:         rtl-fix.patch
35
36# vine
37Patch100:       nautilus-2.8.2-vine.patch
38
39BuildRoot:      %{_tmppath}/%{name}-%{version}-root
40Requires:       gamin
41Requires:       vine-menus >= %{vine_menus_version}
42Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
43Requires:       libexif >= %{libexif_version}
44
45Requires(pre,preun,post): GConf2 >= %{gconf_version}
46Requires(post,postun): rarian-compat
47
48BuildRequires:  glib2-devel >= %{glib2_version}
49BuildRequires:  pango-devel >= %{pango_version}
50BuildRequires:  gtk2-devel >= %{gtk2_version}
51BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}
52BuildRequires:  libxml2-devel >= %{libxml2_version}
53BuildRequires:  gnome-desktop-devel >= %{gnome_desktop_version}
54BuildRequires:  gamin-devel
55BuildRequires:  intltool
56BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
57BuildRequires:  libtool >= 1.4.2-10
58BuildRequires:  automake, autoconf
59BuildRequires:  startup-notification-devel >= %{startup_notification_version}
60#BuildRequires: tracker-devel >= %{tracker_version}
61BuildRequires:  libexif-devel  >= %{libexif_version}
62BuildRequires:  unique-devel
63BuildRequires:  libtool, autoconf
64
65Obsoletes:      nautilus-extras
66Obsoletes:      nautilus-suggested
67Obsoletes:      nautilus-mozilla < 2.0
68
69
70%description
71Nautilus integrates access to files, applications, media,
72Internet-based resources and the Web. Nautilus delivers a dynamic and
73rich user experience. Nautilus is an free software project developed
74under the GNU General Public License and is a core component of the
75GNOME desktop project.
76
77%package devel
78Summary: Support for developing nautilus extensions
79License: LGPLv2+
80Group: Development/Libraries
81Requires: %{name} = %{version}-%{release}
82Requires: pkgconfig
83
84%description devel
85This package provides libraries and header files needed
86for developing nautilus extensions.
87
88%prep
89%setup -q -n %{name}-%{version}
90
91##patch3 -p1 -b .no-delay
92#%patch5 -p1 -b .selinux
93##patch6 -p1 -b .dynamic-search
94%patch7 -p1 -b .rtl-fix
95
96%patch100 -p1 -b .vine
97
98%build
99gtkdocize
100libtoolize --force --copy
101autoreconf -f -i
102CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
103%configure --disable-more-warnings --disable-update-mimedb
104
105export tagname=CC
106LANG=en_US make LIBTOOL=/usr/bin/libtool %{?_smp_mflags}
107
108%install
109rm -rf $RPM_BUILD_ROOT
110
111export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
112export tagname=CC
113LANG=en_US %makeinstall LIBTOOL=/usr/bin/libtool
114unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
115
116## these are in desktop-backgrounds-basic
117## (uncomment when we patch the source to look in the right place)
118## /bin/rm -rf $RPM_BUILD_ROOT%{_datadir}/nautilus/patterns
119
120# make sure desktop files validate by ignoring sr@Latn
121perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
122# desktop-file-install can't handle empty OnlyShowIn correctly
123perl -pi -e 's/OnlyShowIn=;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus-folder-default-handler.desktop
124
125desktop-file-install --vendor gnome --delete-original       \
126  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
127  --add-only-show-in GNOME                                  \
128  $RPM_BUILD_ROOT%{_datadir}/applications/*
129
130perl -pi -e 's/OnlyShowIn=GNOME;/OnlyShowIn=;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus-folder-default-handler.desktop
131
132rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{la,a}
133rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
134rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
135
136mkdir -p $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-2.0
137
138%find_lang %name
139
140%clean
141rm -rf $RPM_BUILD_ROOT
142
143%post
144/sbin/ldconfig
145touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
146export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
147gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
148
149%posttrans
150%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null ||:
151gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
152scrollkeeper-update > /dev/null 2>&1 || :
153
154%pre
155if [ "$1" -gt 1 ]; then
156    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
157    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
158fi
159
160%preun
161if [ "$1" -eq 0 ]; then
162    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
163    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/apps_nautilus_preferences.schemas > /dev/null || :
164fi
165
166%postun
167/sbin/ldconfig
168if [ $1 -eq 0 ] ; then
169    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
170    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
171    scrollkeeper-update > /dev/null 2>&1 || :
172fi
173
174%files  -f %{name}.lang
175%defattr(-,root,root)
176%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
177%{_libdir}/*.so.*
178%dir %{_libdir}/nautilus
179%dir %{_libdir}/nautilus/extensions-2.0
180%{_libexecdir}/nautilus-convert-metadata
181%{_datadir}/nautilus
182%{_datadir}/pixmaps
183%{_datadir}/applications
184%{_datadir}/mime/*
185%{_datadir}/icons/hicolor/*
186%{_bindir}/*
187%{_sysconfdir}/gconf/schemas/*
188%{_mandir}/man1/*
189
190%files devel
191%defattr(-, root, root)
192%{_includedir}/nautilus
193%{_libdir}/pkgconfig/*
194%{_libdir}/*.so
195%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
196
197
198%changelog
199* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
200- removed Requires: eel2
201- added %%posttrans section
202
203* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
204- new upstream release
205
206* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
207- new upstream release
208
209* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
210- new upstream release
211
212* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
213- new upstream release
214- split -devel subpackage
215
216* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
217- new upstream release
218
219* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
220- patch6 needs autoreconf
221
222* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
223- new upstream release
224
225* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
226- new upstream release
227
228* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
229- new upstream release
230- added Requires: gvfs
231
232* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
233- new upstream release
234- added Patches from FC
235  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
236  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
237  - Fix a crash in the Properties dialog while changing owner (patch from head)
238  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
239  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
240
241* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
242- new upstream release
243- dropped Patch11-13 and added Patch7-9 from Fedora
244  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
245  - Add patch from upstream to get audio preview working again
246    (#332251)
247  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
248  - Fix a crash with small fonts (#242350)
249  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
250  - Backport fixes for async thumbnail loading from svn
251
252* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
253- run autoreconf for Patch11 changes
254
255* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
256- remove tracker dependancy, Patch13 detects tracker dynamically.
257
258* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
259- add Patch13 to support user-dirs
260
261* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
262- new upstream release
263- enable tracker support
264- add BuildRequires: tracker-devel, Requires: tracker
265
266* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
267- new upstream release
268
269* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
270- add BuildRequires: gamin-devel, Requires: gamin
271- remove fam dependency (replaced by gamin)
272
273* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
274- new upsteram release
275
276* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
277- really applied Patch110...
278
279* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
280- add Patch110 to fix corruption of help option message.
281
282* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
283- new upstream release
284
285* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
286- fix typo in ja.po
287
288* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
289- update ja.po to translate patch50 related message.
290
291* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
292- add Patch50 to show progressbar on umounting
293  (ubuntu patch in Bug 313639)
294
295* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
296- new upstream release
297
298* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
299- add Patch10 to avoid background rendering delay
300
301* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
302- new upstream release
303
304* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
305- add fix-non-UTF-8-encoding.patch (patch0)
306  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
307
308* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
309- new upstream release
310
311* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
312- new upstream release
313
314* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
315- new upstream release
316
317* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
318- new upstream release
319
320* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
321- rebuild
322
323* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
324- new upstream version
325
326* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
327- new upstream version
328
329* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
330- add vine patch to change some defaults.
331  - change default zoom sine
332  - set always_use_browser
333
334* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
335- new upstream release
336
337* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
338- add Patch110 to fix libegg(egg-recent-model.c)
339  save old umask value before create ".recently-used" file.
340 
341* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
342- change default desktop font to Sans 9 (from Sans 10)
343- add patch10 to build with gtk+-2.4
344
345* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
346- new upstream release
347
348* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
349- new upstream release
350
351* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
352- add backport patch from rawhide (Patch10)
353
354* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
355- modified vine patch
356  - change default zoom level to small
357  - change desktop font to Sans 10
358
359* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
360- new upstream release
361
362* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
363- add desktop icon patch from rawhide
364
365* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
366- remove obsolete ja.po
367
368* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
369- new upstream release
370
371* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
372- new upstream release
373
374* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
375- new upstream release
376
377* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
378- update ja.po
379
380* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
381- new upstream release
382
383* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
384- new upstream release
385
386* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
387- new upstream release
388
389* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
390- new upstream release
391
392* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
393- new upstream release
394
395* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
396- new upstream release
397
398* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
399- add nautilus-cd-burner patch
400
401* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
402- new upstream release
403
404* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
405- discard scrollkeeper outputs.
406- update PreReq tags.
407
408* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
409- change icon for nautilus-file-management-properties
410- update ja.po
411
412* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
413- update ja.po
414- add translation for .desktop files.
415
416* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
417- add Requires: vine-menus
418
419* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
420- new upstream release
421
422* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
423- remove redhatize patch
424
425* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
426- rebuild to remove unneeded dependancy.
427
428* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
429- build for Vine Linux
430
431* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
432- add explicit startup-notification dependency because build system is
433  dumb
434- 2.1.3
435
436* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
437- 2.1.2
438
439* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
440- 2.0.7
441- remove patches that are upstream
442
443* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
444- Add badhack to make weblinks on desktop work
445
446* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
447- fix #70667 assertion failures
448- fix triple click patch
449
450* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
451- don't activate on double click
452
453* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
454- put button press mask in triple-click patch, maybe it will work
455- remove html-hack patch as it does nothing useful
456
457* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
458- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
459  bogus bug reports
460- add hack for HTML mime type handling in a web browser, not
461  nautilus
462
463* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
464- Updated to 2.0.6. Removed the patches I put upstream.
465- Added patch that fixes #72410
466
467* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
468- Add a simple patch so that redhat-config-packages can disable
469  the new window behavior for mounted CDs behavior.
470
471* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
472- Add patch to fix bug #70667
473
474* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
475- remove mp3
476
477* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
478- ignore the "add_to_session" preference as it only broke stuff
479- pad the left margin a bit to cope with poor word wrapping
480
481* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
482- Update to 2.0.5, remove topleft icon patch
483
484* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
485- Add patch to fix the bug where desktop icons get
486  stuck in the top left corner on startup
487
488* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
489- 2.0.4
490
491* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
492- obsolete nautilus-mozilla < 2.0 #69839
493
494* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
495- add rhconfig patch to Bluecurve theme and disable sidebar by default
496
497* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
498- drop start here files, require redhat-menus that has them
499
500* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
501- 2.0.3
502
503* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
504- build for new eel2, gail
505
506* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
507- and add the libexec components, mumble
508
509* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
510- put the components in the file list, were moved upstream
511
512* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
513- 2.0.1
514
515* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
516- Relibtoolize to fix relink problems for solib components
517- Add LANG=en_US to %makeinstall as well
518- Back out previous change, force locale to en_US to prevent UTF-8 problems
519- Add workaround for intltool-merge bug on ia64
520
521* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
522- automated rebuild
523
524* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
525- 2.0.0
526- use desktop-file-install
527- require desktop-backgrounds-basic
528
529* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
530- add wacky hack in hopes of fixing the hang-on-login thing
531
532* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
533- add build requires on new gail
534- rebuild to try to lose broken libgailutil.so.13 dependency
535
536* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
537- rebuild in different environment
538
539* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
540- 1.1.19
541
542* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
543- rebuild in different environment
544
545* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
546- really remove nautilus-devel if we are going to obsolete it
547- don't require hwbrowser
548
549* Sun May 26 2002 Tim Powers <timp@redhat.com>
550- automated rebuild
551
552* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
553- rebuild in different environment
554
555* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
556- 1.1.17
557
558* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
559- 1.1.14
560
561* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
562- require eog
563- obsolete nautilus-devel
564- fix name of schemas file in post
565
566* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
567- Update to 1.1.13
568
569* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
570- put tree view in file list
571
572* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
573- nautilus for gnome 2
574- clean up the spec file and file list a bit
575
576* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
577- merge translations
578
579* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
580- Add patch to fix trash crash
581
582* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
583- fix for metadata tmp race
584- backport thumbnail speed fix and thumbnail inf. loop fix
585
586* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
587- add some fixes from CVS version, including one for #61819 and a couple segfaults
588
589* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
590- fix thumbnails for files with future timestamp, #56862
591
592* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
593- buildrequires intltool #60633
594- apply Alex's pixbuf cache patch to save a few megs #60581
595
596* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
597- drop Milan-specific features, including png10 and ac25 patches
598- copy in 1.0.5 help component to avoid large risky patch
599- remove .la files
600- drop mozilla from ia64 again
601- remove oaf file from nautilus-mozilla that was also in the base
602  package
603
604* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
605- enable mozilla support on ia64
606
607* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
608- require Mozilla 0.9.7
609- Add patch that puts mozilla profile startup before embedding is initialized
610
611* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
612- 1.0.6, require Mozilla 0.9.6
613
614* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
615- Update to 1.0.5
616
617* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
618- Fix handling of GnomeVFSFileInfo structure (#53315)
619
620* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
621- Change handling of names on unmount to fix #52325
622
623* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
624- put nautilus-help.desktop in file list; #53109
625
626* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
627- Add po files from sources.redhat.com
628
629* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
630- Add po files from sources.redhat.com
631
632* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
633- Added patch to fix the .directory issuer
634
635* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
636- I screwed up the build yesterday, so it didn't actually contain the
637  fixes mentioned. This build should contain them.
638
639* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
640- fix bug causing 32000 stats or so in large directories,
641  should speed things up somewhat
642- fix #52104 via gruesome kdesktop-detection hack and setting
643  window type hint on our desktop window
644- fix so Start Here icon displays in sidebar
645- don't load non-local .desktop files
646
647* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
648- make Programs icon into a link, to match the other .desktop files
649- own various directories #51164
650- web page titles in Japanese, #51709
651- tree defaults to only directories #51850
652
653* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
654- make start here icon work again
655- kill some warning spew, #51661
656- cache getpwnam() results to speed things up a bit
657
658* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
659- Fix problem with missing desktop starthere.desktop file
660- New snapshot from our branch, fixes:
661  - On upgrade, icons migrated from GNOME desktop are not properly lined up
662    (#51436)
663  - icons dropped on the desktop don't end up where dropped. (#51441)
664  - Nautilus shouldn't have fam monitor read-only windows. This
665    keeps CDROMS from being unmounted until you close all
666
667    nautilus windows pointing to them. (#51442)
668  - Warnings about 'cannot statfs...' when moving items to trash.
669- Use separate start-here.desktop for panel, since the one used
670  for the root window only works from Nautilus.
671
672* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
673- Changed starthere .desktop files to be links instead
674- of spawning a new nautilus. This makes start-here:
675- much faster.
676
677* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
678- Added hwbrowser dependency
679- New snapshot, fixes the mozilla-view submit form problem
680
681* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
682- Rebuild with new xml-i18n-tools
683- fix crash in creating new desktop files
684
685* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
686- Fix up DnD code some more
687
688* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
689- Sync our CVS version; fixes some MUSTFIX
690  (the one about drawing background on startup,
691   properly translate desktop files, etc.)
692
693* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
694- Fix 64bit cleanness issue
695- Fix NULL mimetype crash
696- Disable additional_text for .desktop files
697
698* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
699- Fix unmounting devices.
700
701* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
702- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
703- mimetype sniffing.
704
705* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
706- Remove the "don't run as root" warning.
707- Remove eazel from bookmarks
708- langified (again? did someone change it?)
709
710* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
711- Apply a patch that makes nautilus dnd reset work with the latest
712- eel release.
713
714* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
715- Build on ia64 without the mozilla component.
716
717* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
718- Fix crash-on-startup showstopper
719- Fix can't-find-images bug (this one was only showing up
720  when built with debug symbols, since it was an uninitialized memory
721  read)
722
723* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
724- sync new tarball from our CVS branch,
725  fixes some drag-and-drop, changes URI scheme names,
726  etc.
727
728* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
729- Add BuildRequires (#49539, 49537)
730- Fix %%post, %%postun (#49720)
731- Background efficiency improvements and hacks
732
733* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
734- Don't launch esd on each mouseover.
735
736* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
737- move first time druid patch into my "CVS outstanding" patch
738- try to really remove Help/Feedback
739- try to really fix Help/Community Support
740- try again to get Start Here in the Go menu
741- try again to get Start Here on the desktop
742- don't show file sizes for .desktop files
743
744* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
745- add newline to ends of .desktop files that were missing them
746
747* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
748- update to my latest 'cvs diff -u' (adds default
749  Start Here link, displays .directory name in sidebar)
750- include /etc/X11/* links (starthere, sysconfig, serverconfig)
751
752* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
753- Patch to remove firsttime druid and flash
754
755* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
756- add hacks for displaying desktop files
757- add hack to turn off the "unwriteable" emblem
758
759* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
760- added defattr to the files lists to be (-,root,root)
761- languified
762
763* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
764- Need to run autoheader too.
765
766* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
767- Make the fam dependency a real runtime dependency
768- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
769- Cleaned up specfile.
770
771* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
772- Change default background and rubberband color.
773- Use the sidebar tabs from the default theme
774- BuildDepend on fam-devel, depend on fam
775- Disable the eazel update pages in the first-time druid.
776- Remove the eazel logo from the first-time druid
777
778* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
779- 1.0.4, removes eazel services icon and wizard page
780- Eazel logo is still in startup wizard for now, needs fixing
781
782* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
783- fix group (s/Desktop/Desktops/) #47134
784- remove ammonite dependency
785
786* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
787- add a different default theme
788- clean up file list overspecificity a bit
789
790* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
791- move to a CVS snapshot of nautilus for now
792  (Darin is my hero for having distcheck work out of CVS)
793
794* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
795- clean up defaults a bit
796
797* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
798- New version
799
800* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
801- Added BuildRequires lines
802- Changed Source to point to ftp.gnome.org instead of just the tarball name
803- Moved %description sections closer to their %package sections
804- Moved %changelog to the end, where so that it's not in the way
805- Changed configure and make install options to allow moving of
806  libraries, includes, binaries more easily
807- Removed hard-coded paths (don't define %prefix or %docdir)
808- replace %{prefix}/bin with %{_bindir}
809- replace %{prefix}/share with %{_datadir}
810- replace %{prefix}/lib with %{_libdir}
811- replace %{prefix}/include with %{_includedir}
812
813* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
814- removed obsoletes from sub packages and added mozilla and trilobite
815subpackages
816
817* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
818- created this thing
Note: See TracBrowser for help on using the repository browser.