source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 5038

Revision 5038, 30.0 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2.1

Line 
1%define glib2_version 2.30.0
2%define pango_version 1.28.4
3%define gtk3_version 3.2.0
4%define libxml2_version 2.7.8
5%define eog_version 3.0.1
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.0.0
8%define vine_menus_version 3.0
9%define gnome_menus_version 2.32.0
10%define startup_notification_version 0.10
11%define libexif_version 0.6.19
12%define gconf_version 2.32.0
13%define gobject_introspection_version 0.9.8
14
15Name:           nautilus
16Summary:        Nautilus is a file manager for GNOME
17Summary(ja):    Nautilus - GNOME ファイルマネージャ
18Version:        3.2.1
19Release:        1%{?_dist_release}
20License:        GPLv2+
21Group:          User Interface/Desktops
22URL:            http://www.gnome.org/projects/nautilus/
23
24Vendor:         Project Vine
25Distribution:   Vine Linux
26Packager:       Takemikaduchi
27
28Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.2/%{name}-%{version}.tar.xz
29
30# Some changes to default config
31Patch1:         nautilus-2.5.7-rhconfig.patch
32Patch3:         background-no-delay.patch
33
34# Why is this not upstream ?
35Patch6:         nautilus-2.23.5-dynamic-search.patch
36
37Patch7:         rtl-fix.patch
38
39# vine
40Patch100:       nautilus-2.8.2-vine.patch
41Patch101:       nautilus-2.30.0-vine.patch
42
43BuildRoot:      %{_tmppath}/%{name}-%{version}-root
44Requires:       gamin
45Requires:       vine-menus >= %{vine_menus_version}
46Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
47Requires:       libexif >= %{libexif_version}
48Requires:       %{name}-libs = %{version}-%{release}
49
50Requires(pre,preun,post): GConf2 >= %{gconf_version}
51Requires(post,postun): rarian-compat
52
53BuildRequires:  intltool
54BuildRequires:  libtool >= 1.4.2-10
55BuildRequires:  automake, autoconf
56BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
57
58BuildRequires:  glib2-devel >= %{glib2_version}
59BuildRequires:  pango-devel >= %{pango_version}
60BuildRequires:  gtk3-devel >= %{gtk3_version}
61BuildRequires:  libxml2-devel >= %{libxml2_version}
62BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
63BuildRequires:  gamin-devel
64BuildRequires:  startup-notification-devel >= %{startup_notification_version}
65#BuildRequires: tracker-devel
66BuildRequires:  libexif-devel  >= %{libexif_version}
67BuildRequires:  unique3-devel
68BuildRequires:  libnotify-devel
69BuildRequires:  libSM-devel
70BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
71BuildRequires:  gsettings-desktop-schemas
72
73Obsoletes:      nautilus-extras
74Obsoletes:      nautilus-suggested
75Obsoletes:      nautilus-mozilla < 2.0
76Obsoletes:      eel2 <= 2.24.1
77
78Provides:       eel2 <= 2.24.1
79
80
81%description
82Nautilus integrates access to files, applications, media,
83Internet-based resources and the Web. Nautilus delivers a dynamic and
84rich user experience. Nautilus is an free software project developed
85under the GNU General Public License and is a core component of the
86GNOME desktop project.
87
88%description -l ja
89Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
90リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
91豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
92のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
93プロジェクトのコア・コンポーネントです。
94
95%package devel
96Summary: Support for developing nautilus extensions
97Summary(ja): Nautilus 拡張機能開発のためのサポート
98License: LGPLv2+
99Group: Development/Libraries
100Requires: %{name}-libs = %{version}-%{release}
101Requires: pkgconfig
102
103%description devel
104This package provides libraries and header files needed
105for developing nautilus extensions.
106
107%description -l ja devel
108このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
109ヘッダファイルを提供します。
110
111%package libs
112Summary: Libraries for use in nautilus extentions
113Summary(ja): Nautilus 拡張機能で利用するライブラリ
114Group: User Interface/Desktops
115
116%description libs
117This package provides libraries required by nautilus extention
118module.
119
120%description -l ja libs
121このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
122
123%prep
124%setup -q -n %{name}-%{version}
125
126##patch3 -p1 -b .no-delay
127#%patch5 -p1 -b .selinux
128##patch6 -p1 -b .dynamic-search
129%patch7 -p1 -b .rtl-fix
130
131## %patch100 -p1 -b .vine
132## %patch101 -p1 -b .vine
133
134%build
135gtkdocize
136libtoolize --force --copy
137autoreconf -f -i
138CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
139%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
140
141export tagname=CC
142LANG=en_US make LIBTOOL=/usr/bin/libtool %{?_smp_mflags}
143
144%install
145rm -rf $RPM_BUILD_ROOT
146
147export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
148export tagname=CC
149LANG=en_US make install LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT
150unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
151
152## these are in desktop-backgrounds-basic
153## (uncomment when we patch the source to look in the right place)
154## /bin/rm -rf $RPM_BUILD_ROOT%{_datadir}/nautilus/patterns
155
156# make sure desktop files validate by ignoring sr@Latn
157perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
158# desktop-file-install can't handle empty OnlyShowIn correctly
159perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
160
161desktop-file-install --vendor gnome --delete-original       \
162  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
163  --add-only-show-in GNOME                                  \
164  $RPM_BUILD_ROOT%{_datadir}/applications/*
165
166rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
167rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
168
169# mkdir -p $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-3.0
170rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-3.0/*.{la,a}
171
172%find_lang %name
173
174%clean
175rm -rf $RPM_BUILD_ROOT
176
177%post
178/sbin/ldconfig
179touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
180
181%posttrans
182%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null ||:
183gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
184scrollkeeper-update > /dev/null 2>&1 || :
185glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
186
187
188%postun
189/sbin/ldconfig
190if [ $1 -eq 0 ] ; then
191    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
192    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
193    scrollkeeper-update > /dev/null 2>&1 || :
194    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
195fi
196
197%files  -f %{name}.lang
198%defattr(-,root,root)
199%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
200%dir %{_libdir}/nautilus
201%dir %{_libdir}/nautilus/extensions-3.0
202%{_libdir}/nautilus/extensions-3.0/*.so
203%{_libexecdir}/nautilus-convert-metadata
204%{_datadir}/GConf/gsettings/nautilus.convert
205%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
206%{_datadir}/nautilus
207%{_datadir}/pixmaps
208%{_datadir}/applications
209%{_datadir}/mime/*
210%{_datadir}/icons/hicolor/*
211%{_bindir}/*
212%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
213%{_datadir}/glib-2.0/schemas/
214%{_mandir}/man1/*
215
216%files devel
217%defattr(-, root, root)
218%{_includedir}/nautilus
219%{_libdir}/pkgconfig/*
220%{_libdir}/*.so
221%{_datadir}/gir-1.0
222%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
223
224%files libs
225%defattr(-, root, root)
226%{_libdir}/*.so.*
227%{_libdir}/girepository-1.0
228
229
230%changelog
231* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
232- new upstream release
233
234* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
235- new upstream release
236
237* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
238- new upstream release
239
240* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
241- new upstream release
242
243* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
244- new upstream release
245- drop Patch101
246- change BuildRequires: gtk3-devel instread of gtk2-devel
247- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
248- change BuildRequires: unique3-devel instread of unique-devel
249- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
250
251* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
252- fixed group of libs
253- add translation of summary and description.
254- add Vendor, Distribution and Packager tags.
255
256* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
257- new upstream release
258
259* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
260- new upstream release
261
262* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
263 - new upstream release
264
265* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
266- new upstream release
267- add BuildRequires: gobject-introspection-devel
268- remove BuildRequires: libgnomeui-devel
269- add configure option (--enable-introspection=yes)
270
271* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
272- rebuild with rpm-4.8.1 for pkg-config file
273
274* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
275- split nautilus extention libraries to -libs subpackage.
276
277* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
278- new upstream release
279
280* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
281- new upstream release
282- drop Patch100
283- add Patch101
284- add Obsoletes: eel2 <= 2.24.1
285- add Provides: eel2 <= 2.24.1
286
287* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
288- new upstream release
289- add BuildRequires: libSM-devel
290
291* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
292- removed Requires: eel2
293- added %%posttrans section
294
295* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
296- new upstream release
297
298* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
299- new upstream release
300
301* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
302- new upstream release
303
304* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
305- new upstream release
306- split -devel subpackage
307
308* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
309- new upstream release
310
311* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
312- patch6 needs autoreconf
313
314* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
315- new upstream release
316
317* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
318- new upstream release
319
320* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
321- new upstream release
322- added Requires: gvfs
323
324* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
325- new upstream release
326- added Patches from FC
327  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
328  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
329  - Fix a crash in the Properties dialog while changing owner (patch from head)
330  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
331  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
332
333* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
334- new upstream release
335- dropped Patch11-13 and added Patch7-9 from Fedora
336  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
337  - Add patch from upstream to get audio preview working again
338    (#332251)
339  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
340  - Fix a crash with small fonts (#242350)
341  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
342  - Backport fixes for async thumbnail loading from svn
343
344* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
345- run autoreconf for Patch11 changes
346
347* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
348- remove tracker dependancy, Patch13 detects tracker dynamically.
349
350* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
351- add Patch13 to support user-dirs
352
353* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
354- new upstream release
355- enable tracker support
356- add BuildRequires: tracker-devel, Requires: tracker
357
358* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
359- new upstream release
360
361* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
362- add BuildRequires: gamin-devel, Requires: gamin
363- remove fam dependency (replaced by gamin)
364
365* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
366- new upsteram release
367
368* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
369- really applied Patch110...
370
371* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
372- add Patch110 to fix corruption of help option message.
373
374* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
375- new upstream release
376
377* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
378- fix typo in ja.po
379
380* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
381- update ja.po to translate patch50 related message.
382
383* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
384- add Patch50 to show progressbar on umounting
385  (ubuntu patch in Bug 313639)
386
387* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
388- new upstream release
389
390* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
391- add Patch10 to avoid background rendering delay
392
393* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
394- new upstream release
395
396* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
397- add fix-non-UTF-8-encoding.patch (patch0)
398  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
399
400* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
401- new upstream release
402
403* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
404- new upstream release
405
406* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
407- new upstream release
408
409* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
410- new upstream release
411
412* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
413- rebuild
414
415* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
416- new upstream version
417
418* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
419- new upstream version
420
421* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
422- add vine patch to change some defaults.
423  - change default zoom sine
424  - set always_use_browser
425
426* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
427- new upstream release
428
429* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
430- add Patch110 to fix libegg(egg-recent-model.c)
431  save old umask value before create ".recently-used" file.
432 
433* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
434- change default desktop font to Sans 9 (from Sans 10)
435- add patch10 to build with gtk+-2.4
436
437* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
438- new upstream release
439
440* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
441- new upstream release
442
443* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
444- add backport patch from rawhide (Patch10)
445
446* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
447- modified vine patch
448  - change default zoom level to small
449  - change desktop font to Sans 10
450
451* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
452- new upstream release
453
454* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
455- add desktop icon patch from rawhide
456
457* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
458- remove obsolete ja.po
459
460* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
461- new upstream release
462
463* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
464- new upstream release
465
466* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
467- new upstream release
468
469* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
470- update ja.po
471
472* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
473- new upstream release
474
475* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
476- new upstream release
477
478* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
479- new upstream release
480
481* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
482- new upstream release
483
484* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
485- new upstream release
486
487* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
488- new upstream release
489
490* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
491- add nautilus-cd-burner patch
492
493* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
494- new upstream release
495
496* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
497- discard scrollkeeper outputs.
498- update PreReq tags.
499
500* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
501- change icon for nautilus-file-management-properties
502- update ja.po
503
504* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
505- update ja.po
506- add translation for .desktop files.
507
508* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
509- add Requires: vine-menus
510
511* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
512- new upstream release
513
514* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
515- remove redhatize patch
516
517* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
518- rebuild to remove unneeded dependancy.
519
520* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
521- build for Vine Linux
522
523* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
524- add explicit startup-notification dependency because build system is
525  dumb
526- 2.1.3
527
528* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
529- 2.1.2
530
531* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
532- 2.0.7
533- remove patches that are upstream
534
535* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
536- Add badhack to make weblinks on desktop work
537
538* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
539- fix #70667 assertion failures
540- fix triple click patch
541
542* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
543- don't activate on double click
544
545* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
546- put button press mask in triple-click patch, maybe it will work
547- remove html-hack patch as it does nothing useful
548
549* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
550- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
551  bogus bug reports
552- add hack for HTML mime type handling in a web browser, not
553  nautilus
554
555* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
556- Updated to 2.0.6. Removed the patches I put upstream.
557- Added patch that fixes #72410
558
559* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
560- Add a simple patch so that redhat-config-packages can disable
561  the new window behavior for mounted CDs behavior.
562
563* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
564- Add patch to fix bug #70667
565
566* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
567- remove mp3
568
569* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
570- ignore the "add_to_session" preference as it only broke stuff
571- pad the left margin a bit to cope with poor word wrapping
572
573* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
574- Update to 2.0.5, remove topleft icon patch
575
576* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
577- Add patch to fix the bug where desktop icons get
578  stuck in the top left corner on startup
579
580* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
581- 2.0.4
582
583* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
584- obsolete nautilus-mozilla < 2.0 #69839
585
586* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
587- add rhconfig patch to Bluecurve theme and disable sidebar by default
588
589* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
590- drop start here files, require redhat-menus that has them
591
592* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
593- 2.0.3
594
595* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
596- build for new eel2, gail
597
598* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
599- and add the libexec components, mumble
600
601* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
602- put the components in the file list, were moved upstream
603
604* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
605- 2.0.1
606
607* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
608- Relibtoolize to fix relink problems for solib components
609- Add LANG=en_US to %makeinstall as well
610- Back out previous change, force locale to en_US to prevent UTF-8 problems
611- Add workaround for intltool-merge bug on ia64
612
613* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
614- automated rebuild
615
616* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
617- 2.0.0
618- use desktop-file-install
619- require desktop-backgrounds-basic
620
621* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
622- add wacky hack in hopes of fixing the hang-on-login thing
623
624* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
625- add build requires on new gail
626- rebuild to try to lose broken libgailutil.so.13 dependency
627
628* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
629- rebuild in different environment
630
631* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
632- 1.1.19
633
634* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
635- rebuild in different environment
636
637* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
638- really remove nautilus-devel if we are going to obsolete it
639- don't require hwbrowser
640
641* Sun May 26 2002 Tim Powers <timp@redhat.com>
642- automated rebuild
643
644* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
645- rebuild in different environment
646
647* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
648- 1.1.17
649
650* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
651- 1.1.14
652
653* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
654- require eog
655- obsolete nautilus-devel
656- fix name of schemas file in post
657
658* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
659- Update to 1.1.13
660
661* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
662- put tree view in file list
663
664* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
665- nautilus for gnome 2
666- clean up the spec file and file list a bit
667
668* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
669- merge translations
670
671* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
672- Add patch to fix trash crash
673
674* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
675- fix for metadata tmp race
676- backport thumbnail speed fix and thumbnail inf. loop fix
677
678* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
679- add some fixes from CVS version, including one for #61819 and a couple segfaults
680
681* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
682- fix thumbnails for files with future timestamp, #56862
683
684* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
685- buildrequires intltool #60633
686- apply Alex's pixbuf cache patch to save a few megs #60581
687
688* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
689- drop Milan-specific features, including png10 and ac25 patches
690- copy in 1.0.5 help component to avoid large risky patch
691- remove .la files
692- drop mozilla from ia64 again
693- remove oaf file from nautilus-mozilla that was also in the base
694  package
695
696* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
697- enable mozilla support on ia64
698
699* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
700- require Mozilla 0.9.7
701- Add patch that puts mozilla profile startup before embedding is initialized
702
703* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
704- 1.0.6, require Mozilla 0.9.6
705
706* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
707- Update to 1.0.5
708
709* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
710- Fix handling of GnomeVFSFileInfo structure (#53315)
711
712* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
713- Change handling of names on unmount to fix #52325
714
715* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
716- put nautilus-help.desktop in file list; #53109
717
718* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
719- Add po files from sources.redhat.com
720
721* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
722- Add po files from sources.redhat.com
723
724* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
725- Added patch to fix the .directory issuer
726
727* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
728- I screwed up the build yesterday, so it didn't actually contain the
729  fixes mentioned. This build should contain them.
730
731* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
732- fix bug causing 32000 stats or so in large directories,
733  should speed things up somewhat
734- fix #52104 via gruesome kdesktop-detection hack and setting
735  window type hint on our desktop window
736- fix so Start Here icon displays in sidebar
737- don't load non-local .desktop files
738
739* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
740- make Programs icon into a link, to match the other .desktop files
741- own various directories #51164
742- web page titles in Japanese, #51709
743- tree defaults to only directories #51850
744
745* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
746- make start here icon work again
747- kill some warning spew, #51661
748- cache getpwnam() results to speed things up a bit
749
750* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
751- Fix problem with missing desktop starthere.desktop file
752- New snapshot from our branch, fixes:
753  - On upgrade, icons migrated from GNOME desktop are not properly lined up
754    (#51436)
755  - icons dropped on the desktop don't end up where dropped. (#51441)
756  - Nautilus shouldn't have fam monitor read-only windows. This
757    keeps CDROMS from being unmounted until you close all
758
759    nautilus windows pointing to them. (#51442)
760  - Warnings about 'cannot statfs...' when moving items to trash.
761- Use separate start-here.desktop for panel, since the one used
762  for the root window only works from Nautilus.
763
764* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
765- Changed starthere .desktop files to be links instead
766- of spawning a new nautilus. This makes start-here:
767- much faster.
768
769* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
770- Added hwbrowser dependency
771- New snapshot, fixes the mozilla-view submit form problem
772
773* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
774- Rebuild with new xml-i18n-tools
775- fix crash in creating new desktop files
776
777* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
778- Fix up DnD code some more
779
780* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
781- Sync our CVS version; fixes some MUSTFIX
782  (the one about drawing background on startup,
783   properly translate desktop files, etc.)
784
785* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
786- Fix 64bit cleanness issue
787- Fix NULL mimetype crash
788- Disable additional_text for .desktop files
789
790* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
791- Fix unmounting devices.
792
793* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
794- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
795- mimetype sniffing.
796
797* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
798- Remove the "don't run as root" warning.
799- Remove eazel from bookmarks
800- langified (again? did someone change it?)
801
802* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
803- Apply a patch that makes nautilus dnd reset work with the latest
804- eel release.
805
806* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
807- Build on ia64 without the mozilla component.
808
809* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
810- Fix crash-on-startup showstopper
811- Fix can't-find-images bug (this one was only showing up
812  when built with debug symbols, since it was an uninitialized memory
813  read)
814
815* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
816- sync new tarball from our CVS branch,
817  fixes some drag-and-drop, changes URI scheme names,
818  etc.
819
820* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
821- Add BuildRequires (#49539, 49537)
822- Fix %%post, %%postun (#49720)
823- Background efficiency improvements and hacks
824
825* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
826- Don't launch esd on each mouseover.
827
828* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
829- move first time druid patch into my "CVS outstanding" patch
830- try to really remove Help/Feedback
831- try to really fix Help/Community Support
832- try again to get Start Here in the Go menu
833- try again to get Start Here on the desktop
834- don't show file sizes for .desktop files
835
836* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
837- add newline to ends of .desktop files that were missing them
838
839* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
840- update to my latest 'cvs diff -u' (adds default
841  Start Here link, displays .directory name in sidebar)
842- include /etc/X11/* links (starthere, sysconfig, serverconfig)
843
844* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
845- Patch to remove firsttime druid and flash
846
847* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
848- add hacks for displaying desktop files
849- add hack to turn off the "unwriteable" emblem
850
851* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
852- added defattr to the files lists to be (-,root,root)
853- languified
854
855* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
856- Need to run autoheader too.
857
858* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
859- Make the fam dependency a real runtime dependency
860- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
861- Cleaned up specfile.
862
863* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
864- Change default background and rubberband color.
865- Use the sidebar tabs from the default theme
866- BuildDepend on fam-devel, depend on fam
867- Disable the eazel update pages in the first-time druid.
868- Remove the eazel logo from the first-time druid
869
870* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
871- 1.0.4, removes eazel services icon and wizard page
872- Eazel logo is still in startup wizard for now, needs fixing
873
874* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
875- fix group (s/Desktop/Desktops/) #47134
876- remove ammonite dependency
877
878* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
879- add a different default theme
880- clean up file list overspecificity a bit
881
882* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
883- move to a CVS snapshot of nautilus for now
884  (Darin is my hero for having distcheck work out of CVS)
885
886* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
887- clean up defaults a bit
888
889* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
890- New version
891
892* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
893- Added BuildRequires lines
894- Changed Source to point to ftp.gnome.org instead of just the tarball name
895- Moved %description sections closer to their %package sections
896- Moved %changelog to the end, where so that it's not in the way
897- Changed configure and make install options to allow moving of
898  libraries, includes, binaries more easily
899- Removed hard-coded paths (don't define %prefix or %docdir)
900- replace %{prefix}/bin with %{_bindir}
901- replace %{prefix}/share with %{_datadir}
902- replace %{prefix}/lib with %{_libdir}
903- replace %{prefix}/include with %{_includedir}
904
905* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
906- removed obsoletes from sub packages and added mozilla and trilobite
907subpackages
908
909* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
910- created this thing
Note: See TracBrowser for help on using the repository browser.