source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 4850

Revision 4850, 30.0 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2.0

Line 
1%define glib2_version 2.30.0
2%define pango_version 1.28.4
3%define gtk3_version 3.2.0
4%define libxml2_version 2.7.8
5%define eog_version 3.0.1
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.0.0
8%define vine_menus_version 3.0
9%define gnome_menus_version 2.32.0
10%define startup_notification_version 0.10
11%define libexif_version 0.6.19
12%define gconf_version 2.32.0
13%define gobject_introspection_version 0.9.8
14
15Name:           nautilus
16Summary:        Nautilus is a file manager for GNOME
17Summary(ja):    Nautilus - GNOME ファイルマネージャ
18Version:        3.2.0
19Release:        1%{?_dist_release}
20License:        GPLv2+
21Group:          User Interface/Desktops
22URL:            http://www.gnome.org/projects/nautilus/
23
24Vendor:         Project Vine
25Distribution:   Vine Linux
26Packager:       Takemikaduchi
27
28Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.2/%{name}-%{version}.tar.xz
29
30# Some changes to default config
31Patch1:         nautilus-2.5.7-rhconfig.patch
32Patch3:         background-no-delay.patch
33
34# Why is this not upstream ?
35Patch6:         nautilus-2.23.5-dynamic-search.patch
36
37Patch7:         rtl-fix.patch
38
39# vine
40Patch100:       nautilus-2.8.2-vine.patch
41Patch101:       nautilus-2.30.0-vine.patch
42
43BuildRoot:      %{_tmppath}/%{name}-%{version}-root
44Requires:       gamin
45Requires:       vine-menus >= %{vine_menus_version}
46Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
47Requires:       libexif >= %{libexif_version}
48Requires:       %{name}-libs = %{version}-%{release}
49
50Requires(pre,preun,post): GConf2 >= %{gconf_version}
51Requires(post,postun): rarian-compat
52
53BuildRequires:  glib2-devel >= %{glib2_version}
54BuildRequires:  pango-devel >= %{pango_version}
55BuildRequires:  gtk3-devel >= %{gtk3_version}
56BuildRequires:  libxml2-devel >= %{libxml2_version}
57BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
58BuildRequires:  gamin-devel
59BuildRequires:  intltool
60BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
61BuildRequires:  libtool >= 1.4.2-10
62BuildRequires:  automake, autoconf
63BuildRequires:  startup-notification-devel >= %{startup_notification_version}
64#BuildRequires: tracker-devel >= %{tracker_version}
65BuildRequires:  libexif-devel  >= %{libexif_version}
66BuildRequires:  unique3-devel
67BuildRequires:  libnotify-devel
68BuildRequires:  libSM-devel
69BuildRequires:  libtool, autoconf
70BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
71BuildRequires:  gsettings-desktop-schemas
72
73Obsoletes:      nautilus-extras
74Obsoletes:      nautilus-suggested
75Obsoletes:      nautilus-mozilla < 2.0
76Obsoletes:      eel2 <= 2.24.1
77
78Provides:       eel2 <= 2.24.1
79
80
81%description
82Nautilus integrates access to files, applications, media,
83Internet-based resources and the Web. Nautilus delivers a dynamic and
84rich user experience. Nautilus is an free software project developed
85under the GNU General Public License and is a core component of the
86GNOME desktop project.
87
88%description -l ja
89Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
90リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
91豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
92のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
93プロジェクトのコア・コンポーネントです。
94
95%package devel
96Summary: Support for developing nautilus extensions
97Summary(ja): Nautilus 拡張機能開発のためのサポート
98License: LGPLv2+
99Group: Development/Libraries
100Requires: %{name}-libs = %{version}-%{release}
101Requires: pkgconfig
102
103%description devel
104This package provides libraries and header files needed
105for developing nautilus extensions.
106
107%description -l ja devel
108このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
109ヘッダファイルを提供します。
110
111%package libs
112Summary: Libraries for use in nautilus extentions
113Summary(ja): Nautilus 拡張機能で利用するライブラリ
114Group: User Interface/Desktops
115
116%description libs
117This package provides libraries required by nautilus extention
118module.
119
120%description -l ja libs
121このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
122
123%prep
124%setup -q -n %{name}-%{version}
125
126##patch3 -p1 -b .no-delay
127#%patch5 -p1 -b .selinux
128##patch6 -p1 -b .dynamic-search
129%patch7 -p1 -b .rtl-fix
130
131## %patch100 -p1 -b .vine
132## %patch101 -p1 -b .vine
133
134%build
135gtkdocize
136libtoolize --force --copy
137autoreconf -f -i
138CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
139%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
140
141export tagname=CC
142LANG=en_US make LIBTOOL=/usr/bin/libtool %{?_smp_mflags}
143
144%install
145rm -rf $RPM_BUILD_ROOT
146
147export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
148export tagname=CC
149LANG=en_US make install LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT
150unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
151
152## these are in desktop-backgrounds-basic
153## (uncomment when we patch the source to look in the right place)
154## /bin/rm -rf $RPM_BUILD_ROOT%{_datadir}/nautilus/patterns
155
156# make sure desktop files validate by ignoring sr@Latn
157perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
158# desktop-file-install can't handle empty OnlyShowIn correctly
159perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
160
161desktop-file-install --vendor gnome --delete-original       \
162  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
163  --add-only-show-in GNOME                                  \
164  $RPM_BUILD_ROOT%{_datadir}/applications/*
165
166rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
167rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
168
169# mkdir -p $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-3.0
170rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-3.0/*.{la,a}
171
172%find_lang %name
173
174%clean
175rm -rf $RPM_BUILD_ROOT
176
177%post
178/sbin/ldconfig
179touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
180
181%posttrans
182%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null ||:
183gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
184scrollkeeper-update > /dev/null 2>&1 || :
185glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
186
187
188%postun
189/sbin/ldconfig
190if [ $1 -eq 0 ] ; then
191    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
192    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
193    scrollkeeper-update > /dev/null 2>&1 || :
194    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
195fi
196
197%files  -f %{name}.lang
198%defattr(-,root,root)
199%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
200%dir %{_libdir}/nautilus
201%dir %{_libdir}/nautilus/extensions-3.0
202%{_libdir}/nautilus/extensions-3.0/*.so
203%{_libexecdir}/nautilus-convert-metadata
204%{_datadir}/GConf/gsettings/nautilus.convert
205%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
206%{_datadir}/nautilus
207%{_datadir}/pixmaps
208%{_datadir}/applications
209%{_datadir}/mime/*
210%{_datadir}/icons/hicolor/*
211%{_bindir}/*
212%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
213%{_datadir}/glib-2.0/schemas/
214%{_mandir}/man1/*
215
216%files devel
217%defattr(-, root, root)
218%{_includedir}/nautilus
219%{_libdir}/pkgconfig/*
220%{_libdir}/*.so
221%{_datadir}/gir-1.0
222%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
223
224%files libs
225%defattr(-, root, root)
226%{_libdir}/*.so.*
227%{_libdir}/girepository-1.0
228
229
230%changelog
231* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
232- new upstream release
233
234* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
235- new upstream release
236
237* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
238- new upstream release
239
240* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
241- new upstream release
242- drop Patch101
243- change BuildRequires: gtk3-devel instread of gtk2-devel
244- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
245- change BuildRequires: unique3-devel instread of unique-devel
246- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
247
248* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
249- fixed group of libs
250- add translation of summary and description.
251- add Vendor, Distribution and Packager tags.
252
253* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
254- new upstream release
255
256* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
257- new upstream release
258
259* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
260 - new upstream release
261
262* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
263- new upstream release
264- add BuildRequires: gobject-introspection-devel
265- remove BuildRequires: libgnomeui-devel
266- add configure option (--enable-introspection=yes)
267
268* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
269- rebuild with rpm-4.8.1 for pkg-config file
270
271* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
272- split nautilus extention libraries to -libs subpackage.
273
274* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
275- new upstream release
276
277* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
278- new upstream release
279- drop Patch100
280- add Patch101
281- add Obsoletes: eel2 <= 2.24.1
282- add Provides: eel2 <= 2.24.1
283
284* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
285- new upstream release
286- add BuildRequires: libSM-devel
287
288* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
289- removed Requires: eel2
290- added %%posttrans section
291
292* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
293- new upstream release
294
295* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
296- new upstream release
297
298* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
299- new upstream release
300
301* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
302- new upstream release
303- split -devel subpackage
304
305* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
306- new upstream release
307
308* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
309- patch6 needs autoreconf
310
311* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
312- new upstream release
313
314* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
315- new upstream release
316
317* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
318- new upstream release
319- added Requires: gvfs
320
321* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
322- new upstream release
323- added Patches from FC
324  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
325  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
326  - Fix a crash in the Properties dialog while changing owner (patch from head)
327  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
328  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
329
330* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
331- new upstream release
332- dropped Patch11-13 and added Patch7-9 from Fedora
333  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
334  - Add patch from upstream to get audio preview working again
335    (#332251)
336  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
337  - Fix a crash with small fonts (#242350)
338  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
339  - Backport fixes for async thumbnail loading from svn
340
341* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
342- run autoreconf for Patch11 changes
343
344* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
345- remove tracker dependancy, Patch13 detects tracker dynamically.
346
347* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
348- add Patch13 to support user-dirs
349
350* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
351- new upstream release
352- enable tracker support
353- add BuildRequires: tracker-devel, Requires: tracker
354
355* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
356- new upstream release
357
358* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
359- add BuildRequires: gamin-devel, Requires: gamin
360- remove fam dependency (replaced by gamin)
361
362* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
363- new upsteram release
364
365* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
366- really applied Patch110...
367
368* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
369- add Patch110 to fix corruption of help option message.
370
371* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
372- new upstream release
373
374* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
375- fix typo in ja.po
376
377* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
378- update ja.po to translate patch50 related message.
379
380* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
381- add Patch50 to show progressbar on umounting
382  (ubuntu patch in Bug 313639)
383
384* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
385- new upstream release
386
387* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
388- add Patch10 to avoid background rendering delay
389
390* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
391- new upstream release
392
393* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
394- add fix-non-UTF-8-encoding.patch (patch0)
395  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
396
397* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
398- new upstream release
399
400* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
401- new upstream release
402
403* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
404- new upstream release
405
406* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
407- new upstream release
408
409* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
410- rebuild
411
412* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
413- new upstream version
414
415* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
416- new upstream version
417
418* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
419- add vine patch to change some defaults.
420  - change default zoom sine
421  - set always_use_browser
422
423* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
424- new upstream release
425
426* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
427- add Patch110 to fix libegg(egg-recent-model.c)
428  save old umask value before create ".recently-used" file.
429 
430* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
431- change default desktop font to Sans 9 (from Sans 10)
432- add patch10 to build with gtk+-2.4
433
434* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
435- new upstream release
436
437* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
438- new upstream release
439
440* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
441- add backport patch from rawhide (Patch10)
442
443* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
444- modified vine patch
445  - change default zoom level to small
446  - change desktop font to Sans 10
447
448* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
449- new upstream release
450
451* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
452- add desktop icon patch from rawhide
453
454* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
455- remove obsolete ja.po
456
457* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
458- new upstream release
459
460* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
461- new upstream release
462
463* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
464- new upstream release
465
466* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
467- update ja.po
468
469* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
470- new upstream release
471
472* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
473- new upstream release
474
475* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
476- new upstream release
477
478* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
479- new upstream release
480
481* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
482- new upstream release
483
484* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
485- new upstream release
486
487* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
488- add nautilus-cd-burner patch
489
490* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
491- new upstream release
492
493* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
494- discard scrollkeeper outputs.
495- update PreReq tags.
496
497* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
498- change icon for nautilus-file-management-properties
499- update ja.po
500
501* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
502- update ja.po
503- add translation for .desktop files.
504
505* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
506- add Requires: vine-menus
507
508* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
509- new upstream release
510
511* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
512- remove redhatize patch
513
514* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
515- rebuild to remove unneeded dependancy.
516
517* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
518- build for Vine Linux
519
520* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
521- add explicit startup-notification dependency because build system is
522  dumb
523- 2.1.3
524
525* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
526- 2.1.2
527
528* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
529- 2.0.7
530- remove patches that are upstream
531
532* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
533- Add badhack to make weblinks on desktop work
534
535* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
536- fix #70667 assertion failures
537- fix triple click patch
538
539* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
540- don't activate on double click
541
542* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
543- put button press mask in triple-click patch, maybe it will work
544- remove html-hack patch as it does nothing useful
545
546* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
547- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
548  bogus bug reports
549- add hack for HTML mime type handling in a web browser, not
550  nautilus
551
552* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
553- Updated to 2.0.6. Removed the patches I put upstream.
554- Added patch that fixes #72410
555
556* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
557- Add a simple patch so that redhat-config-packages can disable
558  the new window behavior for mounted CDs behavior.
559
560* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
561- Add patch to fix bug #70667
562
563* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
564- remove mp3
565
566* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
567- ignore the "add_to_session" preference as it only broke stuff
568- pad the left margin a bit to cope with poor word wrapping
569
570* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
571- Update to 2.0.5, remove topleft icon patch
572
573* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
574- Add patch to fix the bug where desktop icons get
575  stuck in the top left corner on startup
576
577* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
578- 2.0.4
579
580* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
581- obsolete nautilus-mozilla < 2.0 #69839
582
583* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
584- add rhconfig patch to Bluecurve theme and disable sidebar by default
585
586* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
587- drop start here files, require redhat-menus that has them
588
589* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
590- 2.0.3
591
592* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
593- build for new eel2, gail
594
595* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
596- and add the libexec components, mumble
597
598* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
599- put the components in the file list, were moved upstream
600
601* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
602- 2.0.1
603
604* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
605- Relibtoolize to fix relink problems for solib components
606- Add LANG=en_US to %makeinstall as well
607- Back out previous change, force locale to en_US to prevent UTF-8 problems
608- Add workaround for intltool-merge bug on ia64
609
610* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
611- automated rebuild
612
613* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
614- 2.0.0
615- use desktop-file-install
616- require desktop-backgrounds-basic
617
618* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
619- add wacky hack in hopes of fixing the hang-on-login thing
620
621* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
622- add build requires on new gail
623- rebuild to try to lose broken libgailutil.so.13 dependency
624
625* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
626- rebuild in different environment
627
628* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
629- 1.1.19
630
631* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
632- rebuild in different environment
633
634* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
635- really remove nautilus-devel if we are going to obsolete it
636- don't require hwbrowser
637
638* Sun May 26 2002 Tim Powers <timp@redhat.com>
639- automated rebuild
640
641* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
642- rebuild in different environment
643
644* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
645- 1.1.17
646
647* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
648- 1.1.14
649
650* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
651- require eog
652- obsolete nautilus-devel
653- fix name of schemas file in post
654
655* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
656- Update to 1.1.13
657
658* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
659- put tree view in file list
660
661* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
662- nautilus for gnome 2
663- clean up the spec file and file list a bit
664
665* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
666- merge translations
667
668* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
669- Add patch to fix trash crash
670
671* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
672- fix for metadata tmp race
673- backport thumbnail speed fix and thumbnail inf. loop fix
674
675* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
676- add some fixes from CVS version, including one for #61819 and a couple segfaults
677
678* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
679- fix thumbnails for files with future timestamp, #56862
680
681* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
682- buildrequires intltool #60633
683- apply Alex's pixbuf cache patch to save a few megs #60581
684
685* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
686- drop Milan-specific features, including png10 and ac25 patches
687- copy in 1.0.5 help component to avoid large risky patch
688- remove .la files
689- drop mozilla from ia64 again
690- remove oaf file from nautilus-mozilla that was also in the base
691  package
692
693* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
694- enable mozilla support on ia64
695
696* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
697- require Mozilla 0.9.7
698- Add patch that puts mozilla profile startup before embedding is initialized
699
700* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
701- 1.0.6, require Mozilla 0.9.6
702
703* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
704- Update to 1.0.5
705
706* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
707- Fix handling of GnomeVFSFileInfo structure (#53315)
708
709* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
710- Change handling of names on unmount to fix #52325
711
712* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
713- put nautilus-help.desktop in file list; #53109
714
715* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
716- Add po files from sources.redhat.com
717
718* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
719- Add po files from sources.redhat.com
720
721* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
722- Added patch to fix the .directory issuer
723
724* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
725- I screwed up the build yesterday, so it didn't actually contain the
726  fixes mentioned. This build should contain them.
727
728* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
729- fix bug causing 32000 stats or so in large directories,
730  should speed things up somewhat
731- fix #52104 via gruesome kdesktop-detection hack and setting
732  window type hint on our desktop window
733- fix so Start Here icon displays in sidebar
734- don't load non-local .desktop files
735
736* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
737- make Programs icon into a link, to match the other .desktop files
738- own various directories #51164
739- web page titles in Japanese, #51709
740- tree defaults to only directories #51850
741
742* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
743- make start here icon work again
744- kill some warning spew, #51661
745- cache getpwnam() results to speed things up a bit
746
747* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
748- Fix problem with missing desktop starthere.desktop file
749- New snapshot from our branch, fixes:
750  - On upgrade, icons migrated from GNOME desktop are not properly lined up
751    (#51436)
752  - icons dropped on the desktop don't end up where dropped. (#51441)
753  - Nautilus shouldn't have fam monitor read-only windows. This
754    keeps CDROMS from being unmounted until you close all
755
756    nautilus windows pointing to them. (#51442)
757  - Warnings about 'cannot statfs...' when moving items to trash.
758- Use separate start-here.desktop for panel, since the one used
759  for the root window only works from Nautilus.
760
761* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
762- Changed starthere .desktop files to be links instead
763- of spawning a new nautilus. This makes start-here:
764- much faster.
765
766* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
767- Added hwbrowser dependency
768- New snapshot, fixes the mozilla-view submit form problem
769
770* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
771- Rebuild with new xml-i18n-tools
772- fix crash in creating new desktop files
773
774* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
775- Fix up DnD code some more
776
777* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
778- Sync our CVS version; fixes some MUSTFIX
779  (the one about drawing background on startup,
780   properly translate desktop files, etc.)
781
782* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
783- Fix 64bit cleanness issue
784- Fix NULL mimetype crash
785- Disable additional_text for .desktop files
786
787* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
788- Fix unmounting devices.
789
790* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
791- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
792- mimetype sniffing.
793
794* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
795- Remove the "don't run as root" warning.
796- Remove eazel from bookmarks
797- langified (again? did someone change it?)
798
799* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
800- Apply a patch that makes nautilus dnd reset work with the latest
801- eel release.
802
803* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
804- Build on ia64 without the mozilla component.
805
806* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
807- Fix crash-on-startup showstopper
808- Fix can't-find-images bug (this one was only showing up
809  when built with debug symbols, since it was an uninitialized memory
810  read)
811
812* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
813- sync new tarball from our CVS branch,
814  fixes some drag-and-drop, changes URI scheme names,
815  etc.
816
817* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
818- Add BuildRequires (#49539, 49537)
819- Fix %%post, %%postun (#49720)
820- Background efficiency improvements and hacks
821
822* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
823- Don't launch esd on each mouseover.
824
825* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
826- move first time druid patch into my "CVS outstanding" patch
827- try to really remove Help/Feedback
828- try to really fix Help/Community Support
829- try again to get Start Here in the Go menu
830- try again to get Start Here on the desktop
831- don't show file sizes for .desktop files
832
833* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
834- add newline to ends of .desktop files that were missing them
835
836* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
837- update to my latest 'cvs diff -u' (adds default
838  Start Here link, displays .directory name in sidebar)
839- include /etc/X11/* links (starthere, sysconfig, serverconfig)
840
841* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
842- Patch to remove firsttime druid and flash
843
844* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
845- add hacks for displaying desktop files
846- add hack to turn off the "unwriteable" emblem
847
848* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
849- added defattr to the files lists to be (-,root,root)
850- languified
851
852* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
853- Need to run autoheader too.
854
855* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
856- Make the fam dependency a real runtime dependency
857- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
858- Cleaned up specfile.
859
860* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
861- Change default background and rubberband color.
862- Use the sidebar tabs from the default theme
863- BuildDepend on fam-devel, depend on fam
864- Disable the eazel update pages in the first-time druid.
865- Remove the eazel logo from the first-time druid
866
867* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
868- 1.0.4, removes eazel services icon and wizard page
869- Eazel logo is still in startup wizard for now, needs fixing
870
871* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
872- fix group (s/Desktop/Desktops/) #47134
873- remove ammonite dependency
874
875* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
876- add a different default theme
877- clean up file list overspecificity a bit
878
879* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
880- move to a CVS snapshot of nautilus for now
881  (Darin is my hero for having distcheck work out of CVS)
882
883* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
884- clean up defaults a bit
885
886* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
887- New version
888
889* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
890- Added BuildRequires lines
891- Changed Source to point to ftp.gnome.org instead of just the tarball name
892- Moved %description sections closer to their %package sections
893- Moved %changelog to the end, where so that it's not in the way
894- Changed configure and make install options to allow moving of
895  libraries, includes, binaries more easily
896- Removed hard-coded paths (don't define %prefix or %docdir)
897- replace %{prefix}/bin with %{_bindir}
898- replace %{prefix}/share with %{_datadir}
899- replace %{prefix}/lib with %{_libdir}
900- replace %{prefix}/include with %{_includedir}
901
902* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
903- removed obsoletes from sub packages and added mozilla and trilobite
904subpackages
905
906* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
907- created this thing
Note: See TracBrowser for help on using the repository browser.