source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 4812

Revision 4812, 29.9 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.1.92

Line 
1%define glib2_version 2.28.6
2%define pango_version 1.28.4
3%define gtk3_version 3.0.9
4%define libxml2_version 2.7.8
5%define eog_version 3.0.1
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.0.0
8%define vine_menus_version 3.0
9%define gnome_menus_version 2.32.0
10%define startup_notification_version 0.10
11%define libexif_version 0.6.19
12%define gconf_version 2.32.0
13%define gobject_introspection_version 0.9.8
14
15Name:           nautilus
16Summary:        Nautilus is a file manager for GNOME
17Summary(ja):    Nautilus - GNOME ファイルマネージャ
18Version:        3.1.92
19Release:        1%{?_dist_release}
20License:        GPLv2+
21Group:          User Interface/Desktops
22URL:            http://www.gnome.org/projects/nautilus/
23
24Vendor:         Project Vine
25Distribution:   Vine Linux
26Packager:       Takemikaduchi
27
28Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.1/%{name}-%{version}.tar.xz
29
30# Some changes to default config
31Patch1:         nautilus-2.5.7-rhconfig.patch
32Patch3:         background-no-delay.patch
33
34# Why is this not upstream ?
35Patch6:         nautilus-2.23.5-dynamic-search.patch
36
37Patch7:         rtl-fix.patch
38
39# vine
40Patch100:       nautilus-2.8.2-vine.patch
41Patch101:       nautilus-2.30.0-vine.patch
42
43BuildRoot:      %{_tmppath}/%{name}-%{version}-root
44Requires:       gamin
45Requires:       vine-menus >= %{vine_menus_version}
46Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
47Requires:       libexif >= %{libexif_version}
48Requires:       %{name}-libs = %{version}-%{release}
49
50Requires(pre,preun,post): GConf2 >= %{gconf_version}
51Requires(post,postun): rarian-compat
52
53BuildRequires:  glib2-devel >= %{glib2_version}
54BuildRequires:  pango-devel >= %{pango_version}
55BuildRequires:  gtk3-devel >= %{gtk3_version}
56BuildRequires:  libxml2-devel >= %{libxml2_version}
57BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
58BuildRequires:  gamin-devel
59BuildRequires:  intltool
60BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
61BuildRequires:  libtool >= 1.4.2-10
62BuildRequires:  automake, autoconf
63BuildRequires:  startup-notification-devel >= %{startup_notification_version}
64#BuildRequires: tracker-devel >= %{tracker_version}
65BuildRequires:  libexif-devel  >= %{libexif_version}
66BuildRequires:  unique3-devel
67BuildRequires:  libnotify-devel
68BuildRequires:  libSM-devel
69BuildRequires:  libtool, autoconf
70BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
71BuildRequires:  gsettings-desktop-schemas
72
73Obsoletes:      nautilus-extras
74Obsoletes:      nautilus-suggested
75Obsoletes:      nautilus-mozilla < 2.0
76Obsoletes:      eel2 <= 2.24.1
77
78Provides:       eel2 <= 2.24.1
79
80
81%description
82Nautilus integrates access to files, applications, media,
83Internet-based resources and the Web. Nautilus delivers a dynamic and
84rich user experience. Nautilus is an free software project developed
85under the GNU General Public License and is a core component of the
86GNOME desktop project.
87
88%description -l ja
89Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
90リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
91豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
92のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
93プロジェクトのコア・コンポーネントです。
94
95%package devel
96Summary: Support for developing nautilus extensions
97Summary(ja): Nautilus 拡張機能開発のためのサポート
98License: LGPLv2+
99Group: Development/Libraries
100Requires: %{name}-libs = %{version}-%{release}
101Requires: pkgconfig
102
103%description devel
104This package provides libraries and header files needed
105for developing nautilus extensions.
106
107%description -l ja devel
108このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
109ヘッダファイルを提供します。
110
111%package libs
112Summary: Libraries for use in nautilus extentions
113Summary(ja): Nautilus 拡張機能で利用するライブラリ
114Group: User Interface/Desktops
115
116%description libs
117This package provides libraries required by nautilus extention
118module.
119
120%description -l ja libs
121このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
122
123%prep
124%setup -q -n %{name}-%{version}
125
126##patch3 -p1 -b .no-delay
127#%patch5 -p1 -b .selinux
128##patch6 -p1 -b .dynamic-search
129%patch7 -p1 -b .rtl-fix
130
131## %patch100 -p1 -b .vine
132## %patch101 -p1 -b .vine
133
134%build
135gtkdocize
136libtoolize --force --copy
137autoreconf -f -i
138CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
139%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
140
141export tagname=CC
142LANG=en_US make LIBTOOL=/usr/bin/libtool %{?_smp_mflags}
143
144%install
145rm -rf $RPM_BUILD_ROOT
146
147export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
148export tagname=CC
149LANG=en_US make install LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT
150unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
151
152## these are in desktop-backgrounds-basic
153## (uncomment when we patch the source to look in the right place)
154## /bin/rm -rf $RPM_BUILD_ROOT%{_datadir}/nautilus/patterns
155
156# make sure desktop files validate by ignoring sr@Latn
157perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
158# desktop-file-install can't handle empty OnlyShowIn correctly
159perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
160
161desktop-file-install --vendor gnome --delete-original       \
162  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
163  --add-only-show-in GNOME                                  \
164  $RPM_BUILD_ROOT%{_datadir}/applications/*
165
166rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
167rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
168
169# mkdir -p $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-3.0
170rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-3.0/*.{la,a}
171
172%find_lang %name
173
174%clean
175rm -rf $RPM_BUILD_ROOT
176
177%post
178/sbin/ldconfig
179touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
180
181%posttrans
182%{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null ||:
183gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
184scrollkeeper-update > /dev/null 2>&1 || :
185glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
186
187
188%postun
189/sbin/ldconfig
190if [ $1 -eq 0 ] ; then
191    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
192    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null ||:
193    scrollkeeper-update > /dev/null 2>&1 || :
194    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
195fi
196
197%files  -f %{name}.lang
198%defattr(-,root,root)
199%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
200%dir %{_libdir}/nautilus
201%dir %{_libdir}/nautilus/extensions-3.0
202%{_libdir}/nautilus/extensions-3.0/*.so
203%{_libexecdir}/nautilus-convert-metadata
204%{_datadir}/GConf/gsettings/nautilus.convert
205%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
206%{_datadir}/nautilus
207%{_datadir}/pixmaps
208%{_datadir}/applications
209%{_datadir}/mime/*
210%{_datadir}/icons/hicolor/*
211%{_bindir}/*
212%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
213%{_datadir}/glib-2.0/schemas/
214%{_mandir}/man1/*
215
216%files devel
217%defattr(-, root, root)
218%{_includedir}/nautilus
219%{_libdir}/pkgconfig/*
220%{_libdir}/*.so
221%{_datadir}/gir-1.0
222%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
223
224%files libs
225%defattr(-, root, root)
226%{_libdir}/*.so.*
227%{_libdir}/girepository-1.0
228
229
230%changelog
231* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
232- new upstream release
233
234* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
235- new upstream release
236
237* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
238- new upstream release
239- drop Patch101
240- change BuildRequires: gtk3-devel instread of gtk2-devel
241- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
242- change BuildRequires: unique3-devel instread of unique-devel
243- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
244
245* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
246- fixed group of libs
247- add translation of summary and description.
248- add Vendor, Distribution and Packager tags.
249
250* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
251- new upstream release
252
253* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
254- new upstream release
255
256* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
257 - new upstream release
258
259* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
260- new upstream release
261- add BuildRequires: gobject-introspection-devel
262- remove BuildRequires: libgnomeui-devel
263- add configure option (--enable-introspection=yes)
264
265* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
266- rebuild with rpm-4.8.1 for pkg-config file
267
268* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
269- split nautilus extention libraries to -libs subpackage.
270
271* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
272- new upstream release
273
274* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
275- new upstream release
276- drop Patch100
277- add Patch101
278- add Obsoletes: eel2 <= 2.24.1
279- add Provides: eel2 <= 2.24.1
280
281* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
282- new upstream release
283- add BuildRequires: libSM-devel
284
285* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
286- removed Requires: eel2
287- added %%posttrans section
288
289* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
290- new upstream release
291
292* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
293- new upstream release
294
295* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
296- new upstream release
297
298* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
299- new upstream release
300- split -devel subpackage
301
302* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
303- new upstream release
304
305* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
306- patch6 needs autoreconf
307
308* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
309- new upstream release
310
311* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
312- new upstream release
313
314* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
315- new upstream release
316- added Requires: gvfs
317
318* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
319- new upstream release
320- added Patches from FC
321  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
322  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
323  - Fix a crash in the Properties dialog while changing owner (patch from head)
324  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
325  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
326
327* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
328- new upstream release
329- dropped Patch11-13 and added Patch7-9 from Fedora
330  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
331  - Add patch from upstream to get audio preview working again
332    (#332251)
333  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
334  - Fix a crash with small fonts (#242350)
335  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
336  - Backport fixes for async thumbnail loading from svn
337
338* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
339- run autoreconf for Patch11 changes
340
341* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
342- remove tracker dependancy, Patch13 detects tracker dynamically.
343
344* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
345- add Patch13 to support user-dirs
346
347* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
348- new upstream release
349- enable tracker support
350- add BuildRequires: tracker-devel, Requires: tracker
351
352* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
353- new upstream release
354
355* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
356- add BuildRequires: gamin-devel, Requires: gamin
357- remove fam dependency (replaced by gamin)
358
359* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
360- new upsteram release
361
362* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
363- really applied Patch110...
364
365* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
366- add Patch110 to fix corruption of help option message.
367
368* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
369- new upstream release
370
371* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
372- fix typo in ja.po
373
374* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
375- update ja.po to translate patch50 related message.
376
377* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
378- add Patch50 to show progressbar on umounting
379  (ubuntu patch in Bug 313639)
380
381* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
382- new upstream release
383
384* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
385- add Patch10 to avoid background rendering delay
386
387* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
388- new upstream release
389
390* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
391- add fix-non-UTF-8-encoding.patch (patch0)
392  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
393
394* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
395- new upstream release
396
397* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
398- new upstream release
399
400* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
401- new upstream release
402
403* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
404- new upstream release
405
406* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
407- rebuild
408
409* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
410- new upstream version
411
412* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
413- new upstream version
414
415* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
416- add vine patch to change some defaults.
417  - change default zoom sine
418  - set always_use_browser
419
420* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
421- new upstream release
422
423* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
424- add Patch110 to fix libegg(egg-recent-model.c)
425  save old umask value before create ".recently-used" file.
426 
427* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
428- change default desktop font to Sans 9 (from Sans 10)
429- add patch10 to build with gtk+-2.4
430
431* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
432- new upstream release
433
434* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
435- new upstream release
436
437* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
438- add backport patch from rawhide (Patch10)
439
440* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
441- modified vine patch
442  - change default zoom level to small
443  - change desktop font to Sans 10
444
445* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
446- new upstream release
447
448* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
449- add desktop icon patch from rawhide
450
451* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
452- remove obsolete ja.po
453
454* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
455- new upstream release
456
457* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
458- new upstream release
459
460* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
461- new upstream release
462
463* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
464- update ja.po
465
466* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
467- new upstream release
468
469* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
470- new upstream release
471
472* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
473- new upstream release
474
475* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
476- new upstream release
477
478* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
479- new upstream release
480
481* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
482- new upstream release
483
484* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
485- add nautilus-cd-burner patch
486
487* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
488- new upstream release
489
490* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
491- discard scrollkeeper outputs.
492- update PreReq tags.
493
494* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
495- change icon for nautilus-file-management-properties
496- update ja.po
497
498* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
499- update ja.po
500- add translation for .desktop files.
501
502* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
503- add Requires: vine-menus
504
505* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
506- new upstream release
507
508* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
509- remove redhatize patch
510
511* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
512- rebuild to remove unneeded dependancy.
513
514* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
515- build for Vine Linux
516
517* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
518- add explicit startup-notification dependency because build system is
519  dumb
520- 2.1.3
521
522* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
523- 2.1.2
524
525* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
526- 2.0.7
527- remove patches that are upstream
528
529* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
530- Add badhack to make weblinks on desktop work
531
532* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
533- fix #70667 assertion failures
534- fix triple click patch
535
536* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
537- don't activate on double click
538
539* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
540- put button press mask in triple-click patch, maybe it will work
541- remove html-hack patch as it does nothing useful
542
543* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
544- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
545  bogus bug reports
546- add hack for HTML mime type handling in a web browser, not
547  nautilus
548
549* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
550- Updated to 2.0.6. Removed the patches I put upstream.
551- Added patch that fixes #72410
552
553* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
554- Add a simple patch so that redhat-config-packages can disable
555  the new window behavior for mounted CDs behavior.
556
557* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
558- Add patch to fix bug #70667
559
560* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
561- remove mp3
562
563* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
564- ignore the "add_to_session" preference as it only broke stuff
565- pad the left margin a bit to cope with poor word wrapping
566
567* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
568- Update to 2.0.5, remove topleft icon patch
569
570* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
571- Add patch to fix the bug where desktop icons get
572  stuck in the top left corner on startup
573
574* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
575- 2.0.4
576
577* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
578- obsolete nautilus-mozilla < 2.0 #69839
579
580* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
581- add rhconfig patch to Bluecurve theme and disable sidebar by default
582
583* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
584- drop start here files, require redhat-menus that has them
585
586* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
587- 2.0.3
588
589* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
590- build for new eel2, gail
591
592* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
593- and add the libexec components, mumble
594
595* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
596- put the components in the file list, were moved upstream
597
598* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
599- 2.0.1
600
601* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
602- Relibtoolize to fix relink problems for solib components
603- Add LANG=en_US to %makeinstall as well
604- Back out previous change, force locale to en_US to prevent UTF-8 problems
605- Add workaround for intltool-merge bug on ia64
606
607* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
608- automated rebuild
609
610* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
611- 2.0.0
612- use desktop-file-install
613- require desktop-backgrounds-basic
614
615* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
616- add wacky hack in hopes of fixing the hang-on-login thing
617
618* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
619- add build requires on new gail
620- rebuild to try to lose broken libgailutil.so.13 dependency
621
622* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
623- rebuild in different environment
624
625* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
626- 1.1.19
627
628* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
629- rebuild in different environment
630
631* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
632- really remove nautilus-devel if we are going to obsolete it
633- don't require hwbrowser
634
635* Sun May 26 2002 Tim Powers <timp@redhat.com>
636- automated rebuild
637
638* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
639- rebuild in different environment
640
641* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
642- 1.1.17
643
644* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
645- 1.1.14
646
647* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
648- require eog
649- obsolete nautilus-devel
650- fix name of schemas file in post
651
652* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
653- Update to 1.1.13
654
655* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
656- put tree view in file list
657
658* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
659- nautilus for gnome 2
660- clean up the spec file and file list a bit
661
662* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
663- merge translations
664
665* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
666- Add patch to fix trash crash
667
668* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
669- fix for metadata tmp race
670- backport thumbnail speed fix and thumbnail inf. loop fix
671
672* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
673- add some fixes from CVS version, including one for #61819 and a couple segfaults
674
675* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
676- fix thumbnails for files with future timestamp, #56862
677
678* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
679- buildrequires intltool #60633
680- apply Alex's pixbuf cache patch to save a few megs #60581
681
682* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
683- drop Milan-specific features, including png10 and ac25 patches
684- copy in 1.0.5 help component to avoid large risky patch
685- remove .la files
686- drop mozilla from ia64 again
687- remove oaf file from nautilus-mozilla that was also in the base
688  package
689
690* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
691- enable mozilla support on ia64
692
693* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
694- require Mozilla 0.9.7
695- Add patch that puts mozilla profile startup before embedding is initialized
696
697* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
698- 1.0.6, require Mozilla 0.9.6
699
700* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
701- Update to 1.0.5
702
703* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
704- Fix handling of GnomeVFSFileInfo structure (#53315)
705
706* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
707- Change handling of names on unmount to fix #52325
708
709* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
710- put nautilus-help.desktop in file list; #53109
711
712* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
713- Add po files from sources.redhat.com
714
715* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
716- Add po files from sources.redhat.com
717
718* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
719- Added patch to fix the .directory issuer
720
721* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
722- I screwed up the build yesterday, so it didn't actually contain the
723  fixes mentioned. This build should contain them.
724
725* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
726- fix bug causing 32000 stats or so in large directories,
727  should speed things up somewhat
728- fix #52104 via gruesome kdesktop-detection hack and setting
729  window type hint on our desktop window
730- fix so Start Here icon displays in sidebar
731- don't load non-local .desktop files
732
733* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
734- make Programs icon into a link, to match the other .desktop files
735- own various directories #51164
736- web page titles in Japanese, #51709
737- tree defaults to only directories #51850
738
739* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
740- make start here icon work again
741- kill some warning spew, #51661
742- cache getpwnam() results to speed things up a bit
743
744* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
745- Fix problem with missing desktop starthere.desktop file
746- New snapshot from our branch, fixes:
747  - On upgrade, icons migrated from GNOME desktop are not properly lined up
748    (#51436)
749  - icons dropped on the desktop don't end up where dropped. (#51441)
750  - Nautilus shouldn't have fam monitor read-only windows. This
751    keeps CDROMS from being unmounted until you close all
752
753    nautilus windows pointing to them. (#51442)
754  - Warnings about 'cannot statfs...' when moving items to trash.
755- Use separate start-here.desktop for panel, since the one used
756  for the root window only works from Nautilus.
757
758* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
759- Changed starthere .desktop files to be links instead
760- of spawning a new nautilus. This makes start-here:
761- much faster.
762
763* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
764- Added hwbrowser dependency
765- New snapshot, fixes the mozilla-view submit form problem
766
767* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
768- Rebuild with new xml-i18n-tools
769- fix crash in creating new desktop files
770
771* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
772- Fix up DnD code some more
773
774* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
775- Sync our CVS version; fixes some MUSTFIX
776  (the one about drawing background on startup,
777   properly translate desktop files, etc.)
778
779* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
780- Fix 64bit cleanness issue
781- Fix NULL mimetype crash
782- Disable additional_text for .desktop files
783
784* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
785- Fix unmounting devices.
786
787* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
788- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
789- mimetype sniffing.
790
791* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
792- Remove the "don't run as root" warning.
793- Remove eazel from bookmarks
794- langified (again? did someone change it?)
795
796* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
797- Apply a patch that makes nautilus dnd reset work with the latest
798- eel release.
799
800* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
801- Build on ia64 without the mozilla component.
802
803* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
804- Fix crash-on-startup showstopper
805- Fix can't-find-images bug (this one was only showing up
806  when built with debug symbols, since it was an uninitialized memory
807  read)
808
809* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
810- sync new tarball from our CVS branch,
811  fixes some drag-and-drop, changes URI scheme names,
812  etc.
813
814* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
815- Add BuildRequires (#49539, 49537)
816- Fix %%post, %%postun (#49720)
817- Background efficiency improvements and hacks
818
819* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
820- Don't launch esd on each mouseover.
821
822* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
823- move first time druid patch into my "CVS outstanding" patch
824- try to really remove Help/Feedback
825- try to really fix Help/Community Support
826- try again to get Start Here in the Go menu
827- try again to get Start Here on the desktop
828- don't show file sizes for .desktop files
829
830* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
831- add newline to ends of .desktop files that were missing them
832
833* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
834- update to my latest 'cvs diff -u' (adds default
835  Start Here link, displays .directory name in sidebar)
836- include /etc/X11/* links (starthere, sysconfig, serverconfig)
837
838* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
839- Patch to remove firsttime druid and flash
840
841* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
842- add hacks for displaying desktop files
843- add hack to turn off the "unwriteable" emblem
844
845* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
846- added defattr to the files lists to be (-,root,root)
847- languified
848
849* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
850- Need to run autoheader too.
851
852* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
853- Make the fam dependency a real runtime dependency
854- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
855- Cleaned up specfile.
856
857* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
858- Change default background and rubberband color.
859- Use the sidebar tabs from the default theme
860- BuildDepend on fam-devel, depend on fam
861- Disable the eazel update pages in the first-time druid.
862- Remove the eazel logo from the first-time druid
863
864* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
865- 1.0.4, removes eazel services icon and wizard page
866- Eazel logo is still in startup wizard for now, needs fixing
867
868* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
869- fix group (s/Desktop/Desktops/) #47134
870- remove ammonite dependency
871
872* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
873- add a different default theme
874- clean up file list overspecificity a bit
875
876* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
877- move to a CVS snapshot of nautilus for now
878  (Darin is my hero for having distcheck work out of CVS)
879
880* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
881- clean up defaults a bit
882
883* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
884- New version
885
886* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
887- Added BuildRequires lines
888- Changed Source to point to ftp.gnome.org instead of just the tarball name
889- Moved %description sections closer to their %package sections
890- Moved %changelog to the end, where so that it's not in the way
891- Changed configure and make install options to allow moving of
892  libraries, includes, binaries more easily
893- Removed hard-coded paths (don't define %prefix or %docdir)
894- replace %{prefix}/bin with %{_bindir}
895- replace %{prefix}/share with %{_datadir}
896- replace %{prefix}/lib with %{_libdir}
897- replace %{prefix}/include with %{_includedir}
898
899* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
900- removed obsoletes from sub packages and added mozilla and trilobite
901subpackages
902
903* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
904- created this thing
Note: See TracBrowser for help on using the repository browser.