source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 12005

Revision 12005, 31.6 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define glib2_version 2.48.0
2%define pango_version 1.40.0
3%define gtk3_version 3.20.0
4%define libxml2_version 2.9.1
5%define eog_version 3.20.0
6%define gnome_desktop3_version 3.20.0
7%define vine_menus_version 3.0
8%define startup_notification_version 0.10
9%define libexif_version 0.6.19
10%define tracker_version 1.6.0
11%define gobject_introspection_version 0.9.8
12
13%define _unpackaged_files_terminate_build 1
14
15Name:           nautilus
16Summary:        Nautilus is a file manager for GNOME
17Summary(ja):    Nautilus - GNOME ファイルマネージャ
18Version:        3.30.5
19Release:        1%{?_dist_release}
20License:        GPLv2+
21Group:          User Interface/Desktops
22URL:            http://www.gnome.org/projects/nautilus/
23
24Vendor:         Project Vine
25Distribution:   Vine Linux
26
27Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.20/%{name}-%{version}.tar.xz
28
29# vine
30Patch2000:      nautilus-vine-settings.patch
31
32BuildRoot:      %{_tmppath}/%{name}-%{version}-root
33Requires:       gamin
34Requires:       vine-menus >= %{vine_menus_version}
35Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
36Requires:       libexif >= %{libexif_version}
37Requires:       %{name}-libs = %{version}-%{release}
38
39BuildRequires:  meson
40BuildRequires:  intltool
41BuildRequires:  desktop-file-utils
42
43BuildRequires:  glib2-devel >= %{glib2_version}
44BuildRequires:  pango-devel >= %{pango_version}
45BuildRequires:  gtk3-devel >= %{gtk3_version}
46BuildRequires:  libxml2-devel >= %{libxml2_version}
47BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
48BuildRequires:  gamin-devel
49BuildRequires:  startup-notification-devel >= %{startup_notification_version}
50BuildRequires:  tracker-devel >= %{tracker_version}
51BuildRequires:  libexif-devel >= %{libexif_version}
52BuildRequires:  unique3-devel
53BuildRequires:  libnotify-devel
54BuildRequires:  libSM-devel
55BuildRequires:  exempi-devel
56BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
57BuildRequires:  gsettings-desktop-schemas
58BuildRequires:  libgexiv2-devel
59BuildRequires:  gnome-autoar-devel
60BuildRequires:  libseccomp-devel
61BuildRequires:  libappstream-glib-devel
62
63Obsoletes:      nautilus-extras
64Obsoletes:      nautilus-suggested
65Obsoletes:      nautilus-mozilla < 2.0
66Obsoletes:      eel2 <= 2.24.1
67
68Provides:       eel2 <= 2.24.1
69
70
71%description
72Nautilus integrates access to files, applications, media,
73Internet-based resources and the Web. Nautilus delivers a dynamic and
74rich user experience. Nautilus is an free software project developed
75under the GNU General Public License and is a core component of the
76GNOME desktop project.
77
78%description -l ja
79Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
80リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
81豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
82のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
83プロジェクトのコア・コンポーネントです。
84
85
86%package        devel
87Summary:        Support for developing nautilus extensions
88Summary(ja):    Nautilus 拡張機能開発のためのサポート
89License:        LGPLv2+
90Group:          Development/Libraries
91Requires:       %{name}-libs = %{version}-%{release}
92Requires:       pkgconfig
93
94%description    devel
95This package provides libraries and header files needed
96for developing nautilus extensions.
97
98%description -l ja devel
99このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
100ヘッダファイルを提供します。
101
102
103%package        libs
104Summary:        Libraries for use in nautilus extentions
105Summary(ja):    Nautilus 拡張機能で利用するライブラリ
106Group:          System Environment/Libraries
107
108%description    libs
109This package provides libraries required by nautilus extention
110module.
111
112%description -l ja libs
113このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
114
115
116%package        docs
117Summary:        Documentation for %{name}
118Summary(ja):    %{name} 用のドキュメント
119Group:          Documentation
120BuildArch:      noarch
121
122%description    docs
123This package contains documentation for %{name}.
124
125
126%prep
127%setup -q -n %{name}-%{version}
128
129%patch2000 -p1 -b .vine
130
131%build
132%meson \
133  -Dselinux=false \
134  -Dpackagekit=true \
135  -Dintrospection=true \
136  -Dintrospection=true \
137  -Ddocs=true
138
139%meson_build
140
141%install
142rm -rf $RPM_BUILD_ROOT
143
144%meson_install
145
146# make sure desktop files validate by ignoring sr@Latn
147perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
148# desktop-file-install can't handle empty OnlyShowIn correctly
149perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
150
151desktop-file-install --vendor "" --delete-original       \
152  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
153  --add-only-show-in GNOME                                  \
154  $RPM_BUILD_ROOT%{_datadir}/applications/*
155
156%find_lang %name
157
158%clean
159rm -rf $RPM_BUILD_ROOT
160
161%postun
162if [ $1 -eq 0 ] ; then
163    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
164fi
165
166%posttrans
167glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
168
169%post libs -p /sbin/ldconfig
170%postun libs -p /sbin/ldconfig
171
172
173%files  -f %{name}.lang
174%defattr(-,root,root,-)
175%license LICENSE
176%doc NEWS README*
177%dir %{_libdir}/nautilus
178%dir %{_libdir}/nautilus/extensions-3.0
179%{_libdir}/nautilus/extensions-3.0/*.so
180%{_datadir}/metainfo/org.gnome.Nautilus.appdata.xml
181%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
182%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
183%{_datadir}/gnome-shell/search-providers/org.gnome.Nautilus.search-provider.ini
184%{_datadir}/applications/*.desktop
185%{_datadir}/icons/hicolor/*/apps/*
186%{_bindir}/*
187%{_datadir}/glib-2.0/schemas/
188%{_mandir}/man1/*
189
190%files devel
191%defattr(-,root,root,-)
192%{_includedir}/nautilus
193%{_libdir}/pkgconfig/*
194%{_libdir}/*.so
195%{_datadir}/gir-1.0
196
197%files libs
198%defattr(-,root,root,-)
199%{_libdir}/*.so.*
200%{_libdir}/girepository-1.0/*.typelib
201
202%files docs
203%defattr(-,root,root,-)
204%{_datadir}/gtk-doc/html/libnautilus-extension/*
205
206
207%changelog
208* Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.5-1
209- new upstream release.
210- dropped Patch102.
211- updated Patch2000.
212
213* Sat Jul 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.2-1
214- new upstream release
215- update Patch2000
216
217* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.4-1
218- new upstream release
219
220* Sat Nov 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
221- new upstream release
222
223* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
224- new upstream release
225
226* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
227- new upstream release
228
229* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
230- new upstream release
231
232* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
233- new upstream release
234- update Patch2000 (nautilus-vine-settings.patch)
235- create %%{name}-docs subpackage
236
237* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.2-2
238- moved libs subpackage to System Environment/Libraries Group
239
240* Wed Nov 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
241- new upstream release
242
243* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
244- new upstream release
245- remove Patch0 (nautilus-3.14.0-git20141015.patch)
246
247* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
248- new upstream release
249- add Patch0 (nautilus-3.14.0-git20141015.patch)
250
251* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
252- new upstream release
253
254* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
255- new upstream release
256
257* Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
258- new upstream release
259
260* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
261- new upstream release
262- add Patch2000 (nautilus-vine-settings.patch)
263
264* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
265- new upstream release
266
267* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
268- new upstream release
269
270* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
271- new upstream release
272
273* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
274- new upstream release
275
276* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
277- new upstream release
278
279* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
280- new upstream release
281- remove Patch0,7
282- add BuildRequires: exempi-devel, tracker-devel
283
284* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
285- add Patch0 (nautilus-3.4.2-ja.po.patch)
286
287* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
288- new upstream release
289
290* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
291- new upstream release
292
293* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
294- added patch102 to fix autostart in other desktop environments
295  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
296
297* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
298- new upstream release
299
300* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
301- new upstream release
302
303* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
304- new upstream release
305
306* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
307- new upstream release
308
309* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
310- new upstream release
311- drop Patch101
312- change BuildRequires: gtk3-devel instread of gtk2-devel
313- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
314- change BuildRequires: unique3-devel instread of unique-devel
315- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
316
317* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
318- fixed group of libs
319- add translation of summary and description.
320- add Vendor, Distribution and Packager tags.
321
322* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
323- new upstream release
324
325* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
326- new upstream release
327
328* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
329 - new upstream release
330
331* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
332- new upstream release
333- add BuildRequires: gobject-introspection-devel
334- remove BuildRequires: libgnomeui-devel
335- add configure option (--enable-introspection=yes)
336
337* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
338- rebuild with rpm-4.8.1 for pkg-config file
339
340* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
341- split nautilus extention libraries to -libs subpackage.
342
343* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
344- new upstream release
345
346* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
347- new upstream release
348- drop Patch100
349- add Patch101
350- add Obsoletes: eel2 <= 2.24.1
351- add Provides: eel2 <= 2.24.1
352
353* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
354- new upstream release
355- add BuildRequires: libSM-devel
356
357* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
358- removed Requires: eel2
359- added %%posttrans section
360
361* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
362- new upstream release
363
364* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
365- new upstream release
366
367* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
368- new upstream release
369
370* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
371- new upstream release
372- split -devel subpackage
373
374* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
375- new upstream release
376
377* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
378- patch6 needs autoreconf
379
380* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
381- new upstream release
382
383* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
384- new upstream release
385
386* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
387- new upstream release
388- added Requires: gvfs
389
390* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
391- new upstream release
392- added Patches from FC
393  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
394  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
395  - Fix a crash in the Properties dialog while changing owner (patch from head)
396  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
397  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
398
399* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
400- new upstream release
401- dropped Patch11-13 and added Patch7-9 from Fedora
402  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
403  - Add patch from upstream to get audio preview working again
404    (#332251)
405  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
406  - Fix a crash with small fonts (#242350)
407  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
408  - Backport fixes for async thumbnail loading from svn
409
410* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
411- run autoreconf for Patch11 changes
412
413* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
414- remove tracker dependancy, Patch13 detects tracker dynamically.
415
416* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
417- add Patch13 to support user-dirs
418
419* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
420- new upstream release
421- enable tracker support
422- add BuildRequires: tracker-devel, Requires: tracker
423
424* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
425- new upstream release
426
427* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
428- add BuildRequires: gamin-devel, Requires: gamin
429- remove fam dependency (replaced by gamin)
430
431* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
432- new upsteram release
433
434* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
435- really applied Patch110...
436
437* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
438- add Patch110 to fix corruption of help option message.
439
440* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
441- new upstream release
442
443* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
444- fix typo in ja.po
445
446* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
447- update ja.po to translate patch50 related message.
448
449* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
450- add Patch50 to show progressbar on umounting
451  (ubuntu patch in Bug 313639)
452
453* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
454- new upstream release
455
456* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
457- add Patch10 to avoid background rendering delay
458
459* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
460- new upstream release
461
462* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
463- add fix-non-UTF-8-encoding.patch (patch0)
464  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
465
466* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
467- new upstream release
468
469* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
470- new upstream release
471
472* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
473- new upstream release
474
475* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
476- new upstream release
477
478* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
479- rebuild
480
481* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
482- new upstream version
483
484* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
485- new upstream version
486
487* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
488- add vine patch to change some defaults.
489  - change default zoom sine
490  - set always_use_browser
491
492* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
493- new upstream release
494
495* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
496- add Patch110 to fix libegg(egg-recent-model.c)
497  save old umask value before create ".recently-used" file.
498 
499* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
500- change default desktop font to Sans 9 (from Sans 10)
501- add patch10 to build with gtk+-2.4
502
503* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
504- new upstream release
505
506* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
507- new upstream release
508
509* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
510- add backport patch from rawhide (Patch10)
511
512* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
513- modified vine patch
514  - change default zoom level to small
515  - change desktop font to Sans 10
516
517* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
518- new upstream release
519
520* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
521- add desktop icon patch from rawhide
522
523* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
524- remove obsolete ja.po
525
526* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
527- new upstream release
528
529* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
530- new upstream release
531
532* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
533- new upstream release
534
535* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
536- update ja.po
537
538* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
539- new upstream release
540
541* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
542- new upstream release
543
544* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
545- new upstream release
546
547* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
548- new upstream release
549
550* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
551- new upstream release
552
553* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
554- new upstream release
555
556* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
557- add nautilus-cd-burner patch
558
559* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
560- new upstream release
561
562* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
563- discard scrollkeeper outputs.
564- update PreReq tags.
565
566* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
567- change icon for nautilus-file-management-properties
568- update ja.po
569
570* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
571- update ja.po
572- add translation for .desktop files.
573
574* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
575- add Requires: vine-menus
576
577* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
578- new upstream release
579
580* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
581- remove redhatize patch
582
583* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
584- rebuild to remove unneeded dependancy.
585
586* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
587- build for Vine Linux
588
589* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
590- add explicit startup-notification dependency because build system is
591  dumb
592- 2.1.3
593
594* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
595- 2.1.2
596
597* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
598- 2.0.7
599- remove patches that are upstream
600
601* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
602- Add badhack to make weblinks on desktop work
603
604* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
605- fix #70667 assertion failures
606- fix triple click patch
607
608* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
609- don't activate on double click
610
611* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
612- put button press mask in triple-click patch, maybe it will work
613- remove html-hack patch as it does nothing useful
614
615* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
616- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
617  bogus bug reports
618- add hack for HTML mime type handling in a web browser, not
619  nautilus
620
621* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
622- Updated to 2.0.6. Removed the patches I put upstream.
623- Added patch that fixes #72410
624
625* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
626- Add a simple patch so that redhat-config-packages can disable
627  the new window behavior for mounted CDs behavior.
628
629* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
630- Add patch to fix bug #70667
631
632* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
633- remove mp3
634
635* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
636- ignore the "add_to_session" preference as it only broke stuff
637- pad the left margin a bit to cope with poor word wrapping
638
639* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
640- Update to 2.0.5, remove topleft icon patch
641
642* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
643- Add patch to fix the bug where desktop icons get
644  stuck in the top left corner on startup
645
646* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
647- 2.0.4
648
649* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
650- obsolete nautilus-mozilla < 2.0 #69839
651
652* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
653- add rhconfig patch to Bluecurve theme and disable sidebar by default
654
655* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
656- drop start here files, require redhat-menus that has them
657
658* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
659- 2.0.3
660
661* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
662- build for new eel2, gail
663
664* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
665- and add the libexec components, mumble
666
667* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
668- put the components in the file list, were moved upstream
669
670* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
671- 2.0.1
672
673* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
674- Relibtoolize to fix relink problems for solib components
675- Add LANG=en_US to %makeinstall as well
676- Back out previous change, force locale to en_US to prevent UTF-8 problems
677- Add workaround for intltool-merge bug on ia64
678
679* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
680- automated rebuild
681
682* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
683- 2.0.0
684- use desktop-file-install
685- require desktop-backgrounds-basic
686
687* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
688- add wacky hack in hopes of fixing the hang-on-login thing
689
690* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
691- add build requires on new gail
692- rebuild to try to lose broken libgailutil.so.13 dependency
693
694* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
695- rebuild in different environment
696
697* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
698- 1.1.19
699
700* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
701- rebuild in different environment
702
703* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
704- really remove nautilus-devel if we are going to obsolete it
705- don't require hwbrowser
706
707* Sun May 26 2002 Tim Powers <timp@redhat.com>
708- automated rebuild
709
710* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
711- rebuild in different environment
712
713* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
714- 1.1.17
715
716* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
717- 1.1.14
718
719* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
720- require eog
721- obsolete nautilus-devel
722- fix name of schemas file in post
723
724* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
725- Update to 1.1.13
726
727* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
728- put tree view in file list
729
730* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
731- nautilus for gnome 2
732- clean up the spec file and file list a bit
733
734* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
735- merge translations
736
737* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
738- Add patch to fix trash crash
739
740* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
741- fix for metadata tmp race
742- backport thumbnail speed fix and thumbnail inf. loop fix
743
744* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
745- add some fixes from CVS version, including one for #61819 and a couple segfaults
746
747* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
748- fix thumbnails for files with future timestamp, #56862
749
750* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
751- buildrequires intltool #60633
752- apply Alex's pixbuf cache patch to save a few megs #60581
753
754* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
755- drop Milan-specific features, including png10 and ac25 patches
756- copy in 1.0.5 help component to avoid large risky patch
757- remove .la files
758- drop mozilla from ia64 again
759- remove oaf file from nautilus-mozilla that was also in the base
760  package
761
762* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
763- enable mozilla support on ia64
764
765* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
766- require Mozilla 0.9.7
767- Add patch that puts mozilla profile startup before embedding is initialized
768
769* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
770- 1.0.6, require Mozilla 0.9.6
771
772* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
773- Update to 1.0.5
774
775* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
776- Fix handling of GnomeVFSFileInfo structure (#53315)
777
778* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
779- Change handling of names on unmount to fix #52325
780
781* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
782- put nautilus-help.desktop in file list; #53109
783
784* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
785- Add po files from sources.redhat.com
786
787* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
788- Add po files from sources.redhat.com
789
790* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
791- Added patch to fix the .directory issuer
792
793* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
794- I screwed up the build yesterday, so it didn't actually contain the
795  fixes mentioned. This build should contain them.
796
797* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
798- fix bug causing 32000 stats or so in large directories,
799  should speed things up somewhat
800- fix #52104 via gruesome kdesktop-detection hack and setting
801  window type hint on our desktop window
802- fix so Start Here icon displays in sidebar
803- don't load non-local .desktop files
804
805* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
806- make Programs icon into a link, to match the other .desktop files
807- own various directories #51164
808- web page titles in Japanese, #51709
809- tree defaults to only directories #51850
810
811* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
812- make start here icon work again
813- kill some warning spew, #51661
814- cache getpwnam() results to speed things up a bit
815
816* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
817- Fix problem with missing desktop starthere.desktop file
818- New snapshot from our branch, fixes:
819  - On upgrade, icons migrated from GNOME desktop are not properly lined up
820    (#51436)
821  - icons dropped on the desktop don't end up where dropped. (#51441)
822  - Nautilus shouldn't have fam monitor read-only windows. This
823    keeps CDROMS from being unmounted until you close all
824
825    nautilus windows pointing to them. (#51442)
826  - Warnings about 'cannot statfs...' when moving items to trash.
827- Use separate start-here.desktop for panel, since the one used
828  for the root window only works from Nautilus.
829
830* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
831- Changed starthere .desktop files to be links instead
832- of spawning a new nautilus. This makes start-here:
833- much faster.
834
835* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
836- Added hwbrowser dependency
837- New snapshot, fixes the mozilla-view submit form problem
838
839* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
840- Rebuild with new xml-i18n-tools
841- fix crash in creating new desktop files
842
843* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
844- Fix up DnD code some more
845
846* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
847- Sync our CVS version; fixes some MUSTFIX
848  (the one about drawing background on startup,
849   properly translate desktop files, etc.)
850
851* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
852- Fix 64bit cleanness issue
853- Fix NULL mimetype crash
854- Disable additional_text for .desktop files
855
856* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
857- Fix unmounting devices.
858
859* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
860- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
861- mimetype sniffing.
862
863* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
864- Remove the "don't run as root" warning.
865- Remove eazel from bookmarks
866- langified (again? did someone change it?)
867
868* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
869- Apply a patch that makes nautilus dnd reset work with the latest
870- eel release.
871
872* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
873- Build on ia64 without the mozilla component.
874
875* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
876- Fix crash-on-startup showstopper
877- Fix can't-find-images bug (this one was only showing up
878  when built with debug symbols, since it was an uninitialized memory
879  read)
880
881* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
882- sync new tarball from our CVS branch,
883  fixes some drag-and-drop, changes URI scheme names,
884  etc.
885
886* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
887- Add BuildRequires (#49539, 49537)
888- Fix %%post, %%postun (#49720)
889- Background efficiency improvements and hacks
890
891* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
892- Don't launch esd on each mouseover.
893
894* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
895- move first time druid patch into my "CVS outstanding" patch
896- try to really remove Help/Feedback
897- try to really fix Help/Community Support
898- try again to get Start Here in the Go menu
899- try again to get Start Here on the desktop
900- don't show file sizes for .desktop files
901
902* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
903- add newline to ends of .desktop files that were missing them
904
905* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
906- update to my latest 'cvs diff -u' (adds default
907  Start Here link, displays .directory name in sidebar)
908- include /etc/X11/* links (starthere, sysconfig, serverconfig)
909
910* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
911- Patch to remove firsttime druid and flash
912
913* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
914- add hacks for displaying desktop files
915- add hack to turn off the "unwriteable" emblem
916
917* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
918- added defattr to the files lists to be (-,root,root)
919- languified
920
921* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
922- Need to run autoheader too.
923
924* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
925- Make the fam dependency a real runtime dependency
926- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
927- Cleaned up specfile.
928
929* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
930- Change default background and rubberband color.
931- Use the sidebar tabs from the default theme
932- BuildDepend on fam-devel, depend on fam
933- Disable the eazel update pages in the first-time druid.
934- Remove the eazel logo from the first-time druid
935
936* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
937- 1.0.4, removes eazel services icon and wizard page
938- Eazel logo is still in startup wizard for now, needs fixing
939
940* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
941- fix group (s/Desktop/Desktops/) #47134
942- remove ammonite dependency
943
944* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
945- add a different default theme
946- clean up file list overspecificity a bit
947
948* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
949- move to a CVS snapshot of nautilus for now
950  (Darin is my hero for having distcheck work out of CVS)
951
952* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
953- clean up defaults a bit
954
955* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
956- New version
957
958* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
959- Added BuildRequires lines
960- Changed Source to point to ftp.gnome.org instead of just the tarball name
961- Moved %description sections closer to their %package sections
962- Moved %changelog to the end, where so that it's not in the way
963- Changed configure and make install options to allow moving of
964  libraries, includes, binaries more easily
965- Removed hard-coded paths (don't define %prefix or %docdir)
966- replace %{prefix}/bin with %{_bindir}
967- replace %{prefix}/share with %{_datadir}
968- replace %{prefix}/lib with %{_libdir}
969- replace %{prefix}/include with %{_includedir}
970
971* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
972- removed obsoletes from sub packages and added mozilla and trilobite
973subpackages
974
975* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
976- created this thing
Note: See TracBrowser for help on using the repository browser.