source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 12161

Revision 12161, 31.8 KB checked in by tomop, 5 years ago (diff)

nautilus-3.30.5-2

Line 
1%define glib2_version 2.48.0
2%define pango_version 1.40.0
3%define gtk3_version 3.20.0
4%define libxml2_version 2.9.1
5%define eog_version 3.20.0
6%define gnome_desktop3_version 3.20.0
7%define vine_menus_version 3.0
8%define startup_notification_version 0.10
9%define libexif_version 0.6.19
10%define tracker_version 1.6.0
11%define gobject_introspection_version 0.9.8
12
13%define _unpackaged_files_terminate_build 1
14
15Name:           nautilus
16Summary:        Nautilus is a file manager for GNOME
17Summary(ja):    Nautilus - GNOME ファイルマネージャ
18Version:        3.30.5
19Release:        2%{?_dist_release}
20License:        GPLv2+
21Group:          User Interface/Desktops
22URL:            http://www.gnome.org/projects/nautilus/
23
24Vendor:         Project Vine
25Distribution:   Vine Linux
26
27Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.20/%{name}-%{version}.tar.xz
28
29# vine
30Patch2000:      nautilus-vine-settings.patch
31
32BuildRoot:      %{_tmppath}/%{name}-%{version}-root
33Requires:       gamin
34Requires:       vine-menus >= %{vine_menus_version}
35Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
36Requires:       libexif >= %{libexif_version}
37Requires:       %{name}-libs = %{version}-%{release}
38
39BuildRequires:  meson
40BuildRequires:  intltool
41BuildRequires:  desktop-file-utils
42
43BuildRequires:  glib2-devel >= %{glib2_version}
44BuildRequires:  pango-devel >= %{pango_version}
45BuildRequires:  gtk3-devel >= %{gtk3_version}
46BuildRequires:  libxml2-devel >= %{libxml2_version}
47BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
48BuildRequires:  gamin-devel
49BuildRequires:  startup-notification-devel >= %{startup_notification_version}
50BuildRequires:  tracker-devel >= %{tracker_version}
51BuildRequires:  libexif-devel >= %{libexif_version}
52BuildRequires:  unique3-devel
53BuildRequires:  libnotify-devel
54BuildRequires:  libSM-devel
55BuildRequires:  exempi-devel
56BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
57BuildRequires:  gsettings-desktop-schemas
58BuildRequires:  libgexiv2-devel
59BuildRequires:  gnome-autoar-devel
60BuildRequires:  libseccomp-devel
61BuildRequires:  libappstream-glib-devel
62BuildRequires:  python3-devel
63
64Obsoletes:      nautilus-extras
65Obsoletes:      nautilus-suggested
66Obsoletes:      nautilus-mozilla < 2.0
67Obsoletes:      eel2 <= 2.24.1
68
69Provides:       eel2 <= 2.24.1
70
71
72%description
73Nautilus integrates access to files, applications, media,
74Internet-based resources and the Web. Nautilus delivers a dynamic and
75rich user experience. Nautilus is an free software project developed
76under the GNU General Public License and is a core component of the
77GNOME desktop project.
78
79%description -l ja
80Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
81リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
82豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
83のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
84プロジェクトのコア・コンポーネントです。
85
86
87%package        devel
88Summary:        Support for developing nautilus extensions
89Summary(ja):    Nautilus 拡張機能開発のためのサポート
90License:        LGPLv2+
91Group:          Development/Libraries
92Requires:       %{name}-libs = %{version}-%{release}
93Requires:       pkgconfig
94
95%description    devel
96This package provides libraries and header files needed
97for developing nautilus extensions.
98
99%description -l ja devel
100このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
101ヘッダファイルを提供します。
102
103
104%package        libs
105Summary:        Libraries for use in nautilus extentions
106Summary(ja):    Nautilus 拡張機能で利用するライブラリ
107Group:          System Environment/Libraries
108
109%description    libs
110This package provides libraries required by nautilus extention
111module.
112
113%description -l ja libs
114このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
115
116
117%package        docs
118Summary:        Documentation for %{name}
119Summary(ja):    %{name} 用のドキュメント
120Group:          Documentation
121BuildArch:      noarch
122
123%description    docs
124This package contains documentation for %{name}.
125
126
127%prep
128%setup -q -n %{name}-%{version}
129
130%patch2000 -p1 -b .vine
131
132%build
133%meson \
134  -Dselinux=false \
135  -Dpackagekit=true \
136  -Dintrospection=true \
137  -Dintrospection=true \
138  -Ddocs=true
139
140%meson_build
141
142%install
143rm -rf $RPM_BUILD_ROOT
144
145%meson_install
146
147# make sure desktop files validate by ignoring sr@Latn
148perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
149# desktop-file-install can't handle empty OnlyShowIn correctly
150perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
151
152desktop-file-install --vendor "" --delete-original       \
153  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
154  --add-only-show-in GNOME                                  \
155  $RPM_BUILD_ROOT%{_datadir}/applications/*
156
157%find_lang %name
158
159%clean
160rm -rf $RPM_BUILD_ROOT
161
162%postun
163if [ $1 -eq 0 ] ; then
164    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
165fi
166
167%posttrans
168glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
169
170%post libs -p /sbin/ldconfig
171%postun libs -p /sbin/ldconfig
172
173
174%files  -f %{name}.lang
175%defattr(-,root,root,-)
176%license LICENSE
177%doc NEWS README*
178%dir %{_libdir}/nautilus
179%dir %{_libdir}/nautilus/extensions-3.0
180%{_libdir}/nautilus/extensions-3.0/*.so
181%{_datadir}/metainfo/org.gnome.Nautilus.appdata.xml
182%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
183%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
184%{_datadir}/gnome-shell/search-providers/org.gnome.Nautilus.search-provider.ini
185%{_datadir}/applications/*.desktop
186%{_datadir}/icons/hicolor/*/apps/*
187%{_bindir}/*
188%{_datadir}/glib-2.0/schemas/
189%{_mandir}/man1/*
190
191%files devel
192%defattr(-,root,root,-)
193%{_includedir}/nautilus
194%{_libdir}/pkgconfig/*
195%{_libdir}/*.so
196%{_datadir}/gir-1.0
197
198%files libs
199%defattr(-,root,root,-)
200%{_libdir}/*.so.*
201%{_libdir}/girepository-1.0/*.typelib
202
203%files docs
204%defattr(-,root,root,-)
205%{_datadir}/gtk-doc/html/libnautilus-extension/*
206
207
208%changelog
209* Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.5-1
210- rebuilt with tracker-2.2.2.
211
212* Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.5-1
213- new upstream release.
214- dropped Patch102.
215- updated Patch2000.
216
217* Sat Jul 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.2-1
218- new upstream release
219- update Patch2000
220
221* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.4-1
222- new upstream release
223
224* Sat Nov 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
225- new upstream release
226
227* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
228- new upstream release
229
230* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
231- new upstream release
232
233* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
234- new upstream release
235
236* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
237- new upstream release
238- update Patch2000 (nautilus-vine-settings.patch)
239- create %%{name}-docs subpackage
240
241* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.2-2
242- moved libs subpackage to System Environment/Libraries Group
243
244* Wed Nov 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
245- new upstream release
246
247* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
248- new upstream release
249- remove Patch0 (nautilus-3.14.0-git20141015.patch)
250
251* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
252- new upstream release
253- add Patch0 (nautilus-3.14.0-git20141015.patch)
254
255* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
256- new upstream release
257
258* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
259- new upstream release
260
261* Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
262- new upstream release
263
264* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
265- new upstream release
266- add Patch2000 (nautilus-vine-settings.patch)
267
268* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
269- new upstream release
270
271* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
272- new upstream release
273
274* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
275- new upstream release
276
277* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
278- new upstream release
279
280* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
281- new upstream release
282
283* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
284- new upstream release
285- remove Patch0,7
286- add BuildRequires: exempi-devel, tracker-devel
287
288* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
289- add Patch0 (nautilus-3.4.2-ja.po.patch)
290
291* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
292- new upstream release
293
294* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
295- new upstream release
296
297* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
298- added patch102 to fix autostart in other desktop environments
299  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
300
301* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
302- new upstream release
303
304* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
305- new upstream release
306
307* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
308- new upstream release
309
310* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
311- new upstream release
312
313* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
314- new upstream release
315- drop Patch101
316- change BuildRequires: gtk3-devel instread of gtk2-devel
317- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
318- change BuildRequires: unique3-devel instread of unique-devel
319- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
320
321* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
322- fixed group of libs
323- add translation of summary and description.
324- add Vendor, Distribution and Packager tags.
325
326* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
327- new upstream release
328
329* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
330- new upstream release
331
332* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
333 - new upstream release
334
335* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
336- new upstream release
337- add BuildRequires: gobject-introspection-devel
338- remove BuildRequires: libgnomeui-devel
339- add configure option (--enable-introspection=yes)
340
341* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
342- rebuild with rpm-4.8.1 for pkg-config file
343
344* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
345- split nautilus extention libraries to -libs subpackage.
346
347* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
348- new upstream release
349
350* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
351- new upstream release
352- drop Patch100
353- add Patch101
354- add Obsoletes: eel2 <= 2.24.1
355- add Provides: eel2 <= 2.24.1
356
357* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
358- new upstream release
359- add BuildRequires: libSM-devel
360
361* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
362- removed Requires: eel2
363- added %%posttrans section
364
365* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
366- new upstream release
367
368* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
369- new upstream release
370
371* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
372- new upstream release
373
374* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
375- new upstream release
376- split -devel subpackage
377
378* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
379- new upstream release
380
381* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
382- patch6 needs autoreconf
383
384* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
385- new upstream release
386
387* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
388- new upstream release
389
390* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
391- new upstream release
392- added Requires: gvfs
393
394* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
395- new upstream release
396- added Patches from FC
397  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
398  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
399  - Fix a crash in the Properties dialog while changing owner (patch from head)
400  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
401  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
402
403* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
404- new upstream release
405- dropped Patch11-13 and added Patch7-9 from Fedora
406  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
407  - Add patch from upstream to get audio preview working again
408    (#332251)
409  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
410  - Fix a crash with small fonts (#242350)
411  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
412  - Backport fixes for async thumbnail loading from svn
413
414* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
415- run autoreconf for Patch11 changes
416
417* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
418- remove tracker dependancy, Patch13 detects tracker dynamically.
419
420* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
421- add Patch13 to support user-dirs
422
423* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
424- new upstream release
425- enable tracker support
426- add BuildRequires: tracker-devel, Requires: tracker
427
428* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
429- new upstream release
430
431* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
432- add BuildRequires: gamin-devel, Requires: gamin
433- remove fam dependency (replaced by gamin)
434
435* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
436- new upsteram release
437
438* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
439- really applied Patch110...
440
441* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
442- add Patch110 to fix corruption of help option message.
443
444* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
445- new upstream release
446
447* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
448- fix typo in ja.po
449
450* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
451- update ja.po to translate patch50 related message.
452
453* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
454- add Patch50 to show progressbar on umounting
455  (ubuntu patch in Bug 313639)
456
457* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
458- new upstream release
459
460* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
461- add Patch10 to avoid background rendering delay
462
463* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
464- new upstream release
465
466* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
467- add fix-non-UTF-8-encoding.patch (patch0)
468  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
469
470* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
471- new upstream release
472
473* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
474- new upstream release
475
476* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
477- new upstream release
478
479* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
480- new upstream release
481
482* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
483- rebuild
484
485* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
486- new upstream version
487
488* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
489- new upstream version
490
491* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
492- add vine patch to change some defaults.
493  - change default zoom sine
494  - set always_use_browser
495
496* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
497- new upstream release
498
499* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
500- add Patch110 to fix libegg(egg-recent-model.c)
501  save old umask value before create ".recently-used" file.
502 
503* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
504- change default desktop font to Sans 9 (from Sans 10)
505- add patch10 to build with gtk+-2.4
506
507* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
508- new upstream release
509
510* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
511- new upstream release
512
513* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
514- add backport patch from rawhide (Patch10)
515
516* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
517- modified vine patch
518  - change default zoom level to small
519  - change desktop font to Sans 10
520
521* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
522- new upstream release
523
524* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
525- add desktop icon patch from rawhide
526
527* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
528- remove obsolete ja.po
529
530* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
531- new upstream release
532
533* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
534- new upstream release
535
536* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
537- new upstream release
538
539* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
540- update ja.po
541
542* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
543- new upstream release
544
545* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
546- new upstream release
547
548* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
549- new upstream release
550
551* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
552- new upstream release
553
554* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
555- new upstream release
556
557* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
558- new upstream release
559
560* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
561- add nautilus-cd-burner patch
562
563* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
564- new upstream release
565
566* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
567- discard scrollkeeper outputs.
568- update PreReq tags.
569
570* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
571- change icon for nautilus-file-management-properties
572- update ja.po
573
574* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
575- update ja.po
576- add translation for .desktop files.
577
578* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
579- add Requires: vine-menus
580
581* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
582- new upstream release
583
584* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
585- remove redhatize patch
586
587* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
588- rebuild to remove unneeded dependancy.
589
590* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
591- build for Vine Linux
592
593* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
594- add explicit startup-notification dependency because build system is
595  dumb
596- 2.1.3
597
598* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
599- 2.1.2
600
601* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
602- 2.0.7
603- remove patches that are upstream
604
605* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
606- Add badhack to make weblinks on desktop work
607
608* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
609- fix #70667 assertion failures
610- fix triple click patch
611
612* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
613- don't activate on double click
614
615* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
616- put button press mask in triple-click patch, maybe it will work
617- remove html-hack patch as it does nothing useful
618
619* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
620- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
621  bogus bug reports
622- add hack for HTML mime type handling in a web browser, not
623  nautilus
624
625* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
626- Updated to 2.0.6. Removed the patches I put upstream.
627- Added patch that fixes #72410
628
629* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
630- Add a simple patch so that redhat-config-packages can disable
631  the new window behavior for mounted CDs behavior.
632
633* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
634- Add patch to fix bug #70667
635
636* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
637- remove mp3
638
639* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
640- ignore the "add_to_session" preference as it only broke stuff
641- pad the left margin a bit to cope with poor word wrapping
642
643* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
644- Update to 2.0.5, remove topleft icon patch
645
646* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
647- Add patch to fix the bug where desktop icons get
648  stuck in the top left corner on startup
649
650* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
651- 2.0.4
652
653* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
654- obsolete nautilus-mozilla < 2.0 #69839
655
656* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
657- add rhconfig patch to Bluecurve theme and disable sidebar by default
658
659* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
660- drop start here files, require redhat-menus that has them
661
662* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
663- 2.0.3
664
665* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
666- build for new eel2, gail
667
668* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
669- and add the libexec components, mumble
670
671* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
672- put the components in the file list, were moved upstream
673
674* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
675- 2.0.1
676
677* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
678- Relibtoolize to fix relink problems for solib components
679- Add LANG=en_US to %makeinstall as well
680- Back out previous change, force locale to en_US to prevent UTF-8 problems
681- Add workaround for intltool-merge bug on ia64
682
683* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
684- automated rebuild
685
686* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
687- 2.0.0
688- use desktop-file-install
689- require desktop-backgrounds-basic
690
691* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
692- add wacky hack in hopes of fixing the hang-on-login thing
693
694* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
695- add build requires on new gail
696- rebuild to try to lose broken libgailutil.so.13 dependency
697
698* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
699- rebuild in different environment
700
701* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
702- 1.1.19
703
704* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
705- rebuild in different environment
706
707* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
708- really remove nautilus-devel if we are going to obsolete it
709- don't require hwbrowser
710
711* Sun May 26 2002 Tim Powers <timp@redhat.com>
712- automated rebuild
713
714* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
715- rebuild in different environment
716
717* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
718- 1.1.17
719
720* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
721- 1.1.14
722
723* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
724- require eog
725- obsolete nautilus-devel
726- fix name of schemas file in post
727
728* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
729- Update to 1.1.13
730
731* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
732- put tree view in file list
733
734* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
735- nautilus for gnome 2
736- clean up the spec file and file list a bit
737
738* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
739- merge translations
740
741* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
742- Add patch to fix trash crash
743
744* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
745- fix for metadata tmp race
746- backport thumbnail speed fix and thumbnail inf. loop fix
747
748* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
749- add some fixes from CVS version, including one for #61819 and a couple segfaults
750
751* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
752- fix thumbnails for files with future timestamp, #56862
753
754* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
755- buildrequires intltool #60633
756- apply Alex's pixbuf cache patch to save a few megs #60581
757
758* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
759- drop Milan-specific features, including png10 and ac25 patches
760- copy in 1.0.5 help component to avoid large risky patch
761- remove .la files
762- drop mozilla from ia64 again
763- remove oaf file from nautilus-mozilla that was also in the base
764  package
765
766* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
767- enable mozilla support on ia64
768
769* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
770- require Mozilla 0.9.7
771- Add patch that puts mozilla profile startup before embedding is initialized
772
773* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
774- 1.0.6, require Mozilla 0.9.6
775
776* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
777- Update to 1.0.5
778
779* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
780- Fix handling of GnomeVFSFileInfo structure (#53315)
781
782* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
783- Change handling of names on unmount to fix #52325
784
785* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
786- put nautilus-help.desktop in file list; #53109
787
788* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
789- Add po files from sources.redhat.com
790
791* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
792- Add po files from sources.redhat.com
793
794* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
795- Added patch to fix the .directory issuer
796
797* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
798- I screwed up the build yesterday, so it didn't actually contain the
799  fixes mentioned. This build should contain them.
800
801* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
802- fix bug causing 32000 stats or so in large directories,
803  should speed things up somewhat
804- fix #52104 via gruesome kdesktop-detection hack and setting
805  window type hint on our desktop window
806- fix so Start Here icon displays in sidebar
807- don't load non-local .desktop files
808
809* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
810- make Programs icon into a link, to match the other .desktop files
811- own various directories #51164
812- web page titles in Japanese, #51709
813- tree defaults to only directories #51850
814
815* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
816- make start here icon work again
817- kill some warning spew, #51661
818- cache getpwnam() results to speed things up a bit
819
820* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
821- Fix problem with missing desktop starthere.desktop file
822- New snapshot from our branch, fixes:
823  - On upgrade, icons migrated from GNOME desktop are not properly lined up
824    (#51436)
825  - icons dropped on the desktop don't end up where dropped. (#51441)
826  - Nautilus shouldn't have fam monitor read-only windows. This
827    keeps CDROMS from being unmounted until you close all
828
829    nautilus windows pointing to them. (#51442)
830  - Warnings about 'cannot statfs...' when moving items to trash.
831- Use separate start-here.desktop for panel, since the one used
832  for the root window only works from Nautilus.
833
834* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
835- Changed starthere .desktop files to be links instead
836- of spawning a new nautilus. This makes start-here:
837- much faster.
838
839* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
840- Added hwbrowser dependency
841- New snapshot, fixes the mozilla-view submit form problem
842
843* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
844- Rebuild with new xml-i18n-tools
845- fix crash in creating new desktop files
846
847* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
848- Fix up DnD code some more
849
850* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
851- Sync our CVS version; fixes some MUSTFIX
852  (the one about drawing background on startup,
853   properly translate desktop files, etc.)
854
855* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
856- Fix 64bit cleanness issue
857- Fix NULL mimetype crash
858- Disable additional_text for .desktop files
859
860* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
861- Fix unmounting devices.
862
863* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
864- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
865- mimetype sniffing.
866
867* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
868- Remove the "don't run as root" warning.
869- Remove eazel from bookmarks
870- langified (again? did someone change it?)
871
872* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
873- Apply a patch that makes nautilus dnd reset work with the latest
874- eel release.
875
876* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
877- Build on ia64 without the mozilla component.
878
879* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
880- Fix crash-on-startup showstopper
881- Fix can't-find-images bug (this one was only showing up
882  when built with debug symbols, since it was an uninitialized memory
883  read)
884
885* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
886- sync new tarball from our CVS branch,
887  fixes some drag-and-drop, changes URI scheme names,
888  etc.
889
890* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
891- Add BuildRequires (#49539, 49537)
892- Fix %%post, %%postun (#49720)
893- Background efficiency improvements and hacks
894
895* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
896- Don't launch esd on each mouseover.
897
898* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
899- move first time druid patch into my "CVS outstanding" patch
900- try to really remove Help/Feedback
901- try to really fix Help/Community Support
902- try again to get Start Here in the Go menu
903- try again to get Start Here on the desktop
904- don't show file sizes for .desktop files
905
906* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
907- add newline to ends of .desktop files that were missing them
908
909* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
910- update to my latest 'cvs diff -u' (adds default
911  Start Here link, displays .directory name in sidebar)
912- include /etc/X11/* links (starthere, sysconfig, serverconfig)
913
914* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
915- Patch to remove firsttime druid and flash
916
917* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
918- add hacks for displaying desktop files
919- add hack to turn off the "unwriteable" emblem
920
921* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
922- added defattr to the files lists to be (-,root,root)
923- languified
924
925* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
926- Need to run autoheader too.
927
928* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
929- Make the fam dependency a real runtime dependency
930- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
931- Cleaned up specfile.
932
933* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
934- Change default background and rubberband color.
935- Use the sidebar tabs from the default theme
936- BuildDepend on fam-devel, depend on fam
937- Disable the eazel update pages in the first-time druid.
938- Remove the eazel logo from the first-time druid
939
940* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
941- 1.0.4, removes eazel services icon and wizard page
942- Eazel logo is still in startup wizard for now, needs fixing
943
944* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
945- fix group (s/Desktop/Desktops/) #47134
946- remove ammonite dependency
947
948* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
949- add a different default theme
950- clean up file list overspecificity a bit
951
952* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
953- move to a CVS snapshot of nautilus for now
954  (Darin is my hero for having distcheck work out of CVS)
955
956* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
957- clean up defaults a bit
958
959* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
960- New version
961
962* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
963- Added BuildRequires lines
964- Changed Source to point to ftp.gnome.org instead of just the tarball name
965- Moved %description sections closer to their %package sections
966- Moved %changelog to the end, where so that it's not in the way
967- Changed configure and make install options to allow moving of
968  libraries, includes, binaries more easily
969- Removed hard-coded paths (don't define %prefix or %docdir)
970- replace %{prefix}/bin with %{_bindir}
971- replace %{prefix}/share with %{_datadir}
972- replace %{prefix}/lib with %{_libdir}
973- replace %{prefix}/include with %{_includedir}
974
975* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
976- removed obsoletes from sub packages and added mozilla and trilobite
977subpackages
978
979* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
980- created this thing
Note: See TracBrowser for help on using the repository browser.