source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 9876

Revision 9876, 31.6 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1%define glib2_version 2.46.0
2%define pango_version 1.38.1
3%define gtk3_version 3.18.0
4%define libxml2_version 2.9.1
5%define eog_version 3.18.0
6%define gnome_desktop3_version 3.18.0
7%define vine_menus_version 3.0
8%define startup_notification_version 0.10
9%define libexif_version 0.6.19
10%define tracker_version 1.6.0
11%define gobject_introspection_version 0.9.8
12
13Name:           nautilus
14Summary:        Nautilus is a file manager for GNOME
15Summary(ja):    Nautilus - GNOME ファイルマネージャ
16Version:        3.18.4
17Release:        1%{?_dist_release}
18License:        GPLv2+
19Group:          User Interface/Desktops
20URL:            http://www.gnome.org/projects/nautilus/
21
22Vendor:         Project Vine
23Distribution:   Vine Linux
24Packager:       Takemikaduchi
25
26Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.18/%{name}-%{version}.tar.xz
27
28# vine
29Patch102:       run_in_gnome.patch
30Patch2000:      nautilus-vine-settings.patch
31
32BuildRoot:      %{_tmppath}/%{name}-%{version}-root
33Requires:       gamin
34Requires:       vine-menus >= %{vine_menus_version}
35Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
36Requires:       libexif >= %{libexif_version}
37Requires:       %{name}-libs = %{version}-%{release}
38
39BuildRequires:  intltool
40BuildRequires:  libtool >= 1.4.2-10
41BuildRequires:  automake, autoconf
42BuildRequires:  desktop-file-utils
43
44BuildRequires:  glib2-devel >= %{glib2_version}
45BuildRequires:  pango-devel >= %{pango_version}
46BuildRequires:  gtk3-devel >= %{gtk3_version}
47BuildRequires:  libxml2-devel >= %{libxml2_version}
48BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
49BuildRequires:  gamin-devel
50BuildRequires:  startup-notification-devel >= %{startup_notification_version}
51BuildRequires:  tracker-devel >= %{tracker_version}
52BuildRequires:  libexif-devel >= %{libexif_version}
53BuildRequires:  unique3-devel
54BuildRequires:  libnotify-devel
55BuildRequires:  libSM-devel
56BuildRequires:  exempi-devel
57BuildRequires:  tracker-devel
58BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
59BuildRequires:  gsettings-desktop-schemas
60
61Obsoletes:      nautilus-extras
62Obsoletes:      nautilus-suggested
63Obsoletes:      nautilus-mozilla < 2.0
64Obsoletes:      eel2 <= 2.24.1
65
66Provides:       eel2 <= 2.24.1
67
68
69%description
70Nautilus integrates access to files, applications, media,
71Internet-based resources and the Web. Nautilus delivers a dynamic and
72rich user experience. Nautilus is an free software project developed
73under the GNU General Public License and is a core component of the
74GNOME desktop project.
75
76%description -l ja
77Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
78リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
79豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
80のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
81プロジェクトのコア・コンポーネントです。
82
83
84%package        devel
85Summary:        Support for developing nautilus extensions
86Summary(ja):    Nautilus 拡張機能開発のためのサポート
87License:        LGPLv2+
88Group:          Development/Libraries
89Requires:       %{name}-libs = %{version}-%{release}
90Requires:       pkgconfig
91
92%description    devel
93This package provides libraries and header files needed
94for developing nautilus extensions.
95
96%description -l ja devel
97このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
98ヘッダファイルを提供します。
99
100
101%package        libs
102Summary:        Libraries for use in nautilus extentions
103Summary(ja):    Nautilus 拡張機能で利用するライブラリ
104Group:          System Environment/Libraries
105
106%description    libs
107This package provides libraries required by nautilus extention
108module.
109
110%description -l ja libs
111このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
112
113
114%package        docs
115Summary:        Documentation for %{name}
116Summary(ja):    %{name} 用のドキュメント
117Group:          Documentation
118BuildArch:      noarch
119
120%description    docs
121This package contains documentation for %{name}.
122
123
124%prep
125%setup -q -n %{name}-%{version}
126
127%patch102 -p1 -b .vine
128%patch2000 -p1 -b .vine
129
130%build
131gtkdocize
132libtoolize --force --copy
133autoreconf -f -i
134CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
135%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
136
137make %{?_smp_mflags}
138
139%install
140rm -rf $RPM_BUILD_ROOT
141
142make install DESTDIR=$RPM_BUILD_ROOT
143
144# make sure desktop files validate by ignoring sr@Latn
145perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
146# desktop-file-install can't handle empty OnlyShowIn correctly
147perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
148
149desktop-file-install --vendor "" --delete-original       \
150  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
151  --add-only-show-in GNOME                                  \
152  $RPM_BUILD_ROOT%{_datadir}/applications/*
153
154find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
155
156%find_lang %name
157
158%clean
159rm -rf $RPM_BUILD_ROOT
160
161%postun
162if [ $1 -eq 0 ] ; then
163    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
164fi
165
166%posttrans
167glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
168
169%post libs -p /sbin/ldconfig
170%postun libs -p /sbin/ldconfig
171
172
173%files  -f %{name}.lang
174%defattr(-,root,root,-)
175%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
176%dir %{_libdir}/nautilus
177%dir %{_libdir}/nautilus/extensions-3.0
178%{_libdir}/nautilus/extensions-3.0/*.so
179%{_libexecdir}/nautilus-convert-metadata
180%{_datadir}/GConf/gsettings/nautilus.convert
181%{_datadir}/appdata/org.gnome.Nautilus.appdata.xml
182%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
183%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
184%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
185%{_datadir}/applications/*.desktop
186%{_bindir}/*
187%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
188%{_datadir}/glib-2.0/schemas/
189%{_mandir}/man1/*
190
191%files devel
192%defattr(-,root,root,-)
193%{_includedir}/nautilus
194%{_libdir}/pkgconfig/*
195%{_libdir}/*.so
196%{_datadir}/gir-1.0
197
198%files libs
199%defattr(-,root,root,-)
200%{_libdir}/*.so.*
201%{_libdir}/girepository-1.0/*.typelib
202
203%files docs
204%defattr(-,root,root,-)
205%{_datadir}/gtk-doc/html/libnautilus-extension/*
206
207
208%changelog
209* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.4-1
210- new upstream release
211
212* Sat Nov 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
213- new upstream release
214
215* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
216- new upstream release
217
218* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
219- new upstream release
220
221* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
222- new upstream release
223
224* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
225- new upstream release
226- update Patch2000 (nautilus-vine-settings.patch)
227- create %%{name}-docs subpackage
228
229* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.14.2-2
230- moved libs subpackage to System Environment/Libraries Group
231
232* Wed Nov 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
233- new upstream release
234
235* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
236- new upstream release
237- remove Patch0 (nautilus-3.14.0-git20141015.patch)
238
239* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
240- new upstream release
241- add Patch0 (nautilus-3.14.0-git20141015.patch)
242
243* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
244- new upstream release
245
246* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
247- new upstream release
248
249* Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
250- new upstream release
251
252* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
253- new upstream release
254- add Patch2000 (nautilus-vine-settings.patch)
255
256* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
257- new upstream release
258
259* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
260- new upstream release
261
262* Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
263- new upstream release
264
265* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
266- new upstream release
267
268* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
269- new upstream release
270
271* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
272- new upstream release
273- remove Patch0,7
274- add BuildRequires: exempi-devel, tracker-devel
275
276* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
277- add Patch0 (nautilus-3.4.2-ja.po.patch)
278
279* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
280- new upstream release
281
282* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
283- new upstream release
284
285* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
286- added patch102 to fix autostart in other desktop environments
287  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
288
289* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
290- new upstream release
291
292* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
293- new upstream release
294
295* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
296- new upstream release
297
298* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
299- new upstream release
300
301* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
302- new upstream release
303- drop Patch101
304- change BuildRequires: gtk3-devel instread of gtk2-devel
305- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
306- change BuildRequires: unique3-devel instread of unique-devel
307- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
308
309* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
310- fixed group of libs
311- add translation of summary and description.
312- add Vendor, Distribution and Packager tags.
313
314* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
315- new upstream release
316
317* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
318- new upstream release
319
320* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
321 - new upstream release
322
323* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
324- new upstream release
325- add BuildRequires: gobject-introspection-devel
326- remove BuildRequires: libgnomeui-devel
327- add configure option (--enable-introspection=yes)
328
329* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
330- rebuild with rpm-4.8.1 for pkg-config file
331
332* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
333- split nautilus extention libraries to -libs subpackage.
334
335* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
336- new upstream release
337
338* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
339- new upstream release
340- drop Patch100
341- add Patch101
342- add Obsoletes: eel2 <= 2.24.1
343- add Provides: eel2 <= 2.24.1
344
345* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
346- new upstream release
347- add BuildRequires: libSM-devel
348
349* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
350- removed Requires: eel2
351- added %%posttrans section
352
353* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
354- new upstream release
355
356* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
357- new upstream release
358
359* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
360- new upstream release
361
362* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
363- new upstream release
364- split -devel subpackage
365
366* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
367- new upstream release
368
369* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
370- patch6 needs autoreconf
371
372* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
373- new upstream release
374
375* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
376- new upstream release
377
378* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
379- new upstream release
380- added Requires: gvfs
381
382* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
383- new upstream release
384- added Patches from FC
385  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
386  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
387  - Fix a crash in the Properties dialog while changing owner (patch from head)
388  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
389  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
390
391* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
392- new upstream release
393- dropped Patch11-13 and added Patch7-9 from Fedora
394  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
395  - Add patch from upstream to get audio preview working again
396    (#332251)
397  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
398  - Fix a crash with small fonts (#242350)
399  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
400  - Backport fixes for async thumbnail loading from svn
401
402* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
403- run autoreconf for Patch11 changes
404
405* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
406- remove tracker dependancy, Patch13 detects tracker dynamically.
407
408* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
409- add Patch13 to support user-dirs
410
411* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
412- new upstream release
413- enable tracker support
414- add BuildRequires: tracker-devel, Requires: tracker
415
416* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
417- new upstream release
418
419* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
420- add BuildRequires: gamin-devel, Requires: gamin
421- remove fam dependency (replaced by gamin)
422
423* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
424- new upsteram release
425
426* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
427- really applied Patch110...
428
429* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
430- add Patch110 to fix corruption of help option message.
431
432* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
433- new upstream release
434
435* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
436- fix typo in ja.po
437
438* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
439- update ja.po to translate patch50 related message.
440
441* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
442- add Patch50 to show progressbar on umounting
443  (ubuntu patch in Bug 313639)
444
445* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
446- new upstream release
447
448* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
449- add Patch10 to avoid background rendering delay
450
451* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
452- new upstream release
453
454* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
455- add fix-non-UTF-8-encoding.patch (patch0)
456  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
457
458* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
459- new upstream release
460
461* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
462- new upstream release
463
464* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
465- new upstream release
466
467* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
468- new upstream release
469
470* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
471- rebuild
472
473* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
474- new upstream version
475
476* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
477- new upstream version
478
479* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
480- add vine patch to change some defaults.
481  - change default zoom sine
482  - set always_use_browser
483
484* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
485- new upstream release
486
487* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
488- add Patch110 to fix libegg(egg-recent-model.c)
489  save old umask value before create ".recently-used" file.
490 
491* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
492- change default desktop font to Sans 9 (from Sans 10)
493- add patch10 to build with gtk+-2.4
494
495* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
496- new upstream release
497
498* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
499- new upstream release
500
501* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
502- add backport patch from rawhide (Patch10)
503
504* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
505- modified vine patch
506  - change default zoom level to small
507  - change desktop font to Sans 10
508
509* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
510- new upstream release
511
512* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
513- add desktop icon patch from rawhide
514
515* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
516- remove obsolete ja.po
517
518* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
519- new upstream release
520
521* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
522- new upstream release
523
524* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
525- new upstream release
526
527* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
528- update ja.po
529
530* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
531- new upstream release
532
533* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
534- new upstream release
535
536* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
537- new upstream release
538
539* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
540- new upstream release
541
542* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
543- new upstream release
544
545* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
546- new upstream release
547
548* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
549- add nautilus-cd-burner patch
550
551* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
552- new upstream release
553
554* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
555- discard scrollkeeper outputs.
556- update PreReq tags.
557
558* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
559- change icon for nautilus-file-management-properties
560- update ja.po
561
562* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
563- update ja.po
564- add translation for .desktop files.
565
566* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
567- add Requires: vine-menus
568
569* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
570- new upstream release
571
572* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
573- remove redhatize patch
574
575* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
576- rebuild to remove unneeded dependancy.
577
578* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
579- build for Vine Linux
580
581* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
582- add explicit startup-notification dependency because build system is
583  dumb
584- 2.1.3
585
586* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
587- 2.1.2
588
589* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
590- 2.0.7
591- remove patches that are upstream
592
593* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
594- Add badhack to make weblinks on desktop work
595
596* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
597- fix #70667 assertion failures
598- fix triple click patch
599
600* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
601- don't activate on double click
602
603* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
604- put button press mask in triple-click patch, maybe it will work
605- remove html-hack patch as it does nothing useful
606
607* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
608- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
609  bogus bug reports
610- add hack for HTML mime type handling in a web browser, not
611  nautilus
612
613* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
614- Updated to 2.0.6. Removed the patches I put upstream.
615- Added patch that fixes #72410
616
617* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
618- Add a simple patch so that redhat-config-packages can disable
619  the new window behavior for mounted CDs behavior.
620
621* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
622- Add patch to fix bug #70667
623
624* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
625- remove mp3
626
627* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
628- ignore the "add_to_session" preference as it only broke stuff
629- pad the left margin a bit to cope with poor word wrapping
630
631* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
632- Update to 2.0.5, remove topleft icon patch
633
634* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
635- Add patch to fix the bug where desktop icons get
636  stuck in the top left corner on startup
637
638* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
639- 2.0.4
640
641* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
642- obsolete nautilus-mozilla < 2.0 #69839
643
644* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
645- add rhconfig patch to Bluecurve theme and disable sidebar by default
646
647* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
648- drop start here files, require redhat-menus that has them
649
650* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
651- 2.0.3
652
653* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
654- build for new eel2, gail
655
656* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
657- and add the libexec components, mumble
658
659* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
660- put the components in the file list, were moved upstream
661
662* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
663- 2.0.1
664
665* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
666- Relibtoolize to fix relink problems for solib components
667- Add LANG=en_US to %makeinstall as well
668- Back out previous change, force locale to en_US to prevent UTF-8 problems
669- Add workaround for intltool-merge bug on ia64
670
671* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
672- automated rebuild
673
674* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
675- 2.0.0
676- use desktop-file-install
677- require desktop-backgrounds-basic
678
679* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
680- add wacky hack in hopes of fixing the hang-on-login thing
681
682* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
683- add build requires on new gail
684- rebuild to try to lose broken libgailutil.so.13 dependency
685
686* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
687- rebuild in different environment
688
689* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
690- 1.1.19
691
692* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
693- rebuild in different environment
694
695* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
696- really remove nautilus-devel if we are going to obsolete it
697- don't require hwbrowser
698
699* Sun May 26 2002 Tim Powers <timp@redhat.com>
700- automated rebuild
701
702* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
703- rebuild in different environment
704
705* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
706- 1.1.17
707
708* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
709- 1.1.14
710
711* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
712- require eog
713- obsolete nautilus-devel
714- fix name of schemas file in post
715
716* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
717- Update to 1.1.13
718
719* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
720- put tree view in file list
721
722* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
723- nautilus for gnome 2
724- clean up the spec file and file list a bit
725
726* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
727- merge translations
728
729* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
730- Add patch to fix trash crash
731
732* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
733- fix for metadata tmp race
734- backport thumbnail speed fix and thumbnail inf. loop fix
735
736* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
737- add some fixes from CVS version, including one for #61819 and a couple segfaults
738
739* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
740- fix thumbnails for files with future timestamp, #56862
741
742* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
743- buildrequires intltool #60633
744- apply Alex's pixbuf cache patch to save a few megs #60581
745
746* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
747- drop Milan-specific features, including png10 and ac25 patches
748- copy in 1.0.5 help component to avoid large risky patch
749- remove .la files
750- drop mozilla from ia64 again
751- remove oaf file from nautilus-mozilla that was also in the base
752  package
753
754* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
755- enable mozilla support on ia64
756
757* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
758- require Mozilla 0.9.7
759- Add patch that puts mozilla profile startup before embedding is initialized
760
761* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
762- 1.0.6, require Mozilla 0.9.6
763
764* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
765- Update to 1.0.5
766
767* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
768- Fix handling of GnomeVFSFileInfo structure (#53315)
769
770* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
771- Change handling of names on unmount to fix #52325
772
773* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
774- put nautilus-help.desktop in file list; #53109
775
776* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
777- Add po files from sources.redhat.com
778
779* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
780- Add po files from sources.redhat.com
781
782* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
783- Added patch to fix the .directory issuer
784
785* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
786- I screwed up the build yesterday, so it didn't actually contain the
787  fixes mentioned. This build should contain them.
788
789* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
790- fix bug causing 32000 stats or so in large directories,
791  should speed things up somewhat
792- fix #52104 via gruesome kdesktop-detection hack and setting
793  window type hint on our desktop window
794- fix so Start Here icon displays in sidebar
795- don't load non-local .desktop files
796
797* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
798- make Programs icon into a link, to match the other .desktop files
799- own various directories #51164
800- web page titles in Japanese, #51709
801- tree defaults to only directories #51850
802
803* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
804- make start here icon work again
805- kill some warning spew, #51661
806- cache getpwnam() results to speed things up a bit
807
808* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
809- Fix problem with missing desktop starthere.desktop file
810- New snapshot from our branch, fixes:
811  - On upgrade, icons migrated from GNOME desktop are not properly lined up
812    (#51436)
813  - icons dropped on the desktop don't end up where dropped. (#51441)
814  - Nautilus shouldn't have fam monitor read-only windows. This
815    keeps CDROMS from being unmounted until you close all
816
817    nautilus windows pointing to them. (#51442)
818  - Warnings about 'cannot statfs...' when moving items to trash.
819- Use separate start-here.desktop for panel, since the one used
820  for the root window only works from Nautilus.
821
822* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
823- Changed starthere .desktop files to be links instead
824- of spawning a new nautilus. This makes start-here:
825- much faster.
826
827* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
828- Added hwbrowser dependency
829- New snapshot, fixes the mozilla-view submit form problem
830
831* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
832- Rebuild with new xml-i18n-tools
833- fix crash in creating new desktop files
834
835* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
836- Fix up DnD code some more
837
838* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
839- Sync our CVS version; fixes some MUSTFIX
840  (the one about drawing background on startup,
841   properly translate desktop files, etc.)
842
843* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
844- Fix 64bit cleanness issue
845- Fix NULL mimetype crash
846- Disable additional_text for .desktop files
847
848* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
849- Fix unmounting devices.
850
851* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
852- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
853- mimetype sniffing.
854
855* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
856- Remove the "don't run as root" warning.
857- Remove eazel from bookmarks
858- langified (again? did someone change it?)
859
860* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
861- Apply a patch that makes nautilus dnd reset work with the latest
862- eel release.
863
864* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
865- Build on ia64 without the mozilla component.
866
867* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
868- Fix crash-on-startup showstopper
869- Fix can't-find-images bug (this one was only showing up
870  when built with debug symbols, since it was an uninitialized memory
871  read)
872
873* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
874- sync new tarball from our CVS branch,
875  fixes some drag-and-drop, changes URI scheme names,
876  etc.
877
878* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
879- Add BuildRequires (#49539, 49537)
880- Fix %%post, %%postun (#49720)
881- Background efficiency improvements and hacks
882
883* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
884- Don't launch esd on each mouseover.
885
886* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
887- move first time druid patch into my "CVS outstanding" patch
888- try to really remove Help/Feedback
889- try to really fix Help/Community Support
890- try again to get Start Here in the Go menu
891- try again to get Start Here on the desktop
892- don't show file sizes for .desktop files
893
894* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
895- add newline to ends of .desktop files that were missing them
896
897* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
898- update to my latest 'cvs diff -u' (adds default
899  Start Here link, displays .directory name in sidebar)
900- include /etc/X11/* links (starthere, sysconfig, serverconfig)
901
902* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
903- Patch to remove firsttime druid and flash
904
905* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
906- add hacks for displaying desktop files
907- add hack to turn off the "unwriteable" emblem
908
909* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
910- added defattr to the files lists to be (-,root,root)
911- languified
912
913* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
914- Need to run autoheader too.
915
916* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
917- Make the fam dependency a real runtime dependency
918- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
919- Cleaned up specfile.
920
921* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
922- Change default background and rubberband color.
923- Use the sidebar tabs from the default theme
924- BuildDepend on fam-devel, depend on fam
925- Disable the eazel update pages in the first-time druid.
926- Remove the eazel logo from the first-time druid
927
928* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
929- 1.0.4, removes eazel services icon and wizard page
930- Eazel logo is still in startup wizard for now, needs fixing
931
932* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
933- fix group (s/Desktop/Desktops/) #47134
934- remove ammonite dependency
935
936* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
937- add a different default theme
938- clean up file list overspecificity a bit
939
940* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
941- move to a CVS snapshot of nautilus for now
942  (Darin is my hero for having distcheck work out of CVS)
943
944* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
945- clean up defaults a bit
946
947* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
948- New version
949
950* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
951- Added BuildRequires lines
952- Changed Source to point to ftp.gnome.org instead of just the tarball name
953- Moved %description sections closer to their %package sections
954- Moved %changelog to the end, where so that it's not in the way
955- Changed configure and make install options to allow moving of
956  libraries, includes, binaries more easily
957- Removed hard-coded paths (don't define %prefix or %docdir)
958- replace %{prefix}/bin with %{_bindir}
959- replace %{prefix}/share with %{_datadir}
960- replace %{prefix}/lib with %{_libdir}
961- replace %{prefix}/include with %{_includedir}
962
963* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
964- removed obsoletes from sub packages and added mozilla and trilobite
965subpackages
966
967* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
968- created this thing
Note: See TracBrowser for help on using the repository browser.