source: projects/specs/trunk/n/nautilus/nautilus-vl.spec @ 7046

Revision 7046, 29.8 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define glib2_version 2.34.0
2%define pango_version 1.32.0
3%define gtk3_version 3.6.0
4%define libxml2_version 2.9.0
5%define eog_version 3.6.0
6%define desktop_file_utils_version 0.16
7%define gnome_desktop3_version 3.6.0
8%define vine_menus_version 3.0
9%define startup_notification_version 0.10
10%define libexif_version 0.6.19
11%define gconf_version 2.32.0
12%define gobject_introspection_version 0.9.8
13
14Name:                   nautilus
15Summary:                Nautilus is a file manager for GNOME
16Summary(ja):    Nautilus - GNOME ファイルマネージャ
17Version:                3.6.2
18Release:                1%{?_dist_release}
19License:                GPLv2+
20Group:                  User Interface/Desktops
21URL:                    http://www.gnome.org/projects/nautilus/
22
23Vendor:                 Project Vine
24Distribution:   Vine Linux
25Packager:               Takemikaduchi
26
27Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/3.6/%{name}-%{version}.tar.xz
28
29# Some changes to default config
30Patch1:         nautilus-2.5.7-rhconfig.patch
31
32# vine
33Patch102:       run_in_gnome.patch
34
35BuildRoot:      %{_tmppath}/%{name}-%{version}-root
36Requires:       gamin
37Requires:       vine-menus >= %{vine_menus_version}
38Requires:       gvfs, gvfs-fuse, gvfs-smb, gvfs-archive, gvfs-gphoto2
39Requires:       libexif >= %{libexif_version}
40Requires:       %{name}-libs = %{version}-%{release}
41
42BuildRequires:  intltool
43BuildRequires:  libtool >= 1.4.2-10
44BuildRequires:  automake, autoconf
45BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
46
47BuildRequires:  glib2-devel >= %{glib2_version}
48BuildRequires:  pango-devel >= %{pango_version}
49BuildRequires:  gtk3-devel >= %{gtk3_version}
50BuildRequires:  libxml2-devel >= %{libxml2_version}
51BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
52BuildRequires:  gamin-devel
53BuildRequires:  startup-notification-devel >= %{startup_notification_version}
54#BuildRequires: tracker-devel
55BuildRequires:  libexif-devel  >= %{libexif_version}
56BuildRequires:  unique3-devel
57BuildRequires:  libnotify-devel
58BuildRequires:  libSM-devel
59BuildRequires:  exempi-devel
60BuildRequires:  tracker-devel
61BuildRequires:  gobject-introspection-devel >= %{gobject_introspection_version}
62BuildRequires:  gsettings-desktop-schemas
63
64Obsoletes:      nautilus-extras
65Obsoletes:      nautilus-suggested
66Obsoletes:      nautilus-mozilla < 2.0
67Obsoletes:      eel2 <= 2.24.1
68
69Provides:       eel2 <= 2.24.1
70
71
72%description
73Nautilus integrates access to files, applications, media,
74Internet-based resources and the Web. Nautilus delivers a dynamic and
75rich user experience. Nautilus is an free software project developed
76under the GNU General Public License and is a core component of the
77GNOME desktop project.
78
79%description -l ja
80Nautilus は、ファイル、アプリケーション、メディア、インターネットベースの
81リソースおよびウェブへのアクセスを統合します。Nautilus は、ダイナミックで
82豊かなユーザ体験を実現します。Nautilus は、GNU General Public License
83のもとに開発されているフリーソフトウェアプロジェクトで GNOME デスクトップ
84プロジェクトのコア・コンポーネントです。
85
86%package devel
87Summary: Support for developing nautilus extensions
88Summary(ja): Nautilus 拡張機能開発のためのサポート
89License: LGPLv2+
90Group: Development/Libraries
91Requires: %{name}-libs = %{version}-%{release}
92Requires: pkgconfig
93
94%description devel
95This package provides libraries and header files needed
96for developing nautilus extensions.
97
98%description -l ja devel
99このパッケージは、Nautilus 拡張機能の開発に必要なライブラリおよび
100ヘッダファイルを提供します。
101
102%package libs
103Summary: Libraries for use in nautilus extentions
104Summary(ja): Nautilus 拡張機能で利用するライブラリ
105Group: User Interface/Desktops
106
107%description libs
108This package provides libraries required by nautilus extention
109module.
110
111%description -l ja libs
112このパッケージは、Nautilus 拡張機能が必要とするライブラリを提供します。
113
114%prep
115%setup -q -n %{name}-%{version}
116
117%patch102 -p1 -b .vine
118
119%build
120gtkdocize
121libtoolize --force --copy
122autoreconf -f -i
123CFLAGS="$RPM_OPT_FLAGS -DUGLY_HACK_TO_DETECT_KDE -DNAUTILUS_OMIT_SELF_CHECK" \
124%configure --disable-more-warnings --disable-update-mimedb --enable-introspection=yes
125
126make %{?_smp_mflags}
127
128%install
129rm -rf $RPM_BUILD_ROOT
130
131make install DESTDIR=$RPM_BUILD_ROOT
132
133# make sure desktop files validate by ignoring sr@Latn
134perl -pi -e 's/sr\@Latn/sp/g' $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
135# desktop-file-install can't handle empty OnlyShowIn correctly
136perl -pi -e 's/OnlyShowIn=GNOME;Unity;/OnlyShowIn=GNOME;/' $RPM_BUILD_ROOT%{_datadir}/applications/nautilus.desktop
137
138desktop-file-install --vendor gnome --delete-original       \
139  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
140  --add-only-show-in GNOME                                  \
141  $RPM_BUILD_ROOT%{_datadir}/applications/*
142
143find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
144
145%find_lang %name
146
147%clean
148rm -rf $RPM_BUILD_ROOT
149
150%postun
151if [ $1 -eq 0 ] ; then
152    glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
153fi
154
155%posttrans
156update-mime-database %{_datadir}/mime &> /dev/null ||:
157glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
158
159%post libs -p /sbin/ldconfig
160%postun libs -p /sbin/ldconfig
161
162
163%files  -f %{name}.lang
164%defattr(-,root,root)
165%doc AUTHORS COPYING COPYING-DOCS COPYING.LIB ChangeLog NEWS README
166%dir %{_libdir}/nautilus
167%dir %{_libdir}/nautilus/extensions-3.0
168%{_libdir}/nautilus/extensions-3.0/*.so
169%{_libexecdir}/nautilus-convert-metadata
170%{_libexecdir}/nautilus-shell-search-provider
171%{_datadir}/GConf/gsettings/nautilus.convert
172%{_datadir}/dbus-1/services/org.freedesktop.FileManager1.service
173%{_datadir}/dbus-1/services/org.gnome.Nautilus.service
174%{_datadir}/dbus-1/services/org.gnome.Nautilus.SearchProvider.service
175%{_datadir}/gnome-shell/search-providers/nautilus-search-provider.ini
176%{_datadir}/nautilus
177%{_datadir}/applications
178%{_datadir}/mime/*
179%{_bindir}/*
180%{_sysconfdir}/xdg/autostart/nautilus-autostart.desktop
181%{_datadir}/glib-2.0/schemas/
182%{_mandir}/man1/*
183
184%files devel
185%defattr(-, root, root)
186%{_includedir}/nautilus
187%{_libdir}/pkgconfig/*
188%{_libdir}/*.so
189%{_datadir}/gir-1.0
190%doc %{_datadir}/gtk-doc/html/libnautilus-extension/*
191
192%files libs
193%defattr(-, root, root)
194%{_libdir}/*.so.*
195%{_libdir}/girepository-1.0/*.typelib
196
197
198%changelog
199* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
200- new upstream release
201
202* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
203- new upstream release
204
205* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
206- new upstream release
207- remove Patch0,7
208- add BuildRequires: exempi-devel, tracker-devel
209
210* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
211- add Patch0 (nautilus-3.4.2-ja.po.patch)
212
213* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
214- new upstream release
215
216* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
217- new upstream release
218
219* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.2.1-2
220- added patch102 to fix autostart in other desktop environments
221  (https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/826058)
222
223* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
224- new upstream release
225
226* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
227- new upstream release
228
229* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
230- new upstream release
231
232* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
233- new upstream release
234
235* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
236- new upstream release
237- drop Patch101
238- change BuildRequires: gtk3-devel instread of gtk2-devel
239- change BuildRequires: gnome-desktop3-devel instread of gnome-desktop-devel
240- change BuildRequires: unique3-devel instread of unique-devel
241- add BuildRequires: libnotify-devel, gsettings-desktop-schemas
242
243* Sat Apr 16 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.2.1-2
244- fixed group of libs
245- add translation of summary and description.
246- add Vendor, Distribution and Packager tags.
247
248* Wed Dec 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2.1-1
249- new upstream release
250
251* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
252- new upstream release
253
254* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
255 - new upstream release
256
257* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
258- new upstream release
259- add BuildRequires: gobject-introspection-devel
260- remove BuildRequires: libgnomeui-devel
261- add configure option (--enable-introspection=yes)
262
263* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
264- rebuild with rpm-4.8.1 for pkg-config file
265
266* Sat Jun 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-2
267- split nautilus extention libraries to -libs subpackage.
268
269* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
270- new upstream release
271
272* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
273- new upstream release
274- drop Patch100
275- add Patch101
276- add Obsoletes: eel2 <= 2.24.1
277- add Provides: eel2 <= 2.24.1
278
279* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
280- new upstream release
281- add BuildRequires: libSM-devel
282
283* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-2
284- removed Requires: eel2
285- added %%posttrans section
286
287* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
288- new upstream release
289
290* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
291- new upstream release
292
293* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
294- new upstream release
295
296* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
297- new upstream release
298- split -devel subpackage
299
300* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
301- new upstream release
302
303* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-2
304- patch6 needs autoreconf
305
306* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
307- new upstream release
308
309* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
310- new upstream release
311
312* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
313- new upstream release
314- added Requires: gvfs
315
316* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
317- new upstream release
318- added Patches from FC
319  * Thu Mar 13 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.22.0-2
320  - Don't create application/x-ext-<extension> types for known mimetypes (patch from head)
321  - Fix a crash in the Properties dialog while changing owner (patch from head)
322  * Tue Feb 26 2008 Tomas Bzatek <tbzatek@redhat.com> - 2.21.92-2
323  - Change libbeagle .so name for libbeagle-0.3.0 in nautilus-2.21.1-dynamic-search-r2.patch (#434722)
324
325* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
326- new upstream release
327- dropped Patch11-13 and added Patch7-9 from Fedora
328  * Tue Oct 16 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.0-5
329  - Add patch from upstream to get audio preview working again
330    (#332251)
331  * Tue Oct  2 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-3
332  - Fix a crash with small fonts (#242350)
333  * Tue Oct  2 2007 Alexander Larsson <alexl@redhat.com> - 2.20.0-1
334  - Backport fixes for async thumbnail loading from svn
335
336* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl4
337- run autoreconf for Patch11 changes
338
339* Wed May 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl3
340- remove tracker dependancy, Patch13 detects tracker dynamically.
341
342* Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
343- add Patch13 to support user-dirs
344
345* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
346- new upstream release
347- enable tracker support
348- add BuildRequires: tracker-devel, Requires: tracker
349
350* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
351- new upstream release
352
353* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
354- add BuildRequires: gamin-devel, Requires: gamin
355- remove fam dependency (replaced by gamin)
356
357* Wed Aug 02 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
358- new upsteram release
359
360* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl3
361- really applied Patch110...
362
363* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
364- add Patch110 to fix corruption of help option message.
365
366* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
367- new upstream release
368
369* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl4
370- fix typo in ja.po
371
372* Wed Mar 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
373- update ja.po to translate patch50 related message.
374
375* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
376- add Patch50 to show progressbar on umounting
377  (ubuntu patch in Bug 313639)
378
379* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
380- new upstream release
381
382* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl2
383- add Patch10 to avoid background rendering delay
384
385* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
386- new upstream release
387
388* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl2
389- add fix-non-UTF-8-encoding.patch (patch0)
390  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=314538
391
392* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
393- new upstream release
394
395* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
396- new upstream release
397
398* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
399- new upstream release
400
401* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
402- new upstream release
403
404* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
405- rebuild
406
407* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
408- new upstream version
409
410* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
411- new upstream version
412
413* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl2
414- add vine patch to change some defaults.
415  - change default zoom sine
416  - set always_use_browser
417
418* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
419- new upstream release
420
421* Fri Oct 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl3
422- add Patch110 to fix libegg(egg-recent-model.c)
423  save old umask value before create ".recently-used" file.
424 
425* Thu Jul 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
426- change default desktop font to Sans 9 (from Sans 10)
427- add patch10 to build with gtk+-2.4
428
429* Wed Feb 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
430- new upstream release
431
432* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
433- new upstream release
434
435* Tue Sep 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
436- add backport patch from rawhide (Patch10)
437
438* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
439- modified vine patch
440  - change default zoom level to small
441  - change desktop font to Sans 10
442
443* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
444- new upstream release
445
446* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl3
447- add desktop icon patch from rawhide
448
449* Sat Sep 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
450- remove obsolete ja.po
451
452* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
453- new upstream release
454
455* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
456- new upstream release
457
458* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
459- new upstream release
460
461* Mon Apr 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl2
462- update ja.po
463
464* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
465- new upstream release
466
467* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
468- new upstream release
469
470* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
471- new upstream release
472
473* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
474- new upstream release
475
476* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
477- new upstream release
478
479* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
480- new upstream release
481
482* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl2
483- add nautilus-cd-burner patch
484
485* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
486- new upstream release
487
488* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
489- discard scrollkeeper outputs.
490- update PreReq tags.
491
492* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
493- change icon for nautilus-file-management-properties
494- update ja.po
495
496* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
497- update ja.po
498- add translation for .desktop files.
499
500* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
501- add Requires: vine-menus
502
503* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
504- new upstream release
505
506* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl4
507- remove redhatize patch
508
509* Tue Dec 17 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl2
510- rebuild to remove unneeded dependancy.
511
512* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
513- build for Vine Linux
514
515* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
516- add explicit startup-notification dependency because build system is
517  dumb
518- 2.1.3
519
520* Wed Nov 13 2002 Havoc Pennington <hp@redhat.com>
521- 2.1.2
522
523* Thu Oct 10 2002 Havoc Pennington <hp@redhat.com>
524- 2.0.7
525- remove patches that are upstream
526
527* Tue Sep  3 2002 Alexander Larsson <alexl@redhat.com>  2.0.6-6
528- Add badhack to make weblinks on desktop work
529
530* Mon Sep  2 2002 Havoc Pennington <hp@redhat.com>
531- fix #70667 assertion failures
532- fix triple click patch
533
534* Mon Sep  2 2002 Jonathan Blandford <jrb@redhat.com>
535- don't activate on double click
536
537* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
538- put button press mask in triple-click patch, maybe it will work
539- remove html-hack patch as it does nothing useful
540
541* Sat Aug 31 2002 Havoc Pennington <hp@redhat.com>
542- require newer redhat-artwork, -menus, eel2, gnome-vfs2 to avoid
543  bogus bug reports
544- add hack for HTML mime type handling in a web browser, not
545  nautilus
546
547* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
548- Updated to 2.0.6. Removed the patches I put upstream.
549- Added patch that fixes #72410
550
551* Wed Aug 28 2002 Owen Taylor <otaylor@redhat.com>
552- Add a simple patch so that redhat-config-packages can disable
553  the new window behavior for mounted CDs behavior.
554
555* Wed Aug 28 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-4
556- Add patch to fix bug #70667
557
558* Sun Aug 25 2002 Havoc Pennington <hp@redhat.com>
559- remove mp3
560
561* Fri Aug 23 2002 Havoc Pennington <hp@redhat.com>
562- ignore the "add_to_session" preference as it only broke stuff
563- pad the left margin a bit to cope with poor word wrapping
564
565* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.5-1
566- Update to 2.0.5, remove topleft icon patch
567
568* Thu Aug 15 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-2
569- Add patch to fix the bug where desktop icons get
570  stuck in the top left corner on startup
571
572* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com> 2.0.4-1
573- 2.0.4
574
575* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
576- obsolete nautilus-mozilla < 2.0 #69839
577
578* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
579- add rhconfig patch to Bluecurve theme and disable sidebar by default
580
581* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
582- drop start here files, require redhat-menus that has them
583
584* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
585- 2.0.3
586
587* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
588- build for new eel2, gail
589
590* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
591- and add the libexec components, mumble
592
593* Wed Jul 24 2002 Havoc Pennington <hp@redhat.com>
594- put the components in the file list, were moved upstream
595
596* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
597- 2.0.1
598
599* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
600- Relibtoolize to fix relink problems for solib components
601- Add LANG=en_US to %makeinstall as well
602- Back out previous change, force locale to en_US to prevent UTF-8 problems
603- Add workaround for intltool-merge bug on ia64
604
605* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
606- automated rebuild
607
608* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
609- 2.0.0
610- use desktop-file-install
611- require desktop-backgrounds-basic
612
613* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
614- add wacky hack in hopes of fixing the hang-on-login thing
615
616* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
617- add build requires on new gail
618- rebuild to try to lose broken libgailutil.so.13 dependency
619
620* Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
621- rebuild in different environment
622
623* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
624- 1.1.19
625
626* Fri May 31 2002 Havoc Pennington <hp@redhat.com>
627- rebuild in different environment
628
629* Thu May 30 2002 Havoc Pennington <hp@redhat.com>
630- really remove nautilus-devel if we are going to obsolete it
631- don't require hwbrowser
632
633* Sun May 26 2002 Tim Powers <timp@redhat.com>
634- automated rebuild
635
636* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
637- rebuild in different environment
638
639* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
640- 1.1.17
641
642* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
643- 1.1.14
644
645* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
646- require eog
647- obsolete nautilus-devel
648- fix name of schemas file in post
649
650* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
651- Update to 1.1.13
652
653* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
654- put tree view in file list
655
656* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
657- nautilus for gnome 2
658- clean up the spec file and file list a bit
659
660* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
661- merge translations
662
663* Thu Apr  4 2002 Alex Larsson <alexl@redhat.com>
664- Add patch to fix trash crash
665
666* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
667- fix for metadata tmp race
668- backport thumbnail speed fix and thumbnail inf. loop fix
669
670* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
671- add some fixes from CVS version, including one for #61819 and a couple segfaults
672
673* Wed Mar 20 2002 Havoc Pennington <hp@redhat.com>
674- fix thumbnails for files with future timestamp, #56862
675
676* Mon Mar 11 2002 Havoc Pennington <hp@redhat.com>
677- buildrequires intltool #60633
678- apply Alex's pixbuf cache patch to save a few megs #60581
679
680* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
681- drop Milan-specific features, including png10 and ac25 patches
682- copy in 1.0.5 help component to avoid large risky patch
683- remove .la files
684- drop mozilla from ia64 again
685- remove oaf file from nautilus-mozilla that was also in the base
686  package
687
688* Mon Jan 28 2002 Bill Nottingham <notting@redhat.com>
689- enable mozilla support on ia64
690
691* Fri Dec 28 2001 Christopher Blizzard <blizzard@redhat.com>
692- require Mozilla 0.9.7
693- Add patch that puts mozilla profile startup before embedding is initialized
694
695* Tue Nov 20 2001 Havoc Pennington <hp@redhat.com>
696- 1.0.6, require Mozilla 0.9.6
697
698* Tue Oct 23 2001 Alex Larsson <alexl@redhat.com>
699- Update to 1.0.5
700
701* Thu Sep  6 2001 Owen Taylor <otaylor@redhat.com>
702- Fix handling of GnomeVFSFileInfo structure (#53315)
703
704* Wed Sep  5 2001 Owen Taylor <otaylor@redhat.com>
705- Change handling of names on unmount to fix #52325
706
707* Tue Sep  4 2001 Havoc Pennington <hp@redhat.com>
708- put nautilus-help.desktop in file list; #53109
709
710* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
711- Add po files from sources.redhat.com
712
713* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
714- Add po files from sources.redhat.com
715
716* Thu Aug 23 2001 Alex Larsson <alexl@redhat.com> 1.0.4-38
717- Added patch to fix the .directory issuer
718
719* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
720- I screwed up the build yesterday, so it didn't actually contain the
721  fixes mentioned. This build should contain them.
722
723* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
724- fix bug causing 32000 stats or so in large directories,
725  should speed things up somewhat
726- fix #52104 via gruesome kdesktop-detection hack and setting
727  window type hint on our desktop window
728- fix so Start Here icon displays in sidebar
729- don't load non-local .desktop files
730
731* Mon Aug 20 2001 Havoc Pennington <hp@redhat.com>
732- make Programs icon into a link, to match the other .desktop files
733- own various directories #51164
734- web page titles in Japanese, #51709
735- tree defaults to only directories #51850
736
737* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
738- make start here icon work again
739- kill some warning spew, #51661
740- cache getpwnam() results to speed things up a bit
741
742* Tue Aug 14 2001 Owen Taylor <otaylor@redhat.com>
743- Fix problem with missing desktop starthere.desktop file
744- New snapshot from our branch, fixes:
745  - On upgrade, icons migrated from GNOME desktop are not properly lined up
746    (#51436)
747  - icons dropped on the desktop don't end up where dropped. (#51441)
748  - Nautilus shouldn't have fam monitor read-only windows. This
749    keeps CDROMS from being unmounted until you close all
750
751    nautilus windows pointing to them. (#51442)
752  - Warnings about 'cannot statfs...' when moving items to trash.
753- Use separate start-here.desktop for panel, since the one used
754  for the root window only works from Nautilus.
755
756* Fri Aug 10 2001 Alexander Larsson <alexl@redhat.com>
757- Changed starthere .desktop files to be links instead
758- of spawning a new nautilus. This makes start-here:
759- much faster.
760
761* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
762- Added hwbrowser dependency
763- New snapshot, fixes the mozilla-view submit form problem
764
765* Wed Aug  8 2001 Jonathan Blandford <jrb@redhat.com>
766- Rebuild with new xml-i18n-tools
767- fix crash in creating new desktop files
768
769* Tue Aug  7 2001 Jonathan Blandford <jrb@redhat.com>
770- Fix up DnD code some more
771
772* Thu Aug 02 2001 Havoc Pennington <hp@redhat.com>
773- Sync our CVS version; fixes some MUSTFIX
774  (the one about drawing background on startup,
775   properly translate desktop files, etc.)
776
777* Wed Aug  1 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-24
778- Fix 64bit cleanness issue
779- Fix NULL mimetype crash
780- Disable additional_text for .desktop files
781
782* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-23
783- Fix unmounting devices.
784
785* Tue Jul 31 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-22
786- Make it depend on gnome-vfs-1.0.1-13. Needed for .desktop
787- mimetype sniffing.
788
789* Mon Jul 30 2001 Alexander Larsson <alexl@redhat.com> 1.0.4-21
790- Remove the "don't run as root" warning.
791- Remove eazel from bookmarks
792- langified (again? did someone change it?)
793
794* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
795- Apply a patch that makes nautilus dnd reset work with the latest
796- eel release.
797
798* Thu Jul 26 2001 Alexander Larsson <alexl@redhat.com>
799- Build on ia64 without the mozilla component.
800
801* Wed Jul 25 2001 Havoc Pennington <hp@redhat.com>
802- Fix crash-on-startup showstopper
803- Fix can't-find-images bug (this one was only showing up
804  when built with debug symbols, since it was an uninitialized memory
805  read)
806
807* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
808- sync new tarball from our CVS branch,
809  fixes some drag-and-drop, changes URI scheme names,
810  etc.
811
812* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
813- Add BuildRequires (#49539, 49537)
814- Fix %%post, %%postun (#49720)
815- Background efficiency improvements and hacks
816
817* Fri Jul 13 2001 Alexander Larsson <alexl@redhat.com>
818- Don't launch esd on each mouseover.
819
820* Wed Jul 11 2001 Havoc Pennington <hp@redhat.com>
821- move first time druid patch into my "CVS outstanding" patch
822- try to really remove Help/Feedback
823- try to really fix Help/Community Support
824- try again to get Start Here in the Go menu
825- try again to get Start Here on the desktop
826- don't show file sizes for .desktop files
827
828* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
829- add newline to ends of .desktop files that were missing them
830
831* Tue Jul 10 2001 Havoc Pennington <hp@redhat.com>
832- update to my latest 'cvs diff -u' (adds default
833  Start Here link, displays .directory name in sidebar)
834- include /etc/X11/* links (starthere, sysconfig, serverconfig)
835
836* Tue Jul 10 2001 Jonathan Blandford <jrb@redhat.com>
837- Patch to remove firsttime druid and flash
838
839* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
840- add hacks for displaying desktop files
841- add hack to turn off the "unwriteable" emblem
842
843* Sun Jul  8 2001 Tim Powers <timp@redhat.com>
844- added defattr to the files lists to be (-,root,root)
845- languified
846
847* Sat Jul  7 2001 Alexander Larsson <alexl@redhat.com>
848- Need to run autoheader too.
849
850* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
851- Make the fam dependency a real runtime dependency
852- by linking to libfam (nautilus-1.0.4-fam-lib.patch)
853- Cleaned up specfile.
854
855* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
856- Change default background and rubberband color.
857- Use the sidebar tabs from the default theme
858- BuildDepend on fam-devel, depend on fam
859- Disable the eazel update pages in the first-time druid.
860- Remove the eazel logo from the first-time druid
861
862* Thu Jul 05 2001 Havoc Pennington <hp@redhat.com>
863- 1.0.4, removes eazel services icon and wizard page
864- Eazel logo is still in startup wizard for now, needs fixing
865
866* Tue Jul 03 2001 Havoc Pennington <hp@redhat.com>
867- fix group (s/Desktop/Desktops/) #47134
868- remove ammonite dependency
869
870* Wed Jun 27 2001 Havoc Pennington <hp@redhat.com>
871- add a different default theme
872- clean up file list overspecificity a bit
873
874* Tue Jun 26 2001 Havoc Pennington <hp@redhat.com>
875- move to a CVS snapshot of nautilus for now
876  (Darin is my hero for having distcheck work out of CVS)
877
878* Thu May 10 2001 Jonathan Blandford <jrb@redhat.com>
879- clean up defaults a bit
880
881* Wed May  9 2001 Jonathan Blandford <jrb@redhat.com>
882- New version
883
884* Tue Apr 17 2001 Gregory Leblanc <gleblanc@grego1.cu-portland.edu>
885- Added BuildRequires lines
886- Changed Source to point to ftp.gnome.org instead of just the tarball name
887- Moved %description sections closer to their %package sections
888- Moved %changelog to the end, where so that it's not in the way
889- Changed configure and make install options to allow moving of
890  libraries, includes, binaries more easily
891- Removed hard-coded paths (don't define %prefix or %docdir)
892- replace %{prefix}/bin with %{_bindir}
893- replace %{prefix}/share with %{_datadir}
894- replace %{prefix}/lib with %{_libdir}
895- replace %{prefix}/include with %{_includedir}
896
897* Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
898- removed obsoletes from sub packages and added mozilla and trilobite
899subpackages
900
901* Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
902- created this thing
Note: See TracBrowser for help on using the repository browser.