source: projects/specs/trunk/m/monodoc-core/monodoc-core-vl.spec @ 521

Revision 521, 5.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define mono_dir %(/usr/bin/monodir)
2Name: monodoc-core
3License: GNU General Public License (GPL)
4Group: Development/Tools/Other
5Summary: Monodoc--A Documentation Browser Written in C#
6Summary(ja): C# で書かれたドキュメントブラウザ
7URL: http://www.mono-project.com
8Version: 2.0
9Release: 1%{?_dist_release}
10Source0: http://mono.ximian.com/monobuild/preview/sources/monodoc/monodoc-%{version}.zip
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12Provides: monodoc
13BuildArch: noarch
14BuildRequires: mono-devel unzip
15BuildRequires: mono-web
16
17%description
18Monodoc is a documentation browser for the Mono project. It is written
19in C# using the GTK# libraries.
20
21%if 0
22%define __find_provides env sh -c 'filelist=($(cat)) && { printf "%s\\n" "${filelist[@]}" | /usr/lib/rpm/find-provides && printf "%s\\n" "${filelist[@]}" | /usr/bin/mono-find-provides ; } | sort | uniq'
23%define __find_requires env sh -c 'filelist=($(cat)) && { printf "%s\\n" "${filelist[@]}" | /usr/lib/rpm/find-requires && printf "%s\\n" "${filelist[@]}" | /usr/bin/mono-find-requires ; } | sort | uniq'
24%endif
25
26
27%prep
28%setup -q -n monodoc-%{version}
29
30%build
31export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
32./configure \
33  --prefix=%{_prefix} \
34  --libdir=%{_prefix}/lib \
35  --libexecdir=%{_prefix}/lib \
36  --localstatedir=%{_localstatedir} \
37  --mandir=%{_mandir} \
38  --infodir=%{_infodir} \
39  --sysconfdir=%{_sysconfdir}
40make
41
42%install
43%{__rm} -rf $RPM_BUILD_ROOT
44export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
45make install DESTDIR=$RPM_BUILD_ROOT
46
47install -d $RPM_BUILD_ROOT%{_datadir}
48mv $RPM_BUILD_ROOT/%{_prefix}/lib/pkgconfig $RPM_BUILD_ROOT%{_datadir}
49
50## remove files
51rm -f $RPM_BUILD_ROOT%{_prefix}/lib/monodoc/sources/gtk-sharp-docs.tree
52rm -f $RPM_BUILD_ROOT%{_prefix}/lib/monodoc/sources/gtk-sharp-docs.zip
53
54
55%clean
56rm -rf ${RPM_BUILD_ROOT}
57
58
59%files
60%defattr(-, root, root)
61%doc AUTHORS ChangeLog NEWS README
62%{_bindir}/mdassembler
63%{_bindir}/mdcs2ecma
64%{_bindir}/mdnormalizer
65%{_bindir}/mdoc
66%{_bindir}/mdoc-assemble
67%{_bindir}/mdoc-export-html
68%{_bindir}/mdoc-export-msxdoc
69%{_bindir}/mdoc-update
70%{_bindir}/mdoc-validate
71%{_bindir}/mdvalidater
72%{_bindir}/mod
73%{_bindir}/monodocer
74%{_bindir}/monodocs2html
75%{_bindir}/monodocs2slashdoc
76%{mono_dir}/monodoc
77%{mono_dir}/gac/monodoc
78%{_prefix}/lib/monodoc
79%{_datadir}/pkgconfig/monodoc.pc
80%{_mandir}/man1/*
81%{_mandir}/man5/mdoc.5*
82
83# Should be in mono-tools now...?
84#%{_prefix}/share/applications/monodoc.desktop
85#%{_prefix}/share/pixmaps/monodoc.png
86
87%changelog
88* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1vl5
89- initial build for VineSeed
90        - updated monodoc to 2.0
91        - applied vine versioning policy
92        - added japanese summary
93        - spec in utf-8
94
95* Tue Mar 25 2008 wberrier@suse.de
96- Update to 1.9
97  - Documentation fixes and updates to match mono 1.9
98* Mon Jan 14 2008 wberrier@suse.de
99- Update to 1.2.6
100  - Documentation updates to match mono 1.2.6
101* Fri Aug  3 2007 wberrier@suse.de
102- Update to 1.2.5
103  - Documentation updates to match mono 1.2.5
104  - several improvements and fixes to 'monodocer' utility
105* Wed Jun  6 2007 wberrier@novell.com
106- Update to 1.2.4
107  - Documentation updates to match mono 1.2.4
108* Fri Apr 13 2007 wberrier@novell.com
109- add %%debug_package so debug packages get created
110* Wed Apr 11 2007 wberrier@novell.com
111- Add mono dep/req for older distros
112* Thu Mar  1 2007 wberrier@suse.de
113- Update to 1.2.3
114  - API Documentation updates
115  - Formatting fixes
116  - Sub documentation for 2.0 APIs
117* Sat Dec  2 2006 wberrier@suse.de
118- Update to 1.2.1 (Fate #301111)
119  - Sqlite Docs update
120  - new manpages
121  - doc generation updates and fixes
122* Fri Oct 20 2006 wberrier@suse.de
123- Update to 1.1.18
124  - generics support and will display generic types
125  - documents custom attributes with their actual constructor calls
126  - monodocs2html now includes inherited members on type pages
127* Wed Oct 18 2006 wberrier@suse.de
128- Remove manual Requires.  mono-devel isn't needed, and all other
129  deps will be generated automatically. (bnc #212972)
130* Wed Aug 30 2006 wberrier@suse.de
131- Update to 1.1.17
132  - Updated documentation for mono 1.1.17
133* Mon Jul 31 2006 wberrier@suse.de
134- Update to 1.1.16
135- Fixes problem with missing documentation (pathnames too long
136  for a tar.gz file)
137- Append the node kind to the node caption. Fixes a crash when
138  editing uncompiled help sources.
139* Wed Jan 25 2006 mls@suse.de
140- converted neededforbuild to BuildRequires
141* Wed Jan 11 2006 ro@suse.de
142- added mono-devel to nfb to get monoized provides
143* Fri Jan  6 2006 wberrier@suse.de
144- Update to 1.1.13, clean up deps
145* Thu Dec 15 2005 wberrier@suse.de
146- Update to 1.1.11, remove run_ldconfig
147* Thu Nov 10 2005 wberrier@suse.de
148- Update to 1.1.10, remove icu deps
149* Fri Oct  7 2005 wberrier@suse.de
150- Update to 1.1.9
151* Wed Sep 28 2005 dmueller@suse.de
152- add norootforbuild
153* Sun Sep 25 2005 ro@suse.de
154- fix file-conflict with gtk-sharp2
155* Fri Aug 26 2005 wberrier@suse.de
156- renmae package to monodoc-core
157* Mon Aug 15 2005 ro@suse.de
158- added check-build.sh
159* Thu Aug 11 2005 ro@suse.de
160- fix last change
161* Thu Aug 11 2005 ro@suse.de
162- moved pkgconfig file to /usr/share (noarch package)
163* Wed Aug 10 2005 ro@suse.de
164- keep monodoc script until we have a mono-tools package
165* Tue Aug  9 2005 gekker@suse.de
166- Update to version 1.0.7
167- Remove upstreamed patches
168* Mon Jul 18 2005 dkukawka@suse.de
169- changed package to noarch
170* Tue Feb 22 2005 ro@suse.de
171- fix build on x86_64
172* Mon Feb 21 2005 clahey@suse.de
173- Update to 1.0.6.
174* Sun Feb  6 2005 ro@suse.de
175- adapt pc-file
176* Thu Jan 20 2005 ro@suse.de
177- fix build on lib64
178* Fri Dec  3 2004 dkukawka@suse.de
179- fix libexecdir, now all {libdir}/monodoc files now at /usr/lib
180  instead of /usr/lib64 (with symlink)
181* Fri Dec  3 2004 ro@suse.de
182- removed wrong re-definitions of find_{requires,provides}
183* Tue Nov 30 2004 dkukawka@suse.de
184- init
Note: See TracBrowser for help on using the repository browser.