source: projects/specs/trunk/m/monodevelop/monodevelop-vl.spec @ 766

Revision 766, 12.1 KB checked in by owa, 14 years ago (diff)

updated mono to 2.6.3

Line 
1%define mono_dir %(/usr/bin/monodir)
2Summary: A Full-Featured IDE for Mono and Gtk#
3Summary(ja): Gtk# 版 Mono 統合開発環境
4Name: monodevelop
5Version: 2.2.2
6Release: 1%{?_dist_release}
7License: LGPL2.1
8Group: Applications/Development
9BuildArch: noarch
10URL: http://www.monodevelop.org/
11Source: http://mono.ximian.com/monobuild/preview/sources/%{name}/%{name}-%{version}.tar.bz2
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: mono-core >= 2.0
14Requires: monodoc >= 2.0
15Requires: gtk-sharp2 >= 2.8.0
16Requires: gtksourceview-sharp2 >= 0.10
17Requires: mono-addins mono-web
18Requires: mono-basic
19Requires: xsp
20Requires: pkgconfig
21PreReq: shared-mime-info
22BuildRequires: mono-devel mono-basic mono-nunit monodoc
23BuildRequires: gconf-sharp2 gtk-sharp2-gapi gtksourceview-sharp2
24BuildRequires: xsp mono-addins
25BuildRequires: intltool perl-XML-Parser shared-mime-info
26
27%description
28MonoDevelop is intended to be a full-featured integrated development
29environment (IDE) for mono and Gtk#. It was originally a port of
30SharpDevelop 0.98. See http://monodevelop.com/ for more information.
31
32%description -l ja
33MonoDevelop は mono と Gtk# のすべての機能を取り込んだ統合 IDE 環境を
34提供しようと考えてます。元は SharpDevelop 0.98 です。
35より詳しい説明は http://monodevelop.com/ をご覧ください。
36
37
38%prep
39%setup -q
40
41
42%build
43export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
44./configure \
45        --prefix=%{_prefix} \
46    --enable-subversion \
47    --enable-monoextensions \
48    --enable-aspnet \
49    --disable-update-mimedb \
50    --disable-update-desktopdb
51make
52
53
54%install
55rm -rf $RPM_BUILD_ROOT
56export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
57make install DESTDIR=$RPM_BUILD_ROOT \
58        GACUTIL_FLAGS="/package monodevelop /root ${RPM_BUILD_ROOT}%{_libdif}"
59
60mkdir -p $RPM_BUILD_ROOT%{_datadir}/pkgconfig
61mv $RPM_BUILD_ROOT%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT%{_datadir}/pkgconfig
62
63%find_lang %{name}
64
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69
70%post
71update-mime-database /usr/share/mime >/dev/null || :
72#%%run_suseconfig -m gtk2
73
74
75%postun
76update-mime-database /usr/share/mime >/dev/null || :
77#%%run_suseconfig -m gtk2
78
79
80%files -f %{name}.lang
81%defattr(-,root,root)
82%{_prefix}/bin/*
83%{_prefix}/lib/monodevelop
84%{_datadir}/applications/monodevelop.desktop
85%{_datadir}/mime/packages/monodevelop.xml
86%{_datadir}/icons/hicolor/*/apps/monodevelop.png
87%{_datadir}/icons/hicolor/scalable/apps/monodevelop.svg
88%{_datadir}/pkgconfig/monodevelop.pc
89%{_datadir}/pkgconfig/monodevelop-core-addins.pc
90%{_mandir}/man1/mdtool.1.gz
91%{_mandir}/man1/monodevelop.1.gz
92
93
94%changelog
95* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.2-1
96- updated monodevelop to 2.2.2
97
98* Sun Dec 27 2009 Shu KONNO <owa@bg.wakwak.com> 2.2-1
99- updated monodevelop to 2.2
100- changed licencse to LGPL2.1
101
102* Mon Jul 27 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-4
103- added description in japanease
104
105* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-3
106- rebuilt with latest rpm to update mono-dependencies
107
108* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-2
109- changed Group to Applications/Development
110
111* Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-1
112- updated monodevelop to 2.0
113
114* Mon Dec 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.1-1
115- updated monodevelop to 1.9.1
116- rebuilt with mono-2.0.1
117
118* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-1
119- initial build for VineSeed
120    - applied vine versioning policy
121    - added japanese summary
122    - spec in utf-8
123
124* Wed Apr  9 2008 wberrier@suse.de
125- Remove vte-sharp2 from build requires.  It's not needed,
126  and that package doesn't exist anymore.
127* Wed Mar 26 2008 wberrier@suse.de
128- Update to 1.0
129  - Bug fixes:
130  - MD Crashes when you drag a menu inside its own submenu
131    (bnc#363865)
132  - Monodevelop and stetic destroy forms (bnc#362596)
133  - Problem with subclassing any container widget (bnc#361650)
134  - Version Control doesn't behave propertly (bnc#363858)
135  - Comment and uncomment function (bnc#325469)
136  - Create Package fails on projects with translations (bnc#362567)
137  - Exception with null arguments or nonexistant paths when
138    compiling/cleaning C project (bnc#361045)
139  - MonoDevelop crashes when creating/opening C++ Console Project
140    (bnc#359567)
141  - Build Output autohide button missing (bnc#368436)
142  - Have to hit esc twice to close the file/new file dialog
143    (bnc#358361)
144- Changes in 0.19 (1.0 RC1)
145  - Will use 2.0 runtime as default
146  - Icons have been tango-ified
147  - More than 85 bugs fixed
148* Mon Jan 14 2008 wberrier@suse.de
149- Fixed .desktop file to adhear to standards
150- Fix naming of Slovenian translation
151- Update to 0.18
152  - packaging split (database, boo, and java in separate packages)
153  - Improved Dock Manager
154  - Circa 75 bugfixes
155- Update to 0.17
156  - Deployment of ASP.NET projects
157  - Support for VS 2005 Web Application projects
158  - ASP.NET Codebehind Generation Improvements
159  - Generation of Satellite Assemblies
160  - Makefile generation improvements
161  - Various other IDE enhancements
162  - Circa 90 bugfixes
163* Wed Oct 10 2007 wberrier@suse.de
164- Don't use fdupes afterall (fails build)
165* Tue Oct  9 2007 wberrier@suse.de
166- Update to 0.16
167  - C/C++ Support
168  - New Database Add-in
169  - Text editor improvements
170  - On-the-fly error underlining
171  - Auto-generation of XML comment tags
172  - New ASP.NET features
173  - Multiple GTK# versions
174  - ChangeLog add-in
175  - More than 100 bugs fixed
176* Mon Sep 24 2007 wberrier@suse.de
177- monodevelop-fix_kde_crash_r86138.patch: fix #309204
178* Fri Aug  3 2007 maw@suse.de
179- Use %%fdupes.
180* Fri Aug  3 2007 wberrier@suse.de
181- Remove upstream monodevelop-rename_ja_JP.patch
182- Update to 0.15
183  - Configurable keybindings
184  - Output pad pinning
185  - Makefile integration
186  - Standard header support for source files
187  - Localization add-in preview
188  - Text editor improvements
189  - Updated gtk# designer (support for gtk# 2.8 and 2.10 widgets)
190  - Assembly signing
191  - Message log for internal messages
192  - More than 60 bugs fixed
193* Thu Jun 14 2007 wberrier@novell.com
194- Put ja_JP locale files in valid location
195  (monodevelop-rename_ja_JP.patch)
196- Update to 0.14
197  - Improved Toolbox and Properties pad
198  - Subversion add-in updates
199  - auth prompts
200  - supports newer versions of subversion
201  - New refactory operations:
202  - rename
203  - implement interface
204  - encapsulate field
205  - Search by filename or classname in Open Solution File Dialog
206  - New class and member selector when browsing source
207  - Improved smart indenting for C#
208  - Project export/conversion
209  - Packaging features: automatic bundling of an app
210  - Desktop integration: automatically generate  shell wrappers,
211  .desktop and .pc files
212  - Improved New Project dialog
213  - New Navigation Toolbar
214  - Gtk# Designer updates:
215  - better widget defaults
216  - supports internal and custom widgets
217  - images assigned to widgets are automatically added to project
218  - Can add file to project while creating them
219  - Improved VS2005 support and VS integration
220  - VB.Net support utilizes new vbnc compiler
221  - Close to 100 bugs fixed
222* Wed May 16 2007 wberrier@novell.com
223- Remove gtkhtml2-devel from BuildRequires (not needed, allows
224  building on sle10)
225* Tue Apr 24 2007 wberrier@novell.com
226- Depend on version of boo found at build time
227* Fri Apr 13 2007 wberrier@novell.com
228- add %%debug_package so debug packages get created
229* Wed Apr 11 2007 wberrier@novell.com
230- Add mono dep/req for older distros
231* Thu Apr  5 2007 wberrier@suse.de
232- Update to 0.13.1:
233  - Bugfix release to fix some asp.net compilation issues
234- Adapt for buildservice
235- Clean up unnecessary BuildRequires
236* Thu Mar  1 2007 wberrier@suse.de
237- Update to 0.13:
238  - More than 70 bugs fixed
239  - Revamped VersionControl addin
240  - New task view features (TODO type lists)
241  - Code completion improvements and fixes
242  - Native support for VisualStudio 2005 Project files
243  - Custom commands in projects
244  - Makefile integration
245  - New Generic Project Type
246  - New Deployment infrastruction
247  - Automatic project reloading when changes in files detected
248  while the project is open
249  - Gtk# designer improvements (Undo/Redo support)
250  - Context sensitive help for classes when F1 is pressed
251  - Support for Win32Icon and Win32Resource options in C# projects
252  - New Layout toolbar which includes a combobox for fast layout
253  switching
254  - Support for files outside of a project directory
255  - Editor wrap mode selector
256  - File viewer selector (possible to have multiple viewers for
257  a filetype)
258  - Improvements in ASP.NET support:
259  - added a new option that can be used to disable compilation-time
260  CodeBehind verification for different configurations
261  - Several important stability fixes in AspNetEdit
262  - Improvements to toolbox, now includes default items with icons
263  - New Go to Type dialog, for easily jumping to a class defined
264  in a project
265* Mon Jan 22 2007 ro@suse.de
266- drop requires for gnome-filesystem
267* Wed Jan  3 2007 wberrier@suse.de
268- handle mime files properly
269  - spec file fixes from Andreas Hanke to fix bnc #225812
270* Thu Oct 19 2006 ro@suse.de
271- added mono-devel to buildrequires
272* Tue Sep  5 2006 wberrier@suse.de
273- Update to 0.12
274  - Better code completion support, supports C# 2.0
275  - Class information is shown using the syntax of the current
276  language
277  - New "Open With" Menu
278  - stetic menu designer
279  - autotools project support
280  - additional addin management features
281  - Support for multiple text file encodings
282  - ASP.NET Support
283  - Lots of bug fixes and better stability
284* Wed Aug 30 2006 wberrier@suse.de
285- Add mono-nunit to BuildRequires
286* Mon Jul 31 2006 wberrier@suse.de
287- Update to 0.11
288- Lots of new features and fixes, too many to list here.  One big
289  addition is the stetic gui designer integration
290- 2.4.0 -> 2.8.0 hack now unnecessary
291* Sun Mar 26 2006 ro@suse.de
292- removed ifarch from noarch package
293* Fri Mar 24 2006 wberrier@suse.de
294- Require mono-basic so that vbnet templates will compile
295* Wed Mar 15 2006 wberrier@suse.de
296- Update references for gtk# 2.4 to 2.8 in template files
297  * * Otherwise all the gtk#2 template projects will fail to compile **
298* Mon Mar 13 2006 wberrier@suse.de
299- Remove mime.cache and quote update_desktop args
300* Fri Feb 17 2006 gekker@suse.de
301- fixup desktop file for UI team
302* Wed Feb  1 2006 aj@suse.de
303- Fix Requires and BuildRequires to build again.
304* Wed Jan 25 2006 mls@suse.de
305- converted neededforbuild to BuildRequires
306* Fri Jan 13 2006 gekker@suse.de
307- Fixup nfb and Requires for new gtk-sharp2 packaging
308* Mon Jan  9 2006 gekker@suse.de
309- Fix to build against new mono version 1.1.13
310* Mon Dec 12 2005 wberrier@suse.de
311- Convert to noarch package, and clean up build deps
312* Tue Nov 29 2005 wberrier@suse.de
313- Update to 0.9 (which obsoletes the version control patch)
314* Fri Nov 18 2005 wberrier@suse.de
315- Patch VersionControl AddIn to compile with mcs 1.1.10
316* Mon Nov  7 2005 sbrabec@suse.cz
317- Renamed rename *-sharp-2_0 to *-sharp2 in Requires (#132436).
318* Tue Oct 25 2005 ro@suse.de
319- remove mono-debugger from nfb for the moment
320* Thu Oct 20 2005 ro@suse.de
321- rename gecko-sharp-2_0 and gtksourceview-sharp-2_0 in nfb
322* Thu Oct 13 2005 wberrier@suse.de
323- Update to 0.8 and add configure options (--enable-nunit --enable-versioncontrol --enable-monoextensions)
324* Thu Sep 22 2005 ro@suse.de
325- remove libgdiplus-devel from nfb (dropped)
326* Tue Sep 13 2005 gekker@suse.de
327- Disable boo support so monodevelop will run (113802)
328* Sun Sep  4 2005 aj@suse.de
329- Update check-build.sh.
330* Tue Aug 30 2005 ro@suse.de
331- do not require mono-debugger on ppc (can not build there)
332* Fri Aug 26 2005 ro@suse.de
333- nfb: monodoc -> monodoc-core
334* Thu Aug 18 2005 gekker@suse.de
335- Fix desktop category for menus.
336* Tue Aug 16 2005 aj@suse.de
337- Add check-build script.
338* Tue Aug  9 2005 gekker@suse.de
339- Fix requirements
340- Remove files that conflict with shared-mime-info
341- Verify that bugs #71734 and #71735 are fixed
342* Sun Aug  7 2005 ro@suse.de
343- rename nfb and deps for gtksourceview-sharp and gecko-sharp
344* Thu Aug  4 2005 gekker@suse.de
345- Update to version 0.7
346- Remove upstreamed patches
347* Wed May 18 2005 gekker@suse.de
348- fix to build with mono-1.1.7
349* Tue Mar  1 2005 gekker@suse.de
350- fix requires (66770).
351* Tue Feb 15 2005 ro@suse.de
352- fix build on x86_64
353* Tue Feb  8 2005 gekker@suse.de
354- Add patches to fix namespacing issues.
355- Add suse_update_desktop_config
356* Mon Dec 13 2004 clahey@suse.de
357- New package.
Note: See TracBrowser for help on using the repository browser.