source: projects/specs/trunk/m/monodevelop/monodevelop-vl.spec @ 9581

Revision 9581, 14.9 KB checked in by inagaki, 9 years ago (diff)

2015-05-26 Ryoichi INAGAKI <ryo1@…>

  • mono-nuget, nunit: NEW package
  • monodevelop: updated


Line 
1Summary:        A Full-Featured IDE for Mono and Gtk#
2Summary(ja):    Gtk# 版 Mono 統合開発環境
3Name:           monodevelop
4Version:        5.9
5Release:        1%{?_dist_release}
6License:        LGPLv2.1 and MIT
7Group:          Applications/Development
8URL:            http://www.monodevelop.org/
9
10Source0:        http://download.mono-project.com/sources/%{name}/%{name}-%{version}.0.431.tar.bz2
11Patch0:         downgrade_to_mvc3.patch
12
13# Vine patch(es)
14Patch70:        monodevelop-5.9-exec.patch
15
16BuildArch:      noarch
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires:  gconf-sharp2-devel
19BuildRequires:  gnome-sharp2-devel
20BuildRequires:  gnome-vfs-sharp2-devel
21BuildRequires:  gtk-sharp2-devel
22BuildRequires:  gtksourceview-sharp2-devel
23BuildRequires:  libgnomeui-devel
24
25BuildRequires:  mono-addins-devel
26BuildRequires:  mono-data
27BuildRequires:  mono-devel
28BuildRequires:  mono-mvc-devel
29BuildRequires:  mono-nuget-devel
30BuildRequires:  mono-wcf-devel
31BuildRequires:  monodoc
32BuildRequires:  nunit-devel
33
34BuildRequires:  intltool perl-XML-Parser shared-mime-info
35BuildRequires:  dos2unix shared-mime-info desktop-file-utils
36BuildRequires:  git
37# Mono.Cecil.dll requires rsync after it's build
38BuildRequires:  rsync
39
40Requires:       mono-basic
41Requires:       mono-web
42Requires:       nunit
43Requires:       xsp
44Requires:       mono-devel
45Requires:       mono-tools
46Requires:       git
47Requires:       pkgconfig
48Requires(post,postun): shared-mime-info
49
50%description
51MonoDevelop is a full-featured integrated development
52environment (IDE) for Mono and Gtk# primarily designed
53for C-Sharp and other .NET languages. It allows to quickly
54create desktop and ASP.NET Web applications. Support
55for Visual Studio file formats eases porting to Linux.
56
57%description -l ja
58MonoDevelop は主として C# やその他の .NET 言語向けの、mono 及び Gtk# の
59すべての機能を取り込んだ統合 IDE 環境です.デスクトップアプリケーション及び
60ASP.NET ウェブアプリケーションを迅速に作成することができます.Visual Studio
61形式のファイルをサポートしており、Linux へのポーティングを簡易にします.
62
63%package devel
64Summary:        Development files for MonoDevelop
65Summary(ja):    MonoDevelop の開発用ファイル
66Group:          Development/Libraries
67Requires:       monodevelop = %{version}-%{release}
68
69%description devel
70This package contains development files for the IDE and plugins.
71
72%prep
73%setup -q
74%patch0 -p1
75%patch70 -p1
76
77%build
78export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
79%configure \
80    --libdir=%{_prefix}/lib \
81    --disable-update-mimedb \
82    --disable-update-desktopdb
83
84#./configure \
85#    --prefix=%{_prefix} \
86#    --enable-subversion \
87#    --enable-monoextensions \
88#    --enable-aspnet \
89#    --disable-update-mimedb \
90#    --disable-update-desktopdb
91make
92
93
94%install
95rm -rf $RPM_BUILD_ROOT
96export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
97make install DESTDIR=$RPM_BUILD_ROOT \
98        GACUTIL_FLAGS="/package monodevelop /root ${RPM_BUILD_ROOT}%{_prefix}/lib"
99
100mkdir -p $RPM_BUILD_ROOT%{_datadir}/pkgconfig
101mv $RPM_BUILD_ROOT%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT%{_datadir}/pkgconfig
102
103cp -a %{_prefix}/lib/mono/nuget/NuGet.Core.dll $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/AddIns/MonoDevelop.PackageManagement/
104cp -a %{_prefix}/lib/mono/nuget/Microsoft.Web.XmlTransform.dll $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/AddIns/MonoDevelop.PackageManagement/
105
106ln -s %{_prefix}/lib/mono/nunit/nunit.core.dll $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/AddIns/NUnit/
107ln -s %{_prefix}/lib/mono/nunit/nunit.core.interfaces.dll $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/AddIns/NUnit/
108ln -s %{_prefix}/lib/mono/nunit/nunit.framework.dll $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/AddIns/NUnit/
109ln -s %{_prefix}/lib/mono/nunit/nunit.util.dll $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/AddIns/NUnit/
110
111rm -rf $RPM_BUILD_ROOT%{_prefix}/lib/monodevelop/locale
112
113%find_lang %{name}
114
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119
120%post
121touch --no-create %{_datadir}/icons/hicolor || :
122
123%postun
124if [ $1 -eq 0 ] ; then
125    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
126    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
127    update-desktop-database -q &> /dev/null
128    update-mime-database %{_datadir}/mime &> /dev/null
129fi
130
131%posttrans
132gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
133update-desktop-database -q &> /dev/null
134update-mime-database %{_datadir}/mime &> /dev/null
135
136
137%files -f %{name}.lang
138%defattr(-,root,root)
139%doc AUTHORS ChangeLog COPYING README
140%{_prefix}/bin/*
141%{_prefix}/lib/monodevelop
142%{_datadir}/applications/monodevelop.desktop
143%{_datadir}/mime/packages/monodevelop.xml
144%{_datadir}/icons/hicolor/*/apps/monodevelop.png
145%{_datadir}/icons/hicolor/scalable/apps/monodevelop.svg
146%{_mandir}/man1/mdtool.1.gz
147%{_mandir}/man1/monodevelop.1.gz
148
149%files devel
150%defattr(-,root,root)
151%{_datadir}/pkgconfig/monodevelop.pc
152%{_datadir}/pkgconfig/monodevelop-core-addins.pc
153
154
155%changelog
156* Tue May 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.9-1
157- new upstream release
158- added Patch0 from OpenSUSE
159- added Patch70 for launching monodevelop
160- split pkgconfig file into devel subpackage
161
162* Mon Apr 25 2011 Shu KONNO <owa@bg.wakwak.com> 2.4.2-2
163- rebuilt with mono-2.10.1-3
164
165* Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
166- updated monodevelop to 2.4.2
167
168* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.4-2
169- rebuild with mono-addins-0.5
170
171* Thu Jun 17 2010 Shu KONNO <owa@bg.wakwak.com> 2.4-1
172- updated monodevelop to 2.4
173- changed source url
174
175* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.2-1
176- updated monodevelop to 2.2.2
177
178* Sun Dec 27 2009 Shu KONNO <owa@bg.wakwak.com> 2.2-1
179- updated monodevelop to 2.2
180- changed licencse to LGPL2.1
181
182* Mon Jul 27 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-4
183- added description in japanease
184
185* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-3
186- rebuilt with latest rpm to update mono-dependencies
187
188* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-2
189- changed Group to Applications/Development
190
191* Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-1
192- updated monodevelop to 2.0
193
194* Mon Dec 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.1-1
195- updated monodevelop to 1.9.1
196- rebuilt with mono-2.0.1
197
198* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-1
199- initial build for VineSeed
200    - applied vine versioning policy
201    - added japanese summary
202    - spec in utf-8
203
204* Wed Apr  9 2008 wberrier@suse.de
205- Remove vte-sharp2 from build requires.  It's not needed,
206  and that package doesn't exist anymore.
207* Wed Mar 26 2008 wberrier@suse.de
208- Update to 1.0
209  - Bug fixes:
210  - MD Crashes when you drag a menu inside its own submenu
211    (bnc#363865)
212  - Monodevelop and stetic destroy forms (bnc#362596)
213  - Problem with subclassing any container widget (bnc#361650)
214  - Version Control doesn't behave propertly (bnc#363858)
215  - Comment and uncomment function (bnc#325469)
216  - Create Package fails on projects with translations (bnc#362567)
217  - Exception with null arguments or nonexistant paths when
218    compiling/cleaning C project (bnc#361045)
219  - MonoDevelop crashes when creating/opening C++ Console Project
220    (bnc#359567)
221  - Build Output autohide button missing (bnc#368436)
222  - Have to hit esc twice to close the file/new file dialog
223    (bnc#358361)
224- Changes in 0.19 (1.0 RC1)
225  - Will use 2.0 runtime as default
226  - Icons have been tango-ified
227  - More than 85 bugs fixed
228* Mon Jan 14 2008 wberrier@suse.de
229- Fixed .desktop file to adhear to standards
230- Fix naming of Slovenian translation
231- Update to 0.18
232  - packaging split (database, boo, and java in separate packages)
233  - Improved Dock Manager
234  - Circa 75 bugfixes
235- Update to 0.17
236  - Deployment of ASP.NET projects
237  - Support for VS 2005 Web Application projects
238  - ASP.NET Codebehind Generation Improvements
239  - Generation of Satellite Assemblies
240  - Makefile generation improvements
241  - Various other IDE enhancements
242  - Circa 90 bugfixes
243* Wed Oct 10 2007 wberrier@suse.de
244- Don't use fdupes afterall (fails build)
245* Tue Oct  9 2007 wberrier@suse.de
246- Update to 0.16
247  - C/C++ Support
248  - New Database Add-in
249  - Text editor improvements
250  - On-the-fly error underlining
251  - Auto-generation of XML comment tags
252  - New ASP.NET features
253  - Multiple GTK# versions
254  - ChangeLog add-in
255  - More than 100 bugs fixed
256* Mon Sep 24 2007 wberrier@suse.de
257- monodevelop-fix_kde_crash_r86138.patch: fix #309204
258* Fri Aug  3 2007 maw@suse.de
259- Use %%fdupes.
260* Fri Aug  3 2007 wberrier@suse.de
261- Remove upstream monodevelop-rename_ja_JP.patch
262- Update to 0.15
263  - Configurable keybindings
264  - Output pad pinning
265  - Makefile integration
266  - Standard header support for source files
267  - Localization add-in preview
268  - Text editor improvements
269  - Updated gtk# designer (support for gtk# 2.8 and 2.10 widgets)
270  - Assembly signing
271  - Message log for internal messages
272  - More than 60 bugs fixed
273* Thu Jun 14 2007 wberrier@novell.com
274- Put ja_JP locale files in valid location
275  (monodevelop-rename_ja_JP.patch)
276- Update to 0.14
277  - Improved Toolbox and Properties pad
278  - Subversion add-in updates
279  - auth prompts
280  - supports newer versions of subversion
281  - New refactory operations:
282  - rename
283  - implement interface
284  - encapsulate field
285  - Search by filename or classname in Open Solution File Dialog
286  - New class and member selector when browsing source
287  - Improved smart indenting for C#
288  - Project export/conversion
289  - Packaging features: automatic bundling of an app
290  - Desktop integration: automatically generate  shell wrappers,
291  .desktop and .pc files
292  - Improved New Project dialog
293  - New Navigation Toolbar
294  - Gtk# Designer updates:
295  - better widget defaults
296  - supports internal and custom widgets
297  - images assigned to widgets are automatically added to project
298  - Can add file to project while creating them
299  - Improved VS2005 support and VS integration
300  - VB.Net support utilizes new vbnc compiler
301  - Close to 100 bugs fixed
302* Wed May 16 2007 wberrier@novell.com
303- Remove gtkhtml2-devel from BuildRequires (not needed, allows
304  building on sle10)
305* Tue Apr 24 2007 wberrier@novell.com
306- Depend on version of boo found at build time
307* Fri Apr 13 2007 wberrier@novell.com
308- add %%debug_package so debug packages get created
309* Wed Apr 11 2007 wberrier@novell.com
310- Add mono dep/req for older distros
311* Thu Apr  5 2007 wberrier@suse.de
312- Update to 0.13.1:
313  - Bugfix release to fix some asp.net compilation issues
314- Adapt for buildservice
315- Clean up unnecessary BuildRequires
316* Thu Mar  1 2007 wberrier@suse.de
317- Update to 0.13:
318  - More than 70 bugs fixed
319  - Revamped VersionControl addin
320  - New task view features (TODO type lists)
321  - Code completion improvements and fixes
322  - Native support for VisualStudio 2005 Project files
323  - Custom commands in projects
324  - Makefile integration
325  - New Generic Project Type
326  - New Deployment infrastruction
327  - Automatic project reloading when changes in files detected
328  while the project is open
329  - Gtk# designer improvements (Undo/Redo support)
330  - Context sensitive help for classes when F1 is pressed
331  - Support for Win32Icon and Win32Resource options in C# projects
332  - New Layout toolbar which includes a combobox for fast layout
333  switching
334  - Support for files outside of a project directory
335  - Editor wrap mode selector
336  - File viewer selector (possible to have multiple viewers for
337  a filetype)
338  - Improvements in ASP.NET support:
339  - added a new option that can be used to disable compilation-time
340  CodeBehind verification for different configurations
341  - Several important stability fixes in AspNetEdit
342  - Improvements to toolbox, now includes default items with icons
343  - New Go to Type dialog, for easily jumping to a class defined
344  in a project
345* Mon Jan 22 2007 ro@suse.de
346- drop requires for gnome-filesystem
347* Wed Jan  3 2007 wberrier@suse.de
348- handle mime files properly
349  - spec file fixes from Andreas Hanke to fix bnc #225812
350* Thu Oct 19 2006 ro@suse.de
351- added mono-devel to buildrequires
352* Tue Sep  5 2006 wberrier@suse.de
353- Update to 0.12
354  - Better code completion support, supports C# 2.0
355  - Class information is shown using the syntax of the current
356  language
357  - New "Open With" Menu
358  - stetic menu designer
359  - autotools project support
360  - additional addin management features
361  - Support for multiple text file encodings
362  - ASP.NET Support
363  - Lots of bug fixes and better stability
364* Wed Aug 30 2006 wberrier@suse.de
365- Add mono-nunit to BuildRequires
366* Mon Jul 31 2006 wberrier@suse.de
367- Update to 0.11
368- Lots of new features and fixes, too many to list here.  One big
369  addition is the stetic gui designer integration
370- 2.4.0 -> 2.8.0 hack now unnecessary
371* Sun Mar 26 2006 ro@suse.de
372- removed ifarch from noarch package
373* Fri Mar 24 2006 wberrier@suse.de
374- Require mono-basic so that vbnet templates will compile
375* Wed Mar 15 2006 wberrier@suse.de
376- Update references for gtk# 2.4 to 2.8 in template files
377  * * Otherwise all the gtk#2 template projects will fail to compile **
378* Mon Mar 13 2006 wberrier@suse.de
379- Remove mime.cache and quote update_desktop args
380* Fri Feb 17 2006 gekker@suse.de
381- fixup desktop file for UI team
382* Wed Feb  1 2006 aj@suse.de
383- Fix Requires and BuildRequires to build again.
384* Wed Jan 25 2006 mls@suse.de
385- converted neededforbuild to BuildRequires
386* Fri Jan 13 2006 gekker@suse.de
387- Fixup nfb and Requires for new gtk-sharp2 packaging
388* Mon Jan  9 2006 gekker@suse.de
389- Fix to build against new mono version 1.1.13
390* Mon Dec 12 2005 wberrier@suse.de
391- Convert to noarch package, and clean up build deps
392* Tue Nov 29 2005 wberrier@suse.de
393- Update to 0.9 (which obsoletes the version control patch)
394* Fri Nov 18 2005 wberrier@suse.de
395- Patch VersionControl AddIn to compile with mcs 1.1.10
396* Mon Nov  7 2005 sbrabec@suse.cz
397- Renamed rename *-sharp-2_0 to *-sharp2 in Requires (#132436).
398* Tue Oct 25 2005 ro@suse.de
399- remove mono-debugger from nfb for the moment
400* Thu Oct 20 2005 ro@suse.de
401- rename gecko-sharp-2_0 and gtksourceview-sharp-2_0 in nfb
402* Thu Oct 13 2005 wberrier@suse.de
403- Update to 0.8 and add configure options (--enable-nunit --enable-versioncontrol --enable-monoextensions)
404* Thu Sep 22 2005 ro@suse.de
405- remove libgdiplus-devel from nfb (dropped)
406* Tue Sep 13 2005 gekker@suse.de
407- Disable boo support so monodevelop will run (113802)
408* Sun Sep  4 2005 aj@suse.de
409- Update check-build.sh.
410* Tue Aug 30 2005 ro@suse.de
411- do not require mono-debugger on ppc (can not build there)
412* Fri Aug 26 2005 ro@suse.de
413- nfb: monodoc -> monodoc-core
414* Thu Aug 18 2005 gekker@suse.de
415- Fix desktop category for menus.
416* Tue Aug 16 2005 aj@suse.de
417- Add check-build script.
418* Tue Aug  9 2005 gekker@suse.de
419- Fix requirements
420- Remove files that conflict with shared-mime-info
421- Verify that bugs #71734 and #71735 are fixed
422* Sun Aug  7 2005 ro@suse.de
423- rename nfb and deps for gtksourceview-sharp and gecko-sharp
424* Thu Aug  4 2005 gekker@suse.de
425- Update to version 0.7
426- Remove upstreamed patches
427* Wed May 18 2005 gekker@suse.de
428- fix to build with mono-1.1.7
429* Tue Mar  1 2005 gekker@suse.de
430- fix requires (66770).
431* Tue Feb 15 2005 ro@suse.de
432- fix build on x86_64
433* Tue Feb  8 2005 gekker@suse.de
434- Add patches to fix namespacing issues.
435- Add suse_update_desktop_config
436* Mon Dec 13 2004 clahey@suse.de
437- New package.
Note: See TracBrowser for help on using the repository browser.