source: projects/specs/trunk/m/monodevelop/monodevelop-vl.spec @ 521

Revision 521, 12.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define mono_dir %(/usr/bin/monodir)
2Summary: A Full-Featured IDE for Mono and Gtk#
3Summary(ja): Gtk# 版 Mono 統合開発環境
4Name: monodevelop
5Version: 2.2
6Release: 1%{?_dist_release}
7License: LGPL2.1
8Group: Applications/Development
9BuildArch: noarch
10URL: http://www.monodevelop.org/
11Source: http://mono.ximian.com/monobuild/preview/sources/%{name}/%{name}-%{version}.tar.bz2
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: mono-core >= 2.0
14Requires: monodoc >= 2.0
15Requires: gtk-sharp2 >= 2.8.0
16Requires: gtksourceview-sharp2 >= 0.10
17Requires: mono-addins mono-web
18Requires: mono-basic
19Requires: xsp
20Requires: pkgconfig
21PreReq: shared-mime-info
22BuildRequires: mono-devel mono-basic mono-nunit monodoc
23BuildRequires: gconf-sharp2 gtk-sharp2-gapi gtksourceview-sharp2
24BuildRequires: xsp mono-addins
25BuildRequires: intltool perl-XML-Parser shared-mime-info
26
27%description
28MonoDevelop is intended to be a full-featured integrated development
29environment (IDE) for mono and Gtk#. It was originally a port of
30SharpDevelop 0.98. See http://monodevelop.com/ for more information.
31
32%description -l ja
33MonoDevelop は mono と Gtk# のすべての機能を取り込んだ統合 IDE 環境を
34提供しようと考えてます。元は SharpDevelop 0.98 です。
35より詳しい説明は http://monodevelop.com/ をご覧ください。
36
37
38%prep
39%setup -q
40
41
42%build
43export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
44./configure \
45        --prefix=%{_prefix} \
46    --enable-subversion \
47    --enable-monoextensions \
48    --enable-aspnet \
49    --disable-update-mimedb \
50    --disable-update-desktopdb
51make
52
53
54%install
55rm -rf $RPM_BUILD_ROOT
56export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
57make install DESTDIR=$RPM_BUILD_ROOT \
58        GACUTIL_FLAGS="/package monodevelop /root ${RPM_BUILD_ROOT}%{_libdif}"
59
60mkdir -p $RPM_BUILD_ROOT%{_datadir}/pkgconfig
61mv $RPM_BUILD_ROOT%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT%{_datadir}/pkgconfig
62
63%find_lang %{name}
64
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69
70%post
71update-mime-database /usr/share/mime >/dev/null || :
72#%%run_suseconfig -m gtk2
73
74
75%postun
76update-mime-database /usr/share/mime >/dev/null || :
77#%%run_suseconfig -m gtk2
78
79
80%files -f %{name}.lang
81%defattr(-,root,root)
82%{_prefix}/bin/*
83%{_prefix}/lib/monodevelop
84%{_datadir}/applications/monodevelop.desktop
85%{_datadir}/mime/packages/monodevelop.xml
86%{_datadir}/icons/hicolor/*/apps/monodevelop.png
87%{_datadir}/icons/hicolor/scalable/apps/monodevelop.svg
88%{_datadir}/pkgconfig/monodevelop.pc
89%{_datadir}/pkgconfig/monodevelop-core-addins.pc
90%{_mandir}/man1/mdtool.1.gz
91%{_mandir}/man1/monodevelop.1.gz
92
93
94%changelog
95* Sun Dec 27 2009 Shu KONNO <owa@bg.wakwak.com> 2.2-1
96- updated monodevelop to 2.2
97- changed licencse to LGPL2.1
98
99* Mon Jul 27 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-4
100- added description in japanease
101
102* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-3
103- rebuilt with latest rpm to update mono-dependencies
104
105* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-2
106- changed Group to Applications/Development
107
108* Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-1
109- updated monodevelop to 2.0
110
111* Mon Dec 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.1-1
112- updated monodevelop to 1.9.1
113- rebuilt with mono-2.0.1
114
115* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-1
116- initial build for VineSeed
117    - applied vine versioning policy
118    - added japanese summary
119    - spec in utf-8
120
121* Wed Apr  9 2008 wberrier@suse.de
122- Remove vte-sharp2 from build requires.  It's not needed,
123  and that package doesn't exist anymore.
124* Wed Mar 26 2008 wberrier@suse.de
125- Update to 1.0
126  - Bug fixes:
127  - MD Crashes when you drag a menu inside its own submenu
128    (bnc#363865)
129  - Monodevelop and stetic destroy forms (bnc#362596)
130  - Problem with subclassing any container widget (bnc#361650)
131  - Version Control doesn't behave propertly (bnc#363858)
132  - Comment and uncomment function (bnc#325469)
133  - Create Package fails on projects with translations (bnc#362567)
134  - Exception with null arguments or nonexistant paths when
135    compiling/cleaning C project (bnc#361045)
136  - MonoDevelop crashes when creating/opening C++ Console Project
137    (bnc#359567)
138  - Build Output autohide button missing (bnc#368436)
139  - Have to hit esc twice to close the file/new file dialog
140    (bnc#358361)
141- Changes in 0.19 (1.0 RC1)
142  - Will use 2.0 runtime as default
143  - Icons have been tango-ified
144  - More than 85 bugs fixed
145* Mon Jan 14 2008 wberrier@suse.de
146- Fixed .desktop file to adhear to standards
147- Fix naming of Slovenian translation
148- Update to 0.18
149  - packaging split (database, boo, and java in separate packages)
150  - Improved Dock Manager
151  - Circa 75 bugfixes
152- Update to 0.17
153  - Deployment of ASP.NET projects
154  - Support for VS 2005 Web Application projects
155  - ASP.NET Codebehind Generation Improvements
156  - Generation of Satellite Assemblies
157  - Makefile generation improvements
158  - Various other IDE enhancements
159  - Circa 90 bugfixes
160* Wed Oct 10 2007 wberrier@suse.de
161- Don't use fdupes afterall (fails build)
162* Tue Oct  9 2007 wberrier@suse.de
163- Update to 0.16
164  - C/C++ Support
165  - New Database Add-in
166  - Text editor improvements
167  - On-the-fly error underlining
168  - Auto-generation of XML comment tags
169  - New ASP.NET features
170  - Multiple GTK# versions
171  - ChangeLog add-in
172  - More than 100 bugs fixed
173* Mon Sep 24 2007 wberrier@suse.de
174- monodevelop-fix_kde_crash_r86138.patch: fix #309204
175* Fri Aug  3 2007 maw@suse.de
176- Use %%fdupes.
177* Fri Aug  3 2007 wberrier@suse.de
178- Remove upstream monodevelop-rename_ja_JP.patch
179- Update to 0.15
180  - Configurable keybindings
181  - Output pad pinning
182  - Makefile integration
183  - Standard header support for source files
184  - Localization add-in preview
185  - Text editor improvements
186  - Updated gtk# designer (support for gtk# 2.8 and 2.10 widgets)
187  - Assembly signing
188  - Message log for internal messages
189  - More than 60 bugs fixed
190* Thu Jun 14 2007 wberrier@novell.com
191- Put ja_JP locale files in valid location
192  (monodevelop-rename_ja_JP.patch)
193- Update to 0.14
194  - Improved Toolbox and Properties pad
195  - Subversion add-in updates
196  - auth prompts
197  - supports newer versions of subversion
198  - New refactory operations:
199  - rename
200  - implement interface
201  - encapsulate field
202  - Search by filename or classname in Open Solution File Dialog
203  - New class and member selector when browsing source
204  - Improved smart indenting for C#
205  - Project export/conversion
206  - Packaging features: automatic bundling of an app
207  - Desktop integration: automatically generate  shell wrappers,
208  .desktop and .pc files
209  - Improved New Project dialog
210  - New Navigation Toolbar
211  - Gtk# Designer updates:
212  - better widget defaults
213  - supports internal and custom widgets
214  - images assigned to widgets are automatically added to project
215  - Can add file to project while creating them
216  - Improved VS2005 support and VS integration
217  - VB.Net support utilizes new vbnc compiler
218  - Close to 100 bugs fixed
219* Wed May 16 2007 wberrier@novell.com
220- Remove gtkhtml2-devel from BuildRequires (not needed, allows
221  building on sle10)
222* Tue Apr 24 2007 wberrier@novell.com
223- Depend on version of boo found at build time
224* Fri Apr 13 2007 wberrier@novell.com
225- add %%debug_package so debug packages get created
226* Wed Apr 11 2007 wberrier@novell.com
227- Add mono dep/req for older distros
228* Thu Apr  5 2007 wberrier@suse.de
229- Update to 0.13.1:
230  - Bugfix release to fix some asp.net compilation issues
231- Adapt for buildservice
232- Clean up unnecessary BuildRequires
233* Thu Mar  1 2007 wberrier@suse.de
234- Update to 0.13:
235  - More than 70 bugs fixed
236  - Revamped VersionControl addin
237  - New task view features (TODO type lists)
238  - Code completion improvements and fixes
239  - Native support for VisualStudio 2005 Project files
240  - Custom commands in projects
241  - Makefile integration
242  - New Generic Project Type
243  - New Deployment infrastruction
244  - Automatic project reloading when changes in files detected
245  while the project is open
246  - Gtk# designer improvements (Undo/Redo support)
247  - Context sensitive help for classes when F1 is pressed
248  - Support for Win32Icon and Win32Resource options in C# projects
249  - New Layout toolbar which includes a combobox for fast layout
250  switching
251  - Support for files outside of a project directory
252  - Editor wrap mode selector
253  - File viewer selector (possible to have multiple viewers for
254  a filetype)
255  - Improvements in ASP.NET support:
256  - added a new option that can be used to disable compilation-time
257  CodeBehind verification for different configurations
258  - Several important stability fixes in AspNetEdit
259  - Improvements to toolbox, now includes default items with icons
260  - New Go to Type dialog, for easily jumping to a class defined
261  in a project
262* Mon Jan 22 2007 ro@suse.de
263- drop requires for gnome-filesystem
264* Wed Jan  3 2007 wberrier@suse.de
265- handle mime files properly
266  - spec file fixes from Andreas Hanke to fix bnc #225812
267* Thu Oct 19 2006 ro@suse.de
268- added mono-devel to buildrequires
269* Tue Sep  5 2006 wberrier@suse.de
270- Update to 0.12
271  - Better code completion support, supports C# 2.0
272  - Class information is shown using the syntax of the current
273  language
274  - New "Open With" Menu
275  - stetic menu designer
276  - autotools project support
277  - additional addin management features
278  - Support for multiple text file encodings
279  - ASP.NET Support
280  - Lots of bug fixes and better stability
281* Wed Aug 30 2006 wberrier@suse.de
282- Add mono-nunit to BuildRequires
283* Mon Jul 31 2006 wberrier@suse.de
284- Update to 0.11
285- Lots of new features and fixes, too many to list here.  One big
286  addition is the stetic gui designer integration
287- 2.4.0 -> 2.8.0 hack now unnecessary
288* Sun Mar 26 2006 ro@suse.de
289- removed ifarch from noarch package
290* Fri Mar 24 2006 wberrier@suse.de
291- Require mono-basic so that vbnet templates will compile
292* Wed Mar 15 2006 wberrier@suse.de
293- Update references for gtk# 2.4 to 2.8 in template files
294  * * Otherwise all the gtk#2 template projects will fail to compile **
295* Mon Mar 13 2006 wberrier@suse.de
296- Remove mime.cache and quote update_desktop args
297* Fri Feb 17 2006 gekker@suse.de
298- fixup desktop file for UI team
299* Wed Feb  1 2006 aj@suse.de
300- Fix Requires and BuildRequires to build again.
301* Wed Jan 25 2006 mls@suse.de
302- converted neededforbuild to BuildRequires
303* Fri Jan 13 2006 gekker@suse.de
304- Fixup nfb and Requires for new gtk-sharp2 packaging
305* Mon Jan  9 2006 gekker@suse.de
306- Fix to build against new mono version 1.1.13
307* Mon Dec 12 2005 wberrier@suse.de
308- Convert to noarch package, and clean up build deps
309* Tue Nov 29 2005 wberrier@suse.de
310- Update to 0.9 (which obsoletes the version control patch)
311* Fri Nov 18 2005 wberrier@suse.de
312- Patch VersionControl AddIn to compile with mcs 1.1.10
313* Mon Nov  7 2005 sbrabec@suse.cz
314- Renamed rename *-sharp-2_0 to *-sharp2 in Requires (#132436).
315* Tue Oct 25 2005 ro@suse.de
316- remove mono-debugger from nfb for the moment
317* Thu Oct 20 2005 ro@suse.de
318- rename gecko-sharp-2_0 and gtksourceview-sharp-2_0 in nfb
319* Thu Oct 13 2005 wberrier@suse.de
320- Update to 0.8 and add configure options (--enable-nunit --enable-versioncontrol --enable-monoextensions)
321* Thu Sep 22 2005 ro@suse.de
322- remove libgdiplus-devel from nfb (dropped)
323* Tue Sep 13 2005 gekker@suse.de
324- Disable boo support so monodevelop will run (113802)
325* Sun Sep  4 2005 aj@suse.de
326- Update check-build.sh.
327* Tue Aug 30 2005 ro@suse.de
328- do not require mono-debugger on ppc (can not build there)
329* Fri Aug 26 2005 ro@suse.de
330- nfb: monodoc -> monodoc-core
331* Thu Aug 18 2005 gekker@suse.de
332- Fix desktop category for menus.
333* Tue Aug 16 2005 aj@suse.de
334- Add check-build script.
335* Tue Aug  9 2005 gekker@suse.de
336- Fix requirements
337- Remove files that conflict with shared-mime-info
338- Verify that bugs #71734 and #71735 are fixed
339* Sun Aug  7 2005 ro@suse.de
340- rename nfb and deps for gtksourceview-sharp and gecko-sharp
341* Thu Aug  4 2005 gekker@suse.de
342- Update to version 0.7
343- Remove upstreamed patches
344* Wed May 18 2005 gekker@suse.de
345- fix to build with mono-1.1.7
346* Tue Mar  1 2005 gekker@suse.de
347- fix requires (66770).
348* Tue Feb 15 2005 ro@suse.de
349- fix build on x86_64
350* Tue Feb  8 2005 gekker@suse.de
351- Add patches to fix namespacing issues.
352- Add suse_update_desktop_config
353* Mon Dec 13 2004 clahey@suse.de
354- New package.
Note: See TracBrowser for help on using the repository browser.