source: projects/specs/trunk/m/monodevelop/monodevelop-vl.spec @ 2222

Revision 2222, 12.5 KB checked in by owa, 14 years ago (diff)

new upstream

Line 
1%define mono_dir %(/usr/bin/monodir)
2Summary: A Full-Featured IDE for Mono and Gtk#
3Summary(ja): Gtk# 版 Mono 統合開発環境
4Name: monodevelop
5Version: 2.4.1
6Release: 1%{?_dist_release}
7License: LGPL2.1
8Group: Applications/Development
9BuildArch: noarch
10URL: http://www.monodevelop.org/
11Source: http://ftp.novell.com/pub/mono/sources/%{name}/%{name}-%{version}.tar.bz2
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: mono-core >= 2.6.1
14Requires: monodoc >= 2.6.1
15Requires: gtk-sharp2 >= 2.12.8
16Requires: gtksourceview-sharp2 >= 0.10
17Requires: mono-addins
18Requires: mono-basic
19Requires: mono-web
20Requires: xsp
21Requires: pkgconfig
22PreReq: shared-mime-info
23BuildRequires: mono-devel mono-basic mono-nunit monodoc
24BuildRequires: gconf-sharp2 gtk-sharp2-gapi gtksourceview-sharp2
25BuildRequires: xsp mono-addins
26BuildRequires: intltool perl-XML-Parser shared-mime-info
27
28%description
29MonoDevelop is intended to be a full-featured integrated development
30environment (IDE) for mono and Gtk#. It was originally a port of
31SharpDevelop 0.98. See http://monodevelop.com/ for more information.
32
33%description -l ja
34MonoDevelop は mono と Gtk# のすべての機能を取り込んだ統合 IDE 環境を
35提供しようと考えてます。元は SharpDevelop 0.98 です。
36より詳しい説明は http://monodevelop.com/ をご覧ください。
37
38
39%prep
40%setup -q
41
42
43%build
44export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
45./configure \
46        --prefix=%{_prefix} \
47    --enable-subversion \
48    --enable-monoextensions \
49    --enable-aspnet \
50    --disable-update-mimedb \
51    --disable-update-desktopdb
52make
53
54
55%install
56rm -rf $RPM_BUILD_ROOT
57export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
58make install DESTDIR=$RPM_BUILD_ROOT \
59        GACUTIL_FLAGS="/package monodevelop /root ${RPM_BUILD_ROOT}%{_libdif}"
60
61mkdir -p $RPM_BUILD_ROOT%{_datadir}/pkgconfig
62mv $RPM_BUILD_ROOT%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT%{_datadir}/pkgconfig
63
64%find_lang %{name}
65
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70
71%post
72update-mime-database /usr/share/mime >/dev/null || :
73
74
75%postun
76update-mime-database /usr/share/mime >/dev/null || :
77
78
79%files -f %{name}.lang
80%defattr(-,root,root)
81%{_prefix}/bin/*
82%{_prefix}/lib/monodevelop
83%{_datadir}/applications/monodevelop.desktop
84%{_datadir}/mime/packages/monodevelop.xml
85%{_datadir}/icons/hicolor/*/apps/monodevelop.png
86%{_datadir}/icons/hicolor/scalable/apps/monodevelop.svg
87%{_datadir}/pkgconfig/monodevelop.pc
88%{_datadir}/pkgconfig/monodevelop-core-addins.pc
89%{_mandir}/man1/mdtool.1.gz
90%{_mandir}/man1/monodevelop.1.gz
91
92
93%changelog
94* Sun Nov 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.4.1-1
95- updated monodevelop to 2.4.1
96
97* Sat Oct 09 2010 Shu KONNO <owa@bg.wakwak.com> 2.4-4
98- rebuilt with mono-2.8
99
100* Wed Oct 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.4-3
101- rebuilt with rpm-4.8.1 for pkg-config
102
103* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.4-2
104- rebuild with mono-addins-0.5
105
106* Thu Jun 17 2010 Shu KONNO <owa@bg.wakwak.com> 2.4-1
107- updated monodevelop to 2.4
108- changed source url
109
110* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.2-1
111- updated monodevelop to 2.2.2
112
113* Sun Dec 27 2009 Shu KONNO <owa@bg.wakwak.com> 2.2-1
114- updated monodevelop to 2.2
115- changed licencse to LGPL2.1
116
117* Mon Jul 27 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-4
118- added description in japanease
119
120* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-3
121- rebuilt with latest rpm to update mono-dependencies
122
123* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-2
124- changed Group to Applications/Development
125
126* Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-1
127- updated monodevelop to 2.0
128
129* Mon Dec 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.1-1
130- updated monodevelop to 1.9.1
131- rebuilt with mono-2.0.1
132
133* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-1
134- initial build for VineSeed
135    - applied vine versioning policy
136    - added japanese summary
137    - spec in utf-8
138
139* Wed Apr  9 2008 wberrier@suse.de
140- Remove vte-sharp2 from build requires.  It's not needed,
141  and that package doesn't exist anymore.
142* Wed Mar 26 2008 wberrier@suse.de
143- Update to 1.0
144  - Bug fixes:
145  - MD Crashes when you drag a menu inside its own submenu
146    (bnc#363865)
147  - Monodevelop and stetic destroy forms (bnc#362596)
148  - Problem with subclassing any container widget (bnc#361650)
149  - Version Control doesn't behave propertly (bnc#363858)
150  - Comment and uncomment function (bnc#325469)
151  - Create Package fails on projects with translations (bnc#362567)
152  - Exception with null arguments or nonexistant paths when
153    compiling/cleaning C project (bnc#361045)
154  - MonoDevelop crashes when creating/opening C++ Console Project
155    (bnc#359567)
156  - Build Output autohide button missing (bnc#368436)
157  - Have to hit esc twice to close the file/new file dialog
158    (bnc#358361)
159- Changes in 0.19 (1.0 RC1)
160  - Will use 2.0 runtime as default
161  - Icons have been tango-ified
162  - More than 85 bugs fixed
163* Mon Jan 14 2008 wberrier@suse.de
164- Fixed .desktop file to adhear to standards
165- Fix naming of Slovenian translation
166- Update to 0.18
167  - packaging split (database, boo, and java in separate packages)
168  - Improved Dock Manager
169  - Circa 75 bugfixes
170- Update to 0.17
171  - Deployment of ASP.NET projects
172  - Support for VS 2005 Web Application projects
173  - ASP.NET Codebehind Generation Improvements
174  - Generation of Satellite Assemblies
175  - Makefile generation improvements
176  - Various other IDE enhancements
177  - Circa 90 bugfixes
178* Wed Oct 10 2007 wberrier@suse.de
179- Don't use fdupes afterall (fails build)
180* Tue Oct  9 2007 wberrier@suse.de
181- Update to 0.16
182  - C/C++ Support
183  - New Database Add-in
184  - Text editor improvements
185  - On-the-fly error underlining
186  - Auto-generation of XML comment tags
187  - New ASP.NET features
188  - Multiple GTK# versions
189  - ChangeLog add-in
190  - More than 100 bugs fixed
191* Mon Sep 24 2007 wberrier@suse.de
192- monodevelop-fix_kde_crash_r86138.patch: fix #309204
193* Fri Aug  3 2007 maw@suse.de
194- Use %%fdupes.
195* Fri Aug  3 2007 wberrier@suse.de
196- Remove upstream monodevelop-rename_ja_JP.patch
197- Update to 0.15
198  - Configurable keybindings
199  - Output pad pinning
200  - Makefile integration
201  - Standard header support for source files
202  - Localization add-in preview
203  - Text editor improvements
204  - Updated gtk# designer (support for gtk# 2.8 and 2.10 widgets)
205  - Assembly signing
206  - Message log for internal messages
207  - More than 60 bugs fixed
208* Thu Jun 14 2007 wberrier@novell.com
209- Put ja_JP locale files in valid location
210  (monodevelop-rename_ja_JP.patch)
211- Update to 0.14
212  - Improved Toolbox and Properties pad
213  - Subversion add-in updates
214  - auth prompts
215  - supports newer versions of subversion
216  - New refactory operations:
217  - rename
218  - implement interface
219  - encapsulate field
220  - Search by filename or classname in Open Solution File Dialog
221  - New class and member selector when browsing source
222  - Improved smart indenting for C#
223  - Project export/conversion
224  - Packaging features: automatic bundling of an app
225  - Desktop integration: automatically generate  shell wrappers,
226  .desktop and .pc files
227  - Improved New Project dialog
228  - New Navigation Toolbar
229  - Gtk# Designer updates:
230  - better widget defaults
231  - supports internal and custom widgets
232  - images assigned to widgets are automatically added to project
233  - Can add file to project while creating them
234  - Improved VS2005 support and VS integration
235  - VB.Net support utilizes new vbnc compiler
236  - Close to 100 bugs fixed
237* Wed May 16 2007 wberrier@novell.com
238- Remove gtkhtml2-devel from BuildRequires (not needed, allows
239  building on sle10)
240* Tue Apr 24 2007 wberrier@novell.com
241- Depend on version of boo found at build time
242* Fri Apr 13 2007 wberrier@novell.com
243- add %%debug_package so debug packages get created
244* Wed Apr 11 2007 wberrier@novell.com
245- Add mono dep/req for older distros
246* Thu Apr  5 2007 wberrier@suse.de
247- Update to 0.13.1:
248  - Bugfix release to fix some asp.net compilation issues
249- Adapt for buildservice
250- Clean up unnecessary BuildRequires
251* Thu Mar  1 2007 wberrier@suse.de
252- Update to 0.13:
253  - More than 70 bugs fixed
254  - Revamped VersionControl addin
255  - New task view features (TODO type lists)
256  - Code completion improvements and fixes
257  - Native support for VisualStudio 2005 Project files
258  - Custom commands in projects
259  - Makefile integration
260  - New Generic Project Type
261  - New Deployment infrastruction
262  - Automatic project reloading when changes in files detected
263  while the project is open
264  - Gtk# designer improvements (Undo/Redo support)
265  - Context sensitive help for classes when F1 is pressed
266  - Support for Win32Icon and Win32Resource options in C# projects
267  - New Layout toolbar which includes a combobox for fast layout
268  switching
269  - Support for files outside of a project directory
270  - Editor wrap mode selector
271  - File viewer selector (possible to have multiple viewers for
272  a filetype)
273  - Improvements in ASP.NET support:
274  - added a new option that can be used to disable compilation-time
275  CodeBehind verification for different configurations
276  - Several important stability fixes in AspNetEdit
277  - Improvements to toolbox, now includes default items with icons
278  - New Go to Type dialog, for easily jumping to a class defined
279  in a project
280* Mon Jan 22 2007 ro@suse.de
281- drop requires for gnome-filesystem
282* Wed Jan  3 2007 wberrier@suse.de
283- handle mime files properly
284  - spec file fixes from Andreas Hanke to fix bnc #225812
285* Thu Oct 19 2006 ro@suse.de
286- added mono-devel to buildrequires
287* Tue Sep  5 2006 wberrier@suse.de
288- Update to 0.12
289  - Better code completion support, supports C# 2.0
290  - Class information is shown using the syntax of the current
291  language
292  - New "Open With" Menu
293  - stetic menu designer
294  - autotools project support
295  - additional addin management features
296  - Support for multiple text file encodings
297  - ASP.NET Support
298  - Lots of bug fixes and better stability
299* Wed Aug 30 2006 wberrier@suse.de
300- Add mono-nunit to BuildRequires
301* Mon Jul 31 2006 wberrier@suse.de
302- Update to 0.11
303- Lots of new features and fixes, too many to list here.  One big
304  addition is the stetic gui designer integration
305- 2.4.0 -> 2.8.0 hack now unnecessary
306* Sun Mar 26 2006 ro@suse.de
307- removed ifarch from noarch package
308* Fri Mar 24 2006 wberrier@suse.de
309- Require mono-basic so that vbnet templates will compile
310* Wed Mar 15 2006 wberrier@suse.de
311- Update references for gtk# 2.4 to 2.8 in template files
312  * * Otherwise all the gtk#2 template projects will fail to compile **
313* Mon Mar 13 2006 wberrier@suse.de
314- Remove mime.cache and quote update_desktop args
315* Fri Feb 17 2006 gekker@suse.de
316- fixup desktop file for UI team
317* Wed Feb  1 2006 aj@suse.de
318- Fix Requires and BuildRequires to build again.
319* Wed Jan 25 2006 mls@suse.de
320- converted neededforbuild to BuildRequires
321* Fri Jan 13 2006 gekker@suse.de
322- Fixup nfb and Requires for new gtk-sharp2 packaging
323* Mon Jan  9 2006 gekker@suse.de
324- Fix to build against new mono version 1.1.13
325* Mon Dec 12 2005 wberrier@suse.de
326- Convert to noarch package, and clean up build deps
327* Tue Nov 29 2005 wberrier@suse.de
328- Update to 0.9 (which obsoletes the version control patch)
329* Fri Nov 18 2005 wberrier@suse.de
330- Patch VersionControl AddIn to compile with mcs 1.1.10
331* Mon Nov  7 2005 sbrabec@suse.cz
332- Renamed rename *-sharp-2_0 to *-sharp2 in Requires (#132436).
333* Tue Oct 25 2005 ro@suse.de
334- remove mono-debugger from nfb for the moment
335* Thu Oct 20 2005 ro@suse.de
336- rename gecko-sharp-2_0 and gtksourceview-sharp-2_0 in nfb
337* Thu Oct 13 2005 wberrier@suse.de
338- Update to 0.8 and add configure options (--enable-nunit --enable-versioncontrol --enable-monoextensions)
339* Thu Sep 22 2005 ro@suse.de
340- remove libgdiplus-devel from nfb (dropped)
341* Tue Sep 13 2005 gekker@suse.de
342- Disable boo support so monodevelop will run (113802)
343* Sun Sep  4 2005 aj@suse.de
344- Update check-build.sh.
345* Tue Aug 30 2005 ro@suse.de
346- do not require mono-debugger on ppc (can not build there)
347* Fri Aug 26 2005 ro@suse.de
348- nfb: monodoc -> monodoc-core
349* Thu Aug 18 2005 gekker@suse.de
350- Fix desktop category for menus.
351* Tue Aug 16 2005 aj@suse.de
352- Add check-build script.
353* Tue Aug  9 2005 gekker@suse.de
354- Fix requirements
355- Remove files that conflict with shared-mime-info
356- Verify that bugs #71734 and #71735 are fixed
357* Sun Aug  7 2005 ro@suse.de
358- rename nfb and deps for gtksourceview-sharp and gecko-sharp
359* Thu Aug  4 2005 gekker@suse.de
360- Update to version 0.7
361- Remove upstreamed patches
362* Wed May 18 2005 gekker@suse.de
363- fix to build with mono-1.1.7
364* Tue Mar  1 2005 gekker@suse.de
365- fix requires (66770).
366* Tue Feb 15 2005 ro@suse.de
367- fix build on x86_64
368* Tue Feb  8 2005 gekker@suse.de
369- Add patches to fix namespacing issues.
370- Add suse_update_desktop_config
371* Mon Dec 13 2004 clahey@suse.de
372- New package.
Note: See TracBrowser for help on using the repository browser.