source: projects/specs/trunk/m/monodevelop/monodevelop-vl.spec @ 1451

Revision 1451, 12.2 KB checked in by owa, 14 years ago (diff)

rebuilt with mono-addins-0.5

Line 
1%define mono_dir %(/usr/bin/monodir)
2Summary: A Full-Featured IDE for Mono and Gtk#
3Summary(ja): Gtk# 版 Mono 統合開発環境
4Name: monodevelop
5Version: 2.4
6Release: 2%{?_dist_release}
7License: LGPL2.1
8Group: Applications/Development
9BuildArch: noarch
10URL: http://www.monodevelop.org/
11Source: http://ftp.novell.com/pub/mono/sources/%{name}/%{name}-%{version}.tar.bz2
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: mono-core >= 2.6.1
14Requires: monodoc >= 2.6.1
15Requires: gtk-sharp2 >= 2.12.8
16Requires: gtksourceview-sharp2 >= 0.10
17Requires: mono-addins
18Requires: mono-basic
19Requires: mono-web
20Requires: xsp
21Requires: pkgconfig
22PreReq: shared-mime-info
23BuildRequires: mono-devel mono-basic mono-nunit monodoc
24BuildRequires: gconf-sharp2 gtk-sharp2-gapi gtksourceview-sharp2
25BuildRequires: xsp mono-addins
26BuildRequires: intltool perl-XML-Parser shared-mime-info
27
28%description
29MonoDevelop is intended to be a full-featured integrated development
30environment (IDE) for mono and Gtk#. It was originally a port of
31SharpDevelop 0.98. See http://monodevelop.com/ for more information.
32
33%description -l ja
34MonoDevelop は mono と Gtk# のすべての機能を取り込んだ統合 IDE 環境を
35提供しようと考えてます。元は SharpDevelop 0.98 です。
36より詳しい説明は http://monodevelop.com/ をご覧ください。
37
38
39%prep
40%setup -q
41
42
43%build
44export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
45./configure \
46        --prefix=%{_prefix} \
47    --enable-subversion \
48    --enable-monoextensions \
49    --enable-aspnet \
50    --disable-update-mimedb \
51    --disable-update-desktopdb
52make
53
54
55%install
56rm -rf $RPM_BUILD_ROOT
57export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
58make install DESTDIR=$RPM_BUILD_ROOT \
59        GACUTIL_FLAGS="/package monodevelop /root ${RPM_BUILD_ROOT}%{_libdif}"
60
61mkdir -p $RPM_BUILD_ROOT%{_datadir}/pkgconfig
62mv $RPM_BUILD_ROOT%{_prefix}/lib/pkgconfig/* $RPM_BUILD_ROOT%{_datadir}/pkgconfig
63
64%find_lang %{name}
65
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70
71%post
72update-mime-database /usr/share/mime >/dev/null || :
73
74
75%postun
76update-mime-database /usr/share/mime >/dev/null || :
77
78
79%files -f %{name}.lang
80%defattr(-,root,root)
81%{_prefix}/bin/*
82%{_prefix}/lib/monodevelop
83%{_datadir}/applications/monodevelop.desktop
84%{_datadir}/mime/packages/monodevelop.xml
85%{_datadir}/icons/hicolor/*/apps/monodevelop.png
86%{_datadir}/icons/hicolor/scalable/apps/monodevelop.svg
87%{_datadir}/pkgconfig/monodevelop.pc
88%{_datadir}/pkgconfig/monodevelop-core-addins.pc
89%{_mandir}/man1/mdtool.1.gz
90%{_mandir}/man1/monodevelop.1.gz
91
92
93%changelog
94* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.4-2
95- rebuild with mono-addins-0.5
96
97* Thu Jun 17 2010 Shu KONNO <owa@bg.wakwak.com> 2.4-1
98- updated monodevelop to 2.4
99- changed source url
100
101* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.2-1
102- updated monodevelop to 2.2.2
103
104* Sun Dec 27 2009 Shu KONNO <owa@bg.wakwak.com> 2.2-1
105- updated monodevelop to 2.2
106- changed licencse to LGPL2.1
107
108* Mon Jul 27 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-4
109- added description in japanease
110
111* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-3
112- rebuilt with latest rpm to update mono-dependencies
113
114* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-2
115- changed Group to Applications/Development
116
117* Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.0-1
118- updated monodevelop to 2.0
119
120* Mon Dec 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.1-1
121- updated monodevelop to 1.9.1
122- rebuilt with mono-2.0.1
123
124* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-1
125- initial build for VineSeed
126    - applied vine versioning policy
127    - added japanese summary
128    - spec in utf-8
129
130* Wed Apr  9 2008 wberrier@suse.de
131- Remove vte-sharp2 from build requires.  It's not needed,
132  and that package doesn't exist anymore.
133* Wed Mar 26 2008 wberrier@suse.de
134- Update to 1.0
135  - Bug fixes:
136  - MD Crashes when you drag a menu inside its own submenu
137    (bnc#363865)
138  - Monodevelop and stetic destroy forms (bnc#362596)
139  - Problem with subclassing any container widget (bnc#361650)
140  - Version Control doesn't behave propertly (bnc#363858)
141  - Comment and uncomment function (bnc#325469)
142  - Create Package fails on projects with translations (bnc#362567)
143  - Exception with null arguments or nonexistant paths when
144    compiling/cleaning C project (bnc#361045)
145  - MonoDevelop crashes when creating/opening C++ Console Project
146    (bnc#359567)
147  - Build Output autohide button missing (bnc#368436)
148  - Have to hit esc twice to close the file/new file dialog
149    (bnc#358361)
150- Changes in 0.19 (1.0 RC1)
151  - Will use 2.0 runtime as default
152  - Icons have been tango-ified
153  - More than 85 bugs fixed
154* Mon Jan 14 2008 wberrier@suse.de
155- Fixed .desktop file to adhear to standards
156- Fix naming of Slovenian translation
157- Update to 0.18
158  - packaging split (database, boo, and java in separate packages)
159  - Improved Dock Manager
160  - Circa 75 bugfixes
161- Update to 0.17
162  - Deployment of ASP.NET projects
163  - Support for VS 2005 Web Application projects
164  - ASP.NET Codebehind Generation Improvements
165  - Generation of Satellite Assemblies
166  - Makefile generation improvements
167  - Various other IDE enhancements
168  - Circa 90 bugfixes
169* Wed Oct 10 2007 wberrier@suse.de
170- Don't use fdupes afterall (fails build)
171* Tue Oct  9 2007 wberrier@suse.de
172- Update to 0.16
173  - C/C++ Support
174  - New Database Add-in
175  - Text editor improvements
176  - On-the-fly error underlining
177  - Auto-generation of XML comment tags
178  - New ASP.NET features
179  - Multiple GTK# versions
180  - ChangeLog add-in
181  - More than 100 bugs fixed
182* Mon Sep 24 2007 wberrier@suse.de
183- monodevelop-fix_kde_crash_r86138.patch: fix #309204
184* Fri Aug  3 2007 maw@suse.de
185- Use %%fdupes.
186* Fri Aug  3 2007 wberrier@suse.de
187- Remove upstream monodevelop-rename_ja_JP.patch
188- Update to 0.15
189  - Configurable keybindings
190  - Output pad pinning
191  - Makefile integration
192  - Standard header support for source files
193  - Localization add-in preview
194  - Text editor improvements
195  - Updated gtk# designer (support for gtk# 2.8 and 2.10 widgets)
196  - Assembly signing
197  - Message log for internal messages
198  - More than 60 bugs fixed
199* Thu Jun 14 2007 wberrier@novell.com
200- Put ja_JP locale files in valid location
201  (monodevelop-rename_ja_JP.patch)
202- Update to 0.14
203  - Improved Toolbox and Properties pad
204  - Subversion add-in updates
205  - auth prompts
206  - supports newer versions of subversion
207  - New refactory operations:
208  - rename
209  - implement interface
210  - encapsulate field
211  - Search by filename or classname in Open Solution File Dialog
212  - New class and member selector when browsing source
213  - Improved smart indenting for C#
214  - Project export/conversion
215  - Packaging features: automatic bundling of an app
216  - Desktop integration: automatically generate  shell wrappers,
217  .desktop and .pc files
218  - Improved New Project dialog
219  - New Navigation Toolbar
220  - Gtk# Designer updates:
221  - better widget defaults
222  - supports internal and custom widgets
223  - images assigned to widgets are automatically added to project
224  - Can add file to project while creating them
225  - Improved VS2005 support and VS integration
226  - VB.Net support utilizes new vbnc compiler
227  - Close to 100 bugs fixed
228* Wed May 16 2007 wberrier@novell.com
229- Remove gtkhtml2-devel from BuildRequires (not needed, allows
230  building on sle10)
231* Tue Apr 24 2007 wberrier@novell.com
232- Depend on version of boo found at build time
233* Fri Apr 13 2007 wberrier@novell.com
234- add %%debug_package so debug packages get created
235* Wed Apr 11 2007 wberrier@novell.com
236- Add mono dep/req for older distros
237* Thu Apr  5 2007 wberrier@suse.de
238- Update to 0.13.1:
239  - Bugfix release to fix some asp.net compilation issues
240- Adapt for buildservice
241- Clean up unnecessary BuildRequires
242* Thu Mar  1 2007 wberrier@suse.de
243- Update to 0.13:
244  - More than 70 bugs fixed
245  - Revamped VersionControl addin
246  - New task view features (TODO type lists)
247  - Code completion improvements and fixes
248  - Native support for VisualStudio 2005 Project files
249  - Custom commands in projects
250  - Makefile integration
251  - New Generic Project Type
252  - New Deployment infrastruction
253  - Automatic project reloading when changes in files detected
254  while the project is open
255  - Gtk# designer improvements (Undo/Redo support)
256  - Context sensitive help for classes when F1 is pressed
257  - Support for Win32Icon and Win32Resource options in C# projects
258  - New Layout toolbar which includes a combobox for fast layout
259  switching
260  - Support for files outside of a project directory
261  - Editor wrap mode selector
262  - File viewer selector (possible to have multiple viewers for
263  a filetype)
264  - Improvements in ASP.NET support:
265  - added a new option that can be used to disable compilation-time
266  CodeBehind verification for different configurations
267  - Several important stability fixes in AspNetEdit
268  - Improvements to toolbox, now includes default items with icons
269  - New Go to Type dialog, for easily jumping to a class defined
270  in a project
271* Mon Jan 22 2007 ro@suse.de
272- drop requires for gnome-filesystem
273* Wed Jan  3 2007 wberrier@suse.de
274- handle mime files properly
275  - spec file fixes from Andreas Hanke to fix bnc #225812
276* Thu Oct 19 2006 ro@suse.de
277- added mono-devel to buildrequires
278* Tue Sep  5 2006 wberrier@suse.de
279- Update to 0.12
280  - Better code completion support, supports C# 2.0
281  - Class information is shown using the syntax of the current
282  language
283  - New "Open With" Menu
284  - stetic menu designer
285  - autotools project support
286  - additional addin management features
287  - Support for multiple text file encodings
288  - ASP.NET Support
289  - Lots of bug fixes and better stability
290* Wed Aug 30 2006 wberrier@suse.de
291- Add mono-nunit to BuildRequires
292* Mon Jul 31 2006 wberrier@suse.de
293- Update to 0.11
294- Lots of new features and fixes, too many to list here.  One big
295  addition is the stetic gui designer integration
296- 2.4.0 -> 2.8.0 hack now unnecessary
297* Sun Mar 26 2006 ro@suse.de
298- removed ifarch from noarch package
299* Fri Mar 24 2006 wberrier@suse.de
300- Require mono-basic so that vbnet templates will compile
301* Wed Mar 15 2006 wberrier@suse.de
302- Update references for gtk# 2.4 to 2.8 in template files
303  * * Otherwise all the gtk#2 template projects will fail to compile **
304* Mon Mar 13 2006 wberrier@suse.de
305- Remove mime.cache and quote update_desktop args
306* Fri Feb 17 2006 gekker@suse.de
307- fixup desktop file for UI team
308* Wed Feb  1 2006 aj@suse.de
309- Fix Requires and BuildRequires to build again.
310* Wed Jan 25 2006 mls@suse.de
311- converted neededforbuild to BuildRequires
312* Fri Jan 13 2006 gekker@suse.de
313- Fixup nfb and Requires for new gtk-sharp2 packaging
314* Mon Jan  9 2006 gekker@suse.de
315- Fix to build against new mono version 1.1.13
316* Mon Dec 12 2005 wberrier@suse.de
317- Convert to noarch package, and clean up build deps
318* Tue Nov 29 2005 wberrier@suse.de
319- Update to 0.9 (which obsoletes the version control patch)
320* Fri Nov 18 2005 wberrier@suse.de
321- Patch VersionControl AddIn to compile with mcs 1.1.10
322* Mon Nov  7 2005 sbrabec@suse.cz
323- Renamed rename *-sharp-2_0 to *-sharp2 in Requires (#132436).
324* Tue Oct 25 2005 ro@suse.de
325- remove mono-debugger from nfb for the moment
326* Thu Oct 20 2005 ro@suse.de
327- rename gecko-sharp-2_0 and gtksourceview-sharp-2_0 in nfb
328* Thu Oct 13 2005 wberrier@suse.de
329- Update to 0.8 and add configure options (--enable-nunit --enable-versioncontrol --enable-monoextensions)
330* Thu Sep 22 2005 ro@suse.de
331- remove libgdiplus-devel from nfb (dropped)
332* Tue Sep 13 2005 gekker@suse.de
333- Disable boo support so monodevelop will run (113802)
334* Sun Sep  4 2005 aj@suse.de
335- Update check-build.sh.
336* Tue Aug 30 2005 ro@suse.de
337- do not require mono-debugger on ppc (can not build there)
338* Fri Aug 26 2005 ro@suse.de
339- nfb: monodoc -> monodoc-core
340* Thu Aug 18 2005 gekker@suse.de
341- Fix desktop category for menus.
342* Tue Aug 16 2005 aj@suse.de
343- Add check-build script.
344* Tue Aug  9 2005 gekker@suse.de
345- Fix requirements
346- Remove files that conflict with shared-mime-info
347- Verify that bugs #71734 and #71735 are fixed
348* Sun Aug  7 2005 ro@suse.de
349- rename nfb and deps for gtksourceview-sharp and gecko-sharp
350* Thu Aug  4 2005 gekker@suse.de
351- Update to version 0.7
352- Remove upstreamed patches
353* Wed May 18 2005 gekker@suse.de
354- fix to build with mono-1.1.7
355* Tue Mar  1 2005 gekker@suse.de
356- fix requires (66770).
357* Tue Feb 15 2005 ro@suse.de
358- fix build on x86_64
359* Tue Feb  8 2005 gekker@suse.de
360- Add patches to fix namespacing issues.
361- Add suse_update_desktop_config
362* Mon Dec 13 2004 clahey@suse.de
363- New package.
Note: See TracBrowser for help on using the repository browser.