source: projects/specs/trunk/m/mono/mono-vl.spec @ 8067

Revision 8067, 28.1 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%bcond_with firstbuild
2
3Summary: .NET runtime environment
4Summary(ja): .NET ランタイム環境
5Name: mono
6Version: 2.10.8
7Release: 2%{?_dist_release}
8Group: Development/Languages
9License: GPL, LGPL, MIT X11
10URL: http://www.mono-project.com/
11Source0: http://ftp.novell.com/pub/mono/sources/mono/%{name}-%{version}.tar.bz2
12Source1: monodir.c
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: bison
15BuildRequires: glib2-devel
16BuildRequires: pkgconfig
17BuildRequires: libicu-devel
18BuildRequires: libgdiplus-devel >= 2.0
19BuildRequires: zlib-devel
20%{!?with_firstbuild:BuildRequires: mono-devel}
21# JIT only availible on these:
22ExclusiveArch: %{ix86} x86_64 ppc ia64 s390 s390x armv4l sparc
23Obsoletes: %{name}-jscript < 2.8
24Obsoletes: %{name}-data-sybase < 2.8
25Obsoletes: %{name}-data-firebird < 2.8
26Obsoletes: bytefx-data-mysql < 2.8
27Distribution: Vine Linux
28Vendor: Project Vine
29Packager: owa
30
31%description
32The Mono runtime implements a JIT engine for the ECMA CLI
33virtual machine (as well as a byte code interpreter, the
34class loader, the garbage collector, threading system and
35metadata access libraries.
36
37%description -l ja
38Mono ランタイムは ECMA CLI 仮想機械用 JIT エンジンの実装です。バイト
39コードインタプリタ、クラスローダ、ガベージコレクタ、スレッドシステム
40およびメタデータアクセスライブラリの機能を持ちます。
41
42%package core
43Summary: The Mono CIL runtime, suitable for running .NET code
44Summary(ja): .NET の実行に適した Mono CIL ランタイム
45Group: Development/Languages
46Requires: libgdiplus
47
48%description core
49This package contains the core of the Mono runtime including its
50Virtual Machine, Just-in-time compiler, C# compiler, security
51tools and libraries (corlib, XML, System.Security, ZipLib,
52I18N, Cairo and Mono.*).
53
54%package devel
55Summary:        Development tools for Mono
56Summary(ja):    Mono 開発ツール
57Group:          Development/Languages
58Requires:       mono-core = %{version}-%{release}
59Requires:       glib2-devel
60
61%description devel
62This package completes the Mono developer toolchain with the mono profiler,
63assembler and other various tools.
64
65%package nunit
66Summary:        NUnit Testing Framework
67Summary(ja):    NUnit テストフレームワーク
68Group:          Development/Languages
69Requires:       mono-core = %{version}-%{release}
70Requires:       glib2-devel
71
72%description nunit
73NUnit is a unit-testing framework for all .NET languages. Initially
74ported from JUnit, the current release, version 2.2, is the fourth
75major release of this Unit based unit testing tool for Microsoft .NET.
76It is written entirely in C# and  has been completely redesigned to
77take advantage of many .NET language features, for example
78custom attributes and other reflection related capabilities. NUnit
79brings xUnit to all .NET languages.
80
81%package locale-extras
82Summary:        Extra locale information for Mono
83Summary(ja):    Mono 用追加ロケール情報
84Group:          Development/Languages
85Requires:       mono-core = %{version}-%{release}
86
87%description locale-extras
88This package contains assemblies to support I18N applications for
89non-latin alphabets.
90
91%package extras
92Summary:        Provides the infrastructure for running and building daemons and services with Mono as well as various stub assemblies
93Group:          Development/Languages
94Requires:       mono-core = %{version}-%{release}
95
96%description extras
97This package provides the libary and application to run services
98and daemons with Mono. It also includes stubs for the following
99.NET 1.1 and 2.0 assemblies: Microsoft.Vsa,
100System.Configuration.Install, System.Management, System.Messaging.
101
102%package winforms
103Summary:        Windows Forms implementation for Mono
104Group:          Development/Languages
105Requires:       mono-core = %{version}-%{release}
106
107%description winforms
108This package provides a fully managed implementation of
109System.Windows.Forms, the default graphical toolkit for .NET
110applications.
111
112%package web
113Summary:        ASP.NET, Remoting, and Web Services for Mono
114Group:          Development/Languages
115Requires:       mono-core = %{version}-%{release}
116
117%description web
118This package provides the ASP.NET libraries and runtime for
119development of web application, web services and remoting support.
120
121%package data
122Summary:        Database connectivity for Mono
123Group:          Development/Languages
124Requires:       mono-core = %{version}-%{release}
125
126%description data
127This package provides a Mono assembly to facilitate data access
128and manipulation with databases, LDAP compatible directory servers
129and/or XML data exchange. Beyond the ADO.NET, Novell.LDAP and
130System.DirectoryServices assemblies, it also includes a command
131line sql application as well as the Microsoft SQL Server and ODBC
132data providers.
133
134%package data-sqlite
135Summary:        sqlite database connectivity for Mono
136Group:          Development/Languages
137Requires:       mono-core = %{version}-%{release}
138Requires:       sqlite
139
140%description data-sqlite
141This package contains the ADO.NET Data provider for the sqlite
142database.
143
144%package data-oracle
145Summary:        Oracle database connectivity for Mono
146Group:          Development/Languages
147Requires:       mono-core = %{version}-%{release}
148
149%description data-oracle
150This package contains the ADO.NET Data provider for the Oracle
151database.
152
153%package data-postgresql
154Summary:        Postgresql database connectivity for Mono
155Group:          Development/Languages
156Requires:       mono-core = %{version}-%{release}
157
158%description data-postgresql
159This package contains the ADO.NET Data provider for the PostgreSQL
160database.
161
162%package -n ibm-data-db2
163Summary:        IBM DB2 database connectivity for Mono
164Group:          Development/Languages
165Requires:       mono-core = %{version}-%{release}
166
167%description -n ibm-data-db2
168This package contains the ADO.NET Data provider for the IBM DB2
169Universal database.
170
171%package -n monodoc
172Summary:        The Mono documentation system
173Group:          Development/Tools
174Requires:       mono-core = %{version}-%{release}
175Obsoletes:  monodoc-core <= 2.0-1vl5
176
177%description -n monodoc
178monodoc is the documentation package for the mono .NET environment
179
180## macros
181%define mono_dir %{_prefix}/lib/mono
182%define mono_doc %{_prefix}/lib/monodoc
183%define bin_and_exe(bin, exe) %{_bindir}/%{1} \
184        %{mono_dir}/%{2}.exe \
185        %{mono_dir}/%{2}.exe.* \
186        %{nil}
187%define gac_and_1dll(dll)  %{mono_dir}/gac/%{1} \
188        %{mono_dir}/%{2}/%{1}.dll \
189        %{nil}
190%define gac_and_2dll(dll)  %{mono_dir}/gac/%{1} \
191        %{mono_dir}/%{2}/%{1}.dll \
192        %{mono_dir}/%{3}/%{1}.dll \
193        %{nil}
194%define gac_and_3dll(dll)  %{mono_dir}/gac/%{1} \
195        %{mono_dir}/%{2}/%{1}.dll \
196        %{mono_dir}/%{3}/%{1}.dll \
197        %{mono_dir}/%{4}/%{1}.dll \
198        %{nil}
199
200
201%prep
202%setup -q
203
204## These are only needed if there are patches to the runtime
205#rm -f libgc/libtool.m4
206#autoreconf --force --install
207#autoreconf --force --install libgc
208
209## Remove prebuilt binaries
210#rm -rf mcs/class/lib/monolite/*
211
212%build
213gcc -o monodir %{SOURCE1} -DMONODIR=\"%{mono_dir}\"
214
215export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
216%configure \
217        --with-jit=yes \
218        --with-ikvm-native=yes \
219        --with-sigaltstack=no \
220        --with-sgen=no \
221        ;
222
223# don't use parallel builds
224# make %{?_smp_mflags}
225make
226
227
228%install
229[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
230make install DESTDIR=%{buildroot}
231
232install monodir %{buildroot}%{_bindir}
233
234## Remove unused files
235%{__rm} -f %{buildroot}%{_libdir}/*.la
236%{__rm} -f %{buildroot}%{_libdir}/*.a
237%{__rm} -f %{buildroot}%{_bindir}/mono-find-provides
238%{__rm} -f %{buildroot}%{_bindir}/mono-find-requires
239
240## This was removed upstream:
241%{__rm} -rf %{buildroot}%{_datadir}/mono-2.0/mono/cil
242%{__rm} -f %{buildroot}%{_bindir}/prj2make
243%{__rm} -f %{buildroot}%{_mandir}/man1/prj2make.*
244%{__rm} -f %{buildroot}%{_mandir}/man1/cilc.*
245## This was referring to fedora:
246%{__rm} -rf %{buildroot}%{mono_dir}/gac/Mono.Security.Win32
247%{__rm} -rf %{buildroot}%{mono_dir}/2.0/Mono.Security.Win32.dll
248%{__rm} -rf %{buildroot}%{mono_dir}/4.0/Mono.Security.Win32.dll
249%{__rm} -rf %{buildroot}%{mono_dir}/xbuild/Microsoft
250%{__rm} -f %{buildroot}%{mono_dir}/2.0/mcs.exe.so
251%{__rm} -f %{buildroot}%{mono_dir}/2.0/mscorlib.dll.so
252%{__rm} -f %{buildroot}%{_datadir}/libgc-mono/README*
253%{__rm} -f %{buildroot}%{_datadir}/libgc-mono/barrett_diagram
254%{__rm} -f %{buildroot}%{_datadir}/libgc-mono/*.html
255%{__rm} -f %{buildroot}%{_datadir}/libgc-mono/gc.man
256%{__rm} -rf %{buildroot}%{_bindir}/mono-configuration-crypto
257%{__rm} -rf %{buildroot}%{_mandir}/man?/mono-configuration-crypto*
258
259
260%find_lang mcs
261
262
263%clean
264[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
265
266%post core -p /sbin/ldconfig
267%postun core -p /sbin/ldconfig
268%post devel -p /sbin/ldconfig
269%postun devel -p /sbin/ldconfig
270
271
272%files core -f mcs.lang
273%defattr(-,root,root,-)
274%doc AUTHORS COPYING.LIB ChangeLog NEWS README
275%{_bindir}/mcs
276%{_bindir}/mono
277%{_bindir}/monodir
278%{_bindir}/mono-api-*
279%{_bindir}/mono-heapviz
280%{_bindir}/peverify
281%{_bindir}/mprof-report
282%{_bindir}/mono-test-install
283%{_libdir}/libMonoPosixHelper.so
284%{_libdir}/libmono-2.0.so.*
285%{_libdir}/libmono-profiler-aot.so.*
286%{_libdir}/libmono-profiler-cov.so.*
287%{_libdir}/libmono-profiler-iomap.so.*
288%{_libdir}/libmono-profiler-log.so*
289%dir %{mono_dir}
290%dir %{mono_dir}/4.0
291%dir %{mono_dir}/3.5
292%dir %{mono_dir}/2.0
293%dir %{mono_dir}/gac
294%dir %{mono_dir}/compat-2.0
295%bin_and_exe ccrewrite 4.0/ccrewrite
296%bin_and_exe csharp 4.0/csharp
297%bin_and_exe csharp2 2.0/csharp
298%bin_and_exe certmgr 4.0/certmgr
299%bin_and_exe chktrust 4.0/chktrust
300%bin_and_exe dmcs 4.0/dmcs
301%bin_and_exe lc 4.0/lc
302%bin_and_exe gacutil 4.0/gacutil
303%bin_and_exe gacutil2 2.0/gacutil
304%bin_and_exe gmcs 2.0/gmcs
305%bin_and_exe installvst 4.0/installvst
306%bin_and_exe mconfig 4.0/mconfig
307%{mono_dir}/2.0/mcs.exe
308%bin_and_exe mod 4.0/mod
309%bin_and_exe mono-cil-strip 4.0/mono-cil-strip
310%bin_and_exe monolinker 2.0/monolinker
311%bin_and_exe mozroots 4.0/mozroots
312%bin_and_exe setreg 4.0/setreg
313%bin_and_exe sn 4.0/sn
314%bin_and_exe sqlmetal 4.0/sqlmetal
315%bin_and_exe svcutil 4.0/svcutil
316%{mono_dir}/4.0/browsercaps-updater.exe*
317%{mono_dir}/4.0/monolinker.exe*
318%{mono_dir}/4.0/ictool.exe*
319%{mono_dir}/4.0/installutil.exe*
320%{mono_dir}/4.0/mono-api-info.exe
321%{mono_dir}/4.0/mscorlib.dll*
322%{mono_dir}/2.0/mscorlib.dll*
323%{mono_dir}/3.5/Microsoft.Build.*
324%exclude %{mono_dir}/3.5/Microsoft.Build.xsd
325%{mono_dir}/4.0/Microsoft.Build.*
326%exclude %{mono_dir}/4.0/Microsoft.Build.xsd
327%{mono_dir}/4.0/Microsoft.CSharp.targets
328%{mono_dir}/3.5/Microsoft.CSharp.targets
329%{mono_dir}/2.0/Microsoft.CSharp.targets
330%{mono_dir}/4.0/Microsoft.Common.targets
331%{mono_dir}/3.5/Microsoft.Common.targets
332%{mono_dir}/2.0/Microsoft.Common.targets
333%{mono_dir}/4.0/Microsoft.VisualBasic.targets
334%{mono_dir}/3.5/Microsoft.VisualBasic.targets
335%{mono_dir}/2.0/Microsoft.VisualBasic.targets
336%{mono_dir}/compat-*/ICSharpCode.SharpZipLib.dll
337%{mono_dir}/gac/Mono.Cecil
338%{mono_dir}/gac/Mono.Cecil.Mdb
339%{mono_dir}/mono-configuration-crypto/4.0/Mono.Configuration.Crypto.dll*
340%{mono_dir}/mono-configuration-crypto/4.0/mono-configuration-crypto.exe*
341%gac_and_2dll cscompmgd 4.0 2.0
342%gac_and_2dll Commons.Xml.Relaxng 4.0 2.0
343%gac_and_2dll CustomMarshalers 4.0 2.0
344%gac_and_2dll I18N 4.0 2.0
345%gac_and_2dll I18N.West 4.0 2.0
346%gac_and_2dll ICSharpCode.SharpZipLib 4.0 2.0
347%gac_and_1dll Microsoft.CSharp 4.0
348%gac_and_2dll Mono.C5 4.0 2.0
349%gac_and_2dll Mono.Cairo 4.0 2.0
350%gac_and_2dll Mono.CompilerServices.SymbolWriter 4.0 2.0
351%gac_and_2dll Mono.Posix 4.0 2.0
352%gac_and_2dll Mono.Security 4.0 2.0
353%gac_and_2dll Mono.CSharp 4.0 2.0
354%gac_and_1dll Mono.CodeContracts 4.0
355%gac_and_2dll Mono.Debugger.Soft 4.0 2.0
356%gac_and_2dll Mono.Management 4.0 2.0
357%gac_and_2dll Mono.Simd 4.0 2.0
358%gac_and_2dll Mono.Tasklets 4.0 2.0
359%gac_and_2dll System 4.0 2.0
360%gac_and_2dll System.Configuration 4.0 2.0
361%gac_and_1dll System.Dynamic 4.0
362%gac_and_2dll System.Drawing 4.0 2.0
363%gac_and_2dll System.Core 4.0 2.0
364%gac_and_1dll System.ComponentModel.Composition 4.0
365%gac_and_2dll System.ComponentModel.DataAnnotations 4.0 2.0
366%gac_and_2dll System.IdentityModel 4.0 2.0
367%gac_and_2dll System.IdentityModel.Selectors 4.0 2.0
368%gac_and_2dll System.Net 4.0 2.0
369%gac_and_1dll System.Numerics 4.0
370%gac_and_1dll System.Runtime.Caching 4.0
371%gac_and_1dll System.Runtime.DurableInstancing 4.0
372%gac_and_2dll System.Runtime.Serialization 4.0 2.0
373%gac_and_2dll System.Runtime.Serialization.Formatters.Soap 4.0 2.0
374%gac_and_2dll System.Security 4.0 2.0
375%gac_and_1dll System.Xaml 4.0
376%gac_and_2dll System.Xml 4.0 2.0
377%gac_and_2dll System.Xml.Linq 4.0 2.0
378%gac_and_2dll OpenSystem.C 4.0 2.0
379%gac_and_2dll WindowsBase 4.0 2.0
380%dir %{_sysconfdir}/mono
381%dir %{_sysconfdir}/mono/4.0
382%dir %{_sysconfdir}/mono/2.0
383%dir %{_sysconfdir}/mono/mconfig
384%config (noreplace) %{_sysconfdir}/mono/config
385%config (noreplace) %{_sysconfdir}/mono/2.0/machine.config
386%config (noreplace) %{_sysconfdir}/mono/4.0/machine.config
387%config (noreplace) %{_sysconfdir}/mono/mconfig/config.xml
388%config (noreplace) %{_sysconfdir}/mono/2.0/settings.map
389%config (noreplace) %{_sysconfdir}/mono/4.0/settings.map
390%{_prefix}/lib/mono-source-libs/
391%{_mandir}/man1/ccrewrite.1.gz
392%{_mandir}/man1/certmgr.1.gz
393%{_mandir}/man1/chktrust.1.gz
394%{_mandir}/man1/csharp.1.gz
395%{_mandir}/man1/gacutil.1.gz
396%{_mandir}/man1/lc.1.gz
397%{_mandir}/man1/mconfig.1.gz
398%{_mandir}/man1/mcs.1.gz
399%{_mandir}/man1/mono.1.gz
400%{_mandir}/man1/monolinker.1.gz
401%{_mandir}/man1/mozroots.1.gz
402%{_mandir}/man1/mprof-report.1.gz
403%{_mandir}/man1/setreg.1.gz
404%{_mandir}/man1/sn.1.gz
405%{_mandir}/man1/resgen.1.gz
406%{_mandir}/man1/mono-api-info.1.gz
407%{_mandir}/man1/mono-cil-strip.1.gz
408%{_mandir}/man5/mono-config.5.gz
409
410%files devel
411%defattr(-,root,root,-)
412%{_bindir}/genxs
413%{_bindir}/mkbundle
414%{_bindir}/mono-gdb.py
415%{_bindir}/monodis
416%{_bindir}/monograph
417%{_bindir}/pedump
418%{_bindir}/xbuild
419%{_libdir}/libmono-2.0.so
420%{_libdir}/libmono-profiler-aot.so
421%{_libdir}/libmono-profiler-cov.so
422%{_libdir}/libmono-profiler-iomap.so
423%{_libdir}/libMonoSupportW.so
424%{_libdir}/libikvm-native.so
425%{mono_dir}/4.0/mkbundle.exe*
426%{mono_dir}/2.0/mkbundle.exe*
427%{mono_dir}/4.0/genxs.exe*
428%{mono_dir}/2.0/genxs.exe*
429%{mono_dir}/2.0/ilasm.exe*
430%bin_and_exe al 4.0/al
431%bin_and_exe al2 2.0/al
432%bin_and_exe caspol 4.0/caspol
433%bin_and_exe cert2spc 4.0/cert2spc
434%bin_and_exe dtd2xsd 4.0/dtd2xsd
435%bin_and_exe dtd2rng 4.0/dtd2rng
436%bin_and_exe sgen 4.0/sgen
437%bin_and_exe ilasm 4.0/ilasm
438%bin_and_exe macpack 4.0/macpack
439%bin_and_exe makecert 4.0/makecert
440%bin_and_exe monop 4.0/monop
441%bin_and_exe monop2 2.0/monop
442%bin_and_exe mono-shlib-cop 4.0/mono-shlib-cop
443%bin_and_exe mono-xmltool 4.0/mono-xmltool
444%bin_and_exe pdb2mdb 4.0/pdb2mdb
445%bin_and_exe permview 4.0/permview
446%bin_and_exe resgen 4.0/resgen
447%bin_and_exe resgen2 2.0/resgen
448%bin_and_exe secutil 4.0/secutil
449%bin_and_exe signcode 4.0/signcode
450%{mono_dir}/xbuild
451%{mono_dir}/xbuild-frameworks
452%{mono_dir}/4.0/xbuild.*
453%{mono_dir}/3.5/xbuild.*
454%{mono_dir}/2.0/xbuild.*
455%{mono_dir}/4.0/culevel.exe*
456%{mono_dir}/2.0/culevel.exe*
457%{mono_dir}/4.0/MSBuild/*.xsd
458%{mono_dir}/3.5/MSBuild/*.xsd
459%{mono_dir}/2.0/MSBuild/*.xsd
460%{mono_dir}/4.0/Microsoft.Build.xsd
461%{mono_dir}/3.5/Microsoft.Build.xsd
462%{mono_dir}/2.0/Microsoft.Build.xsd
463%{mono_dir}/4.0/Microsoft.*.targets
464%{mono_dir}/3.5/Microsoft.*.targets
465%{mono_dir}/2.0/Microsoft.*.targets
466%{mono_dir}/4.0/Microsoft.Common.tasks
467%{mono_dir}/3.5/Microsoft.Common.tasks
468%{mono_dir}/2.0/Microsoft.Common.tasks
469%gac_and_2dll PEAPI 4.0 2.0
470%gac_and_3dll Microsoft.Build.Engine 4.0 3.5 2.0
471%gac_and_3dll Microsoft.Build.Framework 4.0 3.5 2.0
472%gac_and_1dll Microsoft.Build.Tasks 2.0
473%gac_and_1dll Microsoft.Build.Tasks.v4.0 4.0
474%gac_and_1dll Microsoft.Build.Tasks.v3.5 3.5
475%gac_and_1dll Microsoft.Build.Utilities 2.0
476%gac_and_1dll Microsoft.Build.Utilities.v4.0 4.0
477%gac_and_1dll Microsoft.Build.Utilities.v3.5 3.5
478%gac_and_2dll Microsoft.VisualC 4.0 2.0
479%{_libdir}/pkgconfig/cecil.pc
480%{_libdir}/pkgconfig/dotnet.pc
481%{_libdir}/pkgconfig/dotnet35.pc
482%{_libdir}/pkgconfig/mono-cairo.pc
483%{_libdir}/pkgconfig/mono.pc
484%{_libdir}/pkgconfig/mono-2.pc
485%{_libdir}/pkgconfig/mono-lineeditor.pc
486%{_libdir}/pkgconfig/mono-options.pc
487%{_libdir}/pkgconfig/wcf.pc
488%{_includedir}/mono-2.0
489%{_mandir}/man1/al.1.gz
490%{_mandir}/man1/cert2spc.1.gz
491%{_mandir}/man1/dtd2xsd.1.gz
492%{_mandir}/man1/genxs.1.gz
493%{_mandir}/man1/ilasm.1.gz
494%{_mandir}/man1/macpack.1.gz
495%{_mandir}/man1/makecert.1.gz
496%{_mandir}/man1/mkbundle.1.gz
497%{_mandir}/man1/mono-shlib-cop.1.gz
498%{_mandir}/man1/mono-xmltool.1.gz
499%{_mandir}/man1/monodis.1.gz
500%{_mandir}/man1/monop.1.gz
501%{_mandir}/man1/pdb2mdb.1.gz
502%{_mandir}/man1/permview.1.gz
503%{_mandir}/man1/secutil.1.gz
504%{_mandir}/man1/sgen.1.gz
505%{_mandir}/man1/signcode.1.gz
506%{_mandir}/man1/xbuild.1.gz
507
508%files nunit
509%defattr(-,root,root,-)
510%bin_and_exe nunit-console 4.0/nunit-console
511%bin_and_exe nunit-console2 2.0/nunit-console
512%gac_and_2dll nunit.core 4.0 2.0
513%gac_and_2dll nunit.framework 4.0 2.0
514%gac_and_2dll nunit.util 4.0 2.0
515%gac_and_2dll nunit.mocks 4.0 2.0
516%gac_and_2dll nunit-console-runner 4.0 2.0
517%gac_and_2dll nunit.core.extensions 4.0 2.0
518%gac_and_2dll nunit.core.interfaces 4.0 2.0
519%gac_and_2dll nunit.framework.extensions 4.0 2.0
520%{_libdir}/pkgconfig/mono-nunit.pc
521
522%files locale-extras
523%defattr(-,root,root,-)
524%gac_and_2dll I18N.MidEast 4.0 2.0
525%gac_and_2dll I18N.Rare 4.0 2.0
526%gac_and_2dll I18N.CJK 4.0 2.0
527%gac_and_2dll I18N.Other 4.0 2.0
528
529%files extras
530%defattr(-,root,root,-)
531%{_mandir}/man1/mono-service.1.gz
532%bin_and_exe mono-service 4.0/mono-service
533%bin_and_exe mono-service2 2.0/mono-service
534%{mono_dir}/gac/mono-service
535%gac_and_2dll System.Configuration.Install 4.0 2.0
536%gac_and_2dll System.Management 4.0 2.0
537%gac_and_2dll System.Messaging 4.0 2.0
538%gac_and_2dll System.ServiceProcess 4.0 2.0
539%gac_and_2dll System.ServiceModel 4.0 2.0
540%gac_and_1dll System.ServiceModel.Discovery 4.0
541%gac_and_1dll System.ServiceModel.Routing 4.0
542%gac_and_2dll Mono.Messaging.RabbitMQ 4.0 2.0
543%gac_and_2dll Mono.Messaging 4.0 2.0
544%gac_and_2dll RabbitMQ.Client 4.0 2.0
545%{mono_dir}/4.0/RabbitMQ.Client.Apigen.exe*
546%{mono_dir}/2.0/RabbitMQ.Client.Apigen.exe*
547
548%files winforms
549%defattr(-,root,root,-)
550%gac_and_2dll Accessibility 4.0 2.0
551%gac_and_2dll System.Design 4.0 2.0
552%gac_and_2dll System.Drawing.Design 4.0 2.0
553%gac_and_2dll System.Windows.Forms 4.0 2.0
554%gac_and_1dll System.Windows.Forms.DataVisualization 4.0
555
556%files web
557%defattr(-,root,root,-)
558%{mono_dir}/2.0/xsd.exe*
559%{mono_dir}/compat-2.0/System.Web.Extensions*dll
560%{mono_dir}/compat-2.0/System.Web.Mvc.dll
561%bin_and_exe disco 4.0/disco
562%bin_and_exe soapsuds 4.0/soapsuds
563%bin_and_exe xsd 4.0/xsd
564%bin_and_exe wsdl 4.0/wsdl
565%bin_and_exe wsdl2 2.0/wsdl
566%bin_and_exe httpcfg 4.0/httpcfg
567%gac_and_2dll Mono.Http 4.0 2.0
568%gac_and_2dll Mono.Web 4.0 2.0
569%gac_and_2dll Mono.WebBrowser 4.0 2.0
570%gac_and_2dll System.Runtime.Remoting 4.0 2.0
571%gac_and_2dll System.Runtime.Serialization.Formatters.Soap 4.0 2.0
572%gac_and_2dll System.ServiceModel.Web 4.0 2.0
573%gac_and_2dll System.Web 4.0 2.0
574%gac_and_1dll System.Web.ApplicationServices 4.0
575%gac_and_2dll System.Web.Abstractions 4.0 2.0
576%gac_and_2dll System.Web.DynamicData 4.0 2.0
577%gac_and_1dll System.Web.Mvc 2.0
578%gac_and_2dll System.Web.Routing 4.0 2.0
579%gac_and_2dll System.Web.Services 4.0 2.0
580%gac_and_2dll System.Web.Extensions.Design 4.0 2.0
581%gac_and_2dll System.Web.Extensions 4.0 2.0
582%gac_and_1dll Microsoft.Web.Infrastructure 4.0
583%gac_and_1dll WebMatrix.Data 4.0
584%{_mandir}/man1/disco.1.gz
585%{_mandir}/man1/soapsuds.1.gz
586%{_mandir}/man1/wsdl.1.gz
587%{_mandir}/man1/xsd.1.gz
588%config (noreplace) %{_sysconfdir}/mono/browscap.ini
589%config (noreplace) %{_sysconfdir}/mono/2.0/Browsers/Compat.browser
590%config (noreplace) %{_sysconfdir}/mono/4.0/DefaultWsdlHelpGenerator.aspx
591%config (noreplace) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
592%config (noreplace) %{_sysconfdir}/mono/4.0/web.config
593%config (noreplace) %{_sysconfdir}/mono/2.0/web.config
594%{_mandir}/man1/httpcfg.1.gz
595%{_libdir}/pkgconfig/mono.web.pc
596%{_libdir}/pkgconfig/system.web.extensions_1.0.pc
597%{_libdir}/pkgconfig/system.web.extensions.design_1.0.pc
598%{_libdir}/pkgconfig/system.web.mvc.pc
599%{_libdir}/pkgconfig/system.web.mvc2.pc
600
601%files data
602%defattr(-,root,root,-)
603%bin_and_exe sqlsharp 4.0/sqlsharp
604%gac_and_2dll Mono.Data.Tds 4.0 2.0
605%gac_and_2dll Novell.Directory.Ldap 4.0 2.0
606%gac_and_2dll System.Data 4.0 2.0
607%gac_and_2dll System.Data.DataSetExtensions 4.0 2.0
608%gac_and_2dll System.Data.Linq 4.0 2.0
609%gac_and_2dll System.Data.Services 4.0 2.0
610%gac_and_2dll System.Data.Services.Client 4.0 2.0
611%gac_and_2dll System.DirectoryServices 4.0 2.0
612%gac_and_2dll System.EnterpriseServices 4.0 2.0
613%gac_and_2dll System.Transactions 4.0 2.0
614%{_mandir}/man1/sqlsharp.1.gz
615
616%files data-sqlite
617%defattr(-,root,root,-)
618%gac_and_2dll Mono.Data.Sqlite 4.0 2.0
619
620%files data-oracle
621%defattr(-,root,root,-)
622%gac_and_2dll System.Data.OracleClient 4.0 2.0
623
624%files data-postgresql
625%defattr(-,root,root,-)
626%gac_and_2dll Npgsql 4.0 2.0
627
628%files -n ibm-data-db2
629%defattr(-,root,root,-)
630%gac_and_2dll IBM.Data.DB2 4.0 2.0
631
632%files -n monodoc
633%defattr(-, root, root)
634%bin_and_exe mdoc 2.0/mdoc
635%{_bindir}/mdoc-*
636%{_bindir}/mdass*
637%{_bindir}/mdval*
638%{_bindir}/mod
639%{_bindir}/monodoc*
640%{mono_dir}/gac/monodoc
641%{mono_dir}/monodoc/monodoc.dll
642%{mono_doc}/*
643%{_mandir}/man1/md*
644%{_mandir}/man1/monodoc*
645%{_mandir}/man5/mdoc*
646%{_libdir}/pkgconfig/monodoc.pc
647
648
649%changelog
650* Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.8-2
651- rebuild with VineSeed environment
652- remove Requires:libgluezilla in monodoc
653
654* Sun Jan 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.8-1
655- updated mono to 2.10.8
656
657* Sun Jan 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.8-1
658- updated mono to 2.10.8
659
660* Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.6-1
661- updated mono to 2.10.6
662
663* Sat May 07 2011 Shu KONNO <owa@bg.wakwak.com> 2.10.2-1
664- updated mono to 2.10.2
665- dropt Patch1: mono-2.10.1-ppc-len.patch (fixed in the upstream)
666
667* Sun Apr 24 2011 Shu KONNO <owa@bg.wakwak.com> 2.10.1-3
668- added '--with-sgen=no' to all arch
669- dropt %%{mono_dir}/2.0/{mcs.exe,mscorlib.dll}.so
670
671* Sat Apr 16 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.10.1-2
672- remove the old ppc patch (similar codes already in the upstream)
673- add Patch1 (from Gentoo)
674- mono/2.0/mcs.exe.so not available on ppc - remove from the filelist
675  (TODO: see the Fedora's srpm - removing mono/2.0/{mcs,gmcs}.exe.so etc.)
676
677* Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 2.10.1-1
678- updated mono to 2.10.1
679
680* Sat Jan 08 2011 Shu KONNO <owa@bg.wakwak.com> 2.8.2-1
681- updated mono to 2.8.2
682
683* Tue Dec 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-2
684- add Patch0 (mono-2.8.1-ppc.patch)
685- add configure option "--with-sgen=no" and "--disable-system-aot" (ppc only)
686- fix %%files (add %%ifnarch ppc)
687
688* Sun Nov 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-1
689- updated mono to 2.8.1
690
691* Sat Nov 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-2
692- comment out script that removes prebuilt binaries, because gmcs.exe require
693
694* Fri Oct 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-1
695- updated mono to 2.8
696- modified macros used in %%files
697- removed below:
698  - packages:
699    %{name}-jscript, %{name}-data-sybase, %{name}-data-firebird, bytefx-data-mysql
700  - libraries:
701    ByteFX.Data, FirebirdSql.Data.Firebird
702    Mono.Data Mono.Data.TdsClient, Mono.Data.SybaseClient, Mono.Data.SqliteClient
703    Microsoft.JScript, Microsoft.Vsa
704  - commands:
705    cilc, mjs, prj2make (replaced by xbuild)
706
707* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.6.7-2
708- build with rpm-4.8.1-1 for pkg-config file
709
710* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.7-1
711- updated mono to 2.6.7
712
713* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
714- updated mono to 2.6.4
715
716* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
717- updated mono to 2.6.3
718  added RabbitMQ.Client.Apigen.exe
719
720* Thu Dec 31 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-2
721- unuse _smp_mflags
722
723* Sat Dec 26 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-1
724- updated mono to 2.6.1
725- simplified macros
726
727* Mon Dec 14 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-1
728- updated mono to 2.4.3
729  added %%{mono_dir}/2.0/lc.exe*
730  added %%gac_dll System.Web.Mvc
731  added %%{mono_dir}/xbuild/*
732  added %%{_mandir}/man1/lc.1.gz
733  added %%{_mandir}/man1/xbuild.1.gz
734
735* Wed Jul 29 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.3-1
736- updated mono to 2.4.2.3
737
738* Fri Jul 24 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.2-1
739- updated mono to 2.4.2.2
740
741* Tue Jul 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.2.1-1
742- new upstream release
743- build with latest rpm to update mono-dependencies
744
745* Thu Jul 02 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
746- updated mono to 2.4.2
747
748* Mon Apr 27 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4-3
749- fix temporary workaround against build failure on ppc,
750  from RH bugzilla #494026
751  - statically link mono to libmono: remove "--disable-static" from configure
752  - ensure removing *.a files in the install section
753- remove prebuilt binaries under mcs/class/lib/monolite/ before building
754
755* Sun Apr  5 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
756- fixed paths using %%mono_dir, %%mono_doc macros
757- added Requires:libgluezilla >= 2.4 in monodoc
758
759* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
760- new upstream release
761- added monodoc package (Obsoletes: monodoc-core <= 2.0-1vl5)
762
763* Mon Nov 03 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1
764- new upstream release
765- dropt %%{_bindir}/mono-find-{provides,requires}
766- added --with-libgdiplus=installed
767
768* Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-3
769- update to mono-2.0 released source
770- BR: libgdiplus-devel >= 2.0
771
772* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-2vl5
773- removed *.la
774
775* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1vl5
776- updated mono to 2.0
777- updated url
778- changed macro %%monodir to %%mono_dir
779- dropt mono-1.1.13.4-selinux-ia64.patch
780- dropt mono-1.1.13.4-ppc-threading.patch
781- dropt mono-1.2.3-use-monodir.patch
782
783* Tue Aug 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-1vl5
784- applied new versioning policy, spec in utf-8
785- dropt mono-1.2.5-libdir.patch
786- reverted monodir macro to using %%{_prefix}/lib/mono
787
788* Sat Dec 29 2007 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-0vl2
789- updated monodir to %%{_libdir}/mono
790
791* Sat Sep 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5.1-0vl1
792- new upstream release
793- splited mono-basic package
794
795* Sat Oct 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.8.1-0vl1
796- new upstream release
797
798* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.6-0vl1
799- new upstream release
800
801* Thu Apr 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.13.4-2vl2
802- disabled Patch2 on Vine/ppc environment
803
804* Wed Mar 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.4-2vl1
805- updated source and sub-packages based on Fedora packages
806  * Tue Feb 22 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.6-0vl1
807  - new upstream version(mono-1.0.6)
808  * Sun Jan 16 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.5-0vl1
809  - new upstream version(mono-1.0.5)
810  * Sat Nov 06 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.4-0vl1
811  - new upstream version(mono-1.0.4)
812        -- changed to use configure
813  * Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
814  - rebuild for Vine Linux (based on mono.spec inside src archive)
815  - Fixed BuildRequires: gc-devel, libicu-devel
816  - add Japanese translation
817
818* Fri Mar 10 2006 Bill Nottingham <notting@redhat.com> - 1.1.13.4-2
819- rebuild for ppc TLS issue (#184446)
820
821* Fri Mar  3 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.4-1
822- Update to 1.1.13.4
823- Add patch so mono doesn't segfault on PPC SMP machines
824- Minor spec cleanup
825
826* Thu Mar  2 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-5
827- Updated patch from Jakub (1.1.13.2-3 to 1.1.13.2-5 are
828  for bug 182965)
829
830* Tue Feb 28 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-4
831- Updated patch from Paolo Molaro <lupus@ximian.com>
832
833* Mon Feb 27 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-3
834- Patch from Jakub to make work with SELinux better
835
836* Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-2
837- Rebuild
838
839* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.1.13.2-1.1
840- rebuilt for new gcc4.1 snapshot and glibc changes
841
842* Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-1
843- Update to 1.1.13.2
844
845* Fri Jan 13 2006 Alexander Larsson <alexl@redhat.com> - 1.1.13-1
846- Update to 1.13
847- Add libgdiplus dep to mono-core
848- Add s390x to build
849
850* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.12.1-1
851- Update to 1.1.12.1
852
853* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.10-4
854- rebuild
855
856* Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-3
857- Disable s390 due to some build failure
858
859* Thu Nov 17 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-2
860- Build on s390 and x86-64 now
861
862* Tue Nov 15 2005 Alexander Larsson <alexl@redhat.com> - 1.1.10-1
863- Initial version
Note: See TracBrowser for help on using the repository browser.